NAT arkasındaki PC 'lere Erişim
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

+ Konuyu Cevapla
Toplam 4 sonuçtan 1 ile 4 arasındakiler gösteriliyor.
NAT arkasındaki PC 'lere Erişim

Merhaba , Ekteki resimde şekillendirmeye çalıştığım gibi bir ağımız olduğunu var sayalım, içeride private IP kullanılmış ve routerda NAT aktif. Ben iki tane sunucu kurmak istiyorum, biri sadece FTP sunucu

  1. #1
    Özcan İLİKHAN Guest

    Standart NAT arkasındaki PC 'lere Erişim

    Merhaba ,

    Ekteki resimde şekillendirmeye çalıştığım gibi bir ağımız olduğunu var sayalım, içeride private IP kullanılmış ve routerda NAT aktif. Ben iki tane sunucu kurmak istiyorum, biri sadece FTP sunucu olarak kullanılacak, diğeri hem WEB sunucu hemde oyun sunucusu olarak kullanılacak, oyun sunucusuna bağlanmak için gerekli port numaraları 27005, 27015, 27025.

    Bu ağın dışındaki her hangi bir istemcinin içerideki sunuculara(örneğin FTP sunucusuna) erişmesi için ne tür bir konfigürasyona ihtiyacımız var. Mesela cihaza bir adet DSL kart takılmış olsun ve mevcut konfigürasyondan kesitler aşağıdaki gibi olsun. (ADSL hattı üzerinden dışa erişim vermek -performans açısından- mantıklı değil ama bazen iş yerindeki bilgisayarlara çeşitli nedenlerden dolayı dışarından erişmek gerekebiliyor.).

    Böyle birşey mümkünmü? Mümkünse konfigürasyonda ne gibi bir değişiklik yapmamız gerekiyor?


    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    .....
    interface FastEthernet0
    description +++ LAN +++
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    ......
    interface Dialer0
    description +++ TTNet ADSL +++
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    .......
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    .......
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit

  2. #2
    Cumhur / Yahoo Guest

    Standart RE: [cisco-ttl] NAT arkasındaki makinelere erişmek

    Selamlar,

    ip nat inside source static tcp (xxx.xxx.xxx.xxx)ic-ip yyy(ic-port)
    (aaa.aaa.aaa.aaa)dis-ip zzz(dis-port)

    ornek ftp:

    ip nat inside source static tcp 192.168.50.2 21 212.156.4.4 2121

    Kolay gelsin.
    Cumhur

    -----Original Message-----
    From: [email][email protected][/email] [mailto:[email protected]] On Behalf
    Of Özcan YLYKHAN
    Sent: Tuesday, November 08, 2005 23:22
    To: Cisco-TTL
    Subject: [cisco-ttl] NAT arkasındaki makinelere erişmek



    Merhaba ,

    Ekteki resimde şekillendirmeye çalıştığım gibi bir ağımız olduğunu var
    sayalım, içeride private IP kullanılmış ve routerda NAT aktif. Ben iki tane
    sunucu kurmak istiyorum, biri sadece FTP sunucu olarak kullanılacak, diğeri
    hem WEB sunucu hemde oyun sunucusu olarak kullanılacak, oyun sunucusuna
    bağlanmak için gerekli port numaraları 27005, 27015, 27025.

    Bu ağın dışındaki her hangi bir istemcinin içerideki sunuculara(örneğin FTP
    sunucusuna) erişmesi için ne tür bir konfigürasyona ihtiyacımızvar. Mesela
    cihaza bir adet DSL kart takılmış olsun ve mevcut konfigürasyondan kesitler
    aşağıdaki gibi olsun. (ADSL hattı üzerinden dışa erişim vermek -performans
    açısından- mantıklı değil ama bazen iş yerindeki bilgisayarlara çeşitli
    nedenlerden dolayı dışarından erişmek gerekebiliyor.).

    Böyle birşey mümkünmü? Mümkünse konfigürasyonda ne gibi bir değişiklik
    yapmamız gerekiyor?


    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    .....
    interface FastEthernet0
    description +++ LAN +++
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    ......
    interface Dialer0
    description +++ TTNet ADSL +++
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    .......
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    .......
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit




    ---------------------------------
    Yahoo! FareChase - Search multiple travel sites in one click.

    [Non-text portions of this message have been removed]






    --
    Cisco Teknik Tartisma Listesi (Cisco-ttl)

    Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk
    kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da
    bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar.
    Yahoo! Groups Links









    ------------------------ Yahoo! Groups Sponsor --------------------~-->
    Fair play? Video games influencing politics. Click and talk back!
    [url]http://us.click.yahoo.com/T8sf5C/tzNLAA/TtwFAA/26EolB/TM[/url]
    --------------------------------------------------------------------~->

    --
    Cisco Teknik Tartisma Listesi (Cisco-ttl)

    Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk
    kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da
    bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar.
    Yahoo! Groups Links

    <*> To visit your group on the web, go to:
    [url]http://groups.yahoo.com/group/cisco-ttl/[/url]

    <*> To unsubscribe from this group, send an email to:
    [email][email protected][/email]

    <*> Your use of Yahoo! Groups is subject to:
    [url]http://docs.yahoo.com/info/terms/[/url]





  3. #3
    Özcan İLİKHAN Guest

    Standart re: NAT arkasındaki PC 'lere Erişim

    Öncelikle yardımınız için teşekkürler,

    Verdiğiniz komutun <iç-ip> <iç-port> kısmına kadar sorun yok, yalnız dış port kısmını nasıl dinamik yapaliriz? Demek istediğim şu ki dışarıdaki herhangi bir kullanıcı içerideki FTP sunucusuna bağlanmak istediğinde, istemcinin OS u otomatik olarak boş bir portu kullanacaktır ve biz bunun ne olduğunu bilemeyiz, ikincisi dışarıdaki birden çok IP ye veyahut herkese NAT arkasındaki FTP sunucuya erişim vermek istersek nasıl bir komut uygulayabiliriz?

    örneğin
    - Yönlendiriciye sadece 80.90.100.0/24 ağından gelen FTP isteklerini 192.168.1.254 ip li makineye yönlendir.
    - Yönlendiriciye herhangi bir dış ağdan tüm HTTP isteklerini 192.168.1.250 ip li makineye yönlerdir

    ben denemek amacıyla
    ip nat inside source static tcp 192.168.1.250 80 any any

    gibi bir komut girdiğimde "any" ifadelerinden dolayı hata verdi.

    Cumhur / Yahoo <[email protected]> wrote:
    Selamlar,

    ip nat inside source static tcp (xxx.xxx.xxx.xxx)ic-ip yyy(ic-port)
    (aaa.aaa.aaa.aaa)dis-ip zzz(dis-port)

    ornek ftp:

    ip nat inside source static tcp 192.168.50.2 21 212.156.4.4 2121

    Kolay gelsin.
    Cumhur

    -----Original Message-----
    From: [email][email protected][/email] [mailto:[email protected]] On Behalf
    Of Özcan YLYKHAN
    Sent: Tuesday, November 08, 2005 23:22
    To: Cisco-TTL
    Subject: [cisco-ttl] NAT arkasındaki makinelere erişmek



    Merhaba ,

    Ekteki resimde şekillendirmeye çalıştığım gibi bir ağımız olduğunu var
    sayalım, içeride private IP kullanılmış ve routerda NAT aktif. Ben iki tane
    sunucu kurmak istiyorum, biri sadece FTP sunucu olarak kullanılacak, diğeri
    hem WEB sunucu hemde oyun sunucusu olarak kullanılacak, oyun sunucusuna
    bağlanmak için gerekli port numaraları 27005, 27015, 27025.

    Bu ağın dışındaki her hangi bir istemcinin içerideki sunuculara(örneğin FTP
    sunucusuna) erişmesi için ne tür bir konfigürasyona ihtiyacımızvar. Mesela
    cihaza bir adet DSL kart takılmış olsun ve mevcut konfigürasyondan kesitler
    aşağıdaki gibi olsun. (ADSL hattı üzerinden dışa erişim vermek -performans
    açısından- mantıklı değil ama bazen iş yerindeki bilgisayarlara çeşitli
    nedenlerden dolayı dışarından erişmek gerekebiliyor.).

    Böyle birşey mümkünmü? Mümkünse konfigürasyonda ne gibi bir değişiklik
    yapmamız gerekiyor?


    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    .....
    interface FastEthernet0
    description +++ LAN +++
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    ......
    interface Dialer0
    description +++ TTNet ADSL +++
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    .......
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    .......
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit

  4. #4
    Selcuk COSAN Guest

    Standart re: NAT arkasındaki PC 'lere Erişim

    Merhaba aşağıdakileri deneyip sonucu bildirirseniz iyi olur.

    FTP istekleri için
    route-map deneme permit 10

    match ip address 1

    access-list 1 permit 80.90.100.0 0.0.0.255

    ip nat inside source static tcp 192.168.1.254 21 dialer 0 21 route-
    map deneme


    Tüm HTTP istekleri için
    ip nat inside source static tcp 192.168.1.250 80 dialer0 80

    Üçüncü olarak;

    Burada dış port adresini dinamikten ziyade direk ip bazında dönüşüm
    yaptırabilirsiniz.
    ip nat inside source static 192.168.1.10 dialer0

    Bu burada default inside server olacaktır,yani dinamik translation
    tablosunda ya da static tabloda var olan değerlere uymayan tüm
    istekler drop edilmeyecek ve 192.168.1.10 nolu servera
    yönlendirilecektir .Bu da bi güvenlik sorunu oluşturur.Yani yine
    access-list ile kısıtlama yapmanız gerekecektir.

    --- In [email][email protected][/email], "Özcan" "İLİKHAN"
    <[email protected]> wrote:[color=blue]
    >
    > Öncelikle yardımınız için teşekkürler,
    >
    > Verdiğiniz komutun <iç-ip> <iç-port> kısmına kadar sorun yok, [/color]
    yalnız dış port kısmını nasıl dinamik yapaliriz? Demek istediğim şu
    ki dışarıdaki herhangi bir kullanıcı içerideki FTP sunucusuna
    bağlanmak istediğinde, istemcinin OS u otomatik olarak boş bir portu
    kullanacaktır ve biz bunun ne olduğunu bilemeyiz, ikincisi dışarıdaki
    birden çok IP ye veyahut herkese NAT arkasındaki FTP sunucuya erişim
    vermek istersek nasıl bir komut uygulayabiliriz? [color=blue]
    >
    > örneğin
    > - Yönlendiriciye sadece 80.90.100.0/24 ağından gelen FTP [/color]
    isteklerini 192.168.1.254 ip li makineye yönlendir.[color=blue]
    > - Yönlendiriciye herhangi bir dış ağdan tüm HTTP isteklerini [/color]
    192.168.1.250 ip li makineye yönlerdir[color=blue]
    >
    > ben denemek amacıyla
    > ip nat inside source static tcp 192.168.1.250 80 any any
    >
    > gibi bir komut girdiğimde "any" ifadelerinden dolayı hata verdi.
    >
    > Cumhur / Yahoo <[email protected]> wrote:
    > Selamlar,
    >
    > ip nat inside source static tcp (xxx.xxx.xxx.xxx)ic-ip yyy(ic-port)
    > (aaa.aaa.aaa.aaa)dis-ip zzz(dis-port)
    >
    > ornek ftp:
    >
    > ip nat inside source static tcp 192.168.50.2 21 212.156.4.4 2121
    >
    > Kolay gelsin.
    > Cumhur
    >
    > -----Original Message-----
    > From: [email][email protected][/email] [mailto:[email protected]] [/color]
    On Behalf[color=blue]
    > Of Özcan YLYKHAN
    > Sent: Tuesday, November 08, 2005 23:22
    > To: Cisco-TTL
    > Subject: [cisco-ttl] NAT arkasındaki makinelere erişmek
    >
    >
    >
    > Merhaba ,
    >
    > Ekteki resimde şekillendirmeye çalıştığım gibi bir ağımız olduğunu [/color]
    var[color=blue]
    > sayalım, içeride private IP kullanılmış ve routerda NAT aktif. Ben [/color]
    iki tane[color=blue]
    > sunucu kurmak istiyorum, biri sadece FTP sunucu olarak [/color]
    kullanılacak, diğeri[color=blue]
    > hem WEB sunucu hemde oyun sunucusu olarak kullanılacak, oyun [/color]
    sunucusuna[color=blue]
    > bağlanmak için gerekli port numaraları 27005, 27015, 27025.
    >
    > Bu ağın dışındaki her hangi bir istemcinin içerideki sunuculara [/color]
    (örneğin FTP[color=blue]
    > sunucusuna) erişmesi için ne tür bir konfigürasyona ihtiyacımız [/color]
    var. Mesela[color=blue]
    > cihaza bir adet DSL kart takılmış olsun ve mevcut konfigürasyondan [/color]
    kesitler[color=blue]
    > aşağıdaki gibi olsun. (ADSL hattı üzerinden dışa erişim vermek -[/color]
    performans[color=blue]
    > açısından- mantıklı değil ama bazen iş yerindeki bilgisayarlara [/color]
    çeşitli[color=blue]
    > nedenlerden dolayı dışarından erişmek gerekebiliyor.).
    >
    > Böyle birşey mümkünmü? Mümkünse konfigürasyonda ne gibi bir [/color]
    değişiklik[color=blue]
    > yapmamız gerekiyor?
    >
    >
    > interface ATM0
    > no ip address
    > no ip mroute-cache
    > no atm ilmi-keepalive
    > ....
    > interface FastEthernet0
    > description +++ LAN +++
    > ip address 192.168.1.1 255.255.255.0
    > ip nat inside
    > ip tcp adjust-mss 1452
    > .....
    > interface Dialer0
    > description +++ TTNet ADSL +++
    > ip address negotiated
    > ip nat outside
    > encapsulation ppp
    > dialer pool 1
    > dialer-group 1
    > ......
    > ip nat inside source list 1 interface Dialer0 overload
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer0
    > ......
    > access-list 1 permit 192.168.1.0 0.0.0.255
    > dialer-list 1 protocol ip permit
    >

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok