RIP ve OSPF Redistribution

RIP ve OSPF Redistribution

RIP Network Konfigurasyonu

Aşağıdaki şekil bir RIP Network örneğidir. 3 farklı site, serial hat ile birbirine bağlanmıştır. RIP Network’ü, B sınıfı adres ve de 8 bit’lik subnet mask kullanmaktadır. Her bir bölge komşu network numarasına sahiptir.

RIP (Routing Information Protocol) , Routing

Tablo RIP Network Dağılımı, şekildeki RIP Network için network numarası, subnet aralığı ve subnet maskları içeren network adres dağılımlarını listeler. Bütün arayüzler (interface), 130.10.0.0 ağında olmakla birlikte, subnet maskların da yer aldığı adresler de belirtilmektedir. Örneğin; C Router’ı üzerindeki serial 0 arayüzünün ip adresi 130.10.63.3, subnet mask’ı da 255.255.255.0’dır.

RIP(Routing Information Protocol) Routing , Network , Cisco , CCNA , CCNP , Router , Switch , Firewall

RIP (Routing Information Protocol) Konfigurasyon Örnekleri

Aşağıdaki komutlar, Router A için bütün arayüzlere ait olan ip adreslerini belirten ve de RIP protokolünü etkin hale getiren komutlardır.

interface serial 0
ip address 130.10.62.1 255.255.255.0
interface serial 1
ip address 130.10.63.1 255.255.255.0
interface ethernet 0
ip address 130.10.8.1 255.255.255.0
interface tokenring 0
ip address 130.10.9.1 255.255.255.0
router rip
network 130.10.0.0

Aşağıdaki komutlar, Router B için bütün arayüzlere ait olan ip adreslerini belirten ve de RIP (Routing Information Protocol)’ü etkin hale getiren komutlardır.

interface serial 0
ip address 130.10.62.2 255.255.255.0
interface serial 1
ip address 130.10.64.2 255.255.255.0

interface ethernet 0
ip address 130.10.17.2 255.255.255.0
interface tokenring 0
ip address 130.10.16.2 255.255.255.0
router rip
network 130.10.0.0

Aşağıdaki komutlar, Router C için bütün arayüzlere ait olan ip adreslerini belirten ve de RIP (Routing Information Protocol)’ünü etkin hale getiren komutlardır

interface serial 0
ip address 130.10.63.3 255.255.255.0
interface serial 1
ip address 130.10.64.3 255.255.255.0
interface ethernet 0
ip address 130.10.24.3 255.255.255.0
router rip
network 130.10.0.0

RIP Network’ün Merkezine OSPF Ekleme

Bir RIP Network’ünü OSPF’e dönüştürmek için en sık kullanılan adım, diğer network cihazları halihazırda RIP protokolünü çalıştırmaya devam ederken, her iki RIP ve OSPF protokolünü de çalıştıran bir omurga(backbone) router eklemektir. Eklenen bu omurga(backbone) router’lar OSPF Autonomous System Boundary (ASB) router’lardır.

Her bir ASB router’ı, OSPF (Open Shortest Path First)  ve RIP (Routing Information Protocol)  arasındaki routing bilgisi akışını kontrol eder. Aşağıdaki şekilde de görüldüğü gibi, Router A, ASB router’ı olarak konfigüre edilmiştir.

RIP (Routing Information Protocol) , RIP , Cisco , Network , Routing , Cisco RIP

RIP’in backbone router’lar arasında çalışmasına gerek yoktur. Dolayısıyla Router A üzerinde aşağıdaki komutlarla, RIP iptal edilir.

router rip
passive-interface serial 0
passive-interface serial 1

RIP (Routing Information Protocol) , her üç router’da da aşağıdaki komutlar kullanılarak OSPF (Open Shortest Path First)’e yeniden dağıtılır.(Redistribute)

router ospf 109
redistribute rip subnets

‘subnets’ anahtar kelimesi, OSPF’e, tüm subnet yönelmelerini yeniden dağıtmasını söyler. ‘subnets’ anahtar kelimesi olmazsa, sadece alt ağa bölünmemiş networkler OSPF tarafından yeniden dağıtılacaktır. Redistribute edilen route’lar (yeniden dağıtılan yönelmeler) OSPF’te, external 2 tipi yönelmeler şeklinde ortaya çıkar. Her bir RIP domain’i , diğer RIP domain’lerinde ve de OSPF backbone area’da yer alan networkler hakkında bilgi alır. Bu bilgiyi, OSPF yönelmelerini RIP’e yeniden dağıtan aşağıdaki komutlar sayesinde alır.

router rip
redistribute ospf 109 match internal external 1 external 2
default-metric 10

‘redistribute’ komutu, OSPF kelimesini, OSPF yönelmelerini RIP’e doğru yeniden dağıtmak için kullanır. ‘internal’ kelimesi, OSPF iç alanını ve de bu iç alana ait yönelmeleri belirtir. ‘external 1’ 1. Çeşit dış yönelme, ‘external 2’ ise 2. Çeşit dış yönelmedir. Çünkü, örnekteki komut, varsayılan tutumdur. Bu kelimeler ‘write terminal’ ya da ‘show configuration’ komutlarını kullandığınızda gözükmeyebilir.

Çünkü farklı protokollerin metrik değerleri doğrudan kıyaslanamaz. RIP güncellemelerinde kullanılan yeniden dağıtılan yönelmelerin cost değerlerini tanımlamak için varsayılan metrik değerlerini belirtmemiz gerekir. Bütün yeniden dağıtılan yönelmeler, varsayılan metrik değerini kullanacaktır.

Şekil 2’de, RIP bulutlarını doğrudan bağlayan bir yol(path) yoktur. Fakat tipik networklerde bu yollar, ya da arka kapılar(back doors), geribesleme döngülerinin potansiyeline izin verme amaçlı olarak çoğunlukla vardır. Her bir router tarafından kabul edilen ve de advertise edilen(duyurulan) yönelmeleri belirlemek amacıyla access list kullanabilirsiniz. Örneğin; Router A için yazılan konfigürasyondaki Access list 11, OSPF’e, 130.10.8.0’dan 130.10.15.0 networküne doğru olan RIP’ten, yeniden dağıtılan bilgileri öğrenmesi için izin verir.

router ospf 109
redistribute rip subnet
distribute-list 11 out rip
access-list 11 permit 130.10.8.0 0.0.7.255
access-list 11 deny 0.0.0.0 255.255.255.255

Bu komutlar Router A’nın, RIP domain’lerinde OSPF backbone üstüne doğru networkleri advertise etmesini engeller. Dolayısıyla , boundary router’lar yanlış bilgi ve döngü(loop) oluşumundan kurtulmuş olur.

Konfigurasyon Dosyası Örnekleri

  • Router A için tüm konfigürasyon dosyası:

interface serial 0
ip address 130.10.62.1 255.255.255.0
interface serial 1
ip address 130.10.63.1 255.255.255.0
interface ethernet 0
ip address 130.10.8.1 255.255.255.0
interface tokenring 0
ip address 130.10.9.1 255.255.255.0
!
router rip
default-metric 10
network 130.10.0.0
passive-interface serial 0
passive-interface serial 1
redistribute ospf 109 match internal external 1 external 2
!
router ospf 109
network 130.10.62.0 0.0.0.255 area 0
network 130.10.63.0 0.0.0.255 area 0
redistribute rip subnets
distribute-list 11 out rip
!
access-list 11 permit 130.10.8.0 0.0.7.255
access-list 11 deny 0.0.0.0 255.255.255.255

  • Router B için tüm konfigürasyon dosyası:

interface serial 0
ip address 130.10.62.2 255.255.255.0
interface serial 1
ip address 130.10.64.2 255.255.255.0
interface ethernet 0
ip address 130.10.17.2 255.255.255.0
interface tokenring 0
ip address 130.10.16.2 255.255.255.0
!
router rip
default-metric 10
network 130.10.0.0
passive-interface serial 0
passive-interface serial 1
redistribute ospf 109 match internal external 1 external 2
!
router ospf 109
network 130.10.62.0 0.0.0.255 area 0
network 130.10.64.0 0.0.0.255 area 0
redistribute rip subnets
distribute-list 11 out rip
access-list 11 permit 130.10.16.0 0.0.7.255
access-list 11 deny 0.0.0.0 255.255.255.255

  • Router C için tüm konfigürasyon dosyası:

interface serial 0
ip address 130.10.63.3 255.255.255.0
interface serial 1
ip address 130.10.64.3 255.255.255.0
interface ethernet 0
ip address 130.10.24.3 255.255.255.0
!
router rip
default-metric 10
!
network 130.10.0.0
passive-interface serial 0
passive-interface serial 1
redistribute ospf 109 match internal external 1 external 2
!
router ospf 109
network 130.10.63.0 0.0.0.255 area 0
network 130.10.64.0 0.0.0.255 area 0
redistribute rip subnets
distribute-list 11 out rip
access-list 11 permit 130.10.24.0 0.0.7.255
access-list 11 deny 0.0.0.0 255.255.255.255

Open Shortest Path First (OSPF) Area Ekleme

Aşağıdaki şekil 3, RIP bulutlarının OSPF area’ya nasıl dönüştürülebileceğini gösterir. Üç router da area border router’lardır. Area border router’lar, OSPF area ve OSPF backbone arasındaki network bilgi dağılımını kontrol eden router’lardır. Her bir router , kendi area’sı ile ilgili detaylı bilgiyi saklı tutar ve kendi area’larında bulunan diğer area border router’lardan özetlenmiş bilgiyi alır..

OSPF Area’lar arasındaki Routing özetleme Konfigürasyonu

Open Shortest Path First (OSPF) , Cisco , Routing , Network , OSPF Nedir , OSPF Area , OSPF Konfigurasyonu

Şekil 3 aynı zamanda tipik bir VLSM(değişken boyutlu subnet mask) örneğidir. VLSM, aynı ağ numarası için ağın farklı kısımlarında, farklı boyutta network maskları kullanır. VLSM, daha az host’a sahip olan ağların kısımlarında bulunan daha uzun bir mask kullanarak, adres alanlarını muhafaza eder. Tablo 2, network numarası, subnet aralığı ve de subnet maskı içeren OSPF adres dağılımını listeler. Bütün arayüzler 130.10.0.0 networkünü belirtir.

Tablo 2: OSPF Adres Dağılımları

Open Shortest Path First (OSPF) , Routing Information Protocol (RIP) , Network , Cisco

Adres aralığını muhafaza etmek için, area 0’da, bütün serial hatlar için 255.255.255.248 mask’ı kullanılır. Eğer bir area, network numarasının bir komşu aralığını kapsarsa, area border router’ı, backbone içine yerleştirilen yönelmeleri özetlemek için ‘area’ komutuyla birlikte ‘range’ anahtar kelimesi kullanılır.

router ospf 109
network 130.10.8.0 0.0.7.255 area 1
area 1 range 130.10.8.0 255.255.248.0

Bu komutlar, Area 1’den Area 0 içine tüm subnetleri kapsayan tek yönelmenin, 130.10.8.0 255.255.248.0, Router A tarafından duyurulmasına (advertise) izin verir. ‘area’ komutunda ‘range’ anahtar kelimesi olmazsa, Router A, her bir subneti ayrı ayrı duyuracaktır.(advertise) Örneğin; 130.10.8.0 255.255.255.0 için bir yönelme, 130.10.9.0 255.255.255.0 için ayrı bir routing ve dahası.

Çünkü Router A, artık RIP yönelmelerini yeniden dağıtmaya ihtiyaç duymaz.’router rip’ komutu şimdi konfigürasyon dosyasından silinebilir. Fakat , RIP kullanarak router’ları tespit eden hostlar için bazı durumlarda bu komut sıkça kullanılır. RIP silinince, router’ları bulmak için alternatif bir teknik bulunmalıdır. Cisco router’lar aşağıdaki alternatifleri destekler:

ICMP Router Discovery Protocol (IRDP) : Bu teknik, bu kısmın sonundaki örnekte gösterilmiştir. IRDP, router’ları bulmak için tavsiye edilen metottur.’ip irdp’ komutu, router üzerinde IRDP’yi etkin hale getirir. Hostlar da aynı zamanda IRDP çalıştırmalıdır.

Proxy Address Resolution Protocol (ARP) : Eğer router, ARP istek(request) gönderici gibi aynı ağda yer almayan bir host için bir ARP isteği alırsa, ve eğer router, o host için en iyi yönelmeye(route) sahipse, router, kendi lokal data link adresini veren bir ARP yanıt(reply) paketi gönderir. ARP isteği gönderen host daha sonra paketleri, onları isteyen hostlara ileten router’a gönderir. Proxy ARP, router’larda default olarak etkin haldedir. Proxy ARP hostlara şeffaftır.(transparent)

Konfigurasyon Dosyası Örnekleri

Router A için tüm konfigürasyon:

interface serial 0
ip address 130.10.62.1 255.255.255.248
interface serial 1
ip address 130.10.63.1 255.255.255.248
interface ethernet 0
ip address 130.10.8.1 255.255.255.0
ip irdp
interface tokenring 0
ip address 130.10.9.1 255.255.255.0
ip irdp
router ospf 109
network 130.10.62.0 0.0.0.255 area 0
network 130.10.63.0 0.0.0.255 area 0
network 130.10.8.0 0.0.7.255 area 1
area 1 range 130.10.8.0 255.255.248.0

Router B için tüm konfigürasyon:

interface serial 0
ip address 130.10.62.2 255.255.255.248
interface serial 1
ip address 130.10.64.2 255.255.255.248
interface ethernet 0
ip address 130.10.17.2 255.255.255.0
ip irdp
interface tokenring 0
ip address 130.10.16.2 255.255.255.0
ip irdp
router ospf 109
network 130.10.62.0 0.0.0.255 area 0
network 130.10.64.0 0.0.0.255 area 0
network 130.10.16.0 0.0.7.255 area 2
area 2 range 130.10.16.0 255.255.248.0

Router C için tüm konfigürasyon:

interface serial 0
ip address 130.10.63.2 255.255.255.248
interface serial 1
ip address 130.10.64.2 255.255.255.248
interface ethernet 0
ip address 130.10.24.3 255.255.255.0
ip irdp
router ospf 109
network 130.10.63.0 0.0.0.255 area 0
network 130.10.64.0 0.0.0.255 area 0
network 130.10.24.0 0.0.0.255 area 3
area 3 range 130.10.24.0 255.255.248.0

OSPF to RIP Karşılıklı Olarak Redistribution Kurulumu

Bazen karşılıklı olarak redistribution performansı göstermesi gereken bağımsız RIP ve OSPF bulutları gibi daha karmaşık ağ topolojilerini, birbirlerine uyumlu hale getirme ihtiyacı duyarız. Bu senaryoda, potansiyel yönelmeleri, filtrelenmiş yönelmelerden korumak oldukça önemlidir. Şekil 4’teki router hem OSPF hem de RIP çalıştırmaktadır.

Open Shortest Path First (OSPF) Redistribution , OSPF to RIP Redistribution ,  Routing Information Protocol (RIP) , Network , Cisco

Aşağıdaki komutlarla, OSPF Routing RIP içine yeniden dağıtılacaktır. RIP güncellemelerinde yeniden dağıtılan yönelmelerin cost’larını tayin etmek için, varsayılan metrik değerini belirtmelisiniz. RIP içine yeniden dağıtılan tüm yönelmeler, bu varsayılan metrik değerini alacaktır.

! passive interface subcommand from previous example is left out for clarity!
router rip
default-metric 10
network 130.10.0.0
redistribute ospf 109

Yeniden dağıtım(redistribution) konfigüre edildiği zaman, hangi yönelmelerini advertise edildiğinin kontrolünün sıkı sıkıya yapılması olukça iyi bir pratiktir. Aşağıdaki örnekte ‘distribute-list out’ komutu, RIP domain’inden başlatılan OSPF ‘ten gelen yönelmelerin, RIP tarafından görmezden gelinmesine yol açar.

router rip
distribute-list 10 out ospf 109
!
access-list 10 deny 130.10.8.0 0.0.7.255
access-list 10 permit 0.0.0.0 255.255.255.255

Router A: Tüm konfigürasyon aşağıdadır.

interface serial 0
ip add 130.10.62.1 255.255.255.0
!
interface serial 1
ip add 130.10.63.1 255.255.255.0
!
interface ethernet 0
ip add 130.10.8.1 255.255.255.0
!
interface tokenring 0
ip add 130.10.9.1 255.255.255.0
!
router rip
default-metric 10
network 130.10.0.0
passive-interface serial 0
passive-interface serial 1
redistribute ospf 109
distribute-list 10 out ospf 109
!
router ospf 109
network 130.10.62.0 0.0.0.255 area 0
network 130.10.63.0 0.0.0.255 area 0
redistribute rip subnets
distribute-list 11 out rip
!
access-list 10 deny 130.10.8.0 0.0.7.255
access-list 10 permit 0.0.0.0 255.255.255.255
access-list 11 permit 130.10.8.0 0.0.7.255
access-list 11 deny 0.0.0.0 255.255.255.255

ÖZET: OSPF ve RIP protokollerinin beraberce sık kullanılmasından dolayı, buradaki örnekte yer alan uygulamaların kullanımı, bir networkteki bütün protokollerin fonksiyonelliğinin kavranması açısından oldukça önemlidir. Hem RIP hem de OSPF çalıştıran bir ASB router’ı yapılandırabilirsiniz ve de RIP yönelmelerini OSPF içine yeniden dağıtabilirsiniz. Ayrıca yönelme özetlemesi(route summarization) sağlayan area border router’lar kullanarak OSPF area’ları yaratabilirsiniz. Adres alanlarını muhafaza etmek için VLSM kullanınız.

Kaynak:
http://docwiki.cisco.com/wiki/Internetwork_Design_Guide_–_RIP_and_OSPF_Redistribution
Çeviri:
İlker Yazıcıoğlu

3 yorum

  1. iproute2 ye yeni tunnel ekle çalışma modu gre olsun device ismi netb olsun, bağlanacak olduğun karşı tarafın internet ip adresi 195.174.6.140 dır. bizim internet ip adresimiz ise 85.8.5.43 dir ulaşmak için ttl ( time to live ) ise 255 dir diye tanımladık.

  2. Merhaba,

    Öncelikle çok teşekkür ederim yeni başlayan biri için çok bilgilendirici bilgiler.

    Ben bu OSPF kısmında ID yi neye göre belirliyoruz bazen kafa karıştırıyor.

    router ospf 109 yerine router ospf 17 yapsak yine çalışacaktır diyebilirmiyiz ya da ID yi neye göre veriyoruz. Teşekkür ederim.

  3. Merhaba,
    Bahsettiğiniz numara process_id numarasıdır.Process_id numarası, 1 ile 65535 arasında herhangibir sayı olabilir.Bir sıkıntı olmaz.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir