Redistribute OSPF – EIGRP

Bu makalemizde EIGRP network’lerini  OSPF’ networklerine ,  OSPF networklerini EIGRP network’lerine nasıl redistribute edebiliriz , redistribute konfigurasyonu nasıl yapılır. Bundan bahsedeceğiz.

Senaryomuz bu şekilde olsun.

Böyle bir network’te network’leri konuşturabilmek için redistribute yapabiliriz.
Normal Şartlarda Router2 de redistribute yapılmamış olsaydı Router3′ün Routing tablesinde sadece 23.1.1.0 gibi bir network görülecekti ve Router1 e ulaşamayacaktı.

Router2 ise üzerinde hem EIGRP network’leri hem de OSPF network’leri bulunmasına rağmen EIGRP network’lerini Router3′e gönderemiyordu.
Bunu engellemek için Router2′de bir dizi işlemler yapmak gerekiyor.

Bu senaryoyu ben Dynagen Dynamips üzerinde 7200 Router IOS larla gösterdim. Dilerseniz 7200 Router IOS ve Dynagen Dynamips’i sitemizdeki download link’lerinden temin edebilirsiniz.

Router1 show running-config

Router1>

Router1>enable

Router1#show running-config !

!

interface Serial1/0

ip address 10.1.1.1 255.255.255.0

serial restart-delay 0

clockrate 96000

!

!

router eigrp 10

network 10.1.1.0 0.0.0.255

no auto-summary

!

Router1#

###################

Router2#show running-config

hostname Router2

!
interface Serial1/0

ip address 10.1.1.2 255.255.255.0

serial restart-delay 0

!

interface Serial1/1

ip address 23.1.1.1 255.255.255.0

serial restart-delay 0

clockrate 96000

!

router eigrp 10

redistribute ospf 50 metric 10000 100 255 1 1500

network 10.1.1.0 0.0.0.255

no auto-summary

no eigrp log-neighbor-changes

!

router ospf 50

log-adjacency-changes

redistribute eigrp 10 subnets

network 23.1.1.0 0.0.0.255 area 0

Router2#

###################

Router3#show running-config

!

hostname Router3

!

interface Serial1/1

ip address 23.1.1.2 255.255.255.0

serial restart-delay 0

!

router ospf 100

log-adjacency-changes

network 23.1.1.0 0.0.0.255 area 0

!

end

Router3#

###################


Router1 üzerinde 23.1.1.0 network’u olmamasına rağmen EX codu ile Routing tablesine yazdığını görebiliyoruz…
Artık Router1 üzerinde OSPF çalıştırmamasına rağmen , Router3 üzerinde EIGRP çalıştırmamasına rağmen birbirleriyle görüşebilmektedir…

IGRP network’leri ile OSPF network’lerini nasıl konuşturabileceğimiz sanırım anlaşıldı…

Görüşmek üzere.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir