PPP Voip QoS (Quality of Service)

Bu makalemizde PPP Voip QoS (Quality of Service) ‘e değineceğiz.

2 adet Audiocodes Voip cihazını Merkez ve Şube arasında Bağlayalım ve bu bağlantıda ses paketlerine öncelik verelim.Merkez ve Şube arasında kullanılan teknolojiye göre konfigürasyon değişecektir.Biz Yazımızda noktadan noktaya bir yapıda konfigürasyon yapacağız.

(Merkez şube bağlantı konfigürasyonu konumuz dışında olduğu için bundan bahsedilmeyecektir). Router olarak cisco serisi,Voip cihazı olarak Audiocodes kullandım.IP Phone olarak istenilen marka kullanılabilir.

Merkez Router üzerinde adım adım konfigürasyon
1-Ilk olarak access list oluşturalım

Voiprouter(config)#access-list 155 permit udp any any

(udp protokolu kullanan herşeye izin veriyoruz.)

Voiprouter(config)#access-list 155 permit udp any any precedence critical

(Öncelik veriyoruz)

Voiprouter(config)#access-list 155 permit udp any any dscp ef

ses paketleri interface’den çıkmadan önce dscp ef kodu ile belirliyoruz.

Aslında burada paketlerin etiketlenmesi gerekiyor ama biz Voip cihazı kullandığımız için etiketleme Voip cihazı tarafından yapılıyor Eğer Router üzerinde Voice kartlar takılı olsaydı Voip cihaz kullanmayacak ve etiketlemeyi burada yapacaktı.)

Voiprouter(config)#access-list 155 permit udp host 192.168.10.200 host 192.168.20.200

2-Ses paketlerine uygulayacağımız kriterleri belirleyeceğimiz class-map’i yaratıyoruz.Konfigürasyon modunda ;

Voiprouter(config)#class-map match-all sesclass

Voiprouter(config-cmap)#

Voiprouter(config-cmap)#match access-group

(Match komutu ile neye göre uygulayacağımız belirtiyoruz)

burada bir çok seçenek mevcut ama biz örneğimizde access list’ler ile çalışacağız.Bu sebeple

Voiprouter(config-cmap)#match access-group 155

(155 numaralı extended acl oluşturuyoruz)

3-Voip chazları arasındaki sinyalleşme için class map yaratıyoruz.

Voiprouter(config)#class-map signal

(sinyalleşme için class map yaratıyoruz)

Voiprouter(config-cmap)#match access-group 105

(kullanılacak acl seçiyoruz)

Voiprouter(config)#access-list 105 permit tcp any eq 1720 any

(dışarı giden 1720 paketlerini kabul ediyoruz).

Voiprouter(config)#access-list 105 permit tcp any any eq 1720

(içeri gelen 1720 paketlerine izin veriyoruz)

4-Şimdi Policy map yaratalım ve yarattığımız class map ile ilişkilendirelim.

Voiprouter(config)#policy-map ses

(ses adında bir policy map yaratıyoruz)

Voiprouter(config-pmap)#class sesclass

(daha önce sesclass adında yarattığımız class map’i ilişkilendiriyoruz)

Voiprouter(config-pmap-c)#priority ?

(Burada istersek yüzde olarak istersek kbps olarak değer verebiliriz)

<8-2000000>  Kilo Bits per second

percent      % of total bandwidth

Voiprouter(config-pmap-c)#priority 32

(ses paketlerine 32 kbps lik öncelik veriyoruz.)

Voiprouter(config-pmap)#class signal

(sinyalleşme için yarattığımız class map’i ilişkilendiriyoruz)

Voiprouter(config-pmap-c)#bandwidth 4

(sinyalleşme için 4kbps BW veriyoruz)

5-Yarattığımız policy çıkış interface’i altına tanımlıyoruz.

Voiprouter(config)#interface serial 0

Voiprouter(config-if)#service-policy output ses

6-Yapılan konfigürayonu görmek ve izlemek için

Voiprouter#sh policy-map ses

(Bu komut ile yarattığımız policy map’in içeriğini görüyoruz)

Policy Map ses

Class ses

Strict Priority

Bandwidth 32 (kbps) Burst 800 (Bytes) (Öncelik olarak 32 kbps belirlemiştik)

Class signal

Bandwidth 8 (kbps) Max Threshold 64 (packets)

Class class-default

Flow based Fair Queueing

Bandwidth 0 (kbps) Max Threshold 64 (packets)

Voiprouter#sh policy-map interface

(Burada bu interface üzerinde uyuguladığımız policy map’a göre trafiği görüyoruz)

Serial 0

Service-policy output: ses

Class-map: ses (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 155

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 32 (kbps) Burst 800 (Bytes)

(pkts matched/bytes matched) 0/0

(Şu ana kadar bir ses iletişimi olmamış eğer olsa idi burada görecektik)

(total drops/bytes drops) 0/0

Class-map: signal (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 105

Queueing

Output Queue: Conversation 265

Bandwidth 8 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(Şu ana kadar bir sinyalleşme  olmamış eğer olsa idi burada görecektik)

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

294 packets, 25509 bytes

(bizim belirlediğimiz kriterler dışındaki iletişim.Yani ses ve sinyalleşme haricindeki iletişim)

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0

Bu konfigürasyonu Şube router’ında da yapıyoruz.

3 yorum

  1. sh policy-map interface serial0

    çıktısında yer alan

    Bandwidth 32 (kbps) Burst 800 (Bytes)

    ifadesindeki “Burst 800 (Bytes)” ne anlama geliyor. Ve bu değer nasıl ve neye göre set ediliyor

    Teşekkürler…

  2. Ellerinize Sağlık gerçekten çok faydalı bir yazı,
    Sadece ses önceliği vermek içinde tüm bu komutlar girilmelimi?

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir