OSPF LSA Type 3 Summarization

Bu makalemizde OSPF LSA Type 3 Summary ‘i anlatacagiz. Distance-Vector Routing protokollerde Network bilgilerini tasiyan update paketlerinin bir benzeri olan LSA (Link-State Advertisements)  paketi OSPF’ te topoloji ve network bilgilerini tasiyacak .

OSPF komsuluk iliskisi kuran bir Routing Protokol. Bu yüzden periyodik update paketleri atmayacak. LSA paketleri  bir degisiklik oldugunda gönderilen bir paket. Yanliz 30 dakikada bir periyodik olarakta atilir. LSA paketlerinin 11 farkli türü bulunmakta. Simdi sirayla LSA leri tek tek açiklamaya baslayalim.

LSA 1 : Ayni Area içinde bulunan komsu Router larin birbirlerine attiklari paket yapisidir. Bu paket diger area lara ulasmayacaktir. Burada yeni bir tanimla karsilasacagiz. OSPF’ in hiyerarsik yapisinda ABR  (Area Border Router) olarak adlandirdigimiz bir Router bulunmakta. ABR birden fazla Area’ ya bagli Router’ dir. LSA 1 paketi ABR den geçmeyecektir. Router LSA olarak ta adlandirlir.

LSA 2 :  Bu paket ayni Area içerisindeki DR (Designated Router) tarafindan atilir. DR seçilimi komsuluk kurulurken belirlenir. DR seçimi ortamdaki Router larin Router ID degerine bakilarak yapilir. Router ID o Router en büyük IP adresidir. Ve ortamdaki Router’ lardan IP adresi en büyük olan DR seçilir. LSA 2 paketi DR tarafindan broadcast networke gönderilir. Diger area lara geçmez yani ABR tarafindan diger area lara geçemeyecektir. Network LSA olarak ta adlandirilir.

LSA 3 :  LSA 3 paketi ABR tarafindan üretilir. Bir Area bilgisinin diger Area lara ulastirilmasinda kullanilir. örnegin Area 1 bilgisini Area0 ‘ a ulastirmk için gelen LSA1 bilgisi LSA 3 e ABR tarafindan dönüstürülür. LSA 3 Summary LSA olarak ta adlandirilir.

LSA 4 :  OSPF konusan bir Router ayni zamanda diger Routing Protokollerle de çalisabilir. Bu Router’ a ASBR (Autonomous System Boundary Router) olarak adlandirilir. ASBR router’ i diger Routing Protokolden gelen bilgileri OSPF içerisine yönlerdirebilir. Iste bu Router’ i yani ASBR Router’ini OSPF sistemindeki tüm Area lara ileten paket LSA 4 dür. Bu paket ASBR nin bulundugu  Area daki ABR tarafindan üretilir   ve ASBR nin Router ID bilgisini içeririr.

LSA 5 :  Bu paket ASBR tarafindan üretilir. OSPF sistemine diger  farkli Routing bilgilerini iletmek için kullanilir. ASBR tarafindan LSA 5 olarak üretilir ve ABR tarafindan degistirilmeden diger Area lara üretilir.

OSPF ile summarization sadece area’lar arasında ya da ASBR router’ında yapılabilir. Bu çalışmada ABR olan R2 router’ı üzerinde yapılacak konfigürasyon ile R1 ve R3 routerları üzerinde ki Loopback networklerindiğer area’ ya özetlenmesi sağlanacaktır.

Summarization yapılırken dikkat edilecek nokta kullanacağımız network adresleri ve Subnet Mask’ların özetlemek istediğimiz aralıkları kapsayacak şekilde hesaplanmasıdır.Önce Summarization yapılmadan konfigürasyonlarımıza ve R1 – R3 routerlarının Routing Table’larına bakalım. Routerların başlangıçtaki konfigürasyonları şöyle olacaktır;

R1 ve R3 Rourterlarının Routing Table’ları da şu şekilde oluşmuştur;

R1 Router’ı

R1#sh running-config
Building configuration…
hostname R1
interface Loopback0
ip address 193.168.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
ip address 193.168.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback2
ip address 193.168.3.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
ip address 10.1.1.1 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0
network 193.168.1.0 0.0.0.255 area 0
network 193.168.2.0 0.0.0.255 area 0
network 193.168.3.0 0.0.0.255 area 0
!
end
R1#

R2 Router’ı

R2#show running-config
Building configuration…

hostname R2
!
interface Serial1/0
ip address 10.1.1.5 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
ip address 10.1.1.2 255.255.255.252
serial restart-delay 0
!
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.4 0.0.0.3 area 1
!
ip classless
!
end

R2#-

R3 Router’ı

R3#show running-config
Building configuration…

hostname R3
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
ip address 192.168.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback2
ip address 192.168.3.1 255.255.255.0
ip ospf network point-to-point
!
!
interface Serial1/1
ip address 10.1.1.6 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 10.1.1.4 0.0.0.3 area 1
network 192.168.1.0 0.0.0.255 area 1
network 192.168.2.0 0.0.0.255 area 1
network 192.168.3.0 0.0.0.255 area 1
!
ip classless
end

R3#


.

R2 Routerında Summization yapıldıktan sonra

R2 OSPF konfigürasyonu ve diğer routerların routing table’ları şu şekilde oluşacaktır;

R2;
!
router ospf 1
log-adjacency-changes
area 0 range 193.168.0.0 255.255.252.0
area 1 range 192.168.0.0 255.255.252.0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.4 0.0.0.3 area 1
!

1 yorum

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir