Open Shortest Path First (OSPF) Area Tipleri

Open Shortest Path First (OSPF) Area Tipleri

OSPF de çeşitli ihtiyaçları karşılamak amacıyla farklı area tipleri tanımlanmıştır. Bu yazıda elimden geldiğince bu farklı area tiplerini tanıtmaya ve konfigürasyon örnekleri sunmaya çalıştım.

OSPF bize beş farklı area tipi sunuyor:

  • Normal Area
  • Stub Area

  • Totally-Stub Area

  • Not-So-Stubby-Area (NSSA)

  • Totally Not-So-Stubby-Area

Beş farklı area tipi için de alttaki topoloji kullanılmıştır.Topoloji GNS3 üzerinde ve 3660 IOS ile gerçekleştirilmiştir.

Normal Area

Bir area oluşturulduğunda default olarak normal area ‘dır. Area 0, sadece normal area olarak çalışır. Normal area ‘yı diğer area çeşitlerinden ayırabilmek açısından alttaki özellikleri anlamak yararlı olacaktır.

  1. Başka area ‘lardan summary LSA ‘ler kabul edilir.

  2. External LSA ‘ler kabul edilir.
  3. Default LSA ‘ler (default route) kabul edilir.

NOT: Area 0, stub veya nssa olarak tanımlanamaz.

R2(config-router)#area 0 nssa

OSPF: Backbone can not be configured as NSSA area

R2(config-router)#area 0 stub

OSPF: Backbone can not be configured as stub area

Altta R1, R2 ve R3 ve R4’ün konfigürasyonları bulunmaktadır. Burada area 1 için farklı bir area type tanımlanmadığı için area 1 de normal area ‘dır.

R1

interface Loopback0

ip address 50.50.50.50 255.255.255.255

!

interface Ethernet0/0

ip address 10.10.10.1 255.255.255.0

!

router ospf 1

router-id 1.1.1.1

network 50.50.50.50 0.0.0.0 area 0

network 0.0.0.0 255.255.255.255 area 0

R2

interface Ethernet0/0

ip address 10.10.10.2 255.255.255.0

!

interface Ethernet0/1

ip address 20.20.20.1 255.255.255.0

!

router ospf 1

router-id 2.2.2.2

network 10.10.10.0 0.0.0.255 area 0

network 20.20.20.0 0.0.0.255 area 1

R3

interface Ethernet0/0

ip address 30.30.30.1 255.255.255.0

!

interface Ethernet0/1

ip address 20.20.20.2 255.255.255.0!

!

router eigrp 1

redistribute ospf 1 metric 150 10 200 200 1500

network 30.30.30.0 0.0.0.255

no auto-summary

!

router ospf 1

router-id 3.3.3.3

log-adjacency-changes

redistribute eigrp 1 metric 50 subnets

network 20.20.20.0 0.0.0.255 area 1

R4

interface Loopback0

ip address 40.40.40.40 255.255.255.255

!

interface Ethernet0/0

ip address 30.30.30.2 255.255.255.0

!

router eigrp 1

network 30.30.30.0 0.0.0.255

network 40.40.40.40 0.0.0.0

no auto-summary

Bu konfigürasyonlar sonucunda area 1 ‘de bulunan R2 ve R3 üzerinde route tablolarına bakalım.

R2#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

O 50.50.50.50 [110/11] via 10.10.10.1, 00:21:30, Ethernet0/0

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

40.0.0.0/32 is subnetted, 1 subnets

O E2 40.40.40.40 [110/50] via 20.20.20.2, 00:16:59, Ethernet0/1

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

O E2 30.30.30.0 [110/50] via 20.20.20.2, 00:16:59, Ethernet0/1

Görüldüğü gibi area 1 external LSA (bu örnekte EIGRP) dediğimiz route’ları kabul etmiştir. Bu route ‘lar E2 yani external type-2 olarak görünmektedir. Diğer özellikleri ise R3 üzerinden gözlemleyebiliriz.

R3#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

O IA 50.50.50.50 [110/21] via 20.20.20.1, 00:19:59, Ethernet0/1

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

40.0.0.0/32 is subnetted, 1 subnets

D 40.40.40.40 [90/409600] via 30.30.30.2, 00:26:00, Ethernet0/0

10.0.0.0/24 is subnetted, 1 subnets

O IA 10.10.10.0 [110/20] via 20.20.20.1, 00:19:59, Ethernet0/1

30.0.0.0/24 is subnetted, 1 subnets

C 30.30.30.0 is directly connected, Ethernet0/0

IA yani Inter-area olarak görünen route’lar summary LSA olarak belirttiğimiz OSPF type-3 ve type-4 route’lardır.

Burada üçüncü madde olarak yazdığımız default route ‘u görmüyoruz. Fakat R2 üzerinde, ospf process’i altında “default-information originate always” komutunu kullanırsak default route da görünecektir.

Buraya kadar OSPF backbone area dışındaki bir area ‘nın default davranışını incelemiş olduk. Bir sonraki adımda ise stub area ‘yı inceleyeceğiz.

Stub Area

Area 1 stub olarak ayarlandığında external LSA ‘leri kabul etmeyecektir. Yani bu örnekteki EIGRP route’larını almayacaktır. Daha önce kabul ettiği summary LSA’leri ise kabul etmeye devam edecektir. Ayrıca area 1, area 0’dan bir de default route kabul edecektir (R2 ‘de default-information originate komutu bulunmamasına rağmen). Özetleyecek olursak;

  1. Summary LSA ‘ler kabul edilir.

  2. Backbone area’dan default route kabul edilir.

  3. External LSA ‘ler kabul edilmez.

Konfigürasyona bakacak olursak;

R2

router ospf 1

area 1 stub

R3

router ospf 1

area 1 stub

NOT: Bir router üzerinde area 1 stub komutu girildiği anda, o area’daki diğer router ‘lar ile komşuluk düşer. Çünkü area’nın stub yapılması Hello paketinde değişikliğe neden olur. Hello paketleri uyuşmayacağı için komşuluk düşer. Area 1 ‘deki diğer router üzerinde de stub tanımı yapıldığında komşuluk tekrar kurulur.

Bu konfigürasyonlar sonucunda area 1 ‘de bulunan R2 ve R3 üzerinde route tablolarına bakalım.

R2#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

O 50.50.50.50 [110/11] via 10.10.10.1, 00:00:42, Ethernet0/0

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Ethernet0/0

Görüldüğü üzere R2’nin route tablosunda hiçbir external route bulunmamaktadır.

R3#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

O IA 50.50.50.50 [110/21] via 20.20.20.1, 00:04:45, Ethernet0/1

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

40.0.0.0/32 is subnetted, 1 subnets

D 40.40.40.40 [90/409600] via 30.30.30.2, 01:03:31, Ethernet0/0

10.0.0.0/24 is subnetted, 1 subnets

O IA 10.10.10.0 [110/20] via 20.20.20.1, 00:04:45, Ethernet0/1

30.0.0.0/24 is subnetted, 1 subnets

C 30.30.30.0 is directly connected, Ethernet0/0

O*IA 0.0.0.0/0 [110/11] via 20.20.20.1, 00:04:45, Ethernet0/1

R3 ‘ün route tablosuna baktığımızda, normal area iken aldığı 50.50.50.50/32 ve 10.10.10.0/24 için route ‘ları almıştır. Ayrıca bir de default route almış olduğunu görüyoruz.

Totally-Stub Area

Totally-stub area stub area’nın bir formudur. Stub area ‘dan tek farkı stub area’ya ek olarak summary LSA’leri kabul etmemesidir.

Totally-stub konfigürasyonu yapılması Hello paketlerindeki stub kısmına etki etmez.Bu yüzden area 1 ‘deki bütün router’larda yapılmasına gerek yoktur. Summary LSA sadece backbone area ‘dan alındığı için bu örnekte ABR(Area Border Router) olan R2 üzerinde konfigürasyon yapılması yeterlidir.

R2

router ospf 1

area 1 stub no-summary

Bu konfigürasyon sonucu R2 ve R3 üzerinde route tabloları şu şekilde oluşur;

R2#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

O 50.50.50.50 [110/11] via 10.10.10.1, 00:00:07, Ethernet0/0

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Ethernet0/0

Görüldüğü gibi R2 ‘nin route tablosunda birşey değişmemiştir. Yani external LSA ‘ler ile ilgili bir etki yaratmamıştır.

R3#sh ip route

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

40.0.0.0/32 is subnetted, 1 subnets

D 40.40.40.40 [90/409600] via 30.30.30.2, 01:15:09, Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

C 30.30.30.0 is directly connected, Ethernet0/0

O*IA 0.0.0.0/0 [110/11] via 20.20.20.1, 00:01:10, Ethernet0/1

R3 ‘ün route tablosuna baktığımızda ise 50.50.50.50/32 ve 10.10.10.0/24 route ‘larının artık route tablosunda olmadığını sadece default route kabul edilmdiğini görüyoruz.

NSSA (Not-So-Stubby-Area)

Stub bir area’ya external LSA ‘lerin giremediğini önceki kısımlarda yazmıştım. Bu örnek için düşünürsek EIGRP redistribution ile alınması gereken route’lar stub area’ya girmiyordu. NSSA ile bu durumun üstesinden gelinebilir.

Area 1 NSSA yapıldığında, area 0’dan summary LSA’leri almaya devam eder. Stub area’dan farklı olarak ise default route almaz. Fakat bu default route alamayacağı anlamına gelmiyor. OSPF process’i altında nssa tanımına default-information-originate keyword’ü eklenerek default route gönderilmesi de sağlanabilir.

Area 1 NSSA yapıldıktan sonra external LSA’leri kabul edecektir. Yani bu örnekteki EIGRP redistribution ile gelen route’lar area 1 ‘e girebilecektir. Normal external route ‘lar OSPF LSA Type-5 olarak adlandırılır. Aslına bakılırsa NSSA area da Type-5 LSA’leri kabul etmemektedir. Type-5 LSA’ler NSSA içerisine Type-7 LSA olarak girer ve NSSA içerisinde bu şekilde taşınır. Type-7 LSA ‘ler üzerinden route tablosuna yazılan route’lar N1 veya N2 olarak görünür.

NOT: E1 – E2 ve N1- N2 arasındaki fark makalenin en sonunda açıklanmıştır.

NSSA area’nın external olarak aldığı bu Type-7 LSA’ler sadece NSSA içerisinde iletilir. Backbone area’ya gönderileceği zaman ABR üzerinde Type-7to5 dönüşümü yapılır ve bu route’lar area 0’ya Type-5 olarak girer.

NOT: Yukarıda NSSA’in default route almadığını (kabul etmediği değil, sadece almadığı) yazmıştım ve ABR üzerinde nssa tanımına default-information-originate keyword’ü eklenerek NSSA içerisine default route inject edilebileceğini yazmıştım. Bu default route da NSSA içerisine Type-7 olacak girecektir ve N1 veya N2 olarak gözükecektir.

R2

router opsf 1

area 1 nssa

R3

router ospf 1

area 1 nssa

Üstteki komutlarla area, NSSA haline getirilir. Her iki router’da da area type’larını aynı hale getirmeden komşuluk ilişkisinin kurulamayacağını unutmamak gerekir.

Öncelikle area 0 ile ilişkiyi incelemek için R3’ün route tablosuna bakalım:

R3#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

O IA 50.50.50.50 [110/21] via 20.20.20.1, 00:00:09, Ethernet0/1

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

40.0.0.0/32 is subnetted, 1 subnets

D 40.40.40.40 [90/409600] via 30.30.30.2, 00:01:25, Ethernet0/0

10.0.0.0/24 is subnetted, 1 subnets

O IA 10.10.10.0 [110/20] via 20.20.20.1, 00:00:09, Ethernet0/1

30.0.0.0/24 is subnetted, 1 subnets

C 30.30.30.0 is directly connected, Ethernet0/0

Görüldüğü üzere 50.50.50.50/32 ve 10.10.10.0/24 Inter-area route olarak route tablosundaki yerlerini almışlar. Şimdi buna bir de default-route ekleyelim:

R2

router opsf 1

area 1 nssa default-information-originate

R3#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

O IA 50.50.50.50 [110/21] via 20.20.20.1, 00:04:32, Ethernet0/1

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

40.0.0.0/32 is subnetted, 1 subnets

D 40.40.40.40 [90/409600] via 30.30.30.2, 00:12:53, Ethernet0/0

10.0.0.0/24 is subnetted, 1 subnets

O IA 10.10.10.0 [110/20] via 20.20.20.1, 00:04:32, Ethernet0/1

30.0.0.0/24 is subnetted, 1 subnets

C 30.30.30.0 is directly connected, Ethernet0/0

O*N2 0.0.0.0/0 [110/1] via 20.20.20.1, 00:00:11, Ethernet0/1

Görüldüğü gibi diğer route’ların yanında bir de default route area 1 içerisine inject edilmiştir ve bu default route da N2 (yani Type-7 LSA) olarak görünmektedir.

NOT: Ospf process’i altında yazılan default-information originate komutu farklıdır. Bu örnekte işe yaramayacaktır.

Şimdi de external LSA’lerin durumuna bir göz atalım. Bunun için de R2’nin route tablosuna bakmalıyız.

R2#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

O 50.50.50.50 [110/11] via 10.10.10.1, 00:48:05, Ethernet0/0

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

40.0.0.0/32 is subnetted, 1 subnets

O N2 40.40.40.40 [110/50] via 20.20.20.2, 00:48:05, Ethernet0/1

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

O N2 30.30.30.0 [110/50] via 20.20.20.2, 00:48:05, Ethernet0/1

Görüldüğü gibi EIGRP ‘den redistribution ile alınan 30.30.30.0/24 ve 40.40.40.40/32 route’ları , route tablosuna girmiştir ve N2 olarak görülmektedir.

Type-7 olarak NSSA içinde iletilen LSA’lerin backbone area’ya geçerken Type-5’e çevrileceğini söylemiştik. Bunun için de R1’in route tablosunda 30.30.30.0/24 ve 40.40.40.40/32 E2 olarak gözükecektir.

R0#sh ip route

50.0.0.0/32 is subnetted, 1 subnets

C 50.50.50.50 is directly connected, Loopback0

20.0.0.0/24 is subnetted, 1 subnets

O IA 20.20.20.0 [110/20] via 10.10.10.2, 00:55:48, Ethernet0/0

40.0.0.0/32 is subnetted, 1 subnets

O E2 40.40.40.40 [110/50] via 10.10.10.2, 00:55:42, Ethernet0/0

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

O E2 30.30.30.0 [110/50] via 10.10.10.2, 00:55:42, Ethernet0/0

NSSA-Totally

NSSA-Totally, NSSA ‘in bir formudur. NSSA ‘den tek farkı Type-3 ve Type-4 summary LSA ‘leri kabul etmez. Bunlar yerine bir default route alır. Bu default route’un alınması için ABR’da default-information-originate keyword’ünün kullanılmasına gerek yoktur. Default route, NSSA-Totally’de varsayılan bir davranıştır. Bu default route, öncekinden farklı olarak N2 değil, IA(inter-area) olarak görünür.

NSSA-Totally, aynı totally-stub gibi sadece ABR üzerinde tanımlandığında yeterlidir. Çünkü NSSA_Totally de Hello paketlerinin içeriğini değiştirmeyeceği için komşuluk ilişkisini etkilemez.

R2

router ospf 1

area 1 nssa no-summary

R3#sh ip route

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/1

40.0.0.0/32 is subnetted, 1 subnets

D 40.40.40.40 [90/409600] via 30.30.30.2, 01:07:45, Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

C 30.30.30.0 is directly connected, Ethernet0/0

O*IA 0.0.0.0/0 [110/11] via 20.20.20.1, 00:00:09, Ethernet0/1

R2 ‘nin route tablosu ise değişmeyecektir.

NOT: Route tablosundaki route’ların E1, N1 veya E2,N2 olarak görünmesi OSPF metric-type ile ilgilidir. Type-1 metric type ‘da route, dışarıdan OSPF içerisine girdikten sonra OSPF domain içinde iletilirken, iletildiği yolların cost’larını alarak iletilir. Yani OSPF domain içindeki her router üzerinde o route için metric(cost) farklı olabilir.

Type-2 metric’de ise OSPF içine girerkenki metric ne ise aynen kalır ve yollar boyunca değişmez. OSPF için default metric type Type-2’dir. Yukarıdaki örneklerde aksi belirtilmediği için sadece E2 ve N2 görünmüştür.

Yazar: Özgür GÜLER

6 yorum

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir