L2 Transport ve L2VPN

Layer 2 Protocol Tunneling (L2PT) ve Cisco Layer 2 VPNs (L2VPN)

Bu makalemizde L2TP / L2VPN nedir ve neden kullanılır anlatmaya çalışacağım.

Öncelikle bir kaç kavramı açıklamaya çalışayım;

VLL (E-Line) : Virtual Lease Line (Point to Point)
VPLS (E-LAN) : Virtual Private Lan Server (Point/Multipoint to Multipoint)
L2TP : Layer 2 Tunnel Protocol (Point to Point)
Pseudowire : Tunellerin genel ismidir.
VPWS : Virtual Private Wire Service -> VLL ve L2TP yi kapsamaktadır.

Virtual Private Wire Services (VPWS) , VPN , L2TP , L2VPN, MPLS

L2TP ile taşıyabileceğimiz protocoller: Frame Relay,  Ethernet,  802.1q, HDLC, PPP

VLL ve VPLS, altyapının MPLS olduğu networklerde kullanılır.
L2TP ise altyapının IP olduğu networklerde kullanılır.
IP/MPLS dediğimizde aslında anlamamız gereken IP ve MPLS teknolojisinin aynı anda kullanılmasıdır. Yani yapımızda hem VLL’ ler hemde L2TP protokolünü kullanan tuneller olabilir.

Frame Relay, Ethernet, 802.1q, HDLC, PPP , Network , VPN , Cisco

L2TP Header:
L2TP Header , VPN , MPLS , Switch , Router , Cisco , CCNA , Network

Session id : Session idler unique olmak zorundadır. Manuel olarak konfigure edilebilir.
Cookie : Encapsulation paket tipine göre 0,4 ve 8 byte olarak kullanılır. Manuel olarak konfigure edilebilir.
PW CE : L2TP paketlerinin numaralarını tutar.

L2TP protokolünü 2 amaç için kullanabiliriz.

1- Kapalı devre: ISP nin bizim routingimize karışmasını istemedigimiz durumlarda. Kapalı devre yapısında, genelde operatorler MPLS protokolü kullandığından VLL VPLS gibi protokolleri daha cok kullanırlar. Ancak MPLS kullanmayan operatorler L2 kapalı devre servisi verebilmek için mecburen L2TP protokolünü kullanmak zorundadırlar.
Örneğin : 4 adet lokasyonum var hepsini merkezi bir lokasyonda toplayarak tek bir yerden internete çıkarmak istiyorum. Bunu L3VPN ile de yapabilirim ancak internet ortamına çıkmış olurum. L2VPN de ise direk operator altyapısından haberleşebilirim. Bu sayede hem stabilite (qos ve drop gibi) hem de bilgi güvenliği özelliklerini maximize etmiş olurum. Eğer altyapımız MPLS olsaydı bunu VLL ile yapardım.

2- Daha yaygın olarak kullanım şekli ise, xDSL operatorlerinin L2TP protokolünü kullanarak IP/MPLS networklerinde ppp sessionunu L2 olarak taşırlar. (desteklenen protokollerden herhangi birisi L2 olarak taşınabilir)
Örneğin : Farklı illerdeki abonelerimizi L2 olarak merkezi bir yere toplayarak authentication yaptırmak ve sonrasında success ise ip adresi atamak veya unsuccess durumunda ise http-redirect ederek ”kullanıcı isminiz hatalı” yazan bir web sayfasına yönlendirmek için kullanabilirim.

LAC (L2TP Access Concentrator) : PPP oturumu için L2TP Tünelin başlatıldığı cihazın ismidir.
LNS (L2TP Network Server) : PPP oturumu için L2TP Tünelin sonlandırıldığı cihazın ismidir.
L2TP Tunnel Switch (LTS) : PPP oturumu için L2TP tünelinin LNS’den sonra başka bir LNS’e uzatılması durumudur.

Cisco , Network , CCNA , CCNP , Router , Switch , Firewall

 

LAC ile LNS Arasındaki Haberleşme;

L2TP , L2VPN , VPN , MPLS , Cisco , Network , CCNA , Router , Switch

SCCRQ: Start-Control-Connection-Request SCCRP: Start-Control-Connection-Reply
SCCCN: Start-Control-Connection-Connected

ICRQ : Incoming-Call-Request ICRP : Incoming-Call-Reply
ICCN : Incoming-Call-Connected ZLB ACK : Zero-Length Body Ack

CDN : Call-Disconnect-Notify
Stop CCN : Stop-Control-Connection-Notification

L2TP tunelin UP/Down bilgilerinin snmp ile alabilmemiz için “snmp-server enable traps l2tun session” komutunu aktif etmemiz gerekmektedir.

L2TP tunellerini static ve dinamik olarak tanımlayabiliriz.
•Statik L2TP Session (nonnegotiated)
•Dinamik L2TP Session (negotiated)
Ben dinamik bir kapalı devre örnegi yapacagım;

Dinamik L2TP tunel adımları:
1. Enable Cisco Express Forwarding (CEF).
2. Configure loopback interfaces.
3. Configure the L2TP class.
4. Configure the pseudowire class.
5. Configure the attachment circuits.
1. ip cef [distributed]

2. interface loopback0
ip address 10.1.1.1 255.255.255.255

3. l2tp-class ciscotrv3
authentication
password 0 cisco

4. pseudowire-class ciscotrpw
encapsulation l2tpv3
protocol l2tpv3 ciscotrv3
ip local interface loopback0

5. interface gigaEthernet1/0
xconnect 10.1.1.2 150 pw-class ciscotrpw
L2TP , L2VPN, Cisco , CCNA , CCNP , Router , Switch , Network , MPLS

LAB ÇALIŞMASI:

R1: PE1
R2: P
R3: PE2
R4: CUST1
R5: CUST2

L2TP , L2VPN , MPLS , Cisco , Router ,Switch , Network , CCNA , CCNP

PE1
hostname PE1
!
ip cef
!
l2tp-class ciscotrv3
authentication
password 7 104D000A0618
!
!
pseudowire-class ciscotrpw
encapsulation l2tpv3
protocol l2tpv3 ciscotrv3
ip local interface Loopback0
!
interface Loopback0
ip address 100.0.0.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 100.0.0.3 10 pw-class ciscotrpw
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0

P

hostname P
!
ip cef
!
interface Loopback0
ip address 100.0.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.6 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!

PE2

!
hostname PE2
!
ip cef
!
!
l2tp-class ciscotrv3
authentication
password 7 060506324F41
!
!
pseudowire-class ciscotrpw
encapsulation l2tpv3
protocol l2tpv3 ciscotrv3
ip local interface Loopback0
!
!
interface Loopback0
ip address 100.0.0.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 100.0.0.1 10 pw-class ciscotrpw
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!

CUST1

hostname Cus1
!
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 0.0.0.0
no auto-summary

CUST2

hostname Cus2
interface Loopback0
ip address 172.16.1.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 0.0.0.0
no auto-summary

Ekran çıktıları:

CUST1’in route çıktısında CUST2 ile  Eigrp komşuluğu kurduğu ve loopbacke erişelebildigi görünmektedir.

L2TP , L2VPN  , MPLS , Cisco , Router , Switch , Firewall , Network , CCNA , CCNP
CUST2’in route çıktısında CUST1 ile eigrp komşuluğu kurduğu ve loopbacke erişelebildigi görünmektedir.

L2TP , L2VPN  , MPLS , Cisco , Router , Switch , Firewall , Network , CCNA , CCNP

R2 görüldüğü üzere sadece routing yapmaktadır.

L2TP , L2VPN  , MPLS , Cisco , Router , Switch , Firewall , Network , CCNA , CCNP

State durumunun establish olduğu görünmektedir.

L2TP , L2VPN  , MPLS , Cisco , Router , Switch , Firewall , Network , CCNA , CCNP

L2TP , L2VPN  , MPLS , Cisco , Router , Switch , Firewall , Network , CCNA , CCNP

Tunelin up ve hangi router/ipler arasında kurulduğu olduğu görünmektedir.

L2TP , L2VPN  , MPLS , Cisco , Router , Switch , Firewall , Network , CCNA , CCNP

L2TP , L2VPN  , MPLS , Cisco , Router , Switch , Firewall , Network , CCNA , CCNP

L2TP , L2VPN  , MPLS , Cisco , Router , Switch , Firewall , Network , CCNA , CCNP

Kaynaklar :

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t2/feature/guide/gtl2tpv3.html#wp1042673
http://mpls-configuration-on-cisco-ios-software.org.ua/1587051990/ch10lev1sec3.html

 

BARIŞ GENÇ
CCIE 27940
CCSI 33089
www.cliguru.com

 

8 yorum

  1. Barış Bey, Gerek işletmelerde çalışanlar gerekse sınavlara hazırlananlar için bu gibi makaleler çok faydalı olmaktadır.
    Emeğinize sağlık teşekkür ederiz.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir