IP Accounting Nedir – Ip Accounting Konfigurasyonu

Bu makalemizde IP Accounting Nedir?  Ip Accounting Konfigurasyonu nasıl yapılır buna değineceğiz.

IP ACCOUNTING:
ip accounting systemden gecen byte leri ve nekadar pacet switch edildigini source ve destination ip addreslerini gosteren bir management servisidir.
eger access-vialotion keyword kullanilmissa yapilan yasa disi access denemelerinide gosterir. (destination ve source addreslerle birlikte)

ip accounting Temel Konfigurasyonu ———————–>

R4#
!
interface Ethernet0/0
ip address 155.1.146.4 255.255.255.0
ip accounting output-packets
half-duplex
!

Test :
R5 a gidip r6 telnet ve r1 ping edelim sonrada r4 a gidip show command ile verify edelim.

R5#
R5#ping 155.1.146.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 155.1.146.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms
R5#telnet 155.1.146.1
Trying 155.1.146.1 … OpenR1>exit

[Connection to 155.1.146.1 closed by foreign host]
R5#


R4#sh ip accounting
Source Destination Packets Bytes
155.1.45.5 155.1.146.1 18 760
155.1.45.5 155.1.146.6 5 500Accounting data age is 2
R4#sh ip accounting ou
R4#sh ip accounting output-packets
Source Destination Packets Bytes
155.1.45.5 155.1.146.1 18 760
155.1.45.5 155.1.146.6 5 500

Accounting data age is 2

Access violation———————–>
Access yasaginin kirilmasi

R4#
!
interface Ethernet0/0
ip address 155.1.146.4 255.255.255.0
ip access-group 100 out
ip accounting output-packets
ip accounting access-violations
half-duplex
!

!
access-list 100 deny tcp any host 155.1.146.1 eq telnet
access-list 100 deny tcp any host 155.1.146.6 eq telnet
access-list 100 permit ip any any
!

Test :
Yine R5 a gidip R1 ve R6 yi telnet yapalim ve show command ini kullanarak verify edelim

R5#
R5#telnet
R5#telnet 155.1.146.1
Trying 155.1.146.1 …
% Destination unreachable; gateway or host downR5#telnet 155.1.146.6
Trying 155.1.146.6 …
% Destination unreachable; gateway or host down

R5#ping 155.1.146.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 155.1.146.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms
R5#

R4#sh ip accounting access-violations
Source Destination Packets Bytes ACL
155.1.45.5 155.1.146.1 6 544 100
155.1.45.5 155.1.146.6 1 44 100Accounting data age is 9

R4#

Precedence base ip accounting———————->
Quality service için precedence base ip accounting

R4#sh run int e0/0
Building configuration…Current configuration : 208 bytes
!
interface Ethernet0/0
ip address 155.1.146.4 255.255.255.0
ip accounting output-packets
ip accounting precedence input
ip accounting precedence output
ip accounting access-violations
half-duplex
end
!

Test :

Şimdi R5 a gidip r1 i telnet yapalim, ve show  tech-support command i ile traffic yaratalim R1 da, ve R4 e gidip show commandi ile verify yapalim.

R5#telnet 155.1.146.1
Trying 155.1.146.1 … Open

R1>en
Password:

R1#sh tech-support page
—traffic yaratalim—>

R4#sh interfaces e0/0 precedence
Ethernet0/0
Input
Precedence 6: 103 packets, 23485 bytes
Output
Precedence 6: 146 packets, 8178 bytes
R4#

MAC address ip accounting————–>
interfacede gorulen mac addressleri
R4#sh run int e0/0
Building configuration…
Current configuration : 275 bytes
!
interface Ethernet0/0
ip address 155.1.146.4 255.255.255.0
ip accounting output-packets
ip accounting mac-address input
ip accounting mac-address output
ip accounting precedence input
ip accounting precedence output
ip accounting access-violations
half-duplex
end
R4#

TEST

r5 a gidip r1 yi ping edelim ve r4 gidip show command ile verify yapalim

R5#ping 155.1.146.1Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 155.1.146.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 m


R4#sh interfaces e0/0 mac-accounting
Ethernet0/0
Input (511 free)
00b0.647d.d520(92 ): 10 packets, 1140 bytes, last: 192893ms ago
Total: 10 packets, 1140 bytes
Output (510 free)
0100.5e00.0009(86 ): 7 packets, 462 bytes, last: 14148ms ago
00b0.647d.d520(92 ): 5 packets, 570 bytes, last: 192897ms ago
Total: 12 packets, 1032 bytes

———->clear <————–
R4#sh ip accounting
Source Destination Packets Bytes
155.1.45.5 155.1.146.1 18 760
155.1.45.5 155.1.146.6 5 500
Accounting data age is 28

R4#sh ip accounting access-violations
Source Destination Packets Bytes ACL
155.1.45.5 155.1.146.1 211 8944 100
155.1.45.5 155.1.146.6 1 44 100
Accounting data age is 28


R4#clear ip accounting

R4#sh ip accounting
Source Destination Packets Bytes
Accounting data age is 0
R4#sh ip accounting access-violations
Source Destination Packets Bytes ACL

Accounting data age is 0


2 yorum

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir