Cisco IOS Kullanımı ve Temel Router Konfigurasyonları

Cisco IOS Kullanımı ve Temel Router Konfigurasyonları

IOS yani – internetwork operation system – adındanda anlaşılacağı gibi işletim sistemi. Peki işletim sistemi nedir ? Kendi tabirimce ifade edersem bir anakart üzerine direk monte edilerek yada soketler yardımıyla kurulmuş elektronik devre topluluğunu yine bu devre üzerindeki işlemci (CPU) yardımıyla yönetmeyi sağlayan yazılım (software) paketidir. Her ne kadar ağımızda biz donanım kısmını görsekte aslında onlara iş yaptıran yani paketleri denetlettiren, yönlendirme işini gördüren software kısmıdır.

Tabi ki aklınıza şu soru gelebilir “ Ne yani IOS olmadan bu iş olmaz mı? ” . Cevap olarak size evet derim ancak kısmen evet. Eğer bu yazıyı okuyacak kadar network bilgisine sahipseniz OSI Referans modelini (OSI) duymuşsunuzdur ) ios ‘lar olmasaydı en fazla bu hardware lerin yapacağı iş layer 2 seviyesinde olurdu ki orada bile switchi göz önünde bulundurunca yine software olayına giriyoruz neden mi çok açık çünkü Switchler de kendi işlerini görmek için bir MAC (Media Access Control) table oluşturmak zorundadır ve bir karar mekanızması oluşturmalıdır onuda chiplerin içine yazılmış olan yazılımlar halleder.

IOS yani baştada dediğim gibi internetwork operation system tabi Cisco kendi yazılımını IOS olarak adlandırır diğer firmalar farklı isim verebilirler mesela Juniper JunOS dediği gibi..

İşletim sistemleri genelde iki çekirdeksel yapıya sahiptir ki bunlara tabanda denilir. Unix tabanlı ve DOS tabanlı işletim sistemleri. Kısa bilgi olarak DOS tabanlı işletim sistemleri windows işletim sistemleridir. Unix tabanlı işletim sistemleri ise duymuşsunuzdur Linux ( türevleri ) sistemleridir. İkisi arasında ki en büyük fark Unix tabanlı işletim sistemlerinin daha kararlı çalışması ve açık kodlu olmasıdır ki IOS larda bu tabanda yazılmıştır. Bir şirket Network sisteminin devamlı ve kararlı çalışmasını ister unix tabanı seçilmesinin sebebinden birisi budur diğeri açık yazılım olmasıdır istediğiniz gibi geliştirebilirsiniz.


Bu kadar tanıtımdan sonra dersimize geçelim artık ilk başta sizlere IOS ların isimlerinin anlamlarından bahsedeyim. Örnek olarak “ c3640-jk9o3s-mz.123-14” genel bir bilgi verelim J yoksa IOS ne işe yarar nerden bilecez işimize yarayanı seçmek lazım J

En başta ki  “c3640” olan kısım bize cihazımızın platformunu gösterir ikinci kısım yani “jk9o3s” kısım IOS un ne gibi özelliklere sahip olduğunu gösterir “mz” kısmı sıkıştırma türünü “123-14” kısmı versiyonunu gösterir.

Cisco ios Özellikleri Tablomuz :

——————————–

y              :ip

7              :adsl

s              :plus

o              :firewall

v              :voice

k9             :IPSEC 3 DES , 64  bit üzeri  encryption

k8             :IPSEC  56  , 64  bit  veya  alti  encryption

3               :IDS

n              :IPX

br2            :AT / IBM

a              :APPN

j              :ENTERPRISE

a3            :SNA  SOFTWARE

Genel olarak IOS isimlerinden anlayacağımız bu şekilde.

Şimdi isterseniz IOS un kullanımı hakkında bilgi edinelim ve bir kaç basit ama işimize her zaman yarayabilecek konfigurasyonları öğrenelim.

Genel olarak IOS larda user, privileged ve global configuration diye 3 modda çalışırsınız fakat sub yani alt modlarda bulunur. Şematik olarak modlarımızı görelim ve daha sonra bunları tanımlayalım.

ios_modes

Router imiz ilk açıldığında eğer önceden bir konfigurasyon yapılıp kaydedilmemişse bize şu soruyu sorar :

“ Continue with configuration dialog? [yes/no]: ”

eğer “yes” dersek bize bazı basit konfigurasyonları yapmamıza yardımcı olur, “no” dersek direk olarak User mode’ a düşmüş oluruz.

USER Mode : Bu modda yapacaklarımız oldukça kısıtlıdır. Etkin olarak konfigurasyonlarımızı burada yapmaya imkan sağlamaz. Bu modu eğer domain de yapacakları kısıtlanmış bir kullanıcı hesabı gibi düşünebilirsiniz. Konfigurasyon yapmak için priviledge mode ye düşmelisiniz. Bu moddayken imlecin yanıp söndüğü satırdaki imlecin hemen sol tarafındaki işaret (promt)” > ” bu şekilde görünür. Unutmayın modlarda dikkat etmeniz gereken yer işaretin(promt) olduğu yerdir. Çünkü işaretimizden önceki kısımda (hostname) değişiklik olabilir. Örneğin ;

Router >

Ankara >

Istanbul >

PRIVILEDGE Mode : Eğer bu moda düşmüşseniz artık cihazımızın Administrator u (yönetici) olmuşsunuz demektir. Çünkü bu modda iken global configurtion ve alt modlara geçebilir yapılan konfigurasyonu silebilir, yada konfigurasyınları değiştirebilirsiniz. Yine bu moddayken işaretimize (promt) dikkat ediyoruz. Priviledge modda işaretimiz “ diyez ” yani   “ # ” bu şekilde olmalıdır. Örnek verirsek;

Router #

Ankara #

Istanbul #

Priviledge mod a nasıl düşeceğimizi dersimizin ilerki kısımlarında “Basic Configuration” kısmında bahsedicez.

GLOBAL CONFIGURATION Mode : Konfigurasyon yaparken en çok kullanacağınız mod hiç kaçınılmaksızın “global configuration mode” olacaktır. Bu moddayken işaretçimiz de biraz değişiklik olacak yani yeni bir eklenti olacak görünümü de bu şekilde “(config)#” olacak. Yine bir örnekle gösterelim ;

Router (config)#

Ankara (config)#

Istanbul (config)#

Access-list, interface, vlan, routing gibi konfigurasyonları yapmak için öncelikle global configuration modda düşmelisiniz. Yine ilerki bölümlerde buraya nasıl düşeceğimizi göreceğiz.

Basit Konfigurasyonlar (Basic Configuratios):

Öncelikle IOS ların unix tabanlı olmasının konfigurasyonda bize ne gibi yarar sağladığını görelim.

Hangi komutu gireceğimiz bir an aklımıza gelmedi yapmamız gereken tek şey “ ? ” komutunu girmek karşımıza gelen listede, bulunduğumuz mod ile girilebilecek komutlar ve komutların açıklaması bulurnur.

Router>?

Exec commands:

access-enable    Create a temporary Access-List entry

access-profile   Apply user-profile to interface

call             Voice call

clear            Reset functions

–More—-

Soru işaretini girdiğimiz her hangi bir karakterle ilgili komut bulunup bulunmadığını görmek içinde kullanabiliriz. Mesela “a” karakteriyle ilgili user modda hangi komutlar varmış bakalım ;

Router>a?

access-enable  access-profile

İlla komutun tamamını girmeniz gerekmez sadece IOS un onu tanıyacağı şekilde yazsanız bile komutunuz kabul görecektir. Mesela user moddayız ve priviledge moda düşmek istiyoruz yapmamız gereken “enable” komutunu vermek. Uzun uzadıya yazmaya gerek yok “en” yazmamız bize yeterlidir çünkü “e” ile başlayan 2 komut var “enable ve exit” bizim için “en” yazmak yeterli olacaktır.

Router>e?

enable  exit /*– modda e karakteri ile bağlayan komutlar

Router>en

Router#

Yok ben komutumu tam görmek isterim derseniz “TAB” tuşu sizin için biçilmiş kaftandır ama yine biraz önceki kuralımız geçerlidir yani bulunduğunuz modda o karakterle başlayan tek komut olması yoksa “TAB” tuşuna istediğiniz kadar basın değişiklik aşağıdaki gibi olur;

Router>e /*-–TAB–

Router>e /*-–TAB–

Router>en /*–TAB–

Router>enable

NOT: Belirtmekte faydalı gördüğüm birşey var ki “TAB” sadece komutlar içindir komutlara özgü sizin gireceğiniz parametrelerde ( IP adresi v.s) işe yaramaz.

? diğer manasıyla help komutunu girdiğimizde komutlarımızı sıralamıştık ama aşağıda “ –- More –- ” diye bir ifade gözünüze çarpmıştır bunun anlamı listenin devamı var demektir. Devam etmek için iki seçeneğiniz vardır klavyenizden “ enter ” yada “ space ” tuşlarına basmak aralarında ki fark “ enter ” bir sonra ki satırı gösterirken “  space ” bir sonraki sayfayı gösterir. Listeyi sonlandırmak içinse “ TAB ” tuşunu kullanabilirsiniz.

Konfigurasyon yapıyorsunuz ve önceki bir komutu tekrarlamanız gerekti yada ufak parametre değişikliği yapacaksınız. Önce girmiş olduğunuz komutları tek tek görmek için “ yukarı ok – aşağı ok ” tuşularını ve imleci hareket ettirmek içinse “ sağ-sol ok ” tuşlarını kullanabilirsiniz.

Konfigurasyon yaparken bazen yazım hatası yada eksiklikler olabilir o zaman IOS size şu hatayı verir ;

Router(config)#enable pasword

^

% Invalid input detected at ‘^’ marker.

Burada gördüğünüz işaret “ ^ ” komutta doğru girdiğiniz bölüme kadar gösterir, gösterilen yerden itibaren sonrasını kontrol ediniz demektir.

IOS un kullanımından biraz bahsettik gelin artık şu ufak çapta konfigurasyonları yapmaya başlayalım.

İlk olarak bize en gerekli olan priviledge ve global configuration moduna düşmeyi öğrenelim.

Router con0 is now available

Press RETURN to get started.

Router>en /*– User Mode

Router>enable /*– User Mode

Router#configure terminal /*– Priviledge Mode

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)# /*– Global-Config. Mode

PRIVILEDGE MODE’ A PASSWORD:

Priviledge moda girişi güvenli kılmak için iki türlü yöntem vardır birisi “secret” diğeri “password” komutuyla yapılır. Farkı genel konfig gösterilirken secret le şifre koyarsanız MD5 le şifrelenmiş olarak, password le olursa metin (text) şeklinde gösterilir.Kullanımları ;

Router(config)#enable secret [girmek istediğimiz şifre]

Router(config)#enable password [girmek istediğimiz şifre]

Konfigurasyonları görmek : Girmiş olduğumuz konfigurasyonlar cihazımızın RAM inde bulunur görüntülemek istersek “show running-config ” yada kısaca “show run” komutunu priviledge mod da çalıştırabiliriz. İşte ilk konfig. mizin sonuçları ;

SECRET komutu kullandıktan sonra show run çıktısı:

Router#show running-config

Building configuration…

Current configuration : 629 bytes

!

version 12.3

no service dhcp

!

hostname Router

!

enable secret 5 $1$mds8$jtKu5QdFKPVYqVxnR4AIz0 /*– MD5 şifreli

!

—————————————————————

PASSWORD Komutu kullandıktan sonra show run çıktısı:

!

enable password cisco

Bundan sonra User moddan Privil. Moda geçerken cihaz bizden şifre ister yazdığınızda hiç bir değişilik olmaz gibi durur fakat endişelenmeyin buda sizin şifre güvenliğiniz içindir.

Router>enable

Password:       /*– cisco girdim

Router#         /*– privil. Moddayım

Şifre girerken dikkat etmeniz gereken nokta büyük/küçük karakter ayrımı olmasıdır.

Hostname Değiştirmek :

Bizim ünlü işaretimizden önce yazan “hostname” yani “Router” yazan kısmı değiştirelim.

Router(config)#hostname [alfanumerik değer] /*– CiscoTR

CiscoTR(config)#

Burada dikkat etmeniz gereken nokta boşluk bıramamanızdır.

Login Banneri eklemek : Bir kişi IOS a login olduğunda görmesini istediğiniz herhangi bir mesajı girebilisiniz.

CiscoTR(config)#banner login # selam CiscoTR dunyasina hos geldiniz #

Burada girilen “#” işareti girdiğiniz metnin başlangıç ve bitiş nktalarını oluşturur. Herhangi bir karakter girebilirsiniz, ancak, dikkat etmeniz gereken bu karakterin girdiğiniz metinde bulunmaması gerektiğidir. Böyle bir durum meydana gelirse login mesajınızda o karakterden sonrası görünmeyecektir.

Message of the Day Banner: login banner il aynı kurallar geçerlidir.

CiscoTR(config)#banner motd #Configured by AcLMasteR#

Interface konfigurasyon uygulamaları : Hiç şüphesiz en gerekli konfigurasyondan birisi interface konfig dir. Başlangıç amaçlı interface konfiurasyonuna kısaca göz atalım.

Önce konfig yapacağımız interface e girelim ben fastethernet 0/0 seçtim.

CiscoTR(config)#interface fastEthernet 0/0

CiscoTR(config-if)#

Cihazınızda ki interface listesini ve bulundukları durumu görmek için

CiscoTR# show ip interface brief

komutunu kullanabilirsiniz. Hiç bir zaman unutmamanız gereken komutlardan bir tanesi

CiscoTR(config-if)# no shutdown

Çünkü Cisco cihazlarıda interface lerin hepsi default olarak kapalıdır(down). Size bir komut daha göstermiş olduk bu arada J.

Interface IP vermek : interfacemize IP vermek için aşağıdaki komutu kullanırız. Bu komutun kullanmış olduğu iki tane parametre vardır IP ve SUBNET MASK. Örnek olarak 192.168.1.1 ip ve 255.255.255.0 subnet mask verelim ;

CiscoTR(config-if)#ip address 192.168.1.1 255.255.255.0

Interface description(tanımalama): Konfigurasyon yaparken daha sonra çıkabilecek bir hata karşısında interface mizin nereyle bağlantı kurduğunu anlamak için bir tanımla bilgisi gireriz. Burada maksat anlaşılabilir bir kelime girmektir.Örnek olarak interface miz Firewall a bağlanan bacağı olsun ;

CiscoTR(config-if)#description FireWall

Interface Bandwidth: Interface mizin kullanacağı trafik miktarını aşağıda belirteceğimiz komutla belirleyebiliriz. Dikkat etmemiz gereken nokta gireceğimiz değer Kilobit cinsinden olacaktır. Default olarak Fastethernet 100 Mbit tir biz bunu 50Mbit olarak değiştirelim ;

CiscoTR(config-if)#bandwidth 50000

Son olarak interface mizin default olan down durumunu up ediyoruz.

CiscoTR(config-if)#no shutdown

CiscoTR(config-if)#

*Mar  1 00:02:54.371: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

*Mar  1 00:02:55.371: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Girmiş olduğumuz değeri teyid edelim

CiscoTR#show interfaces fastEthernet 0/0

FastEthernet0/0 is administratively up, line protocol is up

Hardware is AmdFE, address is cc00.158c.0000 (bia cc00.158c.0000)

Description: FireWall

Internet address is 192.168.1.1/24

MTU 1500 bytes, BW 50000 Kbit , DLY 100 usec

Interface moddan çıkmak için “exit” komutunu girelim ve Priviledge moduna düşelim.

CiscoTR(config-if)#exit

CiscoTR(config)#

IOS ta Telnet oturumu açmak: Telnet yani uzaktan erişimle IOS sumuzu konfigurasyon etmek için telnet oturumlarının açılması gerekir bunun yanında ilk olarak görmüş olduğumuz “secret” komutumuzun aktif olması gerekir.

CiscoTR(config)#line vty 0 4 /*– aynı anda 5 adet telnet oturumu

CiscoTR(config-line)#password cisco

CiscoTR(config-line)#login

CiscoTR(config-line)#exit

CiscoTR(config)#

IOS ta Console oturumu açmak: Console den bağlanmak için bu oturumuda açmalıyız. (default olarak açıktır password koyarak güvenli hale getirebiliriz 😉 )

CiscoTR(config)#line console 0

CiscoTR(config-line)#password cisco

CiscoTR(config-line)#login

CiscoTR(config-line)#exit

CiscoTR(config)#

DHCP Servisini aktiv etmek: IOS unuz da DHCP servisini aktif ederek Router inizi DHCP server yaparak network te IP dağıtımı yapabilirsiniz.Önce bir DHCP Pool (aralık) tanımlamalısınız.

CiscoTR(config)#ip dhcp pool CiscoTR

CiscoTR(dhcp-config)#network 192.168.1.0 255.255.255.0

CiscoTR(dhcp-config)#default-router 192.168.1.1

CiscoTR(dhcp-config)#dns-server 192.168.1.3

CiscoTR(dhcp-config)#domain-name CiscoTR.com

CiscoTR(dhcp-config)#lease 30

IOS umuz bu işlemden sonra girdiğimiz pool aralığında oturan cihazda bulunan interface nin IP adresine göre dağıtım yapacaktır. Eğer bu aralıkta bulunan bir aralığın DHCP tarafından atanmasını önelemek istiyorsak aşağıdaki komutla yapabiliriz.

CiscoTR(config)#ip dhcp excluded-address 192.168.1.2 192.168.1.6

Şimdi biz bu kadar ayarlama yaptık bunları kaydetmemiz gerekiyor, konfigurasyonunuz çalışacaktır fakat RAM de tutulduğu için herhangi elektrik kesintisinde kaybolacaktır. Nasıl hafızaya ( NVRAM ) kaydeceğimizi öğrenelim daha sonra hem şuanda çalışmakta olan ve başlangıçta yüklenen konfigurasyonumuza bakalım ve dersimizi şimdilik bitirelim.

Aşağdaki komutlarımızla kayıt işlemini yapıyoruz yani RAM den NVRAM a ;

CiscoTR#copy  running-config startup-config

Destination filename [startup-config]?

Building configuration…

[OK]

Bu Komutumuz IOS ların tüm versiyonları için geçerlidir.Başka bir komut daha var o ise 12 versiyonlarından sonra işe yarar ve daha kısadır.

CiscoTR#write memory

Building configuration…

[OK]

Siz yine de sınavda ilk vermiş olduğum komutumuzu kullanın.

Çalışan konfigurasyonu görüntüleme : show running-config komutunu kullanıyoruz kısaca show run da kullanılabilir.

CiscoTR# show running-config

Building configuration…

Current configuration : 1096 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CiscoTR

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$i0qX$p6np9eZre4J/R7jwegf6V/

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.2 192.168.1.6

!

ip dhcp pool CiscoTR

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 192.168.1.3

domain-name CiscoTR.com

lease 30

!

no ip ips deny-action ips-interface

!

no ftp-server write-enable

!

no crypto isakmp ccm

!

interface FastEthernet0/0

description FireWall

bandwidth 50000

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

ip http server

no ip http secure-server

ip classless

!

control-plane

!

banner login ^C selam CiscoTR dunyasina hos geldiniz ^C

banner motd ^CConfigured by AcLMasteR^C

!

line con 0

password cisco

login

line aux 0

line vty 0 4

password cisco

login

!

End

Kaydedilmiş konfigurasyonu görüntüleme : Show startup-config komutunu kullanabilirsiniz. Çıktısını göndermeye gerek duymadım çünkü kayıt ettikten sonra değişiklik yapıp kaydetmedik running-config le aynı sonucu alırız.

İyi çalışmalar, Kolay Gelsin

(AcLMasteR)

5 yorum

  1. selamlar öncelikle güzel anlatım teşekkürler. Yalnız ben burda size bi sorum olacaktı:
    bu komutları gerçek cisco cihazımız yoksa (:D) illa ki dyndgs veya cisco packet tracer gibi uygulamalar üzerinde mi çalıştırmak zorundayız yani ben mesela vmware benzeri bi sanallaştırma yöntemiyle bu cisco IOS’u kurup onun üzerinde konfigurasyonlarımı yapamaz mıyım!? sorum saçma gibi gelebilir ama packet tracer falan bazı komutları tanımıyor mesela bundan dolayı gerçek bir IOS üzerinde çalışma yapmak istiyorum bu mümkün mü .. nasıl? değilse neden?:D
    teşekkürler..

  2. @JEYANFER
    GNS programı tamamiyle beklentilerini karşılayacaktır.Eğer istersen bende tüm IOS yazılımları mevcut ve GNS ile bunları yükleyip sanki birebir gerçek routerlar üzerinde çalışabiliyorsun daha fazlasıda mevcut.vmware+gerçek bilgisayarın ve GNS ile hepsini birlikte uygulamalar yapabilmen mevcut(ben o kıvama gelemedim 😀 ama uzmanlarla birlikte yapıldığına şahit oldum) fakat donanımın gerçekten iyi olmalı bir süre sonra bilg. sapıtıyor kaldıramıyor GNS tek kelimeyle mükemmel bir program.

  3. GNS programı tamamiyle beklentilerini karşılayacaktır.Eğer istersen bende tüm IOS yazılımları mevcut ve GNS ile bunları yükleyip sanki birebir gerçek routerlar üzerinde çalışabiliyorsun daha fazlasıda mevcut.vmware+gerçek bilgisayarın ve GNS ile hepsini birlikte uygulamalar yapabilmen mevcut(ben o kıvama gelemedim ama uzmanlarla birlikte yapıldığına şahit oldum) fakat donanımın gerçekten iyi olmalı bir süre sonra bilg. sapıtıyor kaldıramıyor GNS tek kelimeyle mükemmel bir program.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir