HSRP Konfigürasyonu (Hot Standby Router Protocol)

Bu makalemizde Hot Standby Router Protocol (HSRP) Nedir anlamaya çalışacağız.

Daha önce çalışma prensibini anlattığım HSRP ile ilgili bir konfigürasyon örneğini bu yazı içerisinde sizlerle paylaşıyor olacağım. Öncelikle HSRP ile ilgili özet bir bilgiyi yeniden vermek önceki makaleyi okumayan arkadaşlar için faydalı olacaktır. HSRP kısaca aynı işi yaparn birden fazla Router ya da Layer 3 Switchin son kullanıcılara tek bir Router gibi görünmesini sağlayan bir protokoldür. Bu birden fazla Router arasında bir tanesi aktif yönlendirme işlemlerini yürütürken diğeri yedek olarak beklemekte ve aktif çalışan Routerı takip etmektedir.

HSRP terminolojisi içerisinde aktif olarak yönlendirme işlemlerini yapan Router Active Router, yedek olarak bekleyen Router ise Standby Router olarak adlandırılır. Standby Router görevini üstlenen Router paket yönlendirmeler ile ilgili hiç bir şey yapmaz, tam anlamıyla bir yedek olarak bekler. HSRP Routerları bir grup numarası ile aynı grupta olduklarını anlarlar. Standby grup denen bu grubun numarası bizler tarafında belirlenir.

Kısa bir hatırlamanın ardından konfigürasyona girebiliriz. Örnek topolojimiz ve konfigürasyon aşamaları aşağıdaki gibidir;

R1 v R2 Routerlarının Fastethernet interfacelerinde HSRP Konfigürasyonu yapılacak.
2. R2 Routerı’nın Priority değeri 200 iken R1 Routerının ki 150.
3. R1 Routerı Active Router fakat R1 Routerının Serial 1/0 interface’i down olursa priority değer 150’ nin altına düşecek (Interface Tracking )ve R2 Routerı Active rolünü üstlenecek. (Bunun için Preempt enable olmalı)

R1 ve R2 Routerlarının konfigürasyonları aşağıdaki gibidir;

R1#show running-config
Building configuration…
hostname R1
!
interface FastEthernet0/0
ip address 192.168.1.10 255.255.255.0
duplex half
standby 1 ip 192.168.1.1
standby 1 priority 200
standby 1 preempt
standby 1 track Serial1/0 60
!
interface Serial1/0
ip address 12.1.1.1 255.255.255.0
!
R1#

—-

R2#show running-config
Building configuration…
hostname R2
!
interface FastEthernet0/0
ip address 192.168.1.100 255.255.255.0
duplex half
standby 1 ip 192.168.1.1
standby 1 priority 150
standby 1 preempt
!
interface Serial1/0
ip address 13.1.1.1 255.255.255.0

R2#

Yaptığımız konfigürasyonu “Show standby” komutu ile izleyebiliriz.

Sırasiyla R1 ve R2 Routerlarını inceleyelim;

R1 üzerinde Virtual ip adresi 192.168.1.1 olarak börülmektedir. Aynı zamanda R1 Routerı Active Router konumundadır. Çünki priority değeri 200’dür ve R2 Routerından büyüktür. Yine burada Standby router ip adresi 192.168.1.100 olarak görülmektedir. Burada bir başka dikkat edilecek nokta da Interface Tracking kısmıdır. Serial 1/0 interface’inin down olması durumunda bu Routerın priority değeri 60 azalacak, yani 140’a düşecektir.

R2 routerı ise Standby durumundadır ve priority değeri 150’dir.

Şimdi R1 Routerına bağlı olan Serial 1/0 interface’ini Shutdown yaparak durumu izleyeceğiz; Gördüğünüz gibi ilgili interface kapatıldıktan sonra R1 Routerının priority değeri 60 azalıp 140’a düşmüş ve Standby durumuna geçmiştir. Bu durumda R2 Routerı Active rolüne geçmiştir.

Evet arkadaşlar, bu makalemizde giderek çok daha önemli hale gelen, yedekli yapıları çalıştırmada kullanabileceğimiz protokollere HSRP ile bir giriş yaptık. HSRP dışında VRRP ve GLBP gibi protokolleri ile de bu işlemler gerçekleşebilir. Makalenin devam eden bölümlerinde bu protokollerden de bahsedeceğiz.

Umarım faydalı olmuştur, iyi çalımalar.

Hayrullah Kolukısaoğlu

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir