Frame Relay, QoS (Quality of Service)

Bu makalemizde Frame-Relay QOS ( Quality of Service )‘ye değineceğiz. Firmaların merkez ve şubeleri arasında kullandıkları data hatları üzerinden ihtiyaçlar gereği ses ve hatta bu hatlar üzerinden video konferans yapılıyor.Ses,data ve video görüntülerinin aynı anda kullanıldığı durumlarda hat üzerinde çok fazla trafik oluşacağı için bu hatlarladan verim almak neredeyse imkansızdır.Bu yazımızda merkez ve şube arasında FrameRelay kullanılan bir topolojide paketlerin istediğimiz şekilde iletilmesini sağlayacağız.

(FrameRelay konfigürasyonu konumuz dışındadır) Standart olarak iletişimde FIFO (first in first out)modeli kulanılır.Bu durumda hangi paket önce gelirse o paket iletilir ve buda istenmez bizim yapmamız gereken önemli veriler ile önemsiz verilerin ne olduğunu belirtmek ve cihaz üzerinde bu paketleri istediğimiz şekilde yönlendirilmesini sağlamaktır.

(Önemli ve önemsiz veri sıralaması firmalarda farklılık gösterebilmektedir.Biz yazımızda önce ses sonra data paketleri olarak sıralayacağız) Bu yazımızda merkez ve şube arasında FrameRelay kullanılan bir topolojide paketlerin istediğimiz şekilde iletilmesini sağlayacağız.(FrameRelay konfigürasyonu konumuz dışındadır)

Freme Relay QoS(Quality of Service) - CiscoTR.COM

Istanbul için örnek konfigürasyon;

class-map match-all sesclass

match access-group 150

class-map match-all signal

match access-group 160

!

policy-map ses

class sesclass

priority 16

class signal

bandwidth 4

class class-default

fair-queue

!

interface Ethernet0/0

ip address x.x.x.x

no keepalive

half-duplex

!

interface Serial 0

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

frame-relay traffic-shaping

frame-relay ip rtp header-compression

!

interface Serial 0.1 point-to-point

bandwidth 256

ip address 192.168.10.200 255.255.255.0

frame-relay interface-dlci 100

class CIR256

!

map-class frame-relay CIR256

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay mincir 256000

service-policy output ses

frame-relay fragment 320

!

access-list 150 permit udp any any range 16384 32767

access-list 150 permit udp any any precedence critical

access-list 150 permit udp host 192.168.10.200 host 192.168.20.200

access-list 160 permit tcp any eq 1720 any

access-list 160 permit tcp any any eq 172

Bu yapida paketleri istedigimiz sekilde iletilmek için sirasiyla

1-Ilk olarak access list olusturalim

Ses paketleri için;

Voiprouter(config)#access-list 150 permit udp any any 16384 32767 (Ses paket araligina izin veriyoruz.)

Voiprouter(config)#access-list 150 permit udp any any precedence critical (öncelik veriyoruz)

Voiprouter(config)#access-list 150 permit udp host 192.168.10.200 host 192.168.20.200

Sinyallesme için;

Voiprouter(config)#access-list 160 permit tcp any eq 1720 any (disari giden 1720 paketlerini kabul ediyoruz).

Voiprouter(config)#access-list 160 permit tcp any any eq 1720 (içeri gelen 1720 paketlerine izin veriyoruz)

2-Paketlere uygulayacagimiz kriterleri belirleyecegimiz class-map’leri yaratiyoruz.

Ses paketleri için;

Voiprouter(config)#class-map match-all sesclass

Voiprouter(config-cmap)#match access-group (Match komutu ile neye göre uygulayacagimiz belirtiyoruz)

burada bir çok seçenek mevcut ama biz örnegimizde access list’ler ile çalisacagiz.Bu sebeple

Voiprouter(config-cmap)#match access-group 150 (150 numarali extended acl olusturuyoruz)

Sinyallesme için ;

Voiprouter(config)#class-map signal (sinyallesme için class map yaratiyoruz)

Voiprouter(config-cmap)#match access-group 160 (kullanilacak acl seçiyoruz)

3-Simdi Policy map yaratalim ve yarattigimiz class map ile iliskilendirelim.

Voiprouter(config)#policy-map ses (ses adinda bir policy map yaratiyoruz)

Voiprouter(config-pmap)#class sesclass (daha önce sesclass adinda yarattigimiz class map’i iliskilendiriyoruz)

Voiprouter(config-pmap-c)#priority 16 (ses paketlerine 16 kbps lik öncelik veriyoruz.)

Voiprouter(config-pmap)#class signal (sinyallesme için yarattigimiz class map’i iliskilendiriyoruz)

Voiprouter(config-pmap-c)#bandwidth 4 (sinyallesme için 4kbps BW veriyoruz)

Voiprouter(config-pmap)#class class-default (Class-map kullanarak belirtmedigimiz kalan trafik.)

Voiprouter(config-pmap)#fair-queue

4Trafigi sekillendirmek için map-class yaratiyoruz.

Voiprouter(config)#map-class frame-relay CIR256 (CIR256 bizim verdigimiz isim)

Voiprouter(config-map-class)# frame-relay cir 256000 (Hattimiz 256 Kbps burada byte cinsinden yaziyoruz)

Voiprouter(config-map-class)# frame-relay bc 2560

Voiprouter(config-map-class)# frame-relay be 0 (ses trafigi oldugu için “0” degeri veriyoruz)

Voiprouter(config-map-class)# frame-relay mincir 256000 (Standart olarak deger CIR/2 dir.Bu sebeple biz bütün BW gösteriyoruz)

Voiprouter(config-map-class)# service-policy output ses (Yarattigimiz ses adinda policy-map’i gösteriyoruz)

Voiprouter(config-map-class)# frame-relay fragment 320

Voiprouter(config-map-class)# no frame-relay adaptive-shaping becn (mincir degeri verilmeyen konfigürasyonlarda “no” komutu olmadan kullanilir.Bu durumda mincir olarak CIR/2 degeri atanir.Ama biz mincir degerini elle verdik ve “cir” degeri ile esitledik.)

Burada bilmemiz gereken bazi terimler ortaya çikiyor.Ben bu terimleri kisaca açiklamak istiyorum.

CIR (Commited Information Rate) : Kabul edilen iletisim kapasitesi

Hesaplamak için: CIR = Bc X 1000/Tc

Bc (Committed Burst Size) : FrameRelay networklerinde bir Tc zamaninda iletim yapilmasina izin verilen maksimum bit miktari.

Hesaplamak için: Bc = CIR X Tc/1000

Be (Excess Burst Size) : FrameRelay networklerinde bir Tc zamaninda Bc üzerinden asilmasina izin verilen maksimum bit miktari

Tc (Commited rateMeasurement interval)CIR,Bc ve Be nin tanimlandigi Belirli zaman araligidir.Tc degeri normal olarak 1 ve 1.2 saniyeleri arasindadir.

Hesaplamak için: Tc = Bc/CIR X 1000

Fragment : FrameRelay networklerinde bir Tc zamaninda iletim yapilmasina izin verilen maksimum paket büyüklügü

Hesaplamak için: fragment-size =TcxCIR/8

BECN : FrameRelay networklerinde tikaniklik oldugu zaman bunu farkeden cihaz göndericiye uyarida bulunmak amaçli BECN biti gönderir.

Mincir : Hat üzerinde tikaniklik olustugunda cihazlar birbirleri ile haberleserek göndericinin gönderim hizini düsürmesini saglarlar.Bu düsüs en fazla mincir degerine kadardir.Standart olarak CIR/2 dir.

5Son olarak kullandigimiz interface’ler üzerinde ayarlarimizi tanimliyoruz.

a-Ana interface üzeinde;

Voiprouter(config)#interface serial 0

Voiprouter(config-if)#frame-relay traffic-shaping (eger traffic-shaping aktif olmaz ise yapilan konfigürasyon çalismaz)

Voiprouter(config-if)#frame-relay ip rtp header-compression

b-Subinterface üzerinde;

Voiprouter(config)#int serial 0.1

Voiprouter(config-subif)#frame-relay interface-dlci 100

Voiprouter(config-fr-dlci)#class CIR256 (Subinterface’ye yarattigimiz map-class’i tanimliyoruz.)

Yazar:Aşkın ÖZPOLAT

1 yorum

  1. Qos şekilli örnek topoloji ve örnek konfigurasyon nedir .nası yapıcam bana yardımcı olabilrimisniz.yarına ödewım war.Ltfen..we yabancı kelimeler var onları acıklarmısınız..

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir