Port-Security, ErrDisable
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 2 Sayfadan 1. Sayfa 12 SonuncuSonuncu
Toplam 13 sonuçtan 1 ile 10 arasındakiler gösteriliyor.
Port-Security, ErrDisable

Herkese merhabalar, Switch te porta, Port Security uyguladığımda errdisable hatası alıyorum. Daha sonra Kod: #no switchport port-security dediğimde, Port connected durumuna geçiyor. Sorun ne olabilir ?

  1. #1
    ersinerol isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Oct 2011
    Mesajlar
    2

    Standart Port-Security, ErrDisable

    Herkese merhabalar,
    Switch te porta, Port Security uyguladığımda errdisable hatası alıyorum.

    Daha sonra
    Kod:
    #no switchport port-security
    dediğimde, Port connected durumuna geçiyor.

    Sorun ne olabilir ?

  2. #2
    Z_THE_TURK isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Oct 2009
    Bulunduğu yer
    Ankara
    Mesajlar
    78

    Standart

    Port-Security uygulamasını yaparken girdiğiniz komutları tam olarak yazabilirseniz daha net konuşabiliriz. Bir de PS uyguladığınız port üzerine bir şey bağlı mı değil mi? Onuda yazabilriseniz ya da ufak bir topoloji çizip yollarsanız iyi olur.

  3. #3
    ersinerol isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Oct 2011
    Mesajlar
    2

    Standart

    Tam olarak durum şu şekilde switch in bu portunda bir pc vardı o pc ye göre aşağıda ki komutlar girildi sorunsuz çalışıyordu daha sonra bu cihaz o porttan çıkartılıp yerine başka bir pc takıldığında shutdown olmaasının yanında böyle bir sorunla karşı karşıya kaldım...Portu # shutdown ,#noshutdown yapmama rağmen olmuyor ancak port-security i iptal ettiğimde çalışıyor port.Port Securtiy tarafında yazdığım komutlar şu şekilde ;


    conf t
    interface Fa0/33
    switchport access vlan 10
    switchport mode access
    switchport port-security
    switchport port-security aging time 1
    switchport port-security violation shutdown
    switchport port-security mac-address sticky
    spanning-tree portfast
    spanning-tree bpdufilter enable
    end
    wr

  4. #4
    kamilyastik isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Aug 2010
    Mesajlar
    24

    Standart

    no spanning-tree portfast

  5. #5
    ilker61 isimli Üye şimdilik offline konumundadır Onursal Üye - Emektar
    Üyelik tarihi
    Jul 2008
    Mesajlar
    434

    Standart

    #show interface status err-disabled

    komutunu girerek hatayı öğrenebilirsiniz.

  6. #6
    cobanoglu isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Sep 2011
    Bulunduğu yer
    ABD, New York
    Mesajlar
    105

    Standart

    merhaba,

    sorun portfast falan degil.sorun port security maximum mac address default yani 1 de kaldigi icin ve sticky komutununda uygulanmasinda dolayi.


    asagidaki konfigurasyona gore, bu port'a ait sadece bir mac adress ait olabilir, (switchport port-security komutundan dolayi, default sadece 1 mac adres)

    switchport port-security mac-address sticky apply edildigi icinde, bu port'a baglanan ilk PC mac adresi running configurasyonda gorunur zaten. siz baska PC bagladiginiz icin mac adresi uyusmuyor ve kapatiyor.

    bir kac sekilde cozebilirisiniz;

    1. reboot yaparsaniz ilk bagli olan mac adresini siler, calisir.( baska bir cihaz baglandiginda yine reboot gerektirir her zaman)
    2. switchport port-security maximum 2 (1 den buyuh herhangi bir numara) yaparsaniz, 1 den fazla mac alabilecegi icin sorun olmaz.
    3. sticky disable edersiniz.
    4. port-security disable edersiniz.



    kolay gelsin

  7. #7
    ester isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Sep 2010
    Mesajlar
    93

    Standart

    Vermiş olduğunuz cevaplar için teşekkür edeirim.Port security kaldırdığımda sorun gidiyor gibi oluyor ama ikinci taktığım cihazı tekrar taktığımda yine errdisable hatası alıyorum.Daha sonra o portu default port yapıp tekrar switchport mode access dediğimde sorun kalkıyor.

  8. #8
    MCyagli isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jul 2009
    Bulunduğu yer
    Corum - Turkiye
    Mesajlar
    565

    Standart

    Mrb,

    Senaryoya göre herşey normal,

    "switchport port-security aging time 1"

    bu komut boşuna girilmiş...

    Sticky ögrenilen Mac adresleri istesenizde Age Out olmaz .

    ---

    Hem bu komutları uygulayıp,

    hemde ikinci bir cihaz takıldığında çalışmasını istiyorsanız,

    @cobanoglu

    gereken cevapları yazmış.



    ---
    Mehmet Ceyhan YAĞLI
    I learn, I teach

    www.mcyagli.com

  9. #9
    ser_say2002 isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Jul 2010
    Mesajlar
    24

    Standart

    Alıntı ester Nickli Üyeden Alıntı Mesajı göster
    Vermiş olduğunuz cevaplar için teşekkür edeirim.Port security kaldırdığımda sorun gidiyor gibi oluyor ama ikinci taktığım cihazı tekrar taktığımda yine errdisable hatası alıyorum.Daha sonra o portu default port yapıp tekrar switchport mode access dediğimde sorun kalkıyor.
    Selam ,

    almış olduğun errdisable hatasın,ı ilgili portu manuel olarak shut no shut yaparak errdisable durumundan kurtarabilirsin.

  10. #10
    cbir isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Jul 2010
    Mesajlar
    45

    Standart

    conf t
    interface Fa0/33
    switchport access vlan 10
    switchport mode access
    switchport port-security
    switchport port-security aging time 1
    switchport port-security violation shutdown
    switchport port-security mac-address sticky
    spanning-tree portfast
    spanning-tree bpdufilter enable
    end
    wr
    sorun mac-address sticky yapıp kaydetmenizden kaynaklanıyor. wr yapınca bağlı olan cihazın mac adresini start-up config e yazıyor. bu yüzden başka bir cihaz bağladığınızda çalışmıyor.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok