InterVlan Routing - Subinterface Access-List Konfigurasyonu
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 4 sonuçtan 1 ile 4 arasındakiler gösteriliyor.
InterVlan Routing - Subinterface Access-List Konfigurasyonu

Merhaba arkadaşlar, bir router, switch ve iki pc ile bir ağ oluşturdum ve vlan ayarlarını yaptım fakat şöyle bir sıkıntım var, router bağlı olmadığıında iki pc ayrı vlanlarda olduğu için

  1. #1
    mbkurt07 Guest

    Standart InterVlan Routing - Subinterface Access-List Konfigurasyonu

    Merhaba arkadaşlar,

    bir router, switch ve iki pc ile bir ağ oluşturdum ve vlan ayarlarını yaptım fakat şöyle bir sıkıntım var, router bağlı olmadığıında iki pc ayrı vlanlarda olduğu için haberleşemiyor, fakat router bağlanınca router üzerinden birbirlerini görüyor. router bağlı olucada birbirlerini görmelerini istemiyorum. bunu nasıl önleyebilirim. yapmış olduğum ayarlar şu şekilde:

    pc1: ip:192.168.2.2 255 255.255.0 ağ geçidi:192.168.2.1 switch te fastethernet 0/2 ye takılı

    pc2:ip:192.168.3.2 255 255.255.0 ağ geçidi:192.168.3.1 switch te fastethernet 0/3 ye takılı


    Switch>
    Switch>en
    Switch#conf t
    Switch(config)#vlan 2
    Switch(config-vlan)#name vlan2
    Switch(config-vlan)#exit
    Switch(config)#interface fastEthernet 0/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 2

    Switch(config)#
    Switch(config)#vlan 3
    Switch(config-vlan)#name vlan3
    Switch(config-vlan)#exit

    Switch(config)#interface fastEthernet 0/3
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 3
    Switch(config-if)#exit

    Switch(config)#interface fastEthernet 0/1
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#exit

    Switch#show vlan brief

    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Fa0/1, Fa0/4, Fa0/5, Fa0/6
    Fa0/7, Fa0/8, Fa0/9, Fa0/10
    Fa0/11, Fa0/12, Fa0/13, Fa0/14
    Fa0/15, Fa0/16, Fa0/17, Fa0/18
    Fa0/19, Fa0/20, Fa0/21, Fa0/22
    Fa0/23, Fa0/24, Gig1/1, Gig1/2
    2 vlan2 active Fa0/2
    3 vlan3 active Fa0/3
    1002 fddi-default active
    1003 token-ring-default active
    1004 fddinet-default active
    1005 trnet-default active
    Router ayarları

    Router>en
    Router#conf t
    Router(config)#interface fastEthernet 0/0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#interface fastEthernet 0/0.2
    Router(config-subif)#encapsulation dot1Q 2
    Router(config-subif)#ip address 192.168.2.1 255.255.255.0
    Router(config-subif)#exit
    Router(config)#interface fastEthernet 0/0.3
    Router(config-subif)#encapsulation dot1Q 3
    Router(config-subif)#ip address 192.168.3.1 255.255.255.0
    Router(config-subif)#exit

    arkadaşlar eksik olan ayarlar konusunda yardımlarınızı bekliyorum..

  2. #2
    trunkmode isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,332

    Standart

    Aşağıdaki örneği uygularsanız çalışacaktır.

    interface FastEthernet1/0.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.0
    ip access-group VACL in
    !
    interface FastEthernet1/0.3
    encapsulation dot1Q 3
    ip address 192.168.3.1 255.255.255.0
    !
    ip access-list extended VACL
    deny ip 192.168.2.0 0.0.0.255 192.168.3.0 0.0.0.255
    permit ip any any


    CiscoTr#sh access-lists
    Extended IP access list VACL
    10 deny ip 192.168.2.0 0.0.0.255 192.168.3.0 0.0.0.255 (33 matches)
    20 permit ip any any (30 matches)

  3. #3
    mbkurt07 Guest

    Standart

    trunkmode çok teşekkür ederim. söylemiş olduğunuz ayarları kullanarak vlan ların router üzerinden haberleşmesii engellenmiş oldu. burda bir tane access group oluşturduk fakat 5 tane vlan olursa yine farklı isimlerde access group mu oluşturacağız yoksa var olan bu group altında deny ip şeklinde diğerlerini eklememiz mi gerekiyor. birde router içinde vlanların doğal olarak birbirleri ile haberleşmemesi gerekmiyor mu?

  4. #4
    trunkmode isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,332

    Standart

    Merhaba
    Evet aynı access-list altında yeni deny kuralları yazabilirsiniz permit any satırını en sona yazarsanız sorun olmaz.
    Router içerisinde demeyelimde aynı fiziksel interfaceler içinde diyelim sonuçta tek interface kullanılıyor aslında.
    Siz kural yazmadğınızda tümü için permit geçerli olur. Burada bir başka tik nokta var oda aklınızda yer etsin
    standart access-listler hedefe yakın uygulanırken , extended access-listler kaynağa yakın uygulanmalıdır.
    Bizim örneğimiz extended olduğu için kaynağa yakın uyguladık
    Konu trunkmode tarafından (27.04.2011 Saat 22:13 ) değiştirilmiştir.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok