Spanning Tree, Portfast
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

+ Konuyu Cevapla
Toplam 9 sonuçtan 1 ile 9 arasındakiler gösteriliyor.
Spanning Tree, Portfast

Merhaba, Backbone Cisco Catalyst 3550 Series Switch 'imin uzerinde, tum Access ve Trunk Portlarda Spanning Tree Portfast komutu girilmis durumda. Bunun amaci nedir acaba, bu komutu uç switchlerde de koşturmalimiyim.

  1. #1
    NetworkMania Guest

    Standart Spanning Tree, Portfast

    Merhaba,

    Backbone Cisco Catalyst 3550 Series Switch'imin uzerinde, tum Access ve Trunk Portlarda Spanning Tree Portfast komutu girilmis durumda. Bunun amaci nedir acaba, bu komutu uç switchlerde de koşturmalimiyim.

    Ornek:
    !
    interface GigabitEthernet0/2
    switchport access vlan 30
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet0/23
    description LANSW3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    spanning-tree portfast
    !
    Konu NetworkMania tarafından (25.09.2010 Saat 21:28 ) değiştirilmiştir.

  2. #2
    System isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Jun 2007
    Bulunduğu yer
    Ordu / Ünye
    Mesajlar
    501

    Standart

    Merhaba

    Spanning Tree Portfast bilgiye aşağıdaki adresten erişebilirsin.

    http://www.ciscotr.com/forum/cisco-s...data-unit.html

  3. #3
    NetworkMania Guest

    Standart

    Simdi okuduklarimdan anladigim kadariyla, switch uzerinde port trunk ise pek onerilmiyor bu komut. Bende disable ettim bunu tum portlarda. Varsin herkez 30-50 saniye beklesin
    Konu NetworkMania tarafından (25.09.2010 Saat 22:57 ) değiştirilmiştir.

  4. #4
    AcLMasteR isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jan 2008
    Bulunduğu yer
    Ankara
    Mesajlar
    1,195

    Standart

    gel sen hepsini bekletmede pc olan portlara bari yaz
    The day that never comes

  5. #5
    mely isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Oct 2008
    Bulunduğu yer
    Istanbul
    Mesajlar
    326

    Standart

    Switch açıldığında Spanning-Tree protokolu çalısır (default olarak)

    Fakat bu çalışma yaklaşık 50 - 55 sn sürer ve bu süreçte Switch, switching işlemi yapmaz.

    Bu süreyi kısaltmak adına cisco, adminin belirleyeceği portlar dahilinde spanning-tree nin çalışmamasını portfast ile sağlar.

    Şöyle, genel olarak Trunk Portlar portfast yapılmaz, host portları Portfast yapılır. Fakat bu illa böyle olacak diye birşey yok.

    Diyelim ki 2 switchin war ve bunlar sadece tek portlarından birbirine bağlı. Burada Portfast yapman hiçbişey değiştirmez. Çunku Loop hiçbir zaman olusmayacaktır.

    Ama redundant bir yapın war ve herhangi bir portta Spanning-tree çalışmaması, switchin oluşma ihtimali olan Loop u belirlemesini engelleyecek ise portun, portfast olması cok kritik bir hata olur..


    Kolay gelsin..

  6. #6
    NetworkMania Guest

    Standart

    Selamlar,

    Valla 2 switch'te olsa lop olusabilir neden olusmasin ki?. Diyelim ki iki tane switch var ve bunlari client lara cektiniz, sonra bir kablonunu gittigi yerde, bir porta daha ihtiyac oldu, daha sonra oraya kucuk bi switch koydunuz isi hallettiniz, gun geldi diger switch ten bi kabloda aylar sonra oraya bi sekilde cekildi ve onada ayri bir switch konuldu. Hizmetli bosta duran kablonun bir ucunu kucuk switchten alip, diger kucuk switch'e takdi. Al sana loop. Yani olmuyor degil lakin portfast ile kullanilan bir komut vardi simdi unuttum. Sanirim onu kullanmak sorunu cozebilir ama ben yinede hicbir yerde kullanmamayi tercih ediyorum. Kaldi ki benim backbone umun uzerinde bile trunk portlarda kullanilmis bu komut. Ne kadar sakincali bir durummus, ogrendikce bu tur olaylari ortadan kaldirmak icin duzenliyorum bende.

  7. #7
    AcLMasteR isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jan 2008
    Bulunduğu yer
    Ankara
    Mesajlar
    1,195

    Standart

    mely arkadaşımın dediği gibi yaptığınızda 2 switch arasında loop oluşması beklenemez çünkü arada tek port çalışıyor. "Diyelim ki 2 switchin war ve bunlar sadece tek portlarından birbirine bağlı. Burada Portfast yapman hiçbişey değiştirmez. Çunku Loop hiçbir zaman olusmayacaktır.". Sizin dediğinizde yanlış değil iş yerinde benim başıma geldi buna benzer bir durum switchin birisinden bir kablo boşta kalmış onu switchindir diye takmış sonra beni çağırıyor bu terminal neden bağlanmıyor diye bir baktım bizim switchin ışıkları deliye dönmüş gazino tabelası gibi yanıp yanıp sönüyor. neyse...

    Ayrıca spanning-tree portfast komutu trunk portlardada kullanılabileceğini sanıyorum ama trunk olan port üzerinde router yada IP phone--- pc yapısı var ise yine bir sorun teşkil etmez sanırım. Eğre konfigurasyonunuz da bir değişiklik yapmadıysanız şu çıktıyı alıp görme imkanımız varmıdır "sh spanning-tree GigabitEthernet0/23 portfast"

    kolay gele..
    The day that never comes

  8. #8
    mely isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Oct 2008
    Bulunduğu yer
    Istanbul
    Mesajlar
    326

    Standart

    Alıntı NetworkMania Nickli Üyeden Alıntı Mesajı göster
    Selamlar,

    Valla 2 switch'te olsa lop olusabilir neden olusmasin ki?. Diyelim ki iki tane switch var ve bunlari client lara cektiniz, sonra bir kablonunu gittigi yerde, bir porta daha ihtiyac oldu, daha sonra oraya kucuk bi switch koydunuz isi hallettiniz, gun geldi diger switch ten bi kabloda aylar sonra oraya bi sekilde cekildi ve onada ayri bir switch konuldu. Hizmetli bosta duran kablonun bir ucunu kucuk switchten alip, diger kucuk switch'e takdi. Al sana loop. Yani olmuyor degil lakin portfast ile kullanilan bir komut vardi simdi unuttum. Sanirim onu kullanmak sorunu cozebilir ama ben yinede hicbir yerde kullanmamayi tercih ediyorum. Kaldi ki benim backbone umun uzerinde bile trunk portlarda kullanilmis bu komut. Ne kadar sakincali bir durummus, ogrendikce bu tur olaylari ortadan kaldirmak icin duzenliyorum bende.
    arkadaşım senin dediğine göre hizmetli gelip kabloyu takınca ek switche; toplamda switchler birbirine tek kablo ile bağlı olmuyor. Birden fazla kabloyla bağlı oluyor. Ne demek istediğimi biraz daha dikkatli okursan anlayacaksındır..

    Kolay gelsin

  9. #9
    GhoSt isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,664

    Standart

    Alıntı NetworkMania Nickli Üyeden Alıntı Mesajı göster
    Selamlar,

    Valla 2 switch'te olsa lop olusabilir neden olusmasin ki?. Diyelim ki iki tane switch var ve bunlari client lara cektiniz, sonra bir kablonunu gittigi yerde, bir porta daha ihtiyac oldu, daha sonra oraya kucuk bi switch koydunuz isi hallettiniz, gun geldi diger switch ten bi kabloda aylar sonra oraya bi sekilde cekildi ve onada ayri bir switch konuldu. Hizmetli bosta duran kablonun bir ucunu kucuk switchten alip, diger kucuk switch'e takdi. Al sana loop. Yani olmuyor degil lakin portfast ile kullanilan bir komut vardi simdi unuttum. Sanirim onu kullanmak sorunu cozebilir ama ben yinede hicbir yerde kullanmamayi tercih ediyorum. Kaldi ki benim backbone umun uzerinde bile trunk portlarda kullanilmis bu komut. Ne kadar sakincali bir durummus, ogrendikce bu tur olaylari ortadan kaldirmak icin duzenliyorum bende.
    Her ne kadar fantazi gibi gözüksede daha önce böyle bir olay başımıza gelmişti , port sayısı yeterli olmadığı için küçük 8li switchlerden almışlar yanlışlıkla 2 portta bu ufak switch e bağlanmış ve kenar switchlerde spanning-tree de çalışmıyordu bütün yapı çökmüştü sürekli göz kırpan port ışıkları
    Mr.google knows everything , ask to him...

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok