Cisco 6000 Switch, Load Balancing
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 4 sonuçtan 1 ile 4 arasındakiler gösteriliyor.
Cisco 6000 Switch, Load Balancing

Selamlar, Cisco switch uzerinde MS cluster da oldugu gibi servis ici load balancing yapmak istiyorum. CIsco switch arkasina baglayacagim 2 tane windows 2003 server dusunursek.Bunun uzerindeki windows servislerden biri giderse

  1. #1
    ipconvergence Guest

    Arrow Cisco 6000 Switch, Load Balancing

    Selamlar,
    Cisco switch uzerinde MS cluster da oldugu gibi servis ici load balancing yapmak istiyorum.

    CIsco switch arkasina baglayacagim 2 tane windows 2003 server dusunursek.Bunun uzerindeki windows servislerden biri giderse digerindeki ayni degerdeki windows servisi bunun yerini alacak ve devam edecek.Bu sekilde bir high availibity saglamak.Bunun icin cisco 6000 serisi ustu switcler benim isime yarayacakmidir?
    Bunun icin bir dokuman yada bilgi verirseniz, sebvinirim.

    Tesekkurler,

  2. #2
    Orhan ERGUN isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Aug 2008
    Mesajlar
    256

    Standart

    Merhaba,

    Server üzerindeki aktif session kopmadan devam etsin isteniyorsa, serveri bağladığınız portun per-destination load sharing yapması önerilir. Voice uygulamarında per-packet kullanmayısımızın nedeni de budur. Siz per-destination yaptığnızda ( cef enable oldugunda by default per-destination ) switch üzerinde hedef network için routing kaydına baktığınızda traffic sharing counttaki değer paketin nasıl route edileceğini de aslında size acıklıyor.

    Kolay Gelsin

  3. #3
    ipconvergence Guest

    Standart

    Selamlar,
    Tam anlayamadim, o yuzden istedigimi biraz daha aciyorum.

    Bir microsoft clustering yapisi dusunursek, burada 2 server in IP si ayni oluyor.Benim kullandigim application serverlar uzerinde 10 tane kendi ve windows servislerini kullaniyorsa.Sunu yapiyorum mesela, 3 tanesi 1 server uzerinde calissin, 7 tanesi digeri uzerinde calissin.Ve iki server uzerinde de 10 tane servis zaten oluyor.(iki server da birebir ayni).Tabiki aralarinda replikasyon olacak, mesela ilk server kullaniliyorsa ilk server da bir degisiklik olunca 2. server uzerinde de ayni degisiklik oluyor.Benim
    istedigim sey microsoft clustering i bir adet content (layer 4 ) switch ile halletmek.

    1) Iki server olacak, uzerlerinde tipatip ayni application kurulu.(IP leri ayni ayrica)
    2) Aralarinda replikasyon olacak devamli , birindeki degisimi digeri de ayni sekilde algilasin diye.

    3) birindeki herhangi active session (microsoft servisleri vs.) servislerden biri giderse, digeri ayni servisi kendi bunyesinde calistiracak.

    Kisaca MS clustering i switch uzerinde halletmek.

    slmlar




    Alıntı Orhan ERGUN Nickli Üyeden Alıntı Mesajı göster
    Merhaba,

    Server üzerindeki aktif session kopmadan devam etsin isteniyorsa, serveri bağladığınız portun per-destination load sharing yapması önerilir. Voice uygulamarında per-packet kullanmayısımızın nedeni de budur. Siz per-destination yaptığnızda ( cef enable oldugunda by default per-destination ) switch üzerinde hedef network için routing kaydına baktığınızda traffic sharing counttaki değer paketin nasıl route edileceğini de aslında size acıklıyor.

    Kolay Gelsin

  4. #4
    burner Guest

    Standart

    Slm;

    Serverlerin bagli oldugu intleri ayni vlan icerisine koy. o iki interfacelerde virtual mac address yarat ve bu arada snooping i disable et..iki server icin virtual ip address yarat...

    Cisco
    interface FastEthernet2/3
    description "Connection to Microsoft server"
    no ip address
    switchport
    switchport access vlan 200
    !
    interface FastEthernet2/4
    description "Connection to Microsoft server"
    no ip address
    switchport
    switchport access vlan 200
    !
    =============================

    mac-address-table static 0300.5e11.1111 vlan 200 interface fa2/3 fa2/4 disable-snooping

    ==============================

    arp 172.16.63.241 0300.5e11.1111

    ===============================

    interface Vlan200
    description "servers side"
    ip address 10.1.1.250 255.255.255.0

    ================================

    interface Vlan100
    description "Clients side"
    ip address 172.17.63.240 255.255.255.192

    =================================

    ip route 0.0.0.0 0.0.0.0 172.16.63.193
    default gateway
    Umarim isinizi gorur
    Iyi gunler

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok