Cisco 2801 Router G.SHDSL, EIGRP
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 2 Sayfadan 1. Sayfa 12 SonuncuSonuncu
Toplam 12 sonuçtan 1 ile 10 arasındakiler gösteriliyor.
Cisco 2801 Router G.SHDSL, EIGRP

1 adet cisco 2801 router vede 3 adet shdsl kart aldım.Kuracağım yapı aynı noktadaki 3 hattı eigrp ile load balancing yapıp point to point hat üzerinden merkezimdeki cisco 3560g switchde

  1. #1
    voip isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Mar 2008
    Mesajlar
    187

    Standart Cisco 2801 Router G.SHDSL, EIGRP

    1 adet cisco 2801 router vede 3 adet shdsl kart aldım.Kuracağım yapı aynı noktadaki 3 hattı eigrp ile load balancing yapıp point to point hat üzerinden merkezimdeki cisco 3560g switchde sonlandırmak.Konu ile ilgili forumda biraz araştırma yaptım ama config tarafında sıkıntılıyım nasıl bir config yapabilirim.Fikir veya örnek config vermeniz mümkün mü?


    Teşekkürler

  2. #2
    Cagdas Yalman isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Feb 2008
    Mesajlar
    427

    Standart

    cisco 3560g sw tarafı metrodan geliyor anladığım kadarıyla. metro üzerinde G.shdsl sonlandıracaksınız galiba. Bunun için TT her devre için size vlan vermesi gerekiyor. bununla ilgili conf ekteki dosyada bulabilirsiniz. yalnız ben 2 tarafıda aynı şekilde çalıştırdım yani 2 sw arasında load balance yapıyor. g.shdsl tarafında sıkıntı yaşarsanız yardımcı oluruz yine.

    Not: yalnız burda ilginç bir bug var 3 hat ta load balancing yapmak istediğinizde tek devreden gidiyor. 2 veya 4 hat olduğunda sorun yok. pakket tracer ile ilgili bir bug olabilir. normalde tracesi CEF table la göre atar. GNS 3 te gerçek ios ile denedim sorun yok.

    Switch#sh ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    3.0.0.0/32 is subnetted, 1 subnets
    D EX 3.3.3.3 [170/25753600] via 10.1.1.2, 00:00:08, Vlan101
    [170/25753600] via 10.1.1.6, 00:00:07, Vlan102
    [170/25753600] via 10.1.1.10, 00:00:02, Vlan103
    5.0.0.0/32 is subnetted, 1 subnets
    C 5.5.5.5 is directly connected, Loopback0
    10.0.0.0/30 is subnetted, 3 subnets
    C 10.1.1.0 is directly connected, Vlan101
    C 10.1.1.4 is directly connected, Vlan102
    C 10.1.1.8 is directly connected, Vlan103

    Switch#tr
    Switch#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3

    1 10.1.1.2 20 msec 20 msec 20 msec
    Switch#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3

    1 10.1.1.2 43 msec 20 msec 20 msec
    Switch#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3

    1 10.1.1.2 20 msec 20 msec 20 msec
    Switch#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3

    1 10.1.1.2 20 msec 20 msec 30 msec
    Switch#

  3. #3
    voip isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Mar 2008
    Mesajlar
    187

    Standart

    doğrudur metro üzerinden point to point 3 gshdsl devresi 3560g switchde sonlanıcak yalnız file da sanırım sorun var.Yardımın için teşekkürler.

  4. #4
    Cagdas Yalman isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Feb 2008
    Mesajlar
    427

    Standart

    packet tracer 5 ile açılıyor.

    yalnış şöyle bir handikap olabilir aslında 3 lokasyon aynı olacağından TT tarafında aynı kişi devreyi hazırlayacak muhtemelen. TT bazen abzürt hızlarda açabiliyor örneğin 128 k devre 200kda oturuyor. 128 k devrenın cisco tarafında baktığınızda 128+8( DSL frame ) 136k da oturması gerekiyor. hatlar kurulunca hatların buluşma hızlarını kontrol edilmesi gereklidir.

    !
    interface GigabitEthernet0/1
    description TT den gelen Hat
    switchport trunk allowed vlan 101-103
    switchport mode trunk
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan101
    desc 1. devre
    ip address 10.1.1.1 255.255.255.252
    !
    interface Vlan102
    desc 2.devre
    ip address 10.1.1.5 255.255.255.252

    !
    interface Vlan103
    desc 3.devre
    ip address 10.1.1.9 255.255.255.252
    !
    router eigrp 10
    redistribute connected
    network 10.1.1.0 0.0.0.3
    network 10.1.1.4 0.0.0.3
    network 10.1.1.8 0.0.0.3
    no auto-summary
    !
    ip classless
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    end

  5. #5
    voip isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Mar 2008
    Mesajlar
    187

    Standart

    Merhabalar konuda anlattığım konfigurasyonu çağdaşında yardımıyla tamamladım.Sonuçta

    iki noktam var

    1-(node) Cisco 2801 ve 3 gshdsl point to point merkeze
    2-(Merkez) metroethernet 3560g switch

    Node dan merkeze 3 hattıda buluşturdum ve configi aşağıdaki gibi yaptım ancak eigrp tarafında bazı sıkıntılarım var.

    1-eigrp bağlantısı nereyedeyse 10 dakada bir down olup kendi kendine geri geliyor.

    2-switch tarafında configi 3 interface tanımlayarak yaptım bunu tek e düşürebilirmiyim.

    3-Config hakkında yapmam gereken değişiklikler neler olabilir yanlışım var mı?

    configlerim aşağıdadır.yardımcı olanlara şimdiden teşekkürler.


    cisco 2801 config

    Building configuration...

    This command is supported only in CO mode
    This command is supported only in CO mode
    This command is supported only in CO mode
    Current configuration : 1833 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 2801
    !
    boot-start-marker
    boot-end-marker
    !
    !

    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    !
    interface Loopback0
    no ip address
    !
    interface FastEthernet0/0
    ip address 192.168.2.25 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface ATM0/1/0
    no ip address
    no atm ilmi-keepalive
    dsl equipment-type CPE
    dsl operating-mode GSHDSL symmetric annex B
    dsl linerate AUTO
    bridge-group 1
    pvc 0/35
    encapsulation aal5snap
    !
    !
    interface ATM0/2/0
    no ip address
    no atm ilmi-keepalive
    dsl equipment-type CPE
    dsl operating-mode GSHDSL symmetric annex B
    dsl linerate AUTO
    bridge-group 1
    pvc 0/35
    encapsulation aal5snap
    !
    !
    interface ATM0/3/0
    no ip address
    no atm ilmi-keepalive
    dsl equipment-type CPE
    dsl operating-mode GSHDSL symmetric annex B
    dsl linerate AUTO
    bridge-group 1
    pvc 0/35
    encapsulation aal5snap
    !
    !
    interface BVI1
    ip address 172.16.102.1 255.255.255.0
    !

    router eigrp 10
    redistribute connected
    network 172.16.0.0
    no auto-summary
    !
    ip classless

    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    bridge 2 protocol ieee
    bridge 2 route ip
    bridge 3 protocol ieee
    bridge 3 route ip
    !




    Not:Göründüğü üzere şube (gshdsl) tarafında 3 hattı bridge group ile birleştirdim.



    Merkez Metroethernet 3560 tarafı
    Current configuration : 2868 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname PointtoPoint
    !

    !
    no aaa new-model
    system mtu routing 1500
    ip subnet-zero
    !

    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !


    interface GigabitEthernet0/51
    !
    interface GigabitEthernet0/52
    description POINT-TO-POINT-TTNET
    switchport trunk encapsulation dot1q
    switchport mode trunk


    interface Vlan102
    description vlan_102
    ip address 172.16.102.2 255.255.255.0
    !
    interface Vlan104
    description vlan_104
    ip address 172.16.104.2 255.255.255.0
    !
    interface Vlan105
    description vlan_105
    ip address 172.16.105.2 255.255.255.0
    !
    ip classless
    ip http server
    ip http secure-server
    !
    router eigrp 10
    redistribute connected
    network 172.16.0.0
    no auto-summary
    !
    control-plane


    Not:Burda farklı bir configurasyona gitmelimiyim.?
    Konu voip tarafından (09.02.2009 Saat 14:46 ) değiştirilmiştir. Sebep: zx

  6. #6
    Cagdas Yalman isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Feb 2008
    Mesajlar
    427

    Standart

    1-eigrp bağlantısı nereyedeyse 10 dakada bir down olup kendi kendine geri geliyor.

    debug açıp bakmak lazım ?

    2-switch tarafında configi 3 interface tanımlayarak yaptım bunu tek e düşürebilirmiyim.
    Malesef. TT tarafınında 3 farklı vlanda tek porttan gelir. aynı yerden gelmesi için tt nin multilink yapması lazım ama bunu yapmıyor.

    3-Config hakkında yapmam gereken değişiklikler neler olabilir yanlışım var mı?

    1. sorunun cevabını test etmek için bvi değilde 3nü ayrı ipler verip ayrı ayrı eigrp ye alıp kontrol edebilirsin.
    Carpe dieM

  7. #7
    voip isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Mar 2008
    Mesajlar
    187

    Standart

    MErhaba bu altyapıyı kurdum yalnız konunun başında belirttiğin gibi

    (Not: yalnız burda ilginç bir bug var 3 hat ta load balancing yapmak istediğinizde tek devreden gidiyor)


    demiştin.haklısın aynısı başıma geldi.

    cisco 3560g tarafı (Metroethernet)

    router eigrp 100
    redistribute static
    no auto-summary
    network 10.16.14.0 0.0.0.255
    network 172.16.102.0 0.0.0.255
    network 172.16.104.0 0.0.0.255
    network 172.16.105.0 0.0.0.255

    CISCO3560TT#show ip eigrp neighbors
    EIGRP-IPv4100) neighbors for process 100
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    2 172.16.104.1 Vl104 14 00:01:09 1 5000 2 0
    0 172.16.105.1 Vl105 14 00:01:10 1 5000 2 0
    1 172.16.102.1 Vl102 10 00:28:42 525 3150 0 32
    ----------------------------------------------------------------------

    cisco 2801 tarafı (3 adet point to point gshdsl bağlı)

    router eigrp 100
    redistribute static
    network 172.16.20.0 0.0.0.255
    network 172.16.102.0 0.0.0.255
    network 172.16.104.0 0.0.0.255
    network 172.16.105.0 0.0.0.255
    auto-summary


    GDHDSL-2801#show ip eigrp neighbors
    IP-EIGRP neighbors for process 100
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    0 172.16.102.2 AT0/1/0.1 11 00:30:15 20 210 0 3984



    yukarıda görüldüğü gibi 3 interface göstermesi gerekirken sadece AT0/1/0.1 var.Bu konuda fikriniz var mı?
    Konu voip tarafından (08.03.2009 Saat 19:14 ) değiştirilmiştir. Sebep: xc

  8. #8
    Fiver isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Oct 2008
    Mesajlar
    249

    Standart

    Merhaba, meraktan ayni yapiyi ben de PacketTracer'da kurdum. Sizden farkli bir config yaptigimi da sanmiyorum, vlan'lari tek tek network komutlari ile eigrp'ye aktardim. Testlerimde 3 link'in load balance ettigini tum neighbor iliskilerinin kuruldugunu gordum.
    Her iki router'a da eklenen yeni networkler'in, once tek link'ten, 30 saniye icersinde de kalan linklerin hepsinden equal cost link, load balance edicek sekle geldigini goruyorum.
    Yanliz sizin 3560 tarafindaki Eigrp Neighbor ciktisinda vlan104 ve 105'in SRTT'si 1ms (ki gercekci degil) ve Queue'da 2'ser adet hello/update (?) takili durumda. Bu anlik bir olay olabilir, sadece gozume carptigi icin belirtmek istedim.
    Konu Fiver tarafından (09.03.2009 Saat 16:36 ) değiştirilmiştir.

  9. #9
    Cagdas Yalman isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Feb 2008
    Mesajlar
    427

    Standart

    voip configleri yollayabilirmisin?
    Carpe dieM

  10. #10
    voip isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Mar 2008
    Mesajlar
    187

    Standart

    Merhaba configleri gönderiyorum

    Cisco 3560G (metroethernet tarafı)
    Building configuration...

    Current configuration : 5094 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname POINTTOPOINT
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    system mtu routing 1500
    ip subnet-zero
    ip routing
    !
    !
    !

    !
    interface GigabitEthernet0/51
    !
    interface GigabitEthernet0/52
    description TELEKOM-POINT-to-POINT
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface Vlan1
    no ip address

    interface Vlan102
    description 102-GSHDSL
    ip address 172.16.102.2 255.255.255.0
    !
    interface Vlan104
    description 104-GSHDSL
    ip address 172.16.104.2 255.255.255.0
    !
    interface Vlan105
    description 105-GSHDSL
    ip address 172.16.105.2 255.255.255.0

    !
    !
    router eigrp 100
    redistribute static
    no auto-summary
    network 10.16.14.0 0.0.0.255
    network 172.16.102.0 0.0.0.255
    network 172.16.104.0 0.0.0.255
    network 172.16.105.0 0.0.0.255
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.16.14.1
    ip http server
    ip http secure-server

    !
    control-plane
    !
    !

    POINTTOPOINT# sh ip eigrp topology
    EIGRP-IPv4 Topology Table for AS(100)/ID(172.22.1.50)

    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
    r - reply Status, s - sia Status

    P 172.16.20.0/24, 1 successors, FD is 28416
    via 172.16.102.1 (28416/28160), Vlan102
    P 172.16.105.0/24, 1 successors, FD is 2816
    via Connected, Vlan105
    P 0.0.0.0/0, 1 successors, FD is 2816
    via Rstatic (2816/0)
    P 172.16.102.0/24, 1 successors, FD is 2816
    via Connected, Vlan102
    P 172.16.104.0/24, 1 successors, FD is 2816
    via Connected, Vlan104
    P 10.16.14.0/24, 1 successors, FD is 2816
    via Connected, Vlan180


    POINTTOPOINT#sh ip eigrp neighbors
    EIGRP-IPv4100) neighbors for process 100
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    1 172.16.104.1 Vl104 14 00:01:13 1 5000 2 0
    2 172.16.102.1 Vl102 11 05:39:06 110 660 0 34
    POINTTOPOINT#



    GSHDSL TARAFI (cisco 2801)

    CISCO-2801#sh run
    Building configuration...

    Current configuration : 2150 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CISCO-2801
    !
    boot-start-marker
    boot system flash c2801-ipvoice-mz.124-15.T11.bin
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 172.16.20.1 172.16.20.10
    !
    ip dhcp pool local-network
    network 172.16.20.0 255.255.255.0
    default-router 172.16.20.1
    dns-server 172.16.1.144

    !
    !
    multilink bundle-name authenticated
    !


    interface FastEthernet0/0
    ip address 172.16.20.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface ATM0/1/0
    no ip address
    no atm ilmi-keepalive
    dsl equipment-type CPE
    dsl operating-mode GSHDSL symmetric annex B
    dsl linerate AUTO
    !
    interface ATM0/1/0.1 point-to-point
    ip address 172.16.102.1 255.255.255.0
    no snmp trap link-status
    atm route-bridged ip
    pvc 0/35
    encapsulation aal5snap
    !
    !
    interface ATM0/2/0
    no ip address
    no atm ilmi-keepalive
    dsl equipment-type CPE
    dsl operating-mode GSHDSL symmetric annex B
    dsl linerate AUTO
    !
    interface ATM0/2/0.1 point-to-point
    ip address 172.16.104.1 255.255.255.0
    no snmp trap link-status
    atm route-bridged ip
    pvc 0/35
    encapsulation aal5snap
    !
    !
    interface ATM0/3/0
    no ip address
    no atm ilmi-keepalive
    dsl equipment-type CPE
    dsl operating-mode GSHDSL symmetric annex B
    dsl linerate AUTO
    !
    interface ATM0/3/0.1 point-to-point
    ip address 172.16.105.1 255.255.255.0
    no snmp trap link-status
    atm route-bridged ip
    pvc 0/35
    encapsulation aal5snap
    !
    !
    router eigrp 100
    redistribute static
    network 172.16.20.0 0.0.0.255
    network 172.16.102.0 0.0.0.255
    network 172.16.104.0 0.0.0.255
    network 172.16.105.0 0.0.0.255
    auto-summary

    !
    ip http server
    !

    control-plane
    !


    CISCO-2801#sh ip eigrp topology
    IP-EIGRP Topology Table for AS(100)/ID(172.16.105.1)

    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
    r - reply Status, s - sia Status

    P 0.0.0.0/0, 1 successors, FD is 1256448
    via 172.16.102.2 (1256448/2816), ATM0/1/0.1
    P 10.16.14.0/24, 1 successors, FD is 1256448
    via 172.16.102.2 (1256448/2816), ATM0/1/0.1
    P 172.16.20.0/24, 1 successors, FD is 28160
    via Connected, FastEthernet0/0
    P 172.16.104.0/24, 1 successors, FD is 1256192
    via Connected, ATM0/2/0.1
    via 172.16.102.2 (1256448/2816), ATM0/1/0.1
    P 172.16.105.0/24, 1 successors, FD is 1256192
    via Connected, ATM0/3/0.1
    via 172.16.102.2 (1256448/2816), ATM0/1/0.1
    P 172.16.102.0/24, 1 successors, FD is 1256192
    via Connected, ATM0/1/0.1


    CISCO-2801#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 100
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    0 172.16.102.2 AT0/1/0.1 14 05:41:49 76 456 0 7899
    Konu voip tarafından (09.03.2009 Saat 17:21 ) değiştirilmiştir. Sebep: x

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok