ATM Serisi 5 - ATM Üzerinden OSPF
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 2 sonuçtan 1 ile 2 arasındakiler gösteriliyor.
Like Tree1Likes
  • 1 Post By MCyagli
ATM Serisi 5 - ATM Üzerinden OSPF

Bu konu için CCNA RS de ögrendigimiz Frame Relay yeterli degildir. CCNP ROUTE konulari içindeki Frame Relay üzerinden OSPF bilinmesi gerekir. Öyle varsayarak yaziyorum. Bildigimiz gibi OSPF IGP arasinda en

  1. #1
    MCyagli isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jul 2009
    Bulunduğu yer
    Corum - Turkiye
    Mesajlar
    565

    Standart ATM Serisi 5 - ATM Üzerinden OSPF

    Bu konu için CCNA RS de ögrendigimiz Frame Relay yeterli degildir.
    CCNP ROUTE konulari içindeki Frame Relay üzerinden OSPF bilinmesi gerekir.


    Öyle varsayarak yaziyorum.

    Bildigimiz gibi OSPF IGP arasinda en populer
    routing protocol

    Gittigi her yerde kurallarini kendi koyar.

    Frame relay de çalisirkende ayni seyi yapar.

    Onun için OSPF in Frame Relay üzerinde çalisirken ki
    kurallarini hatirlamak gerekir.


    Kisaca OSPF

    çalistigi INTERFACE e bakar

    ve derki " Himm ben Su Network deyim "

    Ve ona göre kurallarini koyar.

    Böyle bir takintisi var.


    OSPF in kafasinda degisik NETWORK çesitleri vardir.

    Mesela bunlar

    Broadcast
    Non-Broadcast
    Point-to-Multipoint
    Point-to-Point
    Point-To-Multipont Non-Broadcast


    dir.

    Ve adamina göre muamele yapmak denir ya,
    aynen öyledir. OSPF network e göre farkli çalisir.

    Mesela CCNA RS de görmüstük.
    Multi Access olan network lerde DR / BDR falan seçerdi.

    Herhangi bir INTERFACE de OSPF çalisirken,

    ----show ip os int xx ---

    yapin Network Type = ? burda bisi yazar. Yukardakilerde biri iste.

    Ve biz istersek ilgili interface e gidip
    NETWORK type i degistirebiliriz ( Orda yazdigindan farkli biis yazabiliriz )

    Peki neydi bu NETWORK TYPE larinin farki ve neden önemliydi?

    Mesela R1 ve R2 nin Frame Relay ortaminda Komsu olmaya çalistigini düsünelim.

    R1 in interface i

    eger NETWORK Type = BROADCAST yazarsa,

    Bu interface in bagli oldugu network de DR/BDR seçilmesi gerektigine inanir.
    Bu interface den gönderdigi Hello her 10 saniyede bir dir ve Dead Time = 40 saniyedir.

    R2 nin Interface in de

    NETWORK TYPE = Point to Multipoint Non Broadcast ise,

    Bu interface in bagli oldugu network de DR/BDR seçilmeyecektir.
    Bu interface den gönderdigi Hello her 40 saniyede bir dir ve Dead Time = 120 saniyedir.


    KOmsu olabilirler mi ?

    Tabiki olmaz.
    Birisi DR/BRD seçelim der. Öbürünnün otur oturdugun yerde is çikarma basima der.
    Birisi her 40 saniyede bir Hello gönderir. Digerinin Dead Time i 40 saniyedir

    Neyse konuyu çokda OSPF nasil çalisir a getirmeyelim.
    Bu konu detayli bir sekilde CCNP ROUTE da islenir.

    Biz gelelim ATM üzeriden OSPF çalistirmaya !

    ***


    Su TOPOLOGY yi kullanalim.

    R1 HUB olsun.
    R2 ve R3 SPOKE olsun.


    Interface olarak Fiziksel interface kullanalim .
    Hatirlacak olursak OSPF frame relay fiziksel interface e
    Non-BROADCAST network gözüyle bakardi.

    NBMA networkun özelliklerini hatirlayalim o halde :

    KOmsuluk STATIC KURUlmak zorunda.
    DR/BDR olacak.
    Layer 2 PVC üzerinde BROADCAST kelimesine gerek yoktu.


    Onun için HUB i DR yapalim.
    BDR a ihtiyacimiz yok.
    Digerlerini DROTHER yapalim.




    Bunlar Frame Relay kurallari idi.

    Burdada aynidir sanirim


    Bakalim.


    Kod:
    R1#
    
    CONF T
    int lo1
    ip add 10.0.0.1 255.255.255.0
    
    router ospf 1
    router-id 1.1.1.1
    network 123.0.0.1 0.0.0.0 area 0
    network 10.0.0.1 0.0.0.0 area 0
    neighbor 123.0.0.2
    neighbor 123.0.0.3
    
    int atm1/0
    ip address 123.0.0.1 255.255.255.0
    IP OSPF PRIORITY 255
    
    pvc 1/112
    pvc 1/113
    
    no sh
    
    end
    wr


    ---> Fiziksel Interface oldugu için Inverse ARP a gerek yok.
    ---> Broadcast kelimesini girmemize gerek yok. Ospf onu
    kendi çözecek. Çünkü NBMA den dolayi Statik Komsuluk
    girdik.





    Kod:
    R2#
    
    conf t
    int lo1
    ip add 20.0.0.2 255.255.255.0
    
    router os 1
    router-id 2.2.2.2
    network 20.0.0.2 0.0.0.0 area 0
    network 123.0.0.2 0.0.0.0 area 0
    
    int atm 1/0
    ip address 123.0.0.2 255.255.255.0
    IP OSPF PRIORITY 0
    
    pvc 1/121
    no sh
    
    end
    wr

    Kod:
    R3#
    
    conf t
    int lo1
    ip add 30.0.0.3 255.255.255.0
    
    router os 1
    router-id 3.3.3.3
    network 30.0.0.3 0.0.0.0 area 0
    network 123.0.0.3 0.0.0.0 area 0
    
    int atm 1/0
    ip address 123.0.0.3 255.255.255.0
    IP OSPF PRIORITY 0
    
    pvc 1/131
    no sh
    
    end
    wr



    Bakalim Sistem çalisiyor mu ?
    -----------------------------------


    R1 üzerinde

    ---- show ip os nei ---

    2.2.2.2 0 FULL/DROTHER 00:01:55 123.0.0.2 ATM1/0
    3.3.3.3 0 FULL/DROTHER 00:01:55 123.0.0.3 ATM1/0




    Peki ROUTing table ?

    --- show ip route ospf ---

    O 20.0.0.2 [110/2] via 123.0.0.2, 00:01:32, ATM1/0
    30.0.0.0/32 is subnetted, 1 subnets
    O 30.0.0.3 [110/2] via 123.0.0.3, 00:00:37, ATM1/0





    ***

    Bu yazi ATM serisinin sonuncusu olsun.

    ILeryen zamanlarda

    MPLS Over ATM
    Ip Multicasting over ATM
    QoS OVer ATM

    gibi konulari nasip olursa yazariz.


    ***

    Düzenlemesini yapıp ekleyeceğim konular ise sırasıyla :


    Bridging Serisi ( Transparent Bridging, CRB, IRB )
    DHCP ( Birazcık Detaylı )
    NAT ( Birazcık Detaylı )
    PPPOX
    DSL
    Hypnotic likes this.
    Mehmet Ceyhan YAĞLI
    I learn, I teach

    www.mcyagli.com

  2. #2
    Hypnotic isimli Üye şimdilik offline konumundadır Co Administrator
    Üyelik tarihi
    Oct 2008
    Bulunduğu yer
    İstanbul
    Mesajlar
    769

    Standart

    döküman süper olmuş. anlatım tarzına sağlık

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok