Network Address Translation (NAT)
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 2 Sayfadan 1. Sayfa 12 SonuncuSonuncu
Toplam 15 sonuçtan 1 ile 10 arasındakiler gösteriliyor.
Network Address Translation (NAT)

Şimdi arkadaşlar Network Address Translation (NAT) konfigurasyonunda kafamı karıştıran küçük bir nokta var. Eğer R1’de Network Address Translation (NAT) yapılmamış olsa 172.16.0.1’den 2.2.2.2’ye giden bir paket hedefine ulaşsa bile geri

  1. #1
    Unknown isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Jun 2011
    Mesajlar
    70

    Standart Network Address Translation (NAT)



    Şimdi arkadaşlar Network Address Translation (NAT) konfigurasyonunda kafamı karıştıran küçük bir nokta var. Eğer R1’de Network Address Translation (NAT) yapılmamış olsa 172.16.0.1’den 2.2.2.2’ye giden bir paket hedefine ulaşsa bile geri dönüşte destination adres : local bir IP olan 172.16.0.1 olduğu için geri dönmez yani yanıt alamayız.

    BU nedenle nat yapıp içerdeki 172.16.0.1’i dışarı çıkarken 199.8.7.1 gibi Dış IP havuzuna ait bir adresle çıkarıyoruz ve Network Address Translation (NAT) tablosunda içerdeki 172.16.0.1 dışarda 199.8.7.1 dir diyede kayıt tutup paket geri geldiğinde eşleştirebiliyoruz. Böylece router1’e ulaşan paket NAT tablosundaki bu eşleşme sayesinde paketi yollayan PC’ye ulaşıyor.

    Yani yanılmıyorsam hedef pakedi bize yollarken destination adres olarak bizdeki 199.8.7.1’i görüp ona gönderiyor. Buraya kadar işlem tamamsa kafam şurda karışıyor.

    Paket benim router’dan çıktı ama benim router’ın dış bacağından çıktı onunda bir IP adresi var. Yani bu durumda 2.2.2.2 bana yanıtı gönderirken hedef olarak aslında router’ımın dış bacak IP’sine gönderiyor olmalı ki benim routerda “haa bana bir paket geldi alıcı kim 172.16.0.1 bakim tabloma bu kimmiş desin o da istemciye yollasın.”diye düşünüyorum.

    Fakat böyle olsa o zaman router pakedi kendine gelmiş gibi görecek içerdeki clienti eşlediğim dış havuz adresi olmayacak gelen pakette çünkü bir IP pakedinde 2 tane alıcı adres olmaz. Bu durumda bu tür bir işlemde router’ın dış bacağı 1.1.1.1 gibi değilde dış havuzumdan çıkış yapan 199.8.7.1 mi oluyor. Router’ın dış adresi bu işlere hiç el sürmüyor mu? Nedir ne değildir anlamadım.

    Yoksa 2.2.2.2 benim router'ın adresini 1.1.1.1 değilde 199.8.7.1 olarak mı görüyor?
    Bu pakedin giderken ve gelirken kaynak ve hedef adresleri nasıl olur?
    Konu Unknown tarafından (25.09.2011 Saat 15:24 ) değiştirilmiştir.

  2. #2
    turkavfatih isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Mar 2008
    Bulunduğu yer
    İstanbul
    Mesajlar
    590

    Standart

    Selam,

    Senin routerının dış bacağı vermiş olduğun örnekte 1.1.1.1 zaten olamaz.Dış bacak ip adresin iç networkunu nat ladıgın ip adresi olması gerek.pc den senın routerına gelen paketın source adresınde pc nın local adresı bulunur.Nat sayesınde bu local adres senın natlamıs oldugun public adrese cevrılır ve routerdan cıkan bu paketın source unda public adresın gozukur.Yanı senın internete gıden paketın gerı donuste senın public ip adresıne gonderılır cunku internettekı bı cıhaz senın local ıp adresını bılmez.Paket routera dondukten sonra router nat tablosunu kontrol eder ve kendı publıc ip adresıyle hangı network natlanmıssa paketı o networke gerı gonderır.Umarım anlaşılır olmustur.
    Juniper Networks

    JNCIA-EX,JNCIS-ER,JNCIS-FWV,JNCIS-SSL

  3. #3
    cobanoglu isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Sep 2011
    Bulunduğu yer
    ABD, New York
    Mesajlar
    105

    Standart

    merhaba,

    R1 outside IP addresi (internete bagli interface) senin Dis IP havuzundan bir IP address olmak zorunda,

    yani senin Public IP adres havuzun 199.X.X.X, ve R1 outside ip addresi 1.1.1.1 olamaz.

    NAT, Inside Local IP adres ve Inside Global adres konularini gozden gecirmen faydali olur.

    Cobanoglu
    CCIE Written, CCIP, CCDP, CCNP, CCNA Voice & Security

  4. #4
    Unknown isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Jun 2011
    Mesajlar
    70

    Standart

    Arkadaşlar cevaplar için teşekkür ederim. Merak ettiğim nokta sayenizde açıklığa kavuştu. Ben o adresin 1.1.1.1 olmayacağını biliyorum Onu sadece dışarıyı ifade etmesi için öylesine yazdım.

  5. #5
    ehsan445 isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Oct 2011
    Mesajlar
    4

    Standart

    Selamlar olsun iki taraflı NAT kanfigurasyonu nasil yapmak olur lütfen bana yardım edin

  6. #6
    turkavfatih isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Mar 2008
    Bulunduğu yer
    İstanbul
    Mesajlar
    590

    Standart

    Selam,

    Konuyu biraz daha açabilirmisin?
    Juniper Networks

    JNCIA-EX,JNCIS-ER,JNCIS-FWV,JNCIS-SSL

  7. #7
    Unknown isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Jun 2011
    Mesajlar
    70

    Standart

    Alıntı turkavfatih Nickli Üyeden Alıntı Mesajı göster
    Selam,

    Konuyu biraz daha açabilirmisin?
    Hocam burdaki hadiseyi sağolsun arkadaşların yardımlarıyla anladık anlamasınada geceden beri bir nat conf ile uğraşıyorum pinglemiyor pt'ye uçmak üzereyim pes dedim yani

  8. #8
    ehsan445 isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Oct 2011
    Mesajlar
    4

    Standart

    benim bir tane Routerim var ounun e(0) lan tarafında ve E(1) wan tarafinda ,Lanimde bir Serverim var onun ip si : 192.168.0.100 Routerimin Lan ip si: 192.168.0.254 ve Wan ip si : 192.168.56.254 mü Wanimden bir ip(192.168.56.21) Lan de ki serveri görmek gerk o yüzden iki taraflı NAT yapmak isterim

  9. #9
    Unknown isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Jun 2011
    Mesajlar
    70

    Standart

    Alıntı ehsan445 Nickli Üyeden Alıntı Mesajı göster
    benim bir tane Routerim var ounun e(0) lan tarafında ve E(1) wan tarafinda ,Lanimde bir Serverim var onun ip si : 192.168.0.100 Routerimin Lan ip si: 192.168.0.254 ve Wan ip si : 192.168.56.254 mü Wanimden bir ip(192.168.56.21) Lan de ki serveri görmek gerk o yüzden iki taraflı NAT yapmak isterim
    Bende istiyorumda niyeyse olmuyor işte havuzdan IP alıp çıktığını görüyorum ama karşılıklı ağlardaki lokal pc'ler birbirini pinglemiyor. Enteresan

  10. #10
    Unknown isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Jun 2011
    Mesajlar
    70

    Standart Konfigürasyonun neden çalışmadığını bulamıyorum



    Arkadaşlar yukarıdaki konf. için show run çıktılarını ekleyeyim. Sonra olaya döneyim

    Kod:
    Adana(config)#do sh ru
    Building configuration...
    
    Current configuration : 862 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Adana
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback1
     ip address 199.8.7.1 255.255.255.0
    !
    interface FastEthernet0/0
     ip address 192.168.1.254 255.255.255.0
     ip nat inside
     duplex auto
     speed auto
    !
    interface FastEthernet1/0
     ip address 1.1.1.1 255.0.0.0
     ip nat outside
     duplex auto
     speed auto
    !
    interface FastEthernet2/0
     no ip address
     duplex auto
     speed auto
     shutdown
    !
    interface FastEthernet3/0
     no ip address
     duplex auto
     speed auto
     shutdown
    !
    router rip
     network 1.0.0.0
     network 199.8.7.0
    !
    ip nat pool burak 199.8.7.2 199.8.7.5 netmask 255.255.255.0
    ip nat inside source list 1 pool burak
    ip classless
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
     login
    !
    !
    !
    end
    
    
    Adana(config)#
    Mersin router'ı için ise

    Kod:
    Mersin(config)#do sh ru
    Building configuration...
    
    Current configuration : 1007 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Mersin
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback2
     ip address 198.7.7.1 255.255.255.0
    !
    interface FastEthernet0/0
     ip address 1.1.1.2 255.0.0.0
     ip nat outside
     duplex auto
     speed auto
    !
    interface FastEthernet1/0
     ip address 192.168.2.254 255.255.255.0
     ip nat inside
     duplex auto
     speed auto
    !
    interface FastEthernet2/0
     ip address 192.168.3.254 255.255.255.0
     ip nat inside
     duplex auto
     speed auto
    !
    interface Serial3/0
     no ip address
     shutdown
    !
    interface FastEthernet4/0
     no ip address
     shutdown
    !
    interface FastEthernet5/0
     no ip address
     shutdown
    !
    router rip
     network 1.0.0.0
     network 198.7.7.0
    !
    ip nat pool mrs 198.7.7.2 198.7.7.5 netmask 255.255.255.0
    ip nat inside source list 1 pool mrs
    ip classless
    !
    !
    access-list 1 permit 192.168.3.0 0.0.0.255
    access-list 1 permit 192.168.2.0 0.0.0.255
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
     login
    !
    !
    !
    end
    
    
    Mersin(config)#
    örneğin
    192.168.1.3'ten Mersin 1.1.1.2 ye ping attığımda Adana router'ına ait show ip nat translation çıktısı aşağıda ki gibi

    Kod:
    Adana(config)#
    Adana(config)#do sh ip nat tr
    Pro  Inside global     Inside local       Outside local      Outside global
    icmp 199.8.7.2:1       192.168.1.2:1      1.1.1.2:1          1.1.1.2:1
    icmp 199.8.7.2:2       192.168.1.2:2      1.1.1.2:2          1.1.1.2:2
    icmp 199.8.7.2:3       192.168.1.2:3      1.1.1.2:3          1.1.1.2:3
    icmp 199.8.7.2:4       192.168.1.2:4      1.1.1.2:4          1.1.1.2:4
    
    Adana(config)#
    veya server'dan Adana router'ına ping attığımda aynı çıktı
    Kod:
    Mersin#
    Mersin#sh ip nat tr
    Pro  Inside global     Inside local       Outside local      Outside global
    icmp 198.7.7.2:1       192.168.3.1:1      1.1.1.1:1          1.1.1.1:1
    icmp 198.7.7.2:2       192.168.3.1:2      1.1.1.1:2          1.1.1.1:2
    icmp 198.7.7.2:3       192.168.3.1:3      1.1.1.1:3          1.1.1.1:3
    icmp 198.7.7.2:4       192.168.3.1:4      1.1.1.1:4          1.1.1.1:4
    
    Mersin#
    şeklinde. Burdan anladığım kadarıyla lokal'deki pc'ler tanımladığım IP havuzundan bir IP alarak çıkıyor ama bir türlü bu pingler routerların ötesindeki bir cliente geçemiyor. Nerde hata olduğunu anlayamadım????

    Mesela çok ilginçtir. 192.168.2.1 adana router'ın dış bacağına ping atıyor ve kendi gateway'inden geçiyor ama adananın gerisindeki 192.168.1.3'e pingleyince aynı yerden geçemiyor. çıktısıda aşağıda

    Kod:
    PC>ipconfig
    
    IP Address......................: 192.168.2.1
    Subnet Mask.....................: 255.255.255.0
    Default Gateway.................: 192.168.2.254
    
    PC>tracert 1.1.1.1
    
    Tracing route to 1.1.1.1 over a maximum of 30 hops: 
    
      1   3 ms      4 ms      2 ms      192.168.2.254
      2   3 ms      4 ms      2 ms      1.1.1.1
    
    Trace complete.
    
    PC>ping 192.168.1.3
    
    Pinging 192.168.1.3 with 32 bytes of data:
    
    Reply from 192.168.2.254: Destination host unreachable.
    Reply from 192.168.2.254: Destination host unreachable.
    Reply from 192.168.2.254: Destination host unreachable.
    Reply from 192.168.2.254: Destination host unreachable.
    
    Ping statistics for 192.168.1.3:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    
    PC>
    PT'de simülasyonda gelip giden paketlerin içeriğine baktığımda NAT tablosunda eşleşme bulunamadı yazıyor ne olduğunu kestirebiliyorum ama havuzdan IP alıp çıkan biri oldumu zaten NAT table bu kaydı alır. Niye buna rağmen eşleşme bulunamadı diyor mana veremedim. Acilll yardıma ihtiyacım var

    Not : Bu arada resimde switch henüz hazır değil gibi görünüyor da ben bu işlemleri yaparken hazır durumdaydı sadece screenshot almak için hazır olmasını beklemedim.
    Konu Unknown tarafından (03.10.2011 Saat 15:01 ) değiştirilmiştir.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok