Cisco 878 Router Uzak Bağlantı Problemi
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 3 Sayfadan 1. Sayfa 123 SonuncuSonuncu
Toplam 21 sonuçtan 1 ile 10 arasındakiler gösteriliyor.
Cisco 878 Router Uzak Bağlantı Problemi

Merhaba elimde bir cisco 878-k9 model router var , telekomdan 2mb gshdsl internet hattı aldık , aşağıdaki gibi basit bi konfigirasyon ile internete çıkışı sağlayabildim. sorularım şöyle : 88.xx.xx.xx nolu

  1. #1
    skarababa isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Feb 2011
    Mesajlar
    9

    Standart Cisco 878 Router Uzak Bağlantı Problemi

    Merhaba
    elimde bir cisco 878-k9 model router var , telekomdan 2mb gshdsl internet hattı aldık , aşağıdaki gibi basit bi konfigirasyon ile internete çıkışı sağlayabildim.
    sorularım şöyle : 88.xx.xx.xx nolu ipden içerdeki 10.0.0.203 nolu serverıma mstsc(3389) yapmak istiyorum
    dış internettende içerde web yayını yapan 10.0.0.205 nolu serverıma erişilebilmesini istiyorum
    tabiki başka yerlerden başka portlarada erişimlerin kapalı olması var birde

    hata mesajları
    *Acces 200 için aldığım hatalar
    Router(config)#access-list 200 permit tcp 88.xx.xx.xx x.x.x.x eq 3389
    % Invalid input detected at '^' marker.
    Router(config)#access-list 200 permit tcp 88.xx.xx.xx 10.0.0.203 eq 3389
    % Invalid input detected at '^' marker.
    Router(config)#access-list 200 permit tcp 88.xx.xx.xx % Invalid input detected at '^' marker.
    Router(config)#access-list 200 permit tcp 88.xx.xx.xx ?
    % Unrecognized command

    ------------ aktif konfigirasyon
    Router>
    Router>
    Router>en
    Router#sh run
    Building configuration...

    Current configuration : 1590 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    !
    no aaa new-model
    !
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    controller DSL 0
    mode atm
    dsl-mode shdsl symmetric annex B
    !
    !
    !
    !
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface ATM0
    mtu 1500
    no ip address
    no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    ip address 10.0.0.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    !
    interface Dialer1
    description GSHDSL_INTERNET
    ip address negotiated
    ip mtu 1460
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1360
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username [email protected] password 0 ghdsl
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1 name GSHDSL_INTERNET
    ip route 0.0.0.0 0.0.0.0 Dialer1 name GSHDSL_INTERNET
    no ip http secure-server
    !
    ip nat source static tcp 10.0.0.203 3389 interface Dialer1 3389
    ip nat source static tcp 10.0.0.205 80 interface Dialer1 80
    ip nat inside source list 100 interface Dialer1 overload
    !
    access-list 100 permit ip 10.0.0.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    login
    !
    scheduler max-task-time 5000
    end

  2. #2
    skarababa isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Feb 2011
    Mesajlar
    9

    Standart

    md5 isimli kullanıcının yazdığı bir cevap vardı dediklerini aynen uyguladım ama ben başarılı olşamadım aşağıda onun yapmamı istedikleri var yukardaki hata mesajalrını alıyorum ben bunları yapınca

    Alıntı max331 Nickli Üyeden Alıntı Mesajı göster
    Merhaba,
    Cevabınızı tam olarak anlayamadım,örnek komut satırı vermeniz mümkünmü ?
    Yapmak istediğim ;
    Örnek satırdaki nat komutuyla dialer1 den gelen bütün 3389 istekleri iç ağımdaki 192.168.0.5 makinasına iletiliyor (ip nat inside source static tcp 192.168.0.5 3389 Dialer1 3389)
    ama ben şöyle bir şey yapmak istiyorum dialer1'e atıyorum 88.99.100.100 real ip adresinden gelen 3389 istekleri kabul etmek ve bunun dışındakileri engellemek.
    ufak bir access-list yazarak halledebilirsin.

    #access-list 200 permit tcp 88.xx.xx.xx x.x.x.x eq 3389

    sonra dialer1 interface'ine gelip

    #ip access-group 200 in

    diyerek acl'i aktif edersin


    kolay gelsin
    M.D.

    bu durumda acces-listi biraz genişletmemiz gerekecek

    #access-list 200 permit tcp 88.xx.xx.xx x.x.x.x eq 3389
    #access-list 200 permit tcp any any eq 80
    #access-list 200 permit tcp any any eq 110
    #access-list 200 permit tcp any any eq 587

    seklinde access-listimizi modifiye ederek sorunu çözebiliriz.

    ufak bir hatırlatama : eger access-list i silecek olursan öncelikle interface altından kaldırmalısın yoksa internetin komple kesilir (implicit deny).

  3. #3
    trunkmode isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,331

    Standart

    Protocol type-code access-list number giriyorsunuz extended uygulayın
    Router(config)#access-list 200 permit ?
    <0x0-0xFFFF> Protocol type-code

    <1-99> IP standard access list
    <100-199> IP extended access list
    <1000-1099> IPX SAP access list
    <1100-1199> Extended 48-bit MAC address access list
    <1200-1299> IPX summary address access list
    <1300-1999> IP standard access list (expanded range)
    <200-299> Protocol type-code access list
    <2000-2699> IP extended access list (expanded range)
    <300-399> DECnet access list
    <600-699> Appletalk access list
    <700-799> 48-bit MAC address access list
    <800-899> IPX standard access list
    <900-999> IPX extended access list

  4. #4
    fkoc isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Feb 2011
    Bulunduğu yer
    Stuttgart / Almanya
    Mesajlar
    19

    Standart

    access-list 110 permit tcp host 88.xx.xx.xx host 10.0.0.203 eq 3389
    access-list 110 permit tcp host 88.xx.xx.xx host 10.0.0.204 eq www

  5. #5
    skarababa isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Feb 2011
    Mesajlar
    9

    Standart

    forumda okuduklarıma göre aşağıdakilerin yapılması gerekiyormuş? birde extend dediğiniz nasıl yapılıyor ? ben bu cisco configirasyonuna hakim değilim forumda okuduklarımı uygulamaya çalışıyorum .

    ip nat source static tcp 10.0.0.203 3389 interface Dialer1 3389
    ip nat source static tcp 10.0.0.205 80 interface Dialer1 80
    ip nat inside source list 100 interface Dialer1 overload
    !
    access-list 100 permit ip 10.0.0.0 0.0.0.255 any
    dialer-list 1 protocol ip permit

  6. #6
    GhoSt isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,664

    Standart

    Access-list ile işiniz yok zaten paketleri geçirir vaziyette çalışıyor cihaz
    ip nat source static tcp 10.0.0.203 3389 88.xx.xx.xx 3389
    komutunu deneyin
    Mr.google knows everything , ask to him...

  7. #7
    trunkmode isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,331

    Standart

    Evet GhoSt yazınca farkettim PAT konfigurasyonu yaparsanız çalışacaktır

  8. #8
    fkoc isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Feb 2011
    Bulunduğu yer
    Stuttgart / Almanya
    Mesajlar
    19

    Standart

    ip nat inside source static tcp <LAN_IP> 3389 <WAN> 3389

  9. #9
    skarababa isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Feb 2011
    Mesajlar
    9

    Standart

    1.access-list 100 permit ip 10.0.0.0 0.0.0.255 any - burda anlatılmak istenen
    10.0.0.0 ip segmenti --- 0.0.0.255 maskına --- (Dışarıdakiherhangi bir ) anyden gelen ne varsa izin ver demek midir ?
    2.ip nat source static tcp 10.0.0.203 3389 88.xx.xx.xx 3389
    88.xx.xx.xx ipsi ve 3389 portundan gelen istekleri 10.0.0.203 3389 gönder demek mi oluyor ?
    3.ip nat inside source list 100 interface Dialer1 overload ne demek ?
    4.dialer-list 1 protocol ip permit ne demek ?
    ona göre şu acces listi komple bi silip tekrar yazıcam
    çünkü şimdi bütün hepsi üst üste bindi galiba ondan çalışmıyor.
    Konu skarababa tarafından (15.02.2011 Saat 14:53 ) değiştirilmiştir.

  10. #10
    GhoSt isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,664

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok