EIGRP Stub Static Konfigurasyon Problemi
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 8 sonuçtan 1 ile 8 arasındakiler gösteriliyor.
EIGRP Stub Static Konfigurasyon Problemi

Arkadaşlar merhaba, Biraz acil bir durum.Eigrp stub static yapıldığında bir türlü çözemediğim bir sıkıntı var.R1 routerı eigrp stub yaptım.Altta konfigürasyonu var. ip route 10.1.4.0 255.255.255.0 10.1.3.10 ile static route yazmıştım.

  1. #1
    ilhan isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2009
    Mesajlar
    31

    Standart EIGRP Stub Static Konfigurasyon Problemi

    Arkadaşlar merhaba,
    Biraz acil bir durum.Eigrp stub static yapıldığında bir türlü çözemediğim bir sıkıntı var.R1 routerı eigrp stub yaptım.Altta konfigürasyonu var. ip route 10.1.4.0 255.255.255.0 10.1.3.10 ile static route yazmıştım.
    R1 e serial 1/1 ile R2 , serial 1/0 ile R4 , ethernet 0/0 ile R2 bağlı. 10.1.4.0 network ünü ethernet 0/1 için tanımladım.
    Altta görüleceği gibi R1 altında eigrp stub static komutu giirili.Fakat diğer routerlardan 10.1.4.1 network ünü pingleyemiyorum.
    Denediğim çözümleri yazıyorum.

    >>> 10.1.4.0 network u connected olduğu için eigrp altında tanımlamadım fakat redistribute connected ile bu çözüldü.
    >>>static route için bir kaç yerde okumuştum eigrp altına redistribute etmek gerekebiliyor. Bunun için de redistribute static metric 1000 1 255 1 1500 komutunu da girdim ve denedim fakat işe yaramadı.
    >>>10.1.4.0 network unu eigrp altında network komutu ile tanımladım fakat yine işe yaramadı.

    Başka ne yapılabilir ,aklıma gelen her şeyi denedim fakat çözülmedi.

    Rack1R1#sh run
    Building configuration...

    Current configuration : 1606 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Rack1R1
    !
    boot-start-marker
    boot-end-marker
    !
    enable password aSKin04
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 192.168.1.1 255.255.255.0
    !
    interface Loopback1
    ip address 192.168.2.1 255.255.255.0
    !
    interface Loopback2
    ip address 192.168.3.1 255.255.255.0
    !
    interface Ethernet0/0
    ip address 10.1.3.1 255.255.255.0
    half-duplex
    !
    interface Ethernet0/1
    ip address 10.1.4.1 255.255.255.0
    half-duplex
    !
    interface Ethernet0/2
    no ip address
    shutdown
    half-duplex
    !
    interface Ethernet0/3
    no ip address
    shutdown
    half-duplex
    !
    interface Serial1/0
    ip address 10.1.2.1 255.255.255.0
    serial restart-delay 0
    !
    interface Serial1/1
    ip address 10.2.2.1 255.255.255.0
    ip summary-address eigrp 100 192.168.0.0 255.255.252.0 5
    serial restart-delay 0
    clock rate 64000
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 100
    redistribute connected
    network 10.1.2.0 0.0.0.255
    network 10.1.3.0 0.0.0.255
    network 10.2.2.0 0.0.0.3
    no auto-summary
    eigrp stub static
    !
    no ip http server
    no ip http secure-server
    ip route 10.1.4.0 255.255.255.0 10.1.3.10 ( 10.1.3.10 R3 ün interface ip si
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    exec-timeout 0 0
    privilege level 15
    line vty 0 4
    password cisco
    login
    !
    !

    Rack1R1#sh cdp ne
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
    S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    Rack1R2 Ser 1/1 156 R S I 3640 Ser 1/1
    Rack1R3 Eth 0/0 178 R S I 3640 Eth 0/0
    Rack1R4 Ser 1/0 134 R S I 3640 Ser 1/0
    end

  2. #2
    mely isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Oct 2008
    Bulunduğu yer
    Istanbul
    Mesajlar
    326

    Standart

    router 3 kime bağlı ?

    Sorunun cok buyuk ihtimalle router 1, router 3 ulaşabiliyo fakat router 3, router 1 e ulaşamıyor. ( ya da diğer routerlar için )Yani routerların routing table larına bak. Sıkıntının burada oldugunu düşünüyorum..
    Kolay Gelsin..

  3. #3
    mely isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Oct 2008
    Bulunduğu yer
    Istanbul
    Mesajlar
    326

    Standart

    source belirterek ping kullan sana daha yardımcı olacaktır sorunu çözmende..

  4. #4
    trunkmode isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,331

    Standart

    Merhaba
    R1 de 10.1.4.0 networku için static route yazmışsınız fakat zaten
    bu network R1 de fa0/1 directly connected!! ve eigrp as de duyurulmuyor
    konfigurasyonları tekrar gözden geçirirmisiniz. Sanırım bir yeri gözden kaçırıyorsunuz
    EIGRP Stub Routing - Cisco Systems

  5. #5
    ilhan isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2009
    Mesajlar
    31

    Standart

    Alıntı trunkmode Nickli Üyeden Alıntı Mesajı göster
    Merhaba
    R1 de 10.1.4.0 networku için static route yazmışsınız fakat zaten
    bu network R1 de fa0/1 directly connected!! ve eigrp as de duyurulmuyor
    konfigurasyonları tekrar gözden geçirirmisiniz. Sanırım bir yeri gözden kaçırıyorsunuz
    EIGRP Stub Routing - Cisco Systems
    trunkmode haklsın bu dedğini de düşündüm aslında eigrp stub summary uygulaması da yaptım ve orda eigrp altında network komutu ile anons edilmeyen directly connected networkleri REDISTRIBUTE CONNECTED komutu ile duyurdum ve karşı routerların pingleyebildiğini gördüm. Burada yine de dediğini yaptım network 10.1.4.0 0.0.0.255 ile tanıttım eigrp altında fakat yine örneğn R4 routerı 10.1.4.1 i pingleyemiyor. Şöyle bir şey denedim ; eigrp stub connected static yaptığımda tüm routerlar 10.1.4.1 i pingleyebiliyor, şöyle bir tespitim var belki doğru belki yanlış . Hem connected hem de static route gibi algılıyor 10.1.4.0 network unu , directly network daha düşük AD ye sahip olduğu için connected gibi düşünüyor.Ne dersiniz ?

    Burada temel sorun hiçbir routerın stub olan R1 routerındaki 10.1.4.1 i pingleyememesi.

  6. #6
    ilhan isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2009
    Mesajlar
    31

    Standart

    arkadaşlar ben anladım galiba mantığı . Aynı network hem directly connected hem de static route ile anons edilirse ,
    eigrp stub static yapılırsa bunu duyurma şansınız olmaz çünkü connected olarak ( AD si daha düşük static e göre ) göreceği için ve siz eigrp stub static connected demediğiniz için diğer routerlar pingleyemecek bu network u . Ben böyle bir sonuç elde ettim...

  7. #7
    trunkmode isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,331

    Standart

    Merhaba
    Fakat ilk sorunda eigrp stub static komutu verdim demiştin
    buna rağmen R1 e ulaşılamıyor demiştin sanırım?
    Toparlayacak olursak son durum nedir ?

  8. #8
    ilhan isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2009
    Mesajlar
    31

    Standart

    Alıntı trunkmode Nickli Üyeden Alıntı Mesajı göster
    Merhaba
    Fakat ilk sorunda eigrp stub static komutu verdim demiştin
    buna rağmen R1 e ulaşılamıyor demiştin sanırım?
    Toparlayacak olursak son durum nedir ?
    son durumu özetlemek gerekirse,
    10.1.4.0 network u R1 routerına connected ve ip route 10.1.4.0 255.255.255.0 10.1.3.10 static route var.

    1. DURUM : eigrp stub static tanımlı durumda. Bu durumda hiçbir router 10.1.4.0 network une ulaşamıyor ( eigrp altında network 10.1.4.0 ile anons ederek de denedim fakat değişmedi sonuç ) ,çünkü hem static hem de connected network olduğu için ve connected in AD si düşük olduğu için izin vermiyor . Hatta redistribute static metric komutunu bile kullandım ama sonuç değişmedi.
    router eigrp 100
    redistribute connected
    redistribute static metric 1000 1 250 1 150
    network 10.1.2.0 0.0.0.255
    network 10.1.3.0 0.0.0.255
    network 10.2.2.0 0.0.0.3
    no auto-summary
    eigrp stub static
    !

    2. DURUM : eigrp stub static connected tanımlı iken tüm routerlar pingleyebiliyor 10.1.4.0 network unu.

    YANİ static route ile anons ettiğiniz network un connected network olmaması lazım . Eğer olursa stub yaparken sadece eigrp stub static yaparsanız diğer routerlar görmeyecektir.Duyurmanız için eigrp stub connected static kullanmak gerekiyor.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok