Policy base routing PBR sorunu
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Reply to Thread
Results 1 to 3 of 3
Policy base routing PBR sorunu

Merhaba Policy base routing konusunu araştırıyorum bunun ile ilgili döküman ve video da buldum. GNS3 ile denediğim ve çalıştırdığım conf real de sorun yaratıyor kısaca ; Router üzerinden trace çektiğim

  1. #1
    max331 is offline Junior Member
    Join Date
    Oct 2007
    Posts
    26

    Default Policy base routing PBR sorunu

    Merhaba

    Policy base routing konusunu araştırıyorum bunun ile ilgili döküman ve video da buldum. GNS3 ile denediğim ve çalıştırdığım conf real de sorun yaratıyor kısaca ;

    Router üzerinden trace çektiğim zaman paketin istediğim interface (Serial0/1/0.1) üzerinden gönderildiğini görüyorum ACL'de hemen match ettiğini belirtiyor ama herhangi bir pc'den trace çektiğimde paketin (Tunnel1)kullandığını görüyorum. Pc den yaptığım testlerde söyle ilginç bir durumda var mesela 10.0.0.16 makinasına ping attığımda ACL'de hiç match alamıyorum ama aynı ip'ye trace çektiğimde ACL paketi match ettiğini belirtiyor gerçi sonuçta paket yine tunnel1 den gidiyor. Sorun ne olabilir ?

    Konfigürasyon örneği aşağıdaki gibi ;

    interface Tunnel1
    description Tunnel_To_MERKEZ
    ip address 172.16.0.2 255.255.255.252
    ip mtu 1420
    tunnel source Dialer1
    tunnel destination 88.88.88.88
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile tempo
    !
    interface FastEthernet0/0
    ip address 10.0.1.1 255.255.255.0
    ip nat inside
    ip policy route-map PBR
    ip virtual-reassembly
    ip route-cache policy
    duplex auto
    speed auto
    !
    !
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    bundle-enable
    !
    interface ATM0/0/0.1 point-to-point
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    !
    interface Serial0
    no ip address
    encapsulation frame-relay IETF
    no fair-queue
    frame-relay traffic-shaping
    frame-relay lmi-type ansi
    !
    interface Serial0.1 point-to-point
    description MERKEZ
    bandwidth 512
    ip address 192.168.0.2 255.255.255.0
    snmp trap link-status
    no cdp enable
    frame-relay interface-dlci 100
    class voice512
    !

    interface Dialer1
    ip nat outside
    xxxxxx
    xxxxxx
    vs
    ppp pap sent-username [email protected] password xxx
    !
    ip local policy route-map PBR
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Tunnel1
    ip route 0.0.0.0 0.0.0.0 Serial0.1 10
    ip route 88.88.88.88 255.255.255.255 dialer1
    !
    !
    ip nat inside source list 1 interface Dialer1 overload
    !
    ip access-list extended PBR
    permit ip any host 10.0.0.16 log
    !

    access-list 1 permit 10.0.1.0 0.0.0.255


    route-map PBR permit 10
    match ip address PBR
    set interface Serial0.1

  2. #2
    Soul is offline Administrator
    Join Date
    Jun 2008
    Posts
    1,080

    Default

    !
    ip access-list extended PBR
    permit ip any host 10.0.0.16 log
    !

    Burada log komuunu silip denedinmi bazı durumlarda 2 adet acl olusturman gerekebilir. + pbr routelara bakmadan önce davranısını belirler yani her sekilde s0/0.1 den gitmesi gerekiyor. su acl düzgün yazarmısın tekrar.
    www.cliguru.com

  3. #3
    max331 is offline Junior Member
    Join Date
    Oct 2007
    Posts
    26

    Default

    Merhaba
    Yardımınız için çok teşekkür ederim.
    Acl aşağıdaki gibi yeniden düzenlendi ve sorun çözüldü.

    ip access-list extended PBR
    permit ip any host 10.0.0.16
    permit ip host 10.0.0.16 any

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts