Network Address Translation (NAT)
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 7 sonuçtan 1 ile 7 arasındakiler gösteriliyor.
Network Address Translation (NAT)

cısco 2612 var.8080 ile cıkıs yapmak ıstıyorum. router 192.168.5.6 FastEthernet0/0 net cıkısı FastEthernet0/1 cıkıs yapmak ıstedıgım ip 192.168.5.1 cıkıs yapmak ıstedıgım port 8080 router a brk#conf term brk<config>ip nat inside

  1. #1
    brkmastIr isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Apr 2009
    Mesajlar
    11

    Arrow Network Address Translation (NAT)

    cısco 2612 var.8080 ile cıkıs yapmak ıstıyorum.

    router 192.168.5.6 FastEthernet0/0
    net cıkısı FastEthernet0/1
    cıkıs yapmak ıstedıgım ip 192.168.5.1
    cıkıs yapmak ıstedıgım port 8080

    router a

    brk#conf term
    brk<config>ip nat inside source static tcp 192.168.5.1 8080 interface FastEthernet0/1 8080
    brk<config>ip nat inside source static udp 192.168.5.1 8080 interface FastEthernet0/1 8080

    yazıyorum ama cıkamıyorum.yardımcı olur musunuz?

  2. #2
    AcLMasteR isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jan 2008
    Bulunduğu yer
    Ankara
    Mesajlar
    1,189

    Standart

    private ip ile nasıl dışarı çıkmayı düşünüyosunuz :S sh run cıktısını atarmısınız
    The day that never comes

  3. #3
    shroud41 Guest

    Standart

    Siz diyorsunuz ki, iç network'ümdeki 192.168.5.1 ip'si dışarı çıkarken fastEthernet0/1'deki ip'yi alsın.Peki fastethernet0/1'e private ip mi verdiniz, yoksa global ip mi?Eğer private verdiyseniz, zaten nat'ın hiçbir anlamı kalmaz.Global verdiyseniz, o zaman sorun, fastethernet0/0'a "ip nat inside", fastethernet 0/1'e "ip nat outside" yazmamanızdan kaynaklanıyor olabilir.

  4. #4
    brkmastIr isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Apr 2009
    Mesajlar
    11

    Standart

    fastethernet 0/0 private
    0/1 ise global

    bu durumda surada mı hata yapıyorum ben?

    ip nat inside source static tcp 192.168.5.1 8080 interface FastEthernet0/1 8080

    bu dogru olan ancak bır de sunu mu yapmalıyım?

    ip nat outside source static tcp 192.168.5.1 8080 interface FastEthernet0/0 8080 ???


    pardon tam tersi de olabilir kafam karıştı.
    Konu brkmastIr tarafından (10.10.2009 Saat 12:21 ) değiştirilmiştir.

  5. #5
    brkmastIr isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Apr 2009
    Mesajlar
    11

    Standart

    router#

    interface FastEthernet0/0
    description $ETH-LAN$
    ip address 192.168.5.6 255.255.255.0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    duplex auto
    speed auto
    no cdp enable
    no mop enabled
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    no cdp enable
    !
    interface Dialer1
    bandwidth 4096
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 1
    dialer remote-name redback
    dialer-group 1

    8080 porttan çıkmak istediğim makinenin ip si ise 192.168.5.1

  6. #6
    brkmastIr isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Apr 2009
    Mesajlar
    11

    Standart

    Son yaptıgım degısıklıkler sonrası nıye olmadı bı bakar mısınız?



    !
    interface FastEthernet0/0
    description $ETH-LAN$
    ip address 192.168.5.6 255.255.255.0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    duplex auto
    speed auto
    no cdp enable
    no mop enabled
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    no cdp enable
    !
    interface Dialer1
    bandwidth 4096
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 1
    dialer remote-name redback
    dialer-group 1
    ppp authentication chap callin
    ppp ipcp dns request
    !
    ip flow-top-talkers
    top 30
    sort-by bytes
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static tcp 192.168.5.1 8080 interface FastEthernet0/0 8080
    ip nat inside source static udp 192.168.5.1 8080 interface FastEthernet0/0 8080
    ip nat outside source static tcp 192.168.5.1 8080 85.105.170.### 8080 extendable
    ip nat outside source static udp 192.168.5.1 8080 85.105.170.### 8080 extendable


    nerede hata yaptım?
    Konu brkmastIr tarafından (10.10.2009 Saat 19:08 ) değiştirilmiştir.

  7. #7
    muratymurat isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Aug 2008
    Mesajlar
    158

    Standart

    ip nat outside source static tcp 192.168.5.1 8080 85.105.170.xx 8080 extendable

    udp neden yapıyorsun gerek yok ayrıca dsl in aldığı reel ip o olmalı ayrıca kullanıcılar nete cıkacakca nat ta yapman gerekıyor ve bu static port nat tan sonra diğer yazdıklarını yazmaman gerek

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok