EIGRP, Default Network - Sayfa 3
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 3 Sayfadan 3. Sayfa BirinciBirinci 123
Toplam 26 sonuçtan 21 ile 26 arasındakiler gösteriliyor.
EIGRP, Default Network

Slm;; blah blah blah whatever!!!! ercanusa, configinde bir sorun gozukmuyor... R1 ve R2 uzerinde "debug ip pac det 101" yapar isen problemi gorebilirsin... acl 101 per icmp any any ...

  1. #21
    burner Guest

    Standart

    Slm;;

    blah blah blah whatever!!!!

    ercanusa, configinde bir sorun gozukmuyor... R1 ve R2 uzerinde "debug ip pac det 101" yapar isen problemi gorebilirsin... acl 101 per icmp any any ...

    Iyi gunler

  2. #22
    ercanusa isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    İstanbul
    Mesajlar
    513

    Standart

    Cisco nun sitesinde şöyle birşey var ;
    Note: IGRP does not understand a route to 0.0.0.0. Therefore, it cannot propagate default routes created using the ip route 0.0.0.0 0.0.0.0 command. Use the ip default-network command to have IGRP propagate a default route.

    EIGRP propagates a route to network 0.0.0.0, but the static route must be redistributed into the routing protocol.

    Burdan benim anladığım bu komut sadece kararlılığı arttırıyor.

    Debug çıktılarıda şu şekilde sanırım ip default-network 192.168.1.0 yazmak yeterli olmuyor,bunu redistribute etmemiz gerekecek.



    R1(config)#interface serial 1/0
    R1(config-if)#ip acc
    R1(config-if)#ip acce
    R1(config-if)#ip access-group 101 out
    R1(config-if)#exit
    R1(config)#exit
    R1#ping 192.168.1.1
    *Apr 3 12:13:12.143: %SYS-5-CONFIG_I: Configured from console by console
    R1#ping 192.168.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

    *Apr 3 12:13:15.487: IP: s=192.168.2.1 (local), d=192.168.1.1, len 100, unroutable
    *Apr 3 12:13:15.487: ICMP type=8, code=0.
    *Apr 3 12:13:17.483: IP: s=192.168.2.1 (local), d=192.168.1.1, len 100, unroutable
    *Apr 3 12:13:17.487: ICMP type=8, code=0.
    *Apr 3 12:13:19.483: IP: s=192.168.2.1 (local), d=192.168.1.1, len 100, unroutable
    *Apr 3 12:13:19.487: ICMP type=8, code=0.
    *Apr 3 12:13:21.483: IP: s=192.168.2.1 (local), d=192.168.1.1, len 100, unroutable
    *Apr 3 12:13:21.487: ICMP type=8, code=0.
    *Apr 3 12:13:23.483: IP: s=192.168.2.1 (local), d=192.168.1.1, len 100, unroutable
    *Apr 3 12:13:23.483: ICMP type=8, code=0.
    Success rate is 0 percent (0/5)
    R1#



    R2(config)#interface serial 1/1
    R2(config-if)#ip acc
    R2(config-if)#ip acce
    R2(config-if)#ip access-group 101 out
    R2(config-if)#exit
    R2(config)#exit
    R2#ping 192.168.1.1
    *Apr 3 12:11:33.451: %SYS-5-CONFIG_I: Configured from console by console
    R2#ping 192.168.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !
    *Apr 3 12:11:37.019: IP: tableid=0, s=192.168.3.1 (local), d=192.168.1.1 (Serial1/1), routed via FIB
    *Apr 3 12:11:37.019: IP: s=192.168.3.1 (local), d=192.168.1.1 (Serial1/1), len 100, sending
    *Apr 3 12:11:37.023: ICMP type=8, code=0!!!
    *Apr 3 12:11:38.023: IP: tableid=0, s=192.168.1.1 (Serial1/1), d=192.168.3.1 (Serial1/1), routed via RIB
    *Apr 3 12:11:38.023: IP: s=192.168.1.1 (Serial1/1), d=192.168.3.1 (Serial1/1), len 100, rcvd 3
    *Apr 3 12:11:38.027: ICMP type=0, code=0
    *Apr 3 12:11:38.031: IP: tableid=0, s=192.168.3.1 (local), d=192.168.1.1 (Serial1/1), routed via FIB
    *Apr 3 12:11:38.035: IP: s=192.168.3.1 (local), d=192.168.1.1 (Serial1/1), len 100, sending
    *Apr 3 12:11:38.035: ICMP type=8, code=0
    *Apr 3 12:11:38.075: IP: tableid=0, s=192.168.1.1 (Serial1/1), d=192.168.3.1 (Serial1/1), routed via RIB
    *Apr 3 12:11:38.079: IP: s=192.168.1.1 (Serial1/1), d=192.168.3.1 (Serial1/1), len 100, rcvd 3
    *Apr 3 12:11:38.083: ICMP type=0, code=0
    *Apr 3 12:11:38.119: IP: tableid=0, s=192.168.3.1 (local), d=192.168.1.1 (Serial1/1), routed via FIB
    *Apr 3 12:11:38.123: IP: s=192.168.3.1 (local), d=192.168.1.1 (Serial1/1), len 100, sending
    *Apr 3 12:11:38.123: ICMP type=8, code=0
    *Apr 3!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 52/431/1012 ms

  3. #23
    burner Guest

    Standart

    Slm;

    Note: IGRP does not understand a route to 0.0.0.0. Therefore, it cannot propagate default routes created using the ip route 0.0.0.0 0.0.0.0 command. Use the ip default-network command to have IGRP propagate a default route.

    EIGRP propagates a route to network 0.0.0.0, but the static route must be redistributed into the routing protocol.
    Burdan benim anladığım bu komut sadece kararlılığı arttırıyor.

    Debug çıktılarıda şu şekilde sanırım ip default-network 192.168.1.0 yazmak yeterli olmuyor,bunu redistribute etmemiz gerekecek.
    Umarim konu anlasilir

    Iyi gunler

    igrp .. not eigrp bunlarin ikisi farkli... Ikincisi evet static route hakkinda dedigi dogrudur ama konumuz ile alakasi yoktur...debug ciktilarindan goruldug uzere o network a giden bir routen yok roter2 uzerinde "unroutable" demesinden goruluyor, anlami senin Gateway of last resort kurulmamis ....
    Ben yine configure ettim aynen senin topologyni ve calisiyor ... hic birseyi hicbirseyin icine redistribute etmene gerek yok zaten amacta burda bu olayi redist etmeden halletmek iki yol var ya ip default-network yada ip default-gateway...
    Configler asagida...

    Kod:
    R1================
    
    R1#sh ip int b
    Interface                  IP-Address      OK? Method Status                Protocol
    Ethernet0/0                150.1.107.10    YES NVRAM  up                    up      
    Ethernet0/1                150.1.104.10    YES NVRAM  up                    up      
    Ethernet0/2                unassigned      YES NVRAM  administratively down down    
    Ethernet0/3                unassigned      YES NVRAM  administratively down down    
    Loopback0                  150.1.10.10     YES NVRAM  up                    up      
    R1#sh run | be router eigrp
    router eigrp 1
     network 150.1.0.0
     no auto-summary
    !
    
    R1#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         150.1.0.0/24 is subnetted, 4 subnets
    D       150.1.4.0 [90/409600] via 150.1.104.4, 00:08:49, Ethernet0/1
    C       150.1.10.0 is directly connected, Loopback0
    C       150.1.107.0 is directly connected, Ethernet0/0
    C       150.1.104.0 is directly connected, Ethernet0/1
    D    192.168.3.0/24 [90/307200] via 150.1.104.4, 00:08:49, Ethernet0/1
    
    
    R3===
    
    
    R3#sh ip int b
    Interface                  IP-Address      OK? Method Status                Protocol
    Ethernet0/0                192.168.3.1     YES manual up                    up      
    Ethernet0/1                unassigned      YES NVRAM  administratively down down    
    Ethernet0/2                unassigned      YES NVRAM  administratively down down    
    Ethernet0/3                unassigned      YES NVRAM  administratively down down    
    Serial1/0                  unassigned      YES NVRAM  administratively down down    
    Serial1/1                  unassigned      YES NVRAM  up                    up      
    Serial1/1.12               150.1.123.1     YES NVRAM  up                    up      
    Serial1/2                  unassigned      YES NVRAM  administratively down down    
    Serial1/3                  unassigned      YES NVRAM  administratively down down    
    Loopback0                  150.1.1.1       YES NVRAM  up                    up      
    Loopback111                192.168.1.1     YES manual up                    up      
    R3#
    
    R3#
    
    R3#sh run | be router eigrp
    router eigrp 1
     network 192.168.3.0
     no auto-summary
    !
    
    R3#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    C    192.168.1.0/24 is directly connected, Loopback111
         150.1.0.0/16 is variably subnetted, 13 subnets, 2 masks
    O       150.1.29.0/24 [110/74] via 150.1.123.2, 00:11:30, Serial1/1.12
    D       150.1.4.0/24 [90/409600] via 192.168.3.4, 00:08:23, Ethernet0/0
    C       150.1.1.0/24 is directly connected, Loopback0
    O       150.1.8.8/32 [110/95] via 150.1.123.2, 00:11:30, Serial1/1.12
    O       150.1.5.5/32 [110/85] via 150.1.123.2, 00:11:30, Serial1/1.12
    O       150.1.2.2/32 [110/65] via 150.1.123.2, 00:11:30, Serial1/1.12
    D       150.1.10.0/24 [90/435200] via 192.168.3.4, 00:07:56, Ethernet0/0
    O       150.1.59.0/24 [110/84] via 150.1.123.2, 00:11:30, Serial1/1.12
    O       150.1.58.0/24 [110/94] via 150.1.123.2, 00:11:30, Serial1/1.12
    C       150.1.123.0/24 is directly connected, Serial1/1.12
    O       150.1.123.2/32 [110/64] via 150.1.123.2, 00:11:30, Serial1/1.12
    D       150.1.107.0/24 [90/332800] via 192.168.3.4, 00:07:57, Ethernet0/0
    D       150.1.104.0/24 [90/307200] via 192.168.3.4, 00:08:24, Ethernet0/0
    C    192.168.3.0/24 is directly connected, Ethernet0/0
    
    
    
    
    R2=============
    
    R2#sh ip int b
    Interface                  IP-Address      OK? Method Status                Protocol
    Ethernet0/0                192.168.3.4     YES manual up                    up      
    Ethernet0/1                150.1.104.4     YES NVRAM  up                    up      
    Ethernet0/2                unassigned      YES NVRAM  administratively down down    
    Ethernet0/3                unassigned      YES NVRAM  administratively down down    
    Loopback0                  150.1.4.4       YES NVRAM  up                    up      
    R2#
    
    !goruldugu uzere hibir redistribution yapilmamis
    !buradada goruldugu uzere sadece bir static route ve ip def-netw comutu
    
    R2#sh run | be router eigrp
    router eigrp 1
     network 150.1.0.0
     network 192.168.3.0
     no auto-summary
    !
    R2#sh run | inc ip route |ip default
    ip default-network 192.168.1.0
    ip route 192.168.1.0 255.255.255.0 192.168.3.1
    R2#
    
    
    
    !bunuda yapabiliriz:
    ip default-network 0.0.0.0
    ip route 0.0.0.0 0.0.0.0 192.168.3.1
    
    !o zaman :
    Gateway of last resort is 192.168.3.1 to network 0.0.0.0
    
    !olurdu....
    
    
    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 192.168.3.1 to network 192.168.1.0
    
    S*   192.168.1.0/24 [1/0] via 192.168.3.1
         150.1.0.0/24 is subnetted, 4 subnets
    C       150.1.4.0 is directly connected, Loopback0
    D       150.1.10.0 [90/409600] via 150.1.104.10, 00:03:39, Ethernet0/1
    D       150.1.107.0 [90/307200] via 150.1.104.10, 00:03:39, Ethernet0/1
    C       150.1.104.0 is directly connected, Ethernet0/1
    C    192.168.3.0/24 is directly connected, Ethernet0/0
    R2#
    
    goruldugu uzere tablemizde 192.168.1.0 bir networ yok ama bu var:
    
    Gateway of last resort is 192.168.3.1 to network 192.168.1.0
    
    TEST EDERSEK:
    
    R2#ping 192.168.1.1 rep 100
    
    Type escape sequence to abort.
    Sending 100, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Success rate is 100 percent (100/100), round-trip min/avg/max = 4/11/68 ms
    R2#

  4. #24
    burner Guest

    Standart

    Slm;

    Iste buda static default route yaratilarak eigrp nin icine redist edilmis hali, ancak bunun digerinden farki eigrp bu external routeyi butun routerlere gonderiyor domain icindeki ve ayni zamanda "Gateway of last resort is 192.168.3.4 to network 0.0.0.0" kuruyor...

    Kod:
    R2#sh run | inc ip route | ip default
    ip route 0.0.0.0 0.0.0.0 192.168.3.1
    
    R2#sh run | be eigrp
    router eigrp 1
     redistribute static metric 1 1 1 1 1
     network 150.1.0.0
     network 192.168.3.0
     no auto-summary
    !
    
    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 192.168.3.1 to network 0.0.0.0
    
         150.1.0.0/24 is subnetted, 4 subnets
    C       150.1.4.0 is directly connected, Loopback0
    D       150.1.10.0 [90/409600] via 150.1.104.10, 00:41:35, Ethernet0/1
    D       150.1.107.0 [90/307200] via 150.1.104.10, 00:41:35, Ethernet0/1
    C       150.1.104.0 is directly connected, Ethernet0/1
    C    192.168.3.0/24 is directly connected, Ethernet0/0
    S*   0.0.0.0/0 [1/0] via 192.168.3.1
    R2#
    
    
    
    =======================================
    
    
    R3#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 150.1.104.4 to network 0.0.0.0
    
         150.1.0.0/24 is subnetted, 4 subnets
    D       150.1.4.0 [90/409600] via 150.1.104.4, 00:42:07, Ethernet0/1
    C       150.1.10.0 is directly connected, Loopback0
    C       150.1.107.0 is directly connected, Ethernet0/0
    C       150.1.104.0 is directly connected, Ethernet0/1
    D    192.168.3.0/24 [90/307200] via 150.1.104.4, 00:42:07, Ethernet0/1
    D*EX 0.0.0.0/0 [170/2560025856] via 150.1.104.4, 00:02:19, Ethernet0/1
    R3#
    
    ===================================================================
    
    R1#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 192.168.3.4 to network 0.0.0.0
    
    C    192.168.1.0/24 is directly connected, Loopback111
         150.1.0.0/16 is variably subnetted, 13 subnets, 2 masks
    O       150.1.29.0/24 [110/74] via 150.1.123.2, 00:47:12, Serial1/1.12
    D       150.1.4.0/24 [90/409600] via 192.168.3.4, 00:44:05, Ethernet0/0
    C       150.1.1.0/24 is directly connected, Loopback0
    O       150.1.8.8/32 [110/95] via 150.1.123.2, 00:47:12, Serial1/1.12
    O       150.1.5.5/32 [110/85] via 150.1.123.2, 00:47:12, Serial1/1.12
    O       150.1.2.2/32 [110/65] via 150.1.123.2, 00:47:12, Serial1/1.12
    D       150.1.10.0/24 [90/435200] via 192.168.3.4, 00:43:38, Ethernet0/0
    O       150.1.59.0/24 [110/84] via 150.1.123.2, 00:47:12, Serial1/1.12
    O       150.1.58.0/24 [110/94] via 150.1.123.2, 00:47:12, Serial1/1.12
    C       150.1.123.0/24 is directly connected, Serial1/1.12
    O       150.1.123.2/32 [110/64] via 150.1.123.2, 00:47:12, Serial1/1.12
    D       150.1.107.0/24 [90/332800] via 192.168.3.4, 00:43:39, Ethernet0/0
    D       150.1.104.0/24 [90/307200] via 192.168.3.4, 00:44:06, Ethernet0/0
    C    192.168.3.0/24 is directly connected, Ethernet0/0
    D*EX 0.0.0.0/0 [170/2560025856] via 192.168.3.4, 00:03:51, Ethernet0/0
    R1#
    Bilmem anlatabildimmi...

    Iyi gunler

  5. #25
    ercanusa isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    İstanbul
    Mesajlar
    513

    Standart

    Eline sağlık burner ,sen oluyor diyorsan doğrudur , ben henüz yapamadım config yukarıda verdiğim gibi, onun üstünde değişiklik yapıp düzeltmeye çalışıyorum.Belki de dynamipsden kaynaklıdır
    Benim merak ettiğim bu komutun yazdığımız statik route u eigrp içine duyurup duyurmadığıydı , sayende duyurduğunu öğrendik.Ben baştan yeni bir lab daha yapıyım umarım bu defa çalışır, keşke yaptığın confiğide verseydin

  6. #26
    inassyCaf Guest

    Standart Hello

    How to bypass web filters?

    What's up? Been lurking for a while and decided to sign up and post.

    Umm so like does anyone know how to browse just about any old site easily while at school? I'm collecting different methods here. Help!

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok