Hot Standby Router Protocol (HSRP)
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 7 sonuçtan 1 ile 7 arasındakiler gösteriliyor.
Hot Standby Router Protocol (HSRP)

Aynı networkte çalışan 2 routerın birisinin down olması durumunda networkün sorunsuz çalışması için yapılıcak olan konfigürasyon aşağıdaki gibidir; Başlamadan önce konfigürasyonu daha rahat anlayabilmek için bazı terimlerin açıklmasını yapalım; standby

  1. #1
    hakan isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Feb 2008
    Bulunduğu yer
    istanbul
    Mesajlar
    760

    Standart Hot Standby Router Protocol (HSRP)

    Aynı networkte çalışan 2 routerın birisinin down olması durumunda networkün sorunsuz çalışması için yapılıcak olan konfigürasyon aşağıdaki gibidir;

    Başlamadan önce konfigürasyonu daha rahat anlayabilmek için bazı terimlerin açıklmasını yapalım;

    standby : Sanal bir router oluşturularak haberleşme sağlanır, her router da bu IP aynı olmalıdır

    standby preempt:
    Her iki routerda da girilierek hazırda kalmaları, hat gittiğinde aktif router olucaklarını, düzeldiğinde eski haline dönüceğini bildirir

    standby priorty:
    Aktif routerın hangisi olduğu tanımlanır, defoult olarak 100' dür. Değeri yüksek olan aktifdir

    standby authentication:
    Routerların birbirlerini doğrulamaları için gönderilen mesajdır, iki routerda da aynı olmalıdır

    standby timers:
    Hattın gidip gitmediği bilgisi için her 5 sn' de bir gönderilen "hello" paketidir. Cevap gelmezse backup router devreye girer



    topolojimiz resimdeki gibidir..





    ROUTER A


    int e0
    ip add 1.0.0.1 255.0.0.0
    standby 1 ip 1.0.0.3
    standby 1 preempt
    standby 1 priority 110
    standby 1 authentication cisco
    standby 1 timers 5 15

    int e1
    ip add 3.0.0.1 255.0.0.0
    router eigrp 1
    network 1.0.0.0
    network 3.0.0.0


    ROUTER B


    int e0
    ip add 1.0.0.2 255.0.0.0
    standby 1 ip 1.0.0.3
    standby 1 preempt
    standby authentication cisco
    standby 1 timers 5 15

    int e1
    ip add 2.0.0.2 255.0.0.0
    router eigrp 1
    network 1.0.0.0
    network 2.0.0.0



    konuyla ilgili diğer makaleler için burayı ve burayı inceleyin lütfen...

  2. #2
    turkavfatih isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Mar 2008
    Bulunduğu yer
    İstanbul
    Mesajlar
    590

    Standart

    Bu güzel paylaşım için teşekkürler hakan hocam emeğinize sağlık...

  3. #3
    ercanusa isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    İstanbul
    Mesajlar
    513

    Standart

    Teşekkürler hakan hocam,
    Yalnız şu komutu onutmuşsun sanki;

    standby 1 track ...

    eklersen daha güzel olur sanırım.

  4. #4
    monopeto Guest

    Standart

    peki track ne işe yarıyor?

  5. #5
    muratymurat isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Aug 2008
    Mesajlar
    158

    Standart

    arkadaslar track ıda ben ekleyeyim
    bu configi yapıp tst ettim çalışıyor.

    Active Router Standby Router
    track 100 interface Serial0/0 line-protocol track 100 interface Serial0/0 line-protocol

    interface FastEthernet0/0 nterface FastEthernet0/0
    ip address 172.30.128.1 255.255.255.0 ip address 172.30.128.2 255.255.255.0
    standby 1 ip 172.30.128.3 standby 1 ip 172.30.128.3
    standby 1 priority 150 standby 1 priority 135
    standby 1 preempt standby 1 preempt
    standby 1 track 100 decrement 20 standby 1 track 100 decrement 20

  6. #6
    monopeto Guest

    Standart

    peki track ne işe yarıyor?

  7. #7
    trunkmode isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,332

    Standart

    Standby konfigurasyonu local tarafı sürekli aktif tutuyor yani hsrp aktif interfacelerin down olması durumunda devreye giriyor. Hsrp aktif olmayan örneğin internet routera bağlı interface lerden birisi down olursa bu durumda tracking gerekir. Burada active Routera deriz ki : eğer dış interface down olursa senin priorty değerin standby routerın altında olsun sen standby konuma geç
    yukarıdaki mesajlardada nasıl yapıldığı var..

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok