Voice, Class-MAP Konfigurasyonu
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Reply to Thread
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37
Voice, Class-MAP Konfigurasyonu

arkadaşlar elimdeki bir routerda 2 mbit int de routerde ses paketlerine öncelik verilmiş yani 2048 için ses öncelikli olsun denmiş . ben bu trafiğin 1 mbit sesiçin ayırsam tamamen 1

  1. #1
    e-mky Guest

    Default Voice, Class-MAP Konfigurasyonu

    arkadaşlar elimdeki bir routerda 2 mbit int de routerde ses paketlerine öncelik verilmiş yani 2048 için ses öncelikli olsun denmiş .

    ben bu trafiğin 1 mbit sesiçin ayırsam tamamen 1 mbit internet için ayırsam nasıl olur.

    bu işlemi nasıl yapabilrim. tam olarak yardımcı olabilrmisiniz.

    ses için yapılan işlemler routerda bu sekilde.

    ayrıca, bu router başka bir merkez üzerinden internete cıkıyor.2 m bit ayrılmış durumda hat olarak. nasıl bir config yapmam gerekir sadece 1 mbit sese ayırmak için...



    !
    class-map match-all voice2
    match ip rtp 2048 2048
    class-map match-all voice
    match ip rtp 16000 16383
    class-map match-all sintallesme
    match access-group 154
    !
    !
    policy-map ses
    class voice
    priority 45
    class sintallesme
    bandwidth 8
    class voice2
    priority 45
    class class-default
    fair-queue
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.2.1.1 255.255.255.0
    ip accounting output-packets
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/3/0
    ip address 192.168.252.2 255.255.255.252
    encapsulation ppp
    service-policy output ses

  2. #2
    e-mky Guest

    Default

    galiba burda su sekilde bir değişiklik yapmam lazım doğrumu...






    class-map match-all voice2
    match ip rtp 2048 2048 ------> match ip rtp 1024 1024

    class-map match-all voice
    match ip rtp 16000 16383 ------> bu kısımda ne yapmam gerekiyor

    class-map match-all sintallesme
    match access-group 154 -----> birde burada ne yapacağımı söylermisiniz.

  3. #3
    ercanusa is offline Senior Member
    Join Date
    Dec 2007
    Location
    İstanbul
    Posts
    513

    Default

    Hocam senin yaptığın configden birşey anlamadım ama istersen istediğin şekilde kendi yazdığım bir config gönderiyim.Şu anda hazır değil ama hazırlayabilirim.

  4. #4
    e-mky Guest

    Default

    bunu ben yampadım yapılmıs bu routerda mevcut olan config.bu config ses ile ilgili kısım olarak alıntı yani bir class-map oluşturulmus anladığım kadarıyla.

    bu router okulun ana routerı ve yanlış bir sey yapmaktan korkuyorum. amacım. 2 mbit olan int 1 m bit ses için ayırmak ve ileride vazgectiğimde nasıl geri alabileceğimide gösterrirseniz sevinirim.

  5. #5
    ercanusa is offline Senior Member
    Join Date
    Dec 2007
    Location
    İstanbul
    Posts
    513

    Default

    Confiğin bir yadeğini alın.Pc ye bir tftp server kurun ve routerda
    # copy startup-config tftp yazın.Bir kaç soru soracak onları cevapladığınız zaman confiğin yedeğini almış olursunuz.Aldığınız yedeği tekrar yüklemek içinde
    #copy tftp startup-config yaparsınız.Bu işlemi dynamipsde yaptım eminim saha deneyimi olan arkadaşlar daha iyi yardımcı olabilir.
    İlk mesajımda da dediğim gibi yukarıdaki config bana karışık geldi.Sizin dediğiniz şeyi ben şu şekilde yapardım.

    class-map match-all voice-in
    match protocol rtp audio

    policy-map voice-in
    class voice-in
    set ip precedence 5


    interface fastethernet 0/0
    service-policy input voice-in

    class-map match-all voice-out
    match ip precedence 5

    policy-map voice-out
    class voice-out
    priority percent 50 --------------bandwith in %50 sini sese ayırıyor

    class class-default
    fair-queue

    interface Serial1/1
    service-policy output voice

    ama bu sadece yazdığınız routerda sese öncelik verecektir.Bu tür bir uygulamanın sağlıkllı çalışması için diğer router üzerindede sese öncelik verilmesi gerekir.
    Last edited by ercanusa; 12.03.2009 at 15:49.

  6. #6
    e-mky Guest

    Default

    peki hocam. bu config le benimkinin arasında bir fark yok aslında cok. ama seninkli daha işlevsel

    bu confiği ben benimkinin üzerinde düzetlsem yani değerleri değiştirsem olurmu.
    mesal a class map ların iine girsem değerleri senin verdiklerinle değiştrisem diyorum.

  7. #7
    ercanusa is offline Senior Member
    Join Date
    Dec 2007
    Location
    İstanbul
    Posts
    513

    Default

    Senin verdiğin config de anlamadığım birkaç nokta var.Eğer onların ne olduğunu söylersen daha iyi yardımcı olabilirim.

    match ip rtp 2048 2048 ----burada 2048 benim bildiğim udp portları,neden 2048 portlarını match ettirdiğini anlamadım.Aynı şekilde 16000 ve 16383 arası udp paketlerinide match ettirmişsin açıkçası bu portların ne işe yaradığını da bilmiyorum.Ses paketlerini match ettirmek içim şöyle bir satır yeterli olur;
    match protocol rtp audio

    match access-group 154 ----- burda bir access-list sinyalleşme için match ettirilmiş ancak verdiğin configde access-list gözükmediği için ne işe yaradığını bilmiyorum.Acess-listide verirsen daha iyi olur.

    priority 45 ,bandwidth 8 gibi değerler girilmiş burada 45 ve 8 kilobit olarak kabul edilir router tarafından.Bunlar çok düşük değerler.
    R1(config-pmap-c)#priority ?
    <8-2000000> Kilo Bits per second
    percent % of total bandwidth

    R1(config-pmap-c)#bandwidth ?
    <8-2000000> Kilo Bits per second
    percent % of total Bandwidth
    remaining % of the remaining bandwidth

  8. #8
    burner Guest

    Default

    Slm;

    class-map match-all voice2
    match ip rtp 2048 2048
    class-map match-all voice
    match ip rtp 16000 16383
    class-map match-all sintallesme
    match access-group 154
    !
    !
    policy-map ses
    class voice
    priority 45
    class sintallesme
    bandwidth 8
    class voice2
    priority 45
    class class-default
    fair-queue
    !
    sunun gibi bisiy:
    access-list xx permit ip any any
    access-list xx deny ip host xxxxxxxx host xxxxxxxx
    access-list xx deny tcp hot yyyyyy host yyyyyy ne 23

    Yaraticilik ornegi, bence bunu Lame of Hall a post etmeli...

    Iyi gunler

  9. #9
    ercanusa is offline Senior Member
    Join Date
    Dec 2007
    Location
    İstanbul
    Posts
    513

    Default

    Hocam cahilliğimi bağışla ama bu lame of hall nedir .

  10. #10
    e-mky Guest

    Default

    arkadaşlar tşkler.. ercanusa söylediklerini denicem ama burner cok ağır anlatıyor benim o kadar bilgim olmadığı çin zorlanıyorum.

    burner yazdığın access list alayamadım.

    ercanusa yukarıda söylediklerinde 48 değerini 60 yapsam yani yükseltsem 48 ve 8



    routerda bulunan access -listler :
    Extended IP access list 155
    10 permit udp any any range 16000 40000
    20 permit udp any eq 1720 any
    30 permit udp any any range 2048 4096

    access-list 155 permit udp any any range 16000 40000
    access-list 155 permit udp any eq 1720 any
    access-list 155 permit udp any any range 2048 4096

    değerini nasıl oluır yada kaç yapmamı önerirsin bu değerleri.

+ Reply to Thread
Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts