OSPF Routing, EIGRP Redistribute
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 2 Sayfadan 1. Sayfa 12 SonuncuSonuncu
Toplam 19 sonuçtan 1 ile 10 arasındakiler gösteriliyor.
OSPF Routing, EIGRP Redistribute

Merhaba, Aşağıdaki gibi basit bir topoloji oluşturdum 3 Router arasında OSPF 1 Router'da Eigrp çalıştırıyorum. Eigrp'yi redistribute ediyorum (yada ettiğimi zannediyorum) fakat Eigrp tarafındaki networklere ulaşamıyorum. Eigrp kendi içerisinde aktif

  1. #1
    Redox isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2007
    Bulunduğu yer
    Istanbul
    Mesajlar
    71

    Lightbulb OSPF Routing, EIGRP Redistribute

    Merhaba,

    Aşağıdaki gibi basit bir topoloji oluşturdum 3 Router arasında OSPF 1 Router'da Eigrp çalıştırıyorum.

    Eigrp'yi redistribute ediyorum (yada ettiğimi zannediyorum) fakat Eigrp tarafındaki networklere ulaşamıyorum. Eigrp kendi içerisinde aktif durumda. Burda eigrp ye erişemememdeki problem neden olabilir ? Bunun haricinde Aşağıda R2 Neighbor olarak R0 ı görmekte burda direct connect olarak R1 i görmesi gerekmezmi ?

    Routerların sh run, route ve neighbor çıktıları aşağıdaki gibidir.

    R0 Confg.
    hostname R0
    !
    interface Serial1/0
    ip address 1.1.1.1 255.255.255.252
    serial restart_delay 0
    !
    router ospf 10
    log-adjacency-changes
    area 5 stub
    network 1.1.1.0 0.0.0.3 area 5
    !
    end
    R1
    hostname R1
    !
    interface Serial1/0
    ip address 1.1.1.2 255.255.255.252
    serial restart_delay 0
    !
    interface Serial1/1
    ip address 2.2.2.1 255.255.255.0
    serial restart_delay 0
    !
    router ospf 15
    log-adjacency-changes
    area 5 stub
    network 1.1.1.0 0.0.0.3 area 5
    network 2.2.2.0 0.0.0.3 area 0
    !
    R2
    hostname R2
    !
    interface Serial1/0
    ip address 2.2.2.2 255.255.255.252
    serial restart_delay 0
    !
    interface Serial1/1
    ip address 3.1.1.1 255.255.255.252
    serial restart_delay 0
    !
    router eigrp 5
    network 3.0.0.0
    no auto-summary
    !
    router ospf 10
    log-adjacency-changes
    redistribute eigrp 5 subnets
    network 2.2.2.0 0.0.0.3 area 0
    !
    end
    R3
    hostname R3
    !
    interface Loopback0
    ip address 172.19.0.105 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    duplex half
    !
    interface Serial1/0
    ip address 3.1.1.2 255.255.255.252
    serial restart_delay 0
    !
    end
    !
    router eigrp 5
    network 3.0.0.0
    no auto-summary
    !
    R0#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is 1.1.1.2 to network 0.0.0.0

    1.0.0.0/30 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Serial1/0
    2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    O IA 2.2.2.0/30 [110/192] via 1.1.1.2, 02:50:16, Serial1/0
    O IA 2.2.2.0/24 [110/128] via 1.1.1.2, 02:50:16, Serial1/0
    O*IA 0.0.0.0/0 [110/65] via 1.1.1.2, 02:50:16, Serial1/0
    Router#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface
    1.1.1.2 0 FULL/ - 00:00:38 1.1.1.2 Serial1/0

    R1
    R1#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    1.0.0.0/30 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Serial1/0
    2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    O 2.2.2.0/30 [110/128] via 2.2.2.2, 02:51:24, Serial1/1
    C 2.2.2.0/24 is directly connected, Serial1/1
    3.0.0.0/30 is subnetted, 1 subnets
    O E2 3.1.1.0 [110/20] via 2.2.2.2, 02:51:09, Serial1/1
    R2#
    R2#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface
    2.2.2.2 0 FULL/ - 00:00:37 2.2.2.2 Serial1/1
    1.1.1.1 0 FULL/ - 00:00:30 1.1.1.1 Serial1/0

    R2
    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    1.0.0.0/30 is subnetted, 1 subnets
    O IA 1.1.1.0 [110/128] via 2.2.2.1, 03:03:29, Serial1/0
    2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 2.2.2.0/30 is directly connected, Serial1/0
    O 2.2.2.0/24 [110/128] via 2.2.2.1, 03:03:29, Serial1/0
    3.0.0.0/30 is subnetted, 1 subnets
    C 3.1.1.0 is directly connected, Serial1/1
    R2#
    R2#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface
    1.1.1.2 0 FULL/ - 00:00:39 2.2.2.1 Serial1/0
    Router#

    R3
    R3#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    3.0.0.0/30 is subnetted, 1 subnets
    C 3.1.1.0 is directly connected, Serial1/0
    172.19.0.0/24 is subnetted, 1 subnets
    C 172.19.0.0 is directly connected, Loopback0
    R3#
    Teşekkürler,

    Konu Redox tarafından (13.02.2009 Saat 09:09 ) değiştirilmiştir.

  2. #2
    burner Guest

    Standart

    Slm;

    OSPF 1 i da eigrp nin icine redistribute etmek zorundasin...

    Iyi gunler

  3. #3
    root isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Jun 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,409

    Standart

    Selamlar,

    oncelikle router 1'in serial 1/1 interface'deki subnetini duzeltmeniz gerekiyor. 255.255.255.0 yapmissiniz bunu 255.255.255.252 yapmalisiniz.

    onun disinda bir sorun goremedim acaba virtual link tanimlamak mi gerekecek? hmm..

  4. #4
    Redox isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2007
    Bulunduğu yer
    Istanbul
    Mesajlar
    71

    Standart

    Selam,

    Bu şekilde bir değişiklik yaptım fakat durum aynı şekilde, gözüken bir problem varmıdır ?

    !
    router eigrp 5
    redistribute ospf 10
    network 3.0.0.0
    no auto-summary
    !
    router ospf 10
    log-adjacency-changes
    redistribute eigrp 5 subnets
    network 2.2.2.0 0.0.0.3 area 0
    !
    Teşekkürler,

  5. #5
    root isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Jun 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,409

    Standart

    traceroute verebilir misin bu arada bana router 0'dan diğer networklere?

    bir de o şekilde sonuçlara bakalım..

    bu arada tam conf versen bu durumlarda daha iyi olur.. hani default gateway tanımı var mı yok mu gibi..

  6. #6
    root isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Jun 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,409

    Standart

    bir de sen router 0'dan nereye ulaşmaya çalışıyorsun? router 3'deki 192'li network'amı?

  7. #7
    Redox isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2007
    Bulunduğu yer
    Istanbul
    Mesajlar
    71

    Standart

    R3 ün seri interfaceine veya loopback'ine ulaşmaya çalışıyorum.

  8. #8
    Redox isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2007
    Bulunduğu yer
    Istanbul
    Mesajlar
    71

    Standart

    Tüm routerların confiğini ekledim, göz atabilirsiniz.

    Web Hosting - Dedicated Server

    R1
    Router#traceroute 3.1.1.2

    Type escape sequence to abort.
    Tracing the route to 3.1.1.2

    1 1.1.1.2 44 msec 192 msec 308 msec
    2 2.2.2.2 200 msec 200 msec 232 msec
    3 * * *
    4 * * *
    5 * * *
    6 * * *

    R2

    Type escape sequence to abort.
    Tracing the route to 3.1.1.2

    1 2.2.2.2 84 msec 84 msec 96 msec
    2 * * *
    3 * * *

    R3
    Router#traceroute 3.1.1.2

    Type escape sequence to abort.
    Tracing the route to 3.1.1.2

    1 3.1.1.2 84 msec 72 msec *

  9. #9
    root isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Jun 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,409

    Standart

    subneti duzelttin mi dedigim?

  10. #10
    Redox isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2007
    Bulunduğu yer
    Istanbul
    Mesajlar
    71

    Standart

    hangi subneti :?

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok