BGP Konfigurasyonu (EBGP , IBGP)
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 26
BGP Konfigurasyonu (EBGP , IBGP)

merhaba arkadaşlar,ben BGP 'e yeni başlıyorum.Ekteki gibi bir yapı için şöyle bir konfigürasyon yaptım ancak Router0 dan Router2 ulaşamıyorum(ping çekemiyorum).Konfigürasyonda nerde hata yaptığımı yada nerde eksiklik olduğunu söylerseniz memnun olurum.Şu

  1. #1
    thrillercd Guest

    Arrow BGP Konfigurasyonu (EBGP , IBGP)

    merhaba arkadaşlar,ben BGP 'e yeni başlıyorum.Ekteki gibi bir yapı için şöyle bir konfigürasyon yaptım ancak Router0 dan Router2 ulaşamıyorum(ping çekemiyorum).Konfigürasyonda nerde hata yaptığımı yada nerde eksiklik olduğunu söylerseniz memnun olurum.Şu anda routerların bağlı olan bacaklarına sadece ip verilmiş başka bir şey yapılmamıştır.Buna göre Router0 için bgp konfigurasyon :

    Router0(config)#router bgp 65100
    Router0(config-router)#neighbor 10.0.0.2 remote-as 65100
    Router0(config-router)#exit

    herbir router için bu mantıkta konfigurasyon yapmayacak mıyım ? yoksa başka bir eksiklik mi var ?

  2. #2
    GhoSt is offline Senior Member
    Join Date
    Dec 2007
    Location
    Ankara
    Posts
    1,664

    Default

    Yaptığım bir konfig var hem external hem internal BGP var içinde bir gözat takıldığın yada anlamadığın yerde yardımcı oluruz tekrar
    Mr.google knows everything , ask to him...

  3. #3
    burner Guest

    Default

    Slm;

    Ikinizin konfigurationlarinda da end to end connectivity bgp ile saglanamaz ya route reflector yada confederation kullanmalisiniz..
    GhoSt84 un configinde igp var ondan dolayi end to end connectivity olusabilir ancak bgp ye r1 den bir route inject edildiginde R4 goremez bu routeyi...
    Rule: ibgp loop onleyici.. bir ibgp peer den alinan bir route diger ibgp ye advertise edilmez...

    thrillercd configurationlarinda r1 route reflector olmali ki r0 dan aldigi routeyi
    r2 ye reflect, yada r2 den aldigi routeyi r0 a reflect etsin...
    Ikinci yol ise confederation olusturulmasi....

    Iyi gunler

  4. #4
    thrillercd Guest

    Default

    GhoSt84 ,hocam cevabın için teşşekkürler.BGP de yeni olduğum için soracağım sorular belki saçma gelebilir.
    BGP nin kendisi bir yönlendirme protokolü değil mi ? Neden bir de EIGRP kullanmışsınız ? EIGRP ,RIP vb. kullanmadan sadece BGP kullansak olmaz mı ?Loopback0 diye bir interface kullanmışsınız bunun yerine direk olarak fiziksel(mesela bağlı olan bir serial yada fastethernet) bir interface kullansak olur mu ?bunun görevi nedir burada ?
    Bide aşağıdaki komutların karşısına ne işe yaradaığını yazarsanız bir cümleyle sevinirim.

    router eigrp 1
    network 10.10.10.0 0.0.0.255 /* burada 0.0.0.255 nedir Wildcarda benziyor,EIGRP de niçin ve nasıl kullanıldığını anlayamadım */

    bgp log-neighbor-changes // ne işe yarıyor
    network 1.1.1.1 mask 255.255.255.255 //ne işe yarıyor
    negighbor 3.3.3.3 remote-as 100 /*buradaki gibi sanal olan ve kendisine komşu olmayanları herkese mi ekliyoruz */
    negighbor 3.3.3.3 update-source loopback0 /*Burada loopback0 yerine fiziksel bir interface yazabilirmiyiz */

  5. #5
    thrillercd Guest

    Default

    burner hocam BGP de çok yeni olduğumdan söylediğin çoğu şeyi anlayamadım ama söylediğin şeyleri biraz araştırdıktan sonra ,umarım sana soru soracak seviyeye gelirim

  6. #6
    burner Guest

    Default

    Slm;

    senin configlerin boyle olmali;
    r0:

    router bgp 6500
    neig 10.0.0.2 remote-as 6500

    r1:
    router bgp 6500
    neig 10.0.0.1 remote-as 6500
    neig 10.0.0.1 route-reflector-client
    neig 20.0.0.2 remote-as 6500
    neig 20.0.0.2 route-reflector-client

    r2:
    router bgp 6500
    neig 20.0.0. remote-as 6500


    Igp bir protocol kullanmak zorunda degilsin bgp icin, genelde next hop ulasimi icin kullanilir igp...eger next hop direk bagli degilse igp yada static routing kullanmak sart...

    R1(10.1.1.1)--->R2(loopback:100.1.1.1)--->R3--->R4--->R5(50.1.1.1)
    eger r1 ile r5 veya R1 ile R2 nin loopback i arasinda bir bgp sessionu kurmak istiyorsaniz igp yada static route kullanmak zorundasiniz...
    ama yok R1 ile R2, R2 ile R3, R3 ile R4, R4 ile R5 arasinda session direkt connected interfaceler ile yapiliyor ise igp ye yada static route kullanmaya gerek yok..

    Umarim biraz da olsa olayi aciklayabilmisimdir
    Iyi gunler

  7. #7
    thrillercd Guest

    Default

    burner hocam, sizin route reflector ile demek istediğiniz konfigürasyon şöylemi olacak ?

    .................................................. ...................
    Router0(config)#router bgp 65100
    Router0(config-router)#neighbor 10.0.0.2 remote-as 65100
    Router0(config-router)#exit


    .................................................. ..................
    Router1#router bgp 65100

    Router1(config-router)#neighbor 10.0.0.1 remote-as 65100

    Router1(config-router)#neighbor 10.0.0.1 route-reflector-client

    Router1(config-router)#neighbor 20.0.0.2 remote-as 65100

    Router1(config-router)#neighbor 20.0.0.2 route-reflector-client

    Router1(config-router)#exit

    .................................................. ..................
    Router2(config)#router bgp 65100
    Router2(config-router)#neighbor 20.0.0.1 remote-as 65100
    Router2(config-router)#exit

  8. #8
    thrillercd Guest

    Default

    burner hocam ,sayfayı yenilemediğim için sizin cevabınızı görmeden yazmışım ) cevabınız çok açıklayıcı teşşekürler.Bu dediğiniz şekilde deneyeceğim.

  9. #9
    burner Guest

    Default

    Slm;

    Dogrudur...

    Iyi gunler

  10. #10
    GhoSt is offline Senior Member
    Join Date
    Dec 2007
    Location
    Ankara
    Posts
    1,664

    Default

    Quote Originally Posted by burner View Post
    Slm;

    Ikinizin konfigurationlarinda da end to end connectivity bgp ile saglanamaz ya route reflector yada confederation kullanmalisiniz..
    GhoSt84 un configinde igp var ondan dolayi end to end connectivity olusabilir ancak bgp ye r1 den bir route inject edildiginde R4 goremez bu routeyi...
    Rule: ibgp loop onleyici.. bir ibgp peer den alinan bir route diger ibgp ye advertise edilmez...

    thrillercd configurationlarinda r1 route reflector olmali ki r0 dan aldigi routeyi
    r2 ye reflect, yada r2 den aldigi routeyi r0 a reflect etsin...
    Ikinci yol ise confederation olusturulmasi....

    Iyi gunler
    Neden R4 göremesin ki R1 deki loopback i görüyordu
    Mr.google knows everything , ask to him...

+ Reply to Thread
Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts