BGP Konfigurasyonu (EBGP , IBGP) - Sayfa 2
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 3 Sayfadan 2. Sayfa BirinciBirinci 123 SonuncuSonuncu
Toplam 26 sonuçtan 11 ile 20 arasındakiler gösteriliyor.
BGP Konfigurasyonu (EBGP , IBGP)

Slm; Bu config lere gore eger R3&R4 da "sh ip bgp" yaptiginizda 1.1.1.1 i bgp tablesinde goremezsiniz...Ancak "sh ip route eigrp" yaptiginiz da 1.1.1.1 i gorebilirsiniz..Yani 1.1.1.1 R3&R4 un routing

  1. #11
    burner Guest

    Standart

    Slm;

    Bu config lere gore eger R3&R4 da "sh ip bgp" yaptiginizda 1.1.1.1 i bgp tablesinde goremezsiniz...Ancak "sh ip route eigrp" yaptiginiz da 1.1.1.1 i gorebilirsiniz..Yani 1.1.1.1 R3&R4 un routing tablesinde ancak bgp tablesinde degil..Bu durumda 1.1.1.1 bgp learned route olmasi gerekirken eigrp den ogreniliyor...(ebgp nin ad si 20 , eigrp nin ad si ise 90).. 1.1.1.1 ebgp learned route R4 icin, R3 icin ise ibgp route...
    Ayni sey 4.4.4.4 icin de gecerli, R1 bu routeyi bgp tablesinde goremezsin, "sh ip bgp " bunu ispatlar...bgp tablesinde olsa dahi, routing tablesine giremez cunku (ibgp ad si 200, eigrp inin ad i 90)...

    R2 ne r1 den aldigi bgp routesini R3 e gonderir nede R3 ten aldigini R1 e gonderir bu durumda..kisacasi R2 route reflector olmasi gerekir R1 ve R3 icin, yada 2.cozum confed yapilmasi gerekir..

    Umarim anlatabilmisimdir

    Iyi gunler

  2. #12
    GhoSt isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,664

    Standart

    R4#sh ip bgp
    BGP table version is 6, local router ID is 4.4.4.4
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path
    *> 1.1.1.1/32 12.12.12.1 0 100 i
    *> 3.3.3.3/32 12.12.12.1 0 0 100 i
    *> 4.4.4.4/32 0.0.0.0 0 32768 i

    Göremezsiniz dediğiniz yer...

    zaten network komutuyla anons ettim görülmemesi imkansızdı , eğer ibgp de hata olmuş olsa route table a çekilmez ve oraya ulaşılamaz olurdu ama her koşulda loopbackler routerların bgp tablolarında görünürdü
    Konu GhoSt tarafından (19.01.2009 Saat 02:39 ) değiştirilmiştir.
    Mr.google knows everything , ask to him...

  3. #13
    burner Guest

    Standart

    Slm;

    Dogrudur, senin orneginde full mesh var gozden kacirmisim... yani r1 ile r3 arasindada bir bgp session var, eger o session olmamis olsa idi diye anla!!!! ... Birde olaya o yonuyle bak...Yeni bir bakis acisi ...

    router eigrp 1
    network 10.10.10.0 0.0.0.255
    normalde network 10.10.10.0 deyince router /8 diye alir 10 ile baslayan butun interfaceleri eigrp procesi icine dahil eder.. ama yukaridaki ornekte ise /24 mask olarak alir ve 10.10.10 ile baslayan interfaceleri eigrp icine dahil eder.
    10.10.10.10 0.0.0.0 denmis olsa sadece o bir interfaceyi eigrp proces ine dahil eder yani advertise eder...
    eger butun int leri advertise etmek istiyor isen 0.0.0.0 255.255.255.255 yaparsin...
    ospf icinde ayni kural gecerli....

    PHP- Kodu:
    bgp log-neighbor-changes 
    bgp neighbor up yada down yada session expair oldugunda consola logg girer.. disable edildiginde ise bu logg lar gorulmez..

    network 1.1.1.1 mask 255.255.255.255
    bgp de networ advertise etmenin bir yontemi, diger yontemler ise redistribution, conditional injections...vs.. burada 1.1.1.1 diye tek bir addresi (host addr) bgp icerisine advertise ediyor

    negighbor 3.3.3.3 remote-as 100
    bgp tcp base bir routing protocol oldugu icin komsunun direk bagli olup olmamasi onemli degil onemli olan iki komsu arasindaki erisebilirlilik eger erisebirlilik var ise bgp sessionu herhangibir neighbor ile yapilabilir bu ister direct bagli olsun ister degil.. (tcp port 179)

    negighbor 3.3.3.3 update-source loopback0
    gayet tabiki yazabilirsin, ancak komsu router in neighbor comutu bu update yaptigin interfaceyi gostermeli...

    ethernet0/0--R1 <---> R2--loopback0
    ethernet0/0 : 10.1.1.1/30
    lo0: 10.100.100.1/32

    r1:
    router bgp 1
    neig 10.100.100.1 remote-as 1
    neig 10.100.100.1 update-source e0/0

    r2:
    router bgp 1
    neig 10.1.1.1 remote-as 1
    neig 10.1.1.1 update-source lo0


    Neyse,

    Iyi gunler
    Konu burner tarafından (19.01.2009 Saat 16:58 ) değiştirilmiştir.

  4. #14
    GhoSt isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,664

    Standart

    teşekkürler güzel ve detaylı bir açıklama olmuş..
    Mr.google knows everything , ask to him...

  5. #15
    Orhan ERGUN isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Aug 2008
    Mesajlar
    256

    Standart

    Merhaba,

    Bende ghost'un konfigurasyonuna baktığımda full-meshi farketemdim , r2'yi reflector yap diyecektim .
    Gozden kaçabilir doğaldır , seviyeyi bozmamanıza sevindim . Bu arada;

    Burner ; son postundaki
    r2:
    router bgp 1
    neig 10.1.1.1 remote-as 1
    neig 10.100.100.1 update-source lo0 > Burdaki neigh 10.1.1.1 olarak düzeltirmsn , kafalar karısmasın ,hızlı yazdın sanırım .


    Kolay Gelsin

  6. #16
    burner Guest

    Standart

    Slm;

    Kusura kalmayin bu yanlistan dolayi. Ayni zamanda tesekkurler Orhan bey duzeltmeden dolayi..

    Iyi gunler

  7. #17
    thrillercd Guest

    Standart

    Alıntı thrillercd Nickli Üyeden Alıntı Mesajı göster
    burner hocam, sizin route reflector ile demek istediğiniz konfigürasyon şöylemi olacak ?

    .................................................. ...................
    Router0(config)#router bgp 65100
    Router0(config-router)#neighbor 10.0.0.2 remote-as 65100
    Router0(config-router)#exit


    .................................................. ..................
    Router1#router bgp 65100

    Router1(config-router)#neighbor 10.0.0.1 remote-as 65100

    Router1(config-router)#neighbor 10.0.0.1 route-reflector-client

    Router1(config-router)#neighbor 20.0.0.2 remote-as 65100

    Router1(config-router)#neighbor 20.0.0.2 route-reflector-client

    Router1(config-router)#exit

    .................................................. ..................
    Router2(config)#router bgp 65100
    Router2(config-router)#neighbor 20.0.0.1 remote-as 65100
    Router2(config-router)#exit
    hocam bu konfigürasyonda bir sorun mu var acaba çalışmıyor.Bu konfigürasyon hariç bir de interfacelere ip ataması yaptım.Ama yine R0 dan R2 ping çekemiyorum.

  8. #18
    Orhan ERGUN isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Aug 2008
    Mesajlar
    256

    Standart

    Merhaba,

    Siz 10.0.0.1 den 10.0.0.2 ye

    20.0.0.1 den 20.0.0.2 ye erişebiliyormusunuz ? Yani R0 to R1 , R1 to R2 connectivityleri varmı şu an , var ise ne ile sağladınız ?


    Kolay Gelsin

  9. #19
    thrillercd Guest

    Standart

    R0 ile R1 ; R1 ile R2 arasında ping çekebiliyorum.Bunlarda direk connected yoluyla bağlantı sağlıyorum.Anak yaptığım BGP konfigürasyonuyla R0 dan R2 pin cekemiyorum. Aşağıda da
    bütün routerların konfigürasyonları var.


    Current configuration : 786 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router0
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip cef
    !
    ip audit po max-events 100
    !
    !

    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex half
    !
    interface FastEthernet1/0
    ip address 10.0.0.1 255.0.0.0
    duplex auto
    speed auto
    !
    interface FastEthernet1/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router bgp 65100
    no synchronization
    bgp log-neighbor-changes
    neighbor 10.0.0.2 remote-as 65100
    no auto-summary
    !
    ip classless
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    stopbits 1
    line aux 0
    line vty 0 4
    !
    !
    end


    .................................................. ..................


    Current configuration : 912 bytes
    !
    version 12.3
    service timestamps debug datetime mse
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip cef
    !
    ip audit po max-events 100
    !

    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex half
    !
    interface FastEthernet1/0
    ip address 10.0.0.2 255.0.0.0
    duplex auto
    speed auto
    !
    interface FastEthernet1/1
    ip address 20.0.0.1 255.0.0.0
    duplex auto
    speed auto
    !
    router bgp 65100
    no synchronization
    bgp log-neighbor-changes
    neighbor 10.0.0.1 remote-as 65100
    neighbor 10.0.0.1 route-reflector-cl
    neighbor 20.0.0.2 remote-as 65100
    neighbor 20.0.0.2 route-reflector-cl
    no auto-summary
    !
    ip classless
    no ip http server
    no ip http secure-server
    !

    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    stopbits 1
    line aux 0
    line vty 0 4
    !
    !
    end
    .................................................. ..................
    Current configuration : 784 bytes
    !
    version 12.3
    service timestamps debug datetime ms
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip cef
    !
    ip audit po max-events 100
    !

    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex half
    !
    interface FastEthernet1/0
    ip address 20.0.0.2 255.0.0.0
    duplex auto
    speed auto
    !
    interface FastEthernet1/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router bgp 65100
    no synchronization
    bgp log-neighbor-changes
    neighbor 20.0.0.1 remote-as 65100
    no auto-summary
    !
    ip classless
    no ip http server
    no ip http secure-server
    !

    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    stopbits 1
    line aux 0
    line vty 0 4
    !
    !
    end

  10. #20
    ercanusa isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    İstanbul
    Mesajlar
    513

    Standart

    Yapman gereken sadece bütün routerlarda
    (config)=#router bgp 65100 yazıp
    kendi üzerindeki networkü duyurmak.
    ör/ (config)#router bgp 65100
    #network 10.0.0.0 mask 255.0.0.0 R1 için
    kolay gelsin

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok