İki Router Arasında Tunnel Oluşturma
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 3 sonuçtan 1 ile 3 arasındakiler gösteriliyor.
İki Router Arasında Tunnel Oluşturma

Bu yazımıda da iki router arasında tunnel oluşturup İKE şifrelemesini yapıcaz, Topolojimiz aşağıdaki gibi olucaktır ROUTER A üzerinde yapılıcak olan config -------------------------------------- Building configuration... Current configuration : 1253 bytes !

  1. #1
    hakan isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Feb 2008
    Bulunduğu yer
    istanbul
    Mesajlar
    760

    Standart İki Router Arasında Tunnel Oluşturma

    Bu yazımıda da iki router arasında tunnel oluşturup İKE şifrelemesini yapıcaz,
    Topolojimiz aşağıdaki gibi olucaktır



    ROUTER A üzerinde yapılıcak olan config

    --------------------------------------

    Building configuration...

    Current configuration : 1253 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname RouterA
    !
    !
    memory-size iomem 10
    ip subnet-zero
    !
    !
    !
    !
    AŞAĞIDA YER ALAN İLK 4 SATIRDA İKE VE İPSEC CONFİGLERİNİ YAPIYORUZ BURADA UNUTLMAMASI GEREKEN KARŞIDAKİ ROUTER BİLGİLERİNİ GİRMEMİZ GEREKTİĞİ.ÇÜNKÜ BİRBİRLERİYLE ŞİFRE ALIŞVERİŞİ YAPICAKLARI İÇİN BİRBİRLERİNİN ŞİFRELERİNİ VE BİLGİLERİNİ BİLMEK ZORUNDALAR
    -------------------------------------------------
    crypto isakmp policy 1
    hash md5
    authentication pre-share
    crypto isakmp keepalive 30 5
    !
    crypto isakmp peer address 14.38.69.71
    set aggressive-mode password cisco123
    set aggressive-mode client-endpoint ipv4-address 14.38.69.70!
    !
    crypto ipsec transform-set myset esp-3des esp-md5-hmac
    !
    crypto map mymap 1 ipsec-isakmp
    set peer 14.38.69.71
    set transform-set myset
    match address 100
    !
    !
    !
    BURADA ÖNEMLİ OLANLARDAN BİRİSİ DE LOOPBACK İNTERFACE, GÖRÜLDÜĞÜ GİBİ BURADA BİR TUNNEL İNTERFACE ÜZERİNDEN DEĞİL LOOPBACK İNTERFACE ÜZERİNDEN TUNNEL YAPILARAK İLETİŞİM KURULUCAK
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Ethernet0/0
    ip address 14.38.69.70 255.255.0.0
    half-duplex
    crypto map mymap
    !
    interface BRI0/0
    no ip address
    shutdown
    !
    interface Ethernet0/1
    no ip address
    shutdown
    half-duplex
    !
    DEFAULT ROUTE YAZIYORUZ
    ip classless
    ip route 0.0.0.0 0.0.0.0 14.38.69.71
    ip http server
    !
    !
    İKİ NETWORKÜN BİRBİRİNE SIKINTISIZ ERİŞİMİ İÇİN ACCESS-LİSTİMİZİ YAZIYORUZ
    access-list 100 permit ip 1.1.1.0 0.0.0.255 2.2.2.0 0.0.0.255
    !
    call rsvp-sync
    !
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    Birinci routerda gerekli ayarları yaptık aynı şekilde diğer routerda da aynı config yapılıcak onu da aşağıya ekliyorum açıklamalar aynı şekilde

    ROUTER B ÜZERİNDE YAPILICAK CONFİG

    Building configuration...

    Current configuration : 1147 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname RouterB
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    crypto isakmp policy 1
    hash md5
    authentication pre-share
    crypto isakmp key cisco123 address 14.38.69.70
    crypto isakmp keepalive 30 5
    !
    !
    crypto ipsec transform-set myset esp-3des esp-md5-hmac
    !
    crypto dynamic-map mymap 10
    set transform-set myset
    !
    !
    crypto map mainmap 1 ipsec-isakmp dynamic mymap
    !
    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 14.38.69.71 255.255.0.0
    duplex auto
    speed auto
    crypto map mainmap
    !
    interface Serial0/0
    no ip address
    shutdown
    no fair-queue
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 14.38.69.70
    no ip http server
    !
    !
    call rsvp-sync
    !
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    !
    line con 0
    exec-timeout 0 0
    speed 115200
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    Anlatım eksikliği yada yazım yanlışı olduysa affola. Kolay gelsin, İyi çalışmalar...

  2. #2
    AcLMasteR isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jan 2008
    Bulunduğu yer
    Ankara
    Mesajlar
    1,189

    Standart

    teşekkürler hocam
    The day that never comes

  3. #3
    root isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Jun 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,409

    Standart

    hocam eline sağlık devamını da bekliyoruz artık.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok