Policy-Based Routing (PBR) kullanarak Code Red isimli worm' u engelleme
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Reply to Thread
Results 1 to 4 of 4
Policy-Based Routing (PBR) kullanarak Code Red isimli worm' u engelleme

Aslında bu işlemin 3 adet yolu var bu gece sadece PBR kullanımını hazırladım ve attım. Yarından itibaren devam edeceğiz. RouterAnkara(config)#access-list 106 permit ip any any dscp 1 RouterAnkara(config)#route-map null_policy_route 10

  1. #1
    datacaterman Guest

    Arrow Policy-Based Routing (PBR) kullanarak Code Red isimli worm' u engelleme

    Aslında bu işlemin 3 adet yolu var bu gece sadece PBR kullanımını hazırladım ve attım. Yarından itibaren devam edeceğiz.


    RouterAnkara(config)#access-list 106 permit ip any any dscp 1

    RouterAnkara(config)#route-map null_policy_route 10
    RouterAnkara(config-route-map)#match ip address 106
    RouterAnkara(config-route-map)#set interface Null0

    RouterAnkara(config)#interface serial 0/0
    RouterAnkara(config-if)#ip policy route-map null_policy_route

    RouterAnkara#show access-list 106
    Extended IP access list 106
    permit ip any any dscp 1 (1506 matches)

    RouterAnkara#show log
    Aug 4 13:25:20: %SEC-6-IPACCESSLOGP:
    list 105 denied tcp A.B.C.D.(0) -> 10.1.1.75(0), 6 packets
    Aug 4 13:26:32: %SEC-6-IPACCESSLOGP:
    list 105 denied tcp A.B.C.D.(0) -> 10.1.1.75(0), 6 packets

  2. #2
    burner Guest

    Default

    Slm;

    Yada

    Cisco sitesinden caldim tum haklari @@@ ;


    Classify inbound "Code Red" hacks with the class-based marking feature in Cisco IOS software, as shown below:

    Router(config)#class-map match-any http-hacks
    Router(config-cmap)#match protocol http url "*default.ida*"
    Router(config-cmap)#match protocol http url "*cmd.exe*"
    Router(config-cmap)#match protocol http url "*root.exe*"

    Router(config)#policy-map mark-inbound-http-hacks
    Router(config-pmap)#class http-hacks
    Router(config-pmap-c)#set ip dscp 1

    Router(config)#interface serial 0/0
    Router(config-if)#service-policy input mark-inbound-http-hacks

    ------>>>>>buradan sonra iki strateji izleyebiliriz.....

    1.

    Router(config)#access-list 105 deny ip any any dscp 1
    Router(config)#access-list 105 permit ip any any

    Router(config)#interface ethernet 0/1
    Router(config-if)#ip access-group 105 out

    2.ikinci seklide ustte gosterildigi gibi, yani;

    Router(config)#access-list 106 permit ip any any dscp 1

    Router(config)#route-map null_policy_route 10
    Router(config-route-map)#match ip address 106
    Router(config-route-map)#set interface Null0

    Router(config)#interface serial 0/0
    Router(config-if)#ip policy route-map null_policy_route


    Iyi gunler
    Last edited by burner; 07.10.2008 at 11:00.

  3. #3
    e-mky Guest

    Default

    hocam burda
    RouterAnkara(config-route-map)#match ip address 106
    (burda 106 yerine 212.12.135.12 ) gbi bir adrewsmi yazacak bunu tam anlamaadım neden p address 106?

  4. #4
    Orhan ERGUN is offline Senior Member
    Join Date
    Aug 2008
    Posts
    256

    Default

    Merhaba,

    match ip address 106

    Buradaki 106 ; yukarıdaki 106 numaralı access-list'in numarasıdır.

    Kolay Gelsin.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts