PPP Over Frame Relay Konfigurasyonu
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 6 sonuçtan 1 ile 6 arasındakiler gösteriliyor.
PPP Over Frame Relay Konfigurasyonu

PPP Over Frame Relay with chap authentications Bugun sizlere ppp over frame-relay dan bir ornek vermeye calisacagim,.... ...Live.... 1...basic configurations..... R2-----------> R2#sh ip int b Interface IP-Address OK? Method Status

  1. #1
    burner Guest

    Standart PPP Over Frame Relay Konfigurasyonu

    PPP Over Frame Relay with chap authentications

    Bugun sizlere ppp over frame-relay dan bir ornek vermeye calisacagim,....
    ...Live....


    1...basic configurations.....



    R2----------->

    R2#sh ip int b
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES TFTP up up
    Serial0/0 unassigned YES NVRAM up up
    FastEthernet0/1 unassigned YES NVRAM up up
    Serial0/1 unassigned YES NVRAM administratively down down
    Loopback0 150.1.2.2 YES manual up up
    R2#


    R2#sh run int s0/0
    Building configuration...

    Current configuration : 69 bytes
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    end
    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    150.1.0.0/32 is subnetted, 1 subnets
    C 150.1.2.2 is directly connected, Loopback0
    R2#



    R3-------------------------->


    R3#sh ip int b
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM up up
    Serial0/0 unassigned YES TFTP up up
    Serial0/0.1 unassigned YES unset deleted down
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    Serial0/1 unassigned YES NVRAM administratively down down
    Loopback0 150.1.3.3 YES manual up up
    R3#

    3#sh run int s0/0
    Building configuration...

    Current configuration : 100 bytes
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    no dce-terminal-timing-enable
    end

    R3#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    150.1.0.0/24 is subnetted, 1 subnets
    C 150.1.3.0 is directly connected, Loopback0
    R3#


    R5---------------------->

    R5#sh ip int b
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM administratively down down
    Serial0/0 unassigned YES TFTP up up
    Serial0/0.1 unassigned YES manual deleted down
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    Serial0/1 unassigned YES NVRAM administratively down down
    Loopback0 150.1.5.5 YES manual up up
    R5#sh run int s0/0
    Building configuration...

    Current configuration : 69 bytes
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    end

    R5#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    150.1.0.0/24 is subnetted, 1 subnets
    C 150.1.5.0 is directly connected, Loopback0
    R5#


    2....Virtual templateleri yaratalim ve interfacelere attach yapalim


    R2------------------>

    R2#sh ip int b
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES TFTP up up
    Serial0/0 unassigned YES NVRAM up up
    FastEthernet0/1 unassigned YES NVRAM up up
    Serial0/1 unassigned YES NVRAM administratively down down
    Virtual-Access1 unassigned YES unset down down
    Virtual-Template1 10.1.0.2 YES manual down down
    Virtual-Access2 10.1.0.2 YES TFTP up up
    Loopback0 150.1.2.2 YES manual up up

    R2#sh run int virtual-template 1
    Building configuration...

    Current configuration : 70 bytes
    !
    interface Virtual-Template1
    ip address 10.1.0.2 255.255.255.0
    end

    R2#sh run int s0/0
    Building configuration...

    Current configuration : 123 bytes
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    frame-relay interface-dlci 205 ppp Virtual-Template1
    end


    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.1.0.0/24 is directly connected, Virtual-Access2
    C 10.1.0.5/32 is directly connected, Virtual-Access2
    150.1.0.0/32 is subnetted, 1 subnets
    C 150.1.2.2 is directly connected, Loopback0
    R2#

    R2#ping 10.1.0.5 rep 1

    Type escape sequence to abort.
    Sending 1, 100-byte ICMP Echos to 10.1.0.5, timeout is 2 seconds:
    !
    Success rate is 100 percent (1/1), round-trip min/avg/max = 56/56/56 ms
    R2#ping 10.1.0.3 rep 1

    Type escape sequence to abort.
    Sending 1, 100-byte ICMP Echos to 10.1.0.3, timeout is 2 seconds:
    !
    Success rate is 100 percent (1/1), round-trip min/avg/max = 116/116/116 ms

    R2#trace 10.1.0.3

    Type escape sequence to abort.
    Tracing the route to 10.1.0.3

    1 10.1.0.5 28 msec 32 msec 28 msec
    2 10.1.0.3 56 msec * 56 msec
    R2#

    R2#ping 150.1.5.5

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 150.1.5.5, timeout is 2 seconds:
    ..
    Success rate is 0 percent (0/2)
    R2#ping 150.1.3.3

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:
    ..
    Success rate is 0 percent (0/2)



    R3------------------>


    R3#sh ip int b
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM up up
    Serial0/0 unassigned YES TFTP up up
    Serial0/0.1 unassigned YES unset deleted down
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    Serial0/1 unassigned YES NVRAM administratively down down
    Virtual-Access1 unassigned YES unset down down
    Virtual-Template1 10.1.0.3 YES manual down down
    Virtual-Access2 10.1.0.3 YES TFTP up up
    Loopback0 150.1.3.3 YES manual up up
    R3#sh run int virtual-template 1
    Building configuration...

    Current configuration : 71 bytes
    !
    interface Virtual-Template1
    ip address 10.1.0.3 255.255.255.0
    end

    R3#sh run int s0/0
    Building configuration...

    Current configuration : 154 bytes
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    no dce-terminal-timing-enable
    frame-relay interface-dlci 305 ppp Virtual-Template1
    end

    R3#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.1.0.0/24 is directly connected, Virtual-Access2
    C 10.1.0.5/32 is directly connected, Virtual-Access2
    150.1.0.0/24 is subnetted, 1 subnets
    C 150.1.3.0 is directly connected, Loopback0
    R3#ping 10.1.0.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.0.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 112/114/117 ms
    R3#trace
    Protocol [ip]:
    Target IP address: 10.1.0.2
    Source address: 10.1.0.3
    Numeric display [n]:
    Timeout in seconds [3]:
    Probe count [3]:
    Minimum Time to Live [1]:
    Maximum Time to Live [30]:
    Port Number [33434]:
    Loose, Strict, Record, Timestamp, Verbose[none]:
    Type escape sequence to abort.
    Tracing the route to 10.1.0.2

    1 10.1.0.5 28 msec 32 msec 28 msec
    2 10.1.0.2 56 msec * 56 msec
    R3#

    R5------------------>

    R5#
    R5#sh ip int b
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM administratively down down
    Serial0/0 unassigned YES TFTP up up
    Serial0/0.1 unassigned YES manual deleted down
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    Serial0/1 unassigned YES NVRAM administratively down down
    Virtual-Access1 unassigned YES unset down down
    Virtual-Template1 10.1.0.5 YES manual down down
    Virtual-Access2 10.1.0.5 YES TFTP up up
    Virtual-Access3 10.1.0.5 YES TFTP up up
    Loopback0 150.1.5.5 YES manual up up
    R5#sh run int virtual-template 1
    Building configuration...

    Current configuration : 70 bytes
    !
    interface Virtual-Template1
    ip address 10.1.0.5 255.255.255.0
    end

    R5#sh run int s0/0
    Building configuration...

    Current configuration : 177 bytes
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    frame-relay interface-dlci 502 ppp Virtual-Template1
    frame-relay interface-dlci 503 ppp Virtual-Template1
    end
    R5#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    C 10.1.0.3/32 is directly connected, Virtual-Access3
    C 10.1.0.2/32 is directly connected, Virtual-Access2
    C 10.1.0.0/24 is directly connected, Virtual-Access3
    is directly connected, Virtual-Access2
    150.1.0.0/24 is subnetted, 1 subnets
    C 150.1.5.0 is directly connected, Loopback0
    R5#
    R5#ping 10.1.0.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.0.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms
    R5#ping 10.1.0.3

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.0.3, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/59/60 ms
    R5#ping
    Protocol [ip]:
    Target IP address: 10.1.0.3
    Repeat count [5]:
    Datagram size [100]:
    Timeout in seconds [2]: 1
    Extended commands [n]: y
    Source address or interface: 150.1.5.5
    Type of service [0]:
    Set DF bit in IP header? [no]:
    Validate reply data? [no]:
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose[none]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.0.3, timeout is 1 seconds:
    Packet sent with a source address of 150.1.5.5
    .....
    Success rate is 0 percent (0/5)
    R5#


    goruldugu uzere sadece loopback adresslerine ulasilamiyor zaten routing tablelerindede bu durum acik ve net bir sekilde goz onunde..

    simdi Rip i networkta configure edelim ve loopback ulasilabilirligi sorununu cozelim, bunun yaninda chap authantication nunu kullanalim ppp icin..
    Dikkat R5(main interface ve multipoint) ta split horizon sorunu yok nedeni ise artik frame relay uzerinden ppp kullaniyoruz..asagida daha acik ve net sekilde gorulebilir....

    R2---------------->

    R2(config)#router rip
    R2(config-router)#ver 2
    R2(config-router)#no auto
    R2(config-router)#netw 10.1.0.0
    R2(config-router)#netw 150.1.0.0
    R2(config-router)#exit
    R2(config)#username R5 password cisco
    R2(config)#int virtual-template 1
    R2(config-if)#ppp authentication chap
    R2(config-if)#end


    R3------------------->

    R3#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    R3(config)#router rip
    R3(config-router)#ver 2
    R3(config-router)#no auto
    R3(config-router)#netw 10.0.0.0
    R3(config-router)#netw 150.1.0.0
    R3(config-router)#exit
    R3(config)#username R5 pass cisco
    R3(config)#int virtual-template 1
    R3(config-if)#ppp authentication chap
    R3(config-if)#
    *Mar 1 04:26:34.006: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down
    R3(config-if)#end
    R3#

    R5----------------->

    R5#sh ip int b
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM administratively down down
    Serial0/0 unassigned YES TFTP up up
    Serial0/0.1 unassigned YES manual deleted down
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    Serial0/1 unassigned YES NVRAM administratively down down
    Virtual-Access1 unassigned YES unset down down
    Virtual-Template1 10.1.0.5 YES manual down down
    Virtual-Access2 10.1.0.5 YES TFTP up down
    Virtual-Access3 10.1.0.5 YES TFTP up down
    Loopback0 150.1.5.5 YES manual up up
    R5#

    simdi goruldugu uzere butun access interfaceler protocol status down cunku ppp authentications enabled r2 ve r3...simdi R5 i config edelim....

    R3#
    R3#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    R3(config)#router rip
    R3(config-router)#ver 2
    R3(config-router)#no auto
    R3(config-router)#netw 10.0.0.0
    R3(config-router)#netw 150.1.0.0
    R3(config-router)#exit
    R5(config)#username R2 pass cisco
    R5(config)#username R3 pass cisco
    R5(config-if)#ppp authentication chap
    R5(config-if)#end
    *Mar 1 04:34:03.339: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
    *Mar 1 04:34:19.373: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up

    R5#sh ip int b
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM administratively down down
    Serial0/0 unassigned YES TFTP up up
    Serial0/0.1 unassigned YES manual deleted down
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    Serial0/1 unassigned YES NVRAM administratively down down
    Virtual-Access1 unassigned YES unset down down
    Virtual-Template1 10.1.0.5 YES manual down down
    Virtual-Access2 10.1.0.5 YES TFTP up up
    Virtual-Access3 10.1.0.5 YES TFTP up up
    Loopback0 150.1.5.5 YES manual up up
    R5#sh run int virtual-temp 1
    Building configuration...

    Current configuration : 95 bytes
    !
    interface Virtual-Template1
    ip address 10.1.0.5 255.255.255.0
    ppp authentication chap
    end

    R5#sh run int s0/0
    Building configuration...

    Current configuration : 177 bytes
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    frame-relay interface-dlci 502 ppp Virtual-Template1
    frame-relay interface-dlci 503 ppp Virtual-Template1
    end
    R5#sh ip route rip
    150.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
    R 150.1.3.0/24 [120/1] via 10.1.0.3, 00:00:02, Virtual-Access3
    R 150.1.2.2/32 [120/1] via 10.1.0.2, 00:00:15, Virtual-Access2
    R5#
    R5#ping 150.1.3.3 rep 2

    Type escape sequence to abort.
    Sending 2, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:
    !!
    Success rate is 100 percent (2/2), round-trip min/avg/max = 60/60/60 ms
    R5#ping 150.1.3.3 rep 2 source 150.1.5.5

    Type escape sequence to abort.
    Sending 2, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:
    Packet sent with a source address of 150.1.5.5
    !!
    Success rate is 100 percent (2/2), round-trip min/avg/max = 56/58/60 ms
    R5#ping 150.1.2.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 150.1.2.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms
    R5#ping 150.1.2.2 rep 2 source 150.1.5.5

    Type escape sequence to abort.
    Sending 2, 100-byte ICMP Echos to 150.1.2.2, timeout is 2 seconds:
    Packet sent with a source address of 150.1.5.5
    !!
    Success rate is 100 percent (2/2), round-trip min/avg/max = 56/58/60 ms
    R5#

    simdi birde frame map a bakalim.............R5#sh frame-relay map

    R5#
    map yok...............

    frame pvc....
    R5#sh frame-relay pvc | inc = ACTIVE
    DLCI = 502, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0
    DLCI = 503, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0
    R5#

    R2--------------->

    R2#sh ip route rip
    10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    R 10.1.0.3/32 [120/1] via 10.1.0.5, 00:00:21, Virtual-Access2
    150.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
    R 150.1.5.0/24 [120/1] via 10.1.0.5, 00:00:21, Virtual-Access2
    R 150.1.3.0/24 [120/2] via 10.1.0.3, 00:00:21, Virtual-Access2
    R2#

    R2#ping 150.1.3.3 rep 2

    Type escape sequence to abort.
    Sending 2, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:
    !!
    Success rate is 100 percent (2/2), round-trip min/avg/max = 112/114/116 ms
    R2#trace 150.1.3.3

    Type escape sequence to abort.
    Tracing the route to 150.1.3.3

    1 10.1.0.5 28 msec 32 msec 28 msec
    2 10.1.0.3 56 msec * 56 msec
    R2#

    R3----------->

    R3#sh ip route rip
    10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    R 10.1.0.2/32 [120/1] via 10.1.0.5, 00:00:06, Virtual-Access2
    150.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
    R 150.1.5.0/24 [120/1] via 10.1.0.5, 00:00:06, Virtual-Access2
    R 150.1.2.2/32 [120/2] via 10.1.0.2, 00:00:06, Virtual-Access2
    R3#

    simdi butun networkleri yada host lari pingleyebiliyoruz, ppp yi frame-relay uzerinde kullanarak, rip v2 ve ayni zamanda ppp chap authentication da calisiyor. Eger ppp auth birazdaha debug edecek olursak R2 da................

    R2#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    R2(config)#no loggin console
    R2(config)#loggin buffer
    R2(config)#end
    R2#debug ppp authentication
    PPP authentication debugging is on
    R2#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    R2(config)#int s0/0
    R2(config-if)#do clear log
    Clear logging buffer [confirm]
    R2(config-if)#shut
    R2(config-if)#no shut
    R2(config-if)#end
    R2#un all
    R2#sh log | inc (CHALLENGE | RESPONSE | SUCCESS | LOGIN)
    *Mar 1 04:56:56.682: Vi2 CHAP: O CHALLENGE id 14 len 23 from "R2"
    *Mar 1 04:56:56.698: Vi2 CHAP: I CHALLENGE id 208 len 23 from "R5"
    *Mar 1 04:56:56.702: Vi2 CHAP: O RESPONSE id 208 len 23 from "R2"
    *Mar 1 04:56:56.706: Vi2 CHAP: I RESPONSE id 14 len 23 from "R5"
    *Mar 1 04:56:56.706: Vi2 PPP: Sent CHAP LOGIN Request
    *Mar 1 04:56:56.710: Vi2 PPP: Received LOGIN Response PASS
    *Mar 1 04:56:56.718: Vi2 CHAP: O SUCCESS id 14 len 4
    *Mar 1 04:56:56.722: Vi2 CHAP: I SUCCESS id 208 len 4
    R2#

    NOt: eger ping i istediginiz zamanda kesmek istiyorsaniz iki kez ard arda ctrl+Shift+6 yaptiginizda ping kesilir!!!!
    ORNEK:
    R2#ping 150.1.3.3 rep 1000000

    Type escape sequence to abort.
    Sending 1000000, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!."( ctrl+Shift+6)x2"
    Success rate is 99 percent (117/118), round-trip min/avg/max = 112/116/185 ms
    R2#ping 150.1.3.3 rep 1000000 timeout 0

    Type escape sequence to abort.
    Sending 1000000, 100-byte ICMP Echos to 150.1.3.3, timeout is 0 seconds:
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    .................................................. ....................
    ...................................."(ctrl+Shift+6 )x2"
    Success rate is 0 percent (0/2066)
    R2#

    Kolay gelsin !!!
    Eklenmiş Resim Eklenmiş Resim
    Konu burner tarafından (09.03.2008 Saat 08:21 ) değiştirilmiştir.

  2. #2
    yaman isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Londra
    Mesajlar
    245

    Standart

    Cok Guzel anlatmissin Burner, Kisaca bir ek.

    PPP over frame-relay neden kullanilir?

    Mesela..

    Bilindigi uzere OSPF LAN uzernide calismasi icin tasarlanmis bir protokoldur yane Ethernet, token ring v.s...Eeee Frame-Relay bir WAN teknolojisidir ve bir noktan diger noktaya gecisi araci bir router sagliyorsa bu sorun teskil eder cunki packetin bir noktadan digerine yonledirlmesi lazimdir.

    Bu ne demek? OSPF TTL value 1 tasir yane TTL eger routera gelirse ve baska bir networka yonlendirme vasitasi ile gecmek zorunda ise TTL rakami 1'den 0'a indirilir buda demktirki paket artik buradan ote gidemez paketin yasam sureci 0'da biter. Bu LAN'larda sorun degil cunki TTL LAN'da dusmez.

    Simdi farz edinki Burne'rin verdigi network semasi OSPF ve siz R2 dan R3'ye routing yapacaksiniz ve OSPF komsuluk iliskisi kuracaksiniz, bu semadaki durum karsinda R2'nun OSPF paketi R5 gider, R5 TTL'li 1 den 0 dusur ve R3 gidemez paket.

    Bu gibi durumlarda PPP kullanilabilir yane R2 ile R3 sanki R5'dan gecerek degilde direk birbirlerine gecis yapiyor gibi gorunur ve bu durumda TTL 1'de kalir.

    Belki pek net bir aciklama degil ama net anlayabilmeniz icin routing protokol'lerin yapisini incelemniz lazim ve ancak ozaman PPP over Frame-relay netlik kazanir.
    Yaman

  3. #3
    root Guest

    Standart

    Aslinda soyle diyebilir miyiz? PPP over frame-relay ya da LL gibi network connection teknolojilerini ve aralarindaki routing'i ogrenmeden once route protocollerin temellerini bilmeniz size bu konulari daha anlasilir kilar. Bu sayede farkli WAN connection teknolojilerinin birbiri arasinda paket trafigini daha rahat anlarsiniz eger routing protokolleri biliyorsaniz. yaman hocam dogru mudur?

  4. #4
    yaman isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Londra
    Mesajlar
    245

    Standart

    Evet Ozgur kardesim aynen oyle, Burner guzel yazmis ve bunu ben anladim, cunki az cok routig protokollerin yapisini bildigimden yoksa anlamak icin biraz arastirma yapmam gerekirdi...

    Isin guzel tarafi Burner burada teoriyi ve calisma bicimini anlatmis ve ogrenemk isteyen arkadaslarda merak uyandirmis.
    Yaman

  5. #5
    burner Guest

    Standart

    Merhaba,

    Himmm!!!! Nasil baslasam.....
    Oncelikle sunu soyleyeyim, Lan routing protocol diye birsey yok, ortada igp(eigrp, ospf, ripv1v2, isis, igrp(emekli oldu), odr(based on cdp)...vs var egp(B G P)..
    ttl valuelerine gelince, butun routing protocoller ya multicast yada broadcast yapar...bgp yine ayri cunku bgp connection oriented routing protocol.

    ospf : hellos multicast(224.0.0.5 - 224.0.0.6(DR) ): ttl =1 , updateler unicast olarak gerceklesir, .
    frame-relayda ospf problem ttl acisindan spoke to spoke adjencies olusmaz, cunku bunlar direk bagli degildir, ama bunu cozmek icin nbma yada broadcast netw type lerinde DR olarak hub u secer isek bu sorunu cozeriz.
    ikinci cozum ospf netw type sini point-to-multipoint yapariz buda problemi cozer.
    ucuncu cozum tunnel...
    dorduncu cozum ppp over frame-relay....
    birde sorun olusumu frame-relay map tan kaynaklanabilir map "Quad Zero-map" diye adlandirilir, bu durumda hic bir sorun yokmus gibi gozukur ama ne zaman ospf i koyunca mesaj alirsiniz ospf neighbor yanlis areada....bunun cozumu routerin config save yapar reload yaparsiniz...

    eigrp:hellos:multicast(224.0.0.10), updates:unicast : ttl = 2 multicast....spoke to spoke problem ancak point-to-multipoint main ve sub interface lerinde olusur oda split horizon u disable etmek sureti ile cozulmus olur, eigrp acisindan sorun var ve split horizonu disable etmek gerekir manually...

    ripv2: multicast(224.0.0.9) , updates:unicast:ttl=2: spoke to spoke problem ancak point-to-multipoint sub int inde olusur oda split horizon u disable etmek sureti ile cozulmus olur, multipoint main int inde rip acisindan bir sorun yok cunku split horizon disabled by default.

    ripv1: ttl=1 broadcast.(emekli oluyor)


    bgp (nasil derler unix dilinde BIG KAHUNA, yani internet protocol): tcp connectivitisi ister, buda ip erisimi gerektirir yani iki neighbor un neighbor olabilimesi icin ip erisimine ihtiyaci vardir, ASLINDA BGP application cunku tcp three way hand shake olusmasi gerekir port 179...
    ve bgp interface base bir routing protocol degil igp ler gibi. Network advertise edersiniz(network commandi ile, redistribute, .... ) network prefixlerini transfer eder ve ulasilabilirligi saglar...Kitaplar kitaplar dolusu bgp buyuk ve buyuk, gozunuzde buyutmeyin bana gore ospf ten kolay
    unicast...:ebgp ttl = 1 spoke to spoke neighbor olamazlar, ama olayi ebgp-multihop comand i ile cozebiliriz.
    yada tunnel ile ...
    ibgp ttl = yuksek bir rakam yani genelde sorun yok, onemli olan next hop erisimi bu erisim varsa genelde sorun yok demektir.

    ODR: cdp uzerine calisir yani cdp yoksa oda yok, genelde hub and spoke framerelay network type lerinde kullanilir.

    yanlis bir bilgi var ise hemen duzeltme isterim, ve memnun olurum biraz yorgunum...Ama bu konular arastirmaya acik konular ve cok genis konular....

    Tesekkurler

  6. #6
    yaman isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Londra
    Mesajlar
    245

    Standart

    Vallahi ben hec bir yanlis gormedim hepiside dogrudur

    Evet dogrudur LAN protokol diye birsey yoktur, benim vermis oldugum LAN ornegi yanlistir, demek istedigim, routing protokoller birbirleri ile ilk baglanti iletisimlerini, genelikle MULTICAST uzerinden yaparlar, bunu icin bu protokoller BROADCAST enabled media uzerinde daha kolay calisrlar buna ornek olsun dieyede ETHERNET dedim mesela, ama bu demek degildirki NON-BROADCAST media uzerinden calisamazlar, bunu cetlerini BURNER'IN vermis oldugu ornekler gosteriyor, benim vermis oldugum ornek 1 OSPF orneginin ne gibi dumlarda FRAME-RELAY'de sorun olabailecegini gostemek icindir. Ve PPP'in ne gibi bir faydasi oldugunu gostermektir.

    Ve soyledigim gibi FRAME-RELAY'i ve PPP'yi net analyabilmek icin, ve butununlestirebilmek icin, ve calisma mantigini anlyabilmek icin biraz diplere inmeniz gerekir buda sizin goreviniz, cunki sebepler bir forumda yazilamayacak kadar coktur, ve ben BURNER'i taktir ediyorumki bu kadar yazmis yine.


    Yane netice itibari ile Burner hakli, benim ornekte bir anlatim hatasi var, umarim bu hatayi duzelmisimdir.
    Konu yaman tarafından (13.03.2008 Saat 06:34 ) değiştirilmiştir.
    Yaman

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok