mpls1.jpg

mpls configuration:

p#s run

Building configuration...

Current configuration : 998 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname p

!

enable secret 5 $1$LWx8$I1u9ZMT7AUUU1H9tE1PiM.

!

memory-size iomem 15

ip subnet-zero

ip cef

no ip domain-lookup

no ftp-server write-enable

!

!

!

interface Loopback0

ip address 202.98.4.3 255.255.255.255

!

interface Ethernet0/0

ip address 10.1.1.10 255.255.255.252

ip ospf cost 20

half-duplex

tag-switching mtu 1508

tag-switching ip

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface Serial0/1

no ip address

shutdown

!

interface Serial0/2

ip address 10.1.1.6 255.255.255.252

ip ospf cost 20

tag-switching mtu 1508

tag-switching ip

clockrate 64000

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

network 10.1.1.6 0.0.0.0 area 0

network 10.1.1.10 0.0.0.0 area 0

!

ip http server

ip classless

ip pim bidir-enable

line con 0

line aux 0

line vty 0 4

password runway

login

!

end

pe1#show run

Building configuration...

Current configuration : 1736 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname pe1

!

logging rate-limit console 10 except errors

enable secret 5 $1$Y7mJ$nQ8wqPkeGiH.phCV1I0OC.

!

ip subnet-zero

ip cef

no ip domain-lookup

!

ip vrf vpna

rd 1:100

route-target export 200:1

route-target import 200:1

no ip dhcp-client network-discovery

no ftp-server write-enable

!

!

controller E1 3/0

!

!

interface Loopback0

ip address 202.98.4.1 255.255.255.255

!

interface Ethernet0/0

ip vrf forwarding vpna

ip address 172.16.1.1 255.255.255.252

half-duplex

tag-switching ip

!

interface Serial0/0

ip address 10.1.1.5 255.255.255.252

ip ospf cost 20

tag-switching mtu 1508

tag-switching ip

!

interface Serial0/1

ip address 10.1.1.1 255.255.255.252

ip ospf cost 100

tag-switching ip

clockrate 64000

!

router ospf 100

log-adjacency-changes

redistribute connected metric-type 1 subnets

redistribute static metric-type 1 subnets

network 10.1.1.0 0.0.0.255 area 0

network 202.98.4.0 0.0.0.255 area 0

!

router bgp 100

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 202.98.4.2 remote-as 100

neighbor 202.98.4.2 update-source Loopback0

neighbor 202.98.4.2 version 4

neighbor 202.98.4.2 activate

!

address-family ipv4 vrf vpna

redistribute connected

redistribute static

no auto-summary

no synchronization

exit-address-family

!

address-family vpnv4

neighbor 202.98.4.2 activate

neighbor 202.98.4.2 send-community extended

exit-address-family

!

ip http server

ip classless

ip route vrf vpna 192.168.3.0 255.255.255.0 172.16.1.2

ip ospf name-lookup

!

!

!

line con 0

line aux 0

line vty 0 4

password runway

login

!

end

pe2#s run

Building configuration...

Current configuration : 1822 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname pe2

!

logging rate-limit console 10 except errors

enable secret 5 $1$1fTh$xuf9cOlwU870HmNykwv3D1

!

ip subnet-zero

ip cef

no ip domain-lookup

!

ip vrf vpna

rd 1:100

route-target export 200:1

route-target import 200:1

no ip dhcp-client network-discovery

no ftp-server write-enable

interface Loopback0

ip address 202.98.4.2 255.255.255.255

!

interface Tunnel0

ip vrf forwarding vpna

no ip address

!

interface Ethernet0/0

ip address 10.1.1.9 255.255.255.252

ip ospf cost 20

half-duplex

tag-switching ip

!

interface Serial0/0

ip address 10.1.1.2 255.255.255.252

ip ospf cost 100

tag-switching ip

no fair-queue

!

interface Serial0/1

no ip address

shutdown

!

interface FastEthernet1/0

ip vrf forwarding vpna

ip address 172.16.2.1 255.255.255.0

duplex auto

speed auto

tag-switching ip

!

router ospf 100

log-adjacency-changes

redistribute connected metric-type 1 subnets

redistribute static metric-type 1 subnets

network 10.1.1.0 0.0.0.255 area 0

!

router bgp 100

no synchronization

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 202.98.4.1 remote-as 100

neighbor 202.98.4.1 update-source Loopback0

neighbor 202.98.4.1 version 4

neighbor 202.98.4.1 activate

no auto-summary

!

address-family ipv4 vrf vpna

redistribute connected

redistribute static

no auto-summary

no synchronization

exit-address-family

!

address-family vpnv4

neighbor 202.98.4.1 activate

neighbor 202.98.4.1 send-community extended

no auto-summary

exit-address-family

!

ip http server

ip classless

ip route vrf vpna 192.168.4.0 255.255.255.0 172.16.2.2

!

!

!

line con 0

line aux 0

line vty 0 4

password runway

login

!

end