MPLS VPN ve Multi-Virtual Route Forwarding
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

+ Konuyu Cevapla
Toplam 2 sonuçtan 1 ile 2 arasındakiler gösteriliyor.
MPLS VPN ve Multi-Virtual Route Forwarding

Slm; Asagida cisco netPro Forum sitesinde sorulmus guzel bir soru var, daha cok var eger bir goz atarsaniz...register olmaniz gerekiyor answer: ???? Basically what I'm trying to do is NAT

  1. #1
    burner Guest

    Standart MPLS VPN ve Multi-Virtual Route Forwarding

    Slm;

    Asagida cisco netPro Forum sitesinde sorulmus guzel bir soru var, daha cok var eger bir goz atarsaniz...register olmaniz gerekiyor

    answer: ????

    Basically what I'm trying to do is NAT our CE router's IP address to a public IP in order to provide internet access to them. The only thing special is that this is on a PE router terminating customer connections with MPLS VRFs. I need to translate to a secondary IP (public) on the ethernet interface which is why I have a pool with a single IP instead of an interface. Here is the relevant configuration.

    interface Looopback1
    ip nat inside

    interface GigabitEthernet0/3
    ip nat outside

    ip nat pool VRF_NAT x.x.x.x x.x.x.x netmask 255.255.255.252

    ip nat inside source route-map VRF_RM pool VRF_NAT vrf GCF01 overload
    !
    access-list 151 deny ip 177.177.176.0 0.0.0.3 10.0.4.0 0.0.0.255
    access-list 151 deny ip 177.177.176.0 0.0.0.3 10.0.5.0 0.0.0.255
    access-list 151 permit ip 177.177.176.0 0.0.0.3 any
    !
    route-map VRF_RM permit 10
    match ip address 151

    (x.x.x.x) is a single public IP address assigned as a secondary IP on the gi0/3 interface

    With this configuration nothing matches the route map and no translations occur. When I change the ip nat inside source command to point to the loopback interface instead of the pool, I get some translations, but it is not translating IPs of the CE router. The CE router interface is 177.177.176.2 and I need that IP translated out of the VRF to the public IP. Any help would be appreciated. Thanks





    Iyi gunler
    Konu burner tarafından (02.06.2009 Saat 15:50 ) değiştirilmiştir.

  2. #2
    Orhan ERGUN isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Aug 2008
    Mesajlar
    256

    Standart

    Merhaba,

    Burda 2 adımda durumu çözebilirsin diye düşünüyorum.

    1 . Natlanacak ip tek bir public ip ve source interfaceindeki 176.2 yi buna natlamak istiyor.

    176.2 için , public ip'ye static bir nat yaz önce.

    2.adımda bu source'dan 4.0 ve 5.0 lokal networklerine giderken , trafiği vrf e sokmalısın , bunun için multi vrf kullanmalıyız. Yani ; destination base access-list yazıp bunu route-map de match ediyor , set vrf vrfname veriyorsun.

    Test etmedim , çalışır diye düşünüyorum.

    Kolay Gelsin

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok