Juniper EX2200 VOİCE VLAN HAKKINDA
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

+ Konuyu Cevapla
Toplam 5 sonuçtan 1 ile 5 arasındakiler gösteriliyor.
Juniper EX2200 VOİCE VLAN HAKKINDA

Merhaba arkadaşlar, günlerdir uğraşıyorum ancak problemi çözemedim.sanal santral kurulumu gerçekleştirdiğimiz müşteride cisco888 ve onun arkasındada telefonların takılı olduğu juniper ex2200 switch var. telefonlar uzak dhcp yani ip helper yapılarak ip

  1. #1
    mazaka isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Mar 2013
    Mesajlar
    14

    Standart Juniper EX2200 VOİCE VLAN HAKKINDA

    Merhaba arkadaşlar,

    günlerdir uğraşıyorum ancak problemi çözemedim.sanal santral kurulumu gerçekleştirdiğimiz müşteride cisco888 ve onun arkasındada telefonların takılı olduğu juniper ex2200 switch var. telefonlar uzak dhcp yani ip helper yapılarak ip alacak.ancak juniper üzerinden telefonlara ip aldıramadık.acaba konfigurasyonda eksiklikmi var..iki cihazında konfiğini sizlerle paylaşıyorum.yardımcı olabilirmisiniz.teşekkürler.

    topoloji :

    cisco888(gateway)>juniper ex2200>ip phone

    cisco 888 konfig :

    hostname deneme
    !
    boot-start-marker
    boot-end-marker
    !
    !
    logging buffered 51200 warnings
    !
    no aaa new-model
    memory-size iomem 10
    !
    crypto pki trustpoint TP-self-signed-3902832446
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3902832446
    revocation-check none
    rsakeypair TP-self-signed-3902832446
    !
    !
    crypto pki certificate chain TP-self-signed-3902832446
    certificate self-signed 01
    3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
    31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
    69666963 6174652D 33393032 38333234 3436301E 170D3133 30383237 30373230
    33315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
    4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39303238
    33323434 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
    8100AED5 294BF309 27EE6938 1A839DD8 EEF17832 5752EE2D 0EDA2C48 0D1B9B97
    6ACEC48B EFA0AF24 D5FC688F 094E336E A0E178D7 EEAB33A9 BFC4F203 FCBB48AA
    641EA766 0FE71CB0 660A9E72 CF434DF3 EEA2DAC5 2883B5C4 54C242D0 29C74479
    1C267230 D50ACCB7 8FE3B1F6 BE34F23C 8E7EFD53 90482351 4E2CD5DE B9F46ADF
    8C0D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
    551D2304 18301680 149FAE02 C3F98AF3 95836EFA 4BFE2EE9 D2EE97B1 CF301D06
    03551D0E 04160414 9FAE02C3 F98AF395 836EFA4B FE2EE9D2 EE97B1CF 300D0609
    2A864886 F70D0101 05050003 818100A3 A044C3B1 6C1C5A36 657DA15C 331E93FE
    63AB7ABB E254A5C7 66FB668D 3EFA7E6B 21278679 64982D6C 3A2DD1F0 48761E01
    031DFE45 ACC481EF 3A181357 E355E48F 348A21BB 1012B67C 6DF03657 EB18B439
    F446A1AC 7644F761 DDF2C293 426E6E8C BA26AFDF 5F1D6715 30440461 1EC88EF1
    7B12CC8D F251EB1A F4819F3C 56948E
    quit
    !
    !
    !
    !
    !
    !
    no ip domain lookup
    ip domain name
    ip cef
    no ipv6 cef
    !
    !
    license udi pid CISCO888-K9 sn FCZ1735C0ZF
    !
    !
    username tt privilege 15 secret 4 O76K9OhGXDcRXYK/BTOu3..etuXHz/eZQJYOzroYOxg
    !
    !
    !
    !
    !
    controller DSL 0
    mode atm
    dsl-mode shdsl symmetric annex B
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 192.168.186.57 255.255.255.255
    !
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    isdn termination multidrop
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
    ip address 172.16.34.2 255.255.255.252
    atm route-bridged ip
    pvc 0/35
    encapsulation aal5snap
    !
    !
    interface FastEthernet0
    switchport trunk native vlan 100
    switchport mode trunk
    no ip address
    !
    interface FastEthernet1
    switchport mode trunk
    no ip address
    !
    interface FastEthernet2
    no ip address
    !
    interface FastEthernet3
    no ip address
    !
    interface Vlan1
    description $ETH_LAN$
    no ip address
    ip tcp adjust-mss 1452
    !
    interface Vlan100
    description voice
    ip address 10.197.14.97 255.255.255.224
    ip helper-address 10.10.80.10
    ip tcp adjust-mss 1452
    !
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 0.0.0.0 0.0.0.0 172.16.34.1
    ip route 10.10.40.2 255.255.255.255 172.16.34.1
    ip route 95.2.191.0 255.255.255.0 172.16.34.1
    !
    no cdp run
    !
    !
    !
    line con 0
    login local
    no modem enable
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    line vty 5 15
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    !
    !
    end




    juniper ex2200 sw

    system {
    host-name deneme_SW;
    root-authentication {
    encrypted-password "$1$Ki7qe6Uw$ABfkt5eTZ1i7vHehTTS930"; ## SECRET-DATA
    }
    login {
    user tt {
    uid 200;
    class super-user;
    authentication {
    encrypted-password "$1$7NW9Kcyw$9sKlII/WM59gTheyt3Cxg/"; ## SECRET-DATA
    }
    }
    }
    services {
    telnet;
    }
    syslog {
    user * {
    any emergency;
    }
    file messages {
    any notice;
    authorization info;
    }
    file interactive-commands {
    interactive-commands any;
    }
    }
    }
    chassis {
    auto-image-upgrade;
    }
    interfaces {
    ge-0/0/0 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/1 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/2 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/3 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/4 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/5 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/6 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/7 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/8 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/9 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/10 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id 100;
    }
    }
    }
    ge-0/0/11 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/12 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members voice-vlan;
    }
    native-vlan-id data-vlan;
    }
    }
    }
    ge-0/0/13 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/14 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/15 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/16 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/17 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/18 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/19 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/20 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/21 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/22 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/0/23 {
    description cisco888;
    unit 0 {
    description cisco888;
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members all;
    }
    native-vlan-id 100;
    }
    }
    }
    ge-0/1/0 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/1/1 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/1/2 {
    unit 0 {
    family ethernet-switching;
    }
    }
    ge-0/1/3 {
    unit 0 {
    family ethernet-switching;
    }
    }
    me0 {
    unit 0 {
    family inet {
    dhcp {
    vendor-id Juniper-ex2200-24p-4g;
    }
    }
    }
    }
    vlan {
    unit 0 {
    family inet {
    dhcp {
    vendor-id Juniper-ex2200-24p-4g;
    }
    }
    }
    unit 100 {
    family inet {
    address 10.197.14.98/27;
    }
    }
    unit 101 {
    family inet {
    address 192.168.38.38/24;
    }
    }
    unit 500 {
    family inet;
    }
    }
    }
    routing-options {
    static {
    route 0.0.0.0/0 next-hop 10.197.14.97;
    }
    }
    protocols {
    lldp {
    interface all;
    }
    lldp-med {
    interface all;
    }
    }
    ethernet-switching-options {
    voip;
    storm-control {
    interface all;
    }
    }
    vlans {
    data-vlan {
    vlan-id 101;
    l3-interface vlan.101;
    }
    default {
    l3-interface vlan.0;
    }
    voice-vlan {
    vlan-id 100;
    l3-interface vlan.100;
    }
    }
    poe {
    interface all;
    }

  2. #2
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,997

    Standart

    Nerden ip alacaklar ?
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  3. #3
    nfkengineer isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Apr 2013
    Mesajlar
    108

    Standart

    Juniperdaki vlan 100 (l3 olan interface) onun ip adresini silip deneyebilir misin ?
    Juniper da vlan 100 ,l3 seviyesine çıkmamalı.


    ya da
    ip helper adresini juniperda yazacaksınız.

    set forwarding-options helpers bootp server 10.10.80.10
    set forwarding-options helpers bootp interface ge-0x/x/x

  4. #4
    mazaka isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Mar 2013
    Mesajlar
    14

    Standart

    @Nexus,

    mpls üzerinden telekoma ait dhcp sunucusundan dhcp relay yapıyoruz.dhcp sunucusuna ping erişimi sağlayabiliyoruz.

    [email protected]_SW> ping 10.10.80.10
    PING 10.10.80.10 (10.10.80.10): 56 data bytes
    64 bytes from 10.10.80.10: icmp_seq=0 ttl=123 time=27.089 ms
    64 bytes from 10.10.80.10: icmp_seq=1 ttl=123 time=15.362 ms
    64 bytes from 10.10.80.10: icmp_seq=2 ttl=123 time=14.829 ms
    ^C
    --- 10.10.80.10 ping statistics ---
    3 packets transmitted, 3 packets received, 0% packet loss
    round-trip min/avg/max/stddev = 14.829/19.093/27.089/5.658 ms

    @nfkengineer,

    dediğinizi uyguladım ancak olmadı.mesela aşağıdaki gibi portu access yaptım ancak yine olmadı.

    [email protected]_SW# set interfaces ge-0/0/1 unit 0 family ethernet-switching port-mode
    access
    [email protected]_SW# set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan member
    vlan-data
    [email protected]_SW# set ethernet-switching-options voip interface ge-0/0/1.0 vlan vlan-data
    turktelekom[email protected]_SW# set ethernet-switching-options voip interface ge-0/0/1.0 forwardingclass
    expedited-forwarding

  5. #5
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,997

    Standart

    Vlanlarının l3 arayüzünü ciscoda oluştur. L3 arayüz altında da ip helper adress komutunu girersin. Juniperda dhcp ile alakalı bir girdi ve l3 vlan olmasına gerek yok.

    İlave olarak :

    Ciscoda dhcp relay servis aktif olmalı.
    Bunu service dhcp komutu ile yapabilirsin.

    Show ip route dhcp ile duruma bakarsın.

    Son olarak mpls vpn var ise telekom dhcp server ile aynı vrf içinde değilsen bunu googleden arat :

    "Configuring DHCP Relay Agent Support for MPLS VPNs"
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok