IPsec VPN ve NAT
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 5 sonuçtan 1 ile 5 arasındakiler gösteriliyor.
Like Tree3Likes
  • 1 Post By Soul
  • 2 Post By MCyagli
IPsec VPN ve NAT

Merhaba arkadaşlar, site to site IPsec VPN yapmak istedim. Buraya kadar güzel gitti fakat; her iki subede NAT yaptığımda yapı çalışmayı kesti. Ben de NAT konfigürasyonunu sildim. Sadce basit bir

  1. #1
    thrillercd Guest

    Standart IPsec VPN ve NAT

    Merhaba arkadaşlar, site to site IPsec VPN yapmak istedim. Buraya kadar güzel gitti fakat; her iki subede NAT yaptığımda yapı çalışmayı kesti. Ben de NAT konfigürasyonunu sildim. Sadce basit bir site to site vpn konfigürasyonu kaldı yapıda. packet trace simülasyonu bu linkte. Ayrıca bir site'nin konfigürasyonu aşağıdaki gibidir. Bu sistemde NAT'ı çalıştırmam gerekiyor. Fikirleriniz için şimdiden teşekkürler.


    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname A
    !
    !
    !
    !
    !
    !
    !
    !
    crypto isakmp policy 5
    encr 3des
    authentication pre-share
    group 2
    lifetime 72000
    !
    crypto isakmp key cisco address 10.0.0.2
    !
    !
    crypto ipsec transform-set STRONG esp-3des esp-sha-hmac
    !
    crypto map CISCO 10 ipsec-isakmp
    set peer 10.0.0.2
    set pfs group2
    set transform-set STRONG
    match address 101
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.0.0.1 255.255.255.0
    duplex auto
    speed auto
    crypto map CISCO
    !
    interface FastEthernet0/1
    ip address 192.168.0.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    !
    !
    access-list 101 permit ip 192.168.0.0 0.0.0.255 192.168.2.0 0.0.0.255
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end

  2. #2
    Soul isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,080

    Standart

    Merhaba

    packet tracer desteklermi bilemiyorum ama gns de bu uygulamayi yapabilirsin...

    Configuring a Router IPsec Tunnel Private-to-Private Network with NAT and a Static - Cisco Systems
    thrillercd likes this.
    www.cliguru.com

  3. #3
    thrillercd Guest

    Standart

    Soul, çok teşekkürler.

  4. #4
    MCyagli isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jul 2009
    Bulunduğu yer
    Corum - Turkiye
    Mesajlar
    565

    Standart

    Merhaba,

    Site to Site - yani bir private network u diger private networke

    ipsec ile baglarken ipsec i tetikleyecek olan ACL nizdir...

    Yani asagidaki ACL yi gorunce

    access-list 101 permit ip 192.168.0.0 0.0.0.255 192.168.2.0 0.0.0.255

    ne zamanki sizin Router bu eslesmeyi gorurse

    ipsec baslar

    ipsec tetiklenir
    gecer - bildiginiz ike 1 ve 2 ...


    simdi NAT yaptiginiz zaman ise


    192.168.0.0 networkunu Public ip ye cevirecegi icin
    Sizin Ipsec icin kullandiginiz Source degismis
    olacak..

    onun icin NAT yaparken
    ilk satira acikca bu trafigi NAT yapmamasini soyleyin.

    Ornegin NAT icin ACL 119 kullanacaksiniz

    bunun ilk satirina sunu ekleyin...

    access-list 119 deny ip 192.168.0.0 0.0.0.255 192.168.2.0 0.0.0.255

    bunu karsi taraftada yapin ...
    thrillercd and abdisik85 like this.
    Mehmet Ceyhan YAĞLI
    I learn, I teach

    www.mcyagli.com

  5. #5
    thrillercd Guest

    Standart

    Alıntı MCYagli Nickli Üyeden Alıntı Mesajı göster
    Merhaba,

    Site to Site - yani bir private network u diger private networke

    ipsec ile baglarken ipsec i tetikleyecek olan ACL nizdir...

    Yani asagidaki ACL yi gorunce

    access-list 101 permit ip 192.168.0.0 0.0.0.255 192.168.2.0 0.0.0.255

    ne zamanki sizin Router bu eslesmeyi gorurse

    ipsec baslar

    ipsec tetiklenir
    gecer - bildiginiz ike 1 ve 2 ...


    simdi NAT yaptiginiz zaman ise


    192.168.0.0 networkunu Public ip ye cevirecegi icin
    Sizin Ipsec icin kullandiginiz Source degismis
    olacak..

    onun icin NAT yaparken
    ilk satira acikca bu trafigi NAT yapmamasini soyleyin.

    Ornegin NAT icin ACL 119 kullanacaksiniz

    bunun ilk satirina sunu ekleyin...

    access-list 119 deny ip 192.168.0.0 0.0.0.255 192.168.2.0 0.0.0.255

    bunu karsi taraftada yapin ...
    Harika bir açıklama, teşekkürler.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok