Frame Relay, QoS Konfigurasyonu
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

+ Konuyu Cevapla
Toplam 5 sonuçtan 1 ile 5 arasındakiler gösteriliyor.
Frame Relay, QoS Konfigurasyonu

Firmaların merkez ve şubeleri arasında kullandıkları data hatları üzerinden ihtiyaçlar gereği ses ve hatta bu hatlar üzerinden video konferans yapılıyor.Ses,data ve video görüntülerinin aynı anda kullanıldığı durumlarda hat üzerinde çok

  1. #1
    cerberus isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Nov 2007
    Mesajlar
    2

    Standart Frame Relay, QoS Konfigurasyonu

    Firmaların merkez ve şubeleri arasında kullandıkları data hatları üzerinden ihtiyaçlar gereği ses ve hatta bu hatlar üzerinden video konferans yapılıyor.Ses,data ve video görüntülerinin aynı anda kullanıldığı durumlarda hat üzerinde çok fazla trafik oluşacağı için bu hatlarladan verim almak neredeyse imkansızdır.Bu yazımızda merkez ve şube arasında FrameRelay kullanılan bir topolojide paketlerin istediğimiz şekilde iletilmesini sağlayacağız.(FrameRelay konfigürasyonu konumuz dışındadır)

    Standart olarak iletişimde FIFO (first in first out)modeli kulanılır.Bu durumda hangi paket önce gelirse o paket iletilir ve buda istenmez bizim yapmamız gereken önemli veriler ile önemsiz verilerin ne olduğunu belirtmek ve cihaz üzerinde bu paketleri istediğimiz şekilde yönlendirilmesini sağlamaktır.(Önemli ve önemsiz veri sıralaması firmalarda farklılık gösterebilmektedir.Biz yazımızda önce ses sonra data paketleri olarak sıralayacağız)Bu yazımızda merkez ve şube arasında FrameRelay kullanılan bir topolojide paketlerin istediğimiz şekilde iletilmesini sağlayacağız.(FrameRelay konfigürasyonu konumuz dışındadır)


    Istanbul için Örnek konfigürasyon;



    Kod:
     class-map match-all sesclass
    
    match access-group 150
    
    class-map match-all signal
    
    match access-group 160
    
    !
    
    policy-map ses
    
    class sesclass
    
    priority 16
    
    class signal
    
    bandwidth 4
    
    class class-default
    
    fair-queue
    
    !
    
    interface Ethernet0/0
    
    ip address x.x.x.x
    
    no keepalive
    
    half-duplex
    
    !
    Kod:
     interface Serial 0
    
    no ip address
    
    encapsulation frame-relay
    
    no ip mroute-cache 
    
    no fair-queue
    
    frame-relay traffic-shaping
    
    frame-relay ip rtp header-compression
    
    !
    
    interface Serial 0.1 point-to-point
    
    bandwidth 256
    
    ip address 192.168.10.200 255.255.255.0
    
    frame-relay interface-dlci 100
    
    class CIR256
    
    !
    Kod:
     map-class frame-relay CIR256
    
    no frame-relay adaptive-shaping
    
    frame-relay cir 256000
    
    frame-relay bc 2560
    
    frame-relay be 0
    
    frame-relay mincir 256000
    
    service-policy output ses
    
    frame-relay fragment 320
    
    !
    Kod:
     access-list 150 permit udp any any range 16384 32767
    
    access-list 150 permit udp any any precedence critical
    
    access-list 150 permit udp host 192.168.10.200 host 192.168.20.200
    
    access-list 160 permit tcp any eq 1720 any
    
    access-list 160 permit tcp any any eq 1720






    Bu yapıda paketleri istediğimiz şekilde iletilmek için sırasıyla



    1-Ilk olarak access list oluşturalım



    Ses paketleri için;

    Kod:
     Voiprouter(config)#access-list 150 permit udp any any 16384 32767 (Ses paket aralığına izin veriyoruz.)
    
    Voiprouter(config)#access-list 150 permit udp any any precedence critical (Öncelik veriyoruz)
    
    Voiprouter(config)#access-list 150 permit udp host 192.168.10.200 host 192.168.20.200
    Sinyalleşme için;

    Kod:
     Voiprouter(config)#access-list 160 permit tcp any eq 1720 any (dışarı giden 1720 paketlerini kabul ediyoruz).
    
    Voiprouter(config)#access-list 160 permit tcp any any eq 1720 (içeri gelen 1720 paketlerine izin veriyoruz)
    2-Paketlere uygulayacağımız kriterleri belirleyeceğimiz class-map’leri yaratıyoruz.



    Konfigürasyon modunda ;



    Ses paketleri için;

    Kod:
     Voiprouter(config)#class-map match-all sesclass
    
    Voiprouter(config-cmap)#match access-group   (Match komutu ile neye göre uygulayacağımız belirtiyoruz)
    burada bir çok seçenek mevcut ama biz örneğimizde access list’ler ile çalışacağız.Bu sebeple

    Kod:
     Voiprouter(config-cmap)#match access-group 150 (150 numaralı extended acl oluşturuyoruz)
    Sinyalleşme için ;

    Kod:
     Voiprouter(config)#class-map signal (sinyalleşme için class map yaratıyoruz)
    
    Voiprouter(config-cmap)#match access-group 160 (kullanılacak acl seçiyoruz)
    3-Şimdi Policy map yaratalım ve yarattığımız class map ile ilişkilendirelim.


    Kod:
    Voiprouter(config)#policy-map ses (ses adında bir policy map yaratıyoruz)
    
    Voiprouter(config-pmap)#class sesclass (daha önce sesclass adında yarattığımız class map’i ilişkilendiriyoruz)
    
    Voiprouter(config-pmap-c)#priority 16 (ses paketlerine 16 kbps lik öncelik veriyoruz.)
    
    Voiprouter(config-pmap)#class signal (sinyalleşme için yarattığımız class map’i ilişkilendiriyoruz)
    
    Voiprouter(config-pmap-c)#bandwidth 4 (sinyalleşme için 4kbps BW veriyoruz)
    
    Voiprouter(config-pmap)#class class-default   (Class-map kullanarak belirtmediğimiz kalan trafik.)
    
    Voiprouter(config-pmap)#fair-queue
    4-Trafiği şekillendirmek için map-class yaratıyoruz.



    Kod:
     Voiprouter(config)#map-class frame-relay CIR256 (CIR256 bizim verdiğimiz isim)
    
    Voiprouter(config-map-class)# frame-relay cir 256000 (Hattımız 256 Kbps burada byte cinsinden yazıyoruz)
    
    Voiprouter(config-map-class)# frame-relay bc 2560 
    
    Voiprouter(config-map-class)# frame-relay be 0 (ses trafiği olduğu için “0” değeri veriyoruz) 
    
    Voiprouter(config-map-class)# frame-relay mincir 256000 (Standart olarak değer CIR/2 dir.Bu sebeple biz bütün BW gösteriyoruz)
    
    Voiprouter(config-map-class)# service-policy output ses (Yarattığımız ses adında policy-map’i gösteriyoruz)
    
    Voiprouter(config-map-class)# frame-relay fragment 320 
    
    Voiprouter(config-map-class)# no frame-relay adaptive-shaping becn
    (mincir değeri verilmeyen konfigürasyonlarda “no” komutu olmadan kullanılır.

    Bu durumda mincir olarak CIR/2 değeri atanır.Ama biz mincir değerini elle verdik ve “cir” değeri ile eşitledik.)



    Burada bilmemiz gereken bazı terimler ortaya çıkıyor.Ben bu terimleri kısaca açıklamak istiyorum.



    CIR (Commited Information Rate) : Kabul edilen iletişim kapasitesi

    Hesaplamak için: CIR = Bc X 1000/Tc

    Bc (Committed Burst Size) : FrameRelay networklerinde bir Tc zamanında iletim yapılmasına izin verilen maksimum bit miktarı.

    Hesaplamak için: Bc = CIR X Tc/1000

    Be (Excess Burst Size) : FrameRelay networklerinde bir Tc zamanında Bc üzerinden aşılmasına izin verilen maksimum bit miktarı

    Tc (Commited rateMeasurement interval) : CIR,Bc ve Be nin tanımlandığı Belirli zaman aralığıdır.Tc değeri normal olarak 1 ve 1.2 saniyeleri arasındadır.

    Hesaplamak için: Tc = Bc/CIR X 1000

    Fragment : FrameRelay networklerinde bir Tc zamanında iletim yapılmasına izin verilen maksimum paket büyüklüğü

    Hesaplamak için: fragment-size =TcxCIR/8

    BECN : FrameRelay networklerinde tıkanıklık olduğu zaman bunu farkeden cihaz göndericiye uyarıda bulunmak amaçlı BECN biti gönderir.

    Mincir : Hat üzerinde tıkanıklık oluştuğunda cihazlar birbirleri ile haberleşerek göndericinin gönderim hızını düşürmesini sağlarlar.Bu düşüş en fazla mincir değerine kadardır.Standart olarak CIR/2 dir.



    5-Son olarak kullandığımız interface’ler üzerinde ayarlarımızı tanımlıyoruz.



    a-Ana interface üzeinde;

    Kod:
     Voiprouter(config)#interface serial 0
    
    Voiprouter(config-if)#frame-relay traffic-shaping (eğer traffic-shaping aktif olmaz ise yapılan konfigürasyon çalışmaz)
    
    Voiprouter(config-if)#frame-relay ip rtp header-compression
    b-Subinterface üzerinde;

    Kod:
     Voiprouter(config)#int serial 0.1
    
    Voiprouter(config-subif)#frame-relay interface-dlci 100
    
    Voiprouter(config-fr-dlci)#class CIR256
    (Subinterface’ye yarattığımız map-class’ı tanımlıyoruz.)

  2. #2
    root isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Jun 2007
    Bulunduğu yer
    Ankara
    Mesajlar
    1,409

    Standart

    Aşkın Bey bu güzel döküman için teşekkür ederiz. elinize sağlık.

  3. #3
    x25
    x25 isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Aug 2007
    Mesajlar
    331

    Standart

    Çok kaliteli bir döküman ellerinize sağlık

    Teknoloji teknoloji üzerine biniyor bir zamanların devrimi olan ISDN köz açıp kapayıncaya kadar XDSL family sinin altında kaldı ve yavaş yavaş tarih kitaplarında yer bulmaya başladı hakeza Frame relay geleceğide muhtemelen Metro Ethernet sisteminin altında kalacağa benziyor G.HSDSL çok iyi bir alternatif oldu Metro ise Gücünü ispatlamış durumda belkide bundan 3-5 yıl sonra Frame Relay kardeşi X25 in yanına gidecek gibi görünüyor...Sosyal Güvenlik Kurumu 81 ilde ki mevcut Frame relay hatlarını Metro Ethernet Ve G. hatlarıyla değiştirmeye başladı bütün kurumlar içinde aynı değişiklik söz konusu olacak...

  4. #4
    latecollision Guest

    Standart

    Mükemmel,emeğinize sağlık,teşekkürler

  5. #5
    mest isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Jul 2007
    Mesajlar
    10

    Standart

    teşekkürler ellerine sağlık hocam güzel döküman!!!

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok