OSPF LSA Summarization, OSPF LSA Tipleri
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

+ Konuyu Cevapla
Toplam 1 sonuçtan 1 ile 1 arasındakiler gösteriliyor.
OSPF LSA Summarization, OSPF LSA Tipleri

OSPF LSA Type 3 Summarization OSPF ile summarization sadece area’lar arasında ya da ASBR router’ında yapılabilir. Bu çalışmada ABR olan R2 router’ı üzerinde yapılacak konfigürasyon ile R1 ve R3 routerları

  1. #1
    latecollision Guest

    Arrow OSPF LSA Summarization, OSPF LSA Tipleri

    OSPF LSA Type 3 Summarization




    OSPF ile summarization sadece area’lar arasında ya da ASBR router’ında yapılabilir. Bu çalışmada ABR olan R2 router’ı üzerinde yapılacak konfigürasyon ile R1 ve R3 routerları üzerinde ki Loopback networklerindiğer area’ ya özetlenmesi sağlanacaktır.

    Summarization yapılırken dikkat edilecek nokta kullanacağımız network adresleri ve Subnet Mask’ların özetlemek istediğimiz aralıkları kapsayacak şekilde hesaplanmasıdır.

    Önce Summarization yapılmadan konfigürasyonlarımıza ve R1 – R3 routerlarının Routing Table’larına bakalım. Routerların başlangıçtaki konfigürasyonları şöyle olacaktır;









    R1 Router’ı

    R1#sh running-config
    Building configuration...
    hostname R1
    interface Loopback0
    ip address 193.168.1.1 255.255.255.0
    ip ospf network point-to-point
    !
    interface Loopback1
    ip address 193.168.2.1 255.255.255.0
    ip ospf network point-to-point
    !
    interface Loopback2
    ip address 193.168.3.1 255.255.255.0
    ip ospf network point-to-point
    !
    interface Serial1/0
    ip address 10.1.1.1 255.255.255.252
    !
    router ospf 1
    log-adjacency-changes
    network 10.1.1.0 0.0.0.3 area 0
    network 193.168.1.0 0.0.0.255 area 0
    network 193.168.2.0 0.0.0.255 area 0
    network 193.168.3.0 0.0.0.255 area 0
    !
    end
    R1#

    R2 Router’ı

    R2#sh run
    Building configuration...

    hostname R2
    !
    interface Serial1/0
    ip address 10.1.1.5 255.255.255.252
    serial restart-delay 0
    !
    interface Serial1/1
    ip address 10.1.1.2 255.255.255.252
    serial restart-delay 0
    !
    !
    router ospf 1
    log-adjacency-changes
    network 10.1.1.0 0.0.0.3 area 0
    network 10.1.1.4 0.0.0.3 area 1
    !
    ip classless
    !
    end

    R2#





    R3 Router’ı

    R3#show runnni
    Building configuration...

    hostname R3
    !
    !
    interface Loopback0
    ip address 192.168.1.1 255.255.255.0
    ip ospf network point-to-point
    !
    interface Loopback1
    ip address 192.168.2.1 255.255.255.0
    ip ospf network point-to-point
    !
    interface Loopback2
    ip address 192.168.3.1 255.255.255.0
    ip ospf network point-to-point
    !
    !
    interface Serial1/1
    ip address 10.1.1.6 255.255.255.252
    !
    router ospf 1
    log-adjacency-changes
    network 10.1.1.4 0.0.0.3 area 1
    network 192.168.1.0 0.0.0.255 area 1
    network 192.168.2.0 0.0.0.255 area 1
    network 192.168.3.0 0.0.0.255 area 1
    !
    ip classless
    end

    R3#








    R1 ve R3 Rourterlarının Routing Table’ları da şu şekilde oluşmuştur;




    R1#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/30 is subnetted, 2 subnets
    C 10.1.1.0 is directly connected, Serial1/0
    O IA 10.1.1.4 [110/128] via 10.1.1.2, 00:03:26, Serial1/0
    C 193.168.1.0/24 is directly connected, Loopback0
    O IA 192.168.1.0/24 [110/129] via 10.1.1.2, 00:03:16, Serial1/0
    C 193.168.3.0/24 is directly connected, Loopback2
    O IA 192.168.2.0/24 [110/129] via 10.1.1.2, 00:03:16, Serial1/0
    C 193.168.2.0/24 is directly connected, Loopback1
    O IA 192.168.3.0/24 [110/129] via 10.1.1.2, 00:03:16, Serial1/0
    R1#



    R3#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/30 is subnetted, 2 subnets
    O IA 10.1.1.0 [110/128] via 10.1.1.5, 00:03:45, Serial1/1
    C 10.1.1.4 is directly connected, Serial1/1
    O IA 193.168.1.0/24 [110/129] via 10.1.1.5, 00:03:45, Serial1/1
    C 192.168.1.0/24 is directly connected, Loopback0
    O IA 193.168.3.0/24 [110/129] via 10.1.1.5, 00:03:45, Serial1/1
    C 192.168.2.0/24 is directly connected, Loopback1
    O IA 193.168.2.0/24 [110/129] via 10.1.1.5, 00:03:45, Serial1/1
    C 192.168.3.0/24 is directly connected, Loopback2
    R3#







    R2 Routerında Summization yapıldıktan sonra R2 OSPF konfigürasyonu ve diğer routerların routing table’ları şu şekilde oluşacaktır;

    R2;

    !
    router ospf 1
    log-adjacency-changes
    area 0 range 193.168.0.0 255.255.252.0
    area 1 range 192.168.0.0 255.255.252.0
    network 10.1.1.0 0.0.0.3 area 0
    network 10.1.1.4 0.0.0.3 area 1
    !
















    R1#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/30 is subnetted, 2 subnets
    C 10.1.1.0 is directly connected, Serial1/0
    O IA 10.1.1.4 [110/128] via 10.1.1.2, 00:09:42, Serial1/0
    C 193.168.1.0/24 is directly connected, Loopback0
    C 193.168.3.0/24 is directly connected, Loopback2
    C 193.168.2.0/24 is directly connected, Loopback1
    O IA 192.168.0.0/22 [110/129] via 10.1.1.2, 00:01:08, Serial1/0
    R1#







    R3#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/30 is subnetted, 2 subnets
    O IA 10.1.1.0 [110/128] via 10.1.1.5, 00:09:20, Serial1/1
    C 10.1.1.4 is directly connected, Serial1/1
    C 192.168.1.0/24 is directly connected, Loopback0
    C 192.168.2.0/24 is directly connected, Loopback1
    C 192.168.3.0/24 is directly connected, Loopback2
    O IA 193.168.0.0/22 [110/129] via 10.1.1.5, 00:01:06, Serial1/1
    R3#


    Kaynak:
    Hayrullah Kolukisaoglu
    Eklenmiş Dosya Eklenmiş Dosya

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok