Arkadaşlar merhabalar. Evde kullandığım aşağıdaki gibi bir topolojim var:

TTNET<----->Air Ties ADSL Modem>--RJ45---<0/0 Cisco 1841 Router 0/1>--RJ45---<Cisco 2960 Switch>--RJ45---<Windows XP PC

Bir tane de ADSL modem'e wireless ile bağlı Windows 7 işletim sistemli bilgisayarım var.

IP'ler : ADSL Modem: 192.168.2.1
Win 7 PC: 192.168.2.24
Cisco Fast Ethernet 0/0 : 192.168.2.2
Cisco Fast Ethernet 0/1 : 192.168.1.1
XP PC: 192.168.1.2

Elimde 2 tane config dosyam var. Şu ana kadar öğrendiğim bilgiler ile router'ı aşağıdaki gibi basit şekilde ayarladığımda bilgisayarlar birbirlerini ping'leyebiliyor.

CONFIG 1:

interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 192.168.1.0 255.255.255.0 FastEthernet0/1
ip route 192.168.2.0 255.255.255.0 FastEthernet0/0
!
ip http server

Malumunuz interface'lere ip verdim, statik route yazdım, bilgisayarlar birbirini görüyor.

Bu arada Air Ties modemimin static routing sayfasına da aşağıdaki bilgileri girdim:

Yönlendirme Tablosu
Bağlantı Hedef IP Ağ Geçidi Ağ Maskesi Metrik
VLAN 1 192.168.1.0 192.168.2.1 255.255.255.0 1
VLAN 1 192.168.2.0 192.168.2.1 255.255.255.0 1

Buraya kadar okey. Ancak yukarıdaki config Windows Xp bilgisayarı internete çıkarmıyor malumunuz. Xp makineyi internete çıkarmak için internetten bulduğum aşağıdaki configürasyonu yaptığımda ise Windows 7 PC, XP PC yi pingleyemiyor. Ancak XP, Windows 7'yi pingleyebiliyor:

CONFIG 2:

Router#copy yedek1 startup-config
Destination filename [startup-config]?
[OK]
1154 bytes copied in 3.336 secs (346 bytes/sec)
Router#
Router#
Router#
Router#show startup-config
Using 1154 out of 196600 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
!
controller DSL 0/0/0
line-term cpe
!
!
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Async1
no ip address
encapsulation slip
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 192.168.1.0 255.255.255.0 FastEthernet0/1
ip route 192.168.2.0 255.255.255.0 FastEthernet0/0
!
ip http server
ip nat inside source list 100 interface FastEthernet0/0 overload
!
access-list 100 permit ip any any
!
control-plane
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password telnet
login
line vty 5 807
exec-timeout 0 0
password telnet
login
!
end

Router#

---------------------------

Windows 7 bilgisayar 192.168.2.2 ip adresini (fa0/0) pingleyebiliyor. Ancak 192.168.1.1'i (fa0/1) pingleyemiyor.

CCNA adayı olarak henüz NAT konusunu işlemedim, bu olayın NAT ile alakalı olabileceğini düşünüyorum. Başka birşeyle de alakası varsa çıkamadım işin içinden, kusuruma bakmayın.

Bu arada neden böyle bir şeye ihtiyaç duyuyorum diye soracak olursanız, Microsoft Mouse Without Borders denen bir program var. Benimde iki bilgisayarın monitörleri yan yana, ancak iki tane klavye ve mouse kullanmak yerine tek klavye ve mouse ile işimi görmek istiyorum. (Bu arada size de şiddetle tavsiye ederim.) Ancak bir bilgisayar diğerini görmediği programı kullanamıyorum. Program için ayar yaptığımda da XP makine nete çıkmıyor.

Konu ile ilgili her türlü yardımınızın için şimdiden teşekkürler.