Border Gateway Protocol (BGP)
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

+ Konuyu Cevapla
Toplam 6 sonuçtan 1 ile 6 arasındakiler gösteriliyor.
Border Gateway Protocol (BGP)

Herkese kolay gelsin, iki farkli isp ile olan baglantilarimiz uzerinden bgp konusmaktayiz. hali hazirda (ic networkumuzden disari cikislar icin) local-preference değerini set ederek oncelikli yolu belirliyor ve onun route tablosunda

  1. #1
    Ali Aydemir Guest

    Standart Border Gateway Protocol (BGP)

    Herkese kolay gelsin,

    iki farkli isp ile olan baglantilarimiz uzerinden bgp konusmaktayiz.
    hali hazirda (ic networkumuzden disari cikislar icin) local-preference
    değerini set ederek oncelikli yolu belirliyor ve onun
    route tablosunda default route olmasını sağlıyoruz.

    Diger hattin da bos durmasini istemiyoruz. Hic degilse DMZ in cikisini
    birinden
    HTTP trafiginin cikisini birinden yapsak bir nebze verim sagliyacagimiz
    kanaatindeyiz.

    Bunun icin izlememiz gereken yol nedir?

    PBR ile denemelerim sonuç vermedi.

  2. #2
    serhat aslan Guest

    Standart re: Border Gateway Protocol (BGP)

    Merhaba,
    PBR bu tur durumlarda sonuc verir, ama burda kendi ip-araliginizi kullaniyorsaniz sorun olabilir, o yuzden tafsiyem bos duran ISP'nin(ISP-B diyelim)networkunde gozuksen bir ip araligindan NATlayarak networke PBR ile cikartmaniz gerekir.
    PBR temel olarak ilgili "networkun secimi (orn: http, telnet vb..)" ve yonlendirmesini yaparken( hangi interface), NAT ise anons edilen IP'lerle ilgili bir sIkInti olmamasi icin IP eslestirmelerini yapmak icin kullanilmasi gerekiyor. Temelde 3 tane IP araliginiz var (ISP-A, ISP-B,Sizin networkunuz...) Burda sizin networkunuz gibi degilde ISP-B gibi gostermeniz lazim.

    kolay gelsin,
    Serhat Aslan

    Ali Aydemir <[email protected]> wrote: Herkese kolay gelsin,

    iki farkli isp ile olan baglantilarimiz uzerinden bgp konusmaktayiz.
    hali hazirda (ic networkumuzden disari cikislar icin) local-preference
    değerini set ederek oncelikli yolu belirliyor ve onun
    route tablosunda default route olmasını sağlıyoruz.

    Diger hattin da bos durmasini istemiyoruz. Hic degilse DMZ in cikisini
    birinden
    HTTP trafiginin cikisini birinden yapsak bir nebze verim sagliyacagimiz
    kanaatindeyiz.

    Bunun icin izlememiz gereken yol nedir?


    PBR ile denemelerim sonuç vermedi.

  3. #3
    Ozan Oguz Guest

    Standart re: Border Gateway Protocol (BGP)

    Merhaba Ali Bey,

    Yaptiginiz denemeleri yazar misiniz ona gore eklemeler ya da cikartmalar yapmamiz mumkun olacaktir.

    Iyi calismalar.

    Ozan Oguz
    Network Consultant

    -----Original Message-----
    From: [email][email protected][/email] [mailto:[email protected]] On Behalf Of Ali Aydemir
    Sent: 28 �ubat 2008 Per�embe 11:26
    To: [email][email protected][/email]
    Subject: [cisco-ttl] BGP Route Secimi

    Herkese kolay gelsin,

    iki farkli isp ile olan baglantilarimiz uzerinden bgp konusmaktayiz.
    hali hazirda (ic networkumuzden disari cikislar icin) local-preference
    deðerini set ederek oncelikli yolu belirliyor ve onun
    route tablosunda default route olmasýný saðlýyoruz.

    Diger hattin da bos durmasini istemiyoruz. Hic degilse DMZ in cikisini
    birinden
    HTTP trafiginin cikisini birinden yapsak bir nebze verim sagliyacagimiz
    kanaatindeyiz.

    Bunun icin izlememiz gereken yol nedir?

  4. #4
    Sinan Ilkiz Guest

    Standart re: Border Gateway Protocol (BGP)

    Ali,

    Ic taraftan dis tarafa dogru cikarken size dogru yapilan anonslara farkli
    local-pref vermen yeterli olacaktir. Ama bunun icin sadece default route
    almak yeterli olmaz, yeterli load balance'a ulasacak kadar route almalisin
    (mesela full route).

    Is sadece cikis yonunu halletmekle bitmeyebilir, gelis yonu icin de ayarlama
    yapman gerekir. Bunun icin en az iki tane /24 network kullanman gerekir.
    Internet dunyasi /24'ten daha kucuk networkleri kabul etmez. Eger tek /24'un
    varsa o zaman diger hizmet saglayici ile konusup yeni bir /24 alip bir takim
    hizmetleri (mesela DMZ) yeni network'e gecirmen gerekebilir. Daha sonra bu
    iki /24'u iki farkli baglantidan farkli sekilde anons ederek (mesela farkli
    AS_PATH ile) gelis yonu icin de load-balance yapabilirsin.

    Bu tip sorular grup icerisinde daha once de gecmisti, arama yaparsan daha
    detayli bilgi bulabilirsin sanirim. Ayrica hizmet saglayicilarindan da
    yardim istersen yardimci olacaklardir.

    Selamlar.

    2008/2/28, Ali Aydemir <[email protected]>:[color=blue]
    >
    > Herkese kolay gelsin,
    >
    > iki farkli isp ile olan baglantilarimiz uzerinden bgp konusmaktayiz.
    > hali hazirda (ic networkumuzden disari cikislar icin) local-preference
    > değerini set ederek oncelikli yolu belirliyor ve onun
    > route tablosunda default route olmasını sağlıyoruz.
    >
    > Diger hattin da bos durmasini istemiyoruz. Hic degilse DMZ in cikisini
    > birinden
    > HTTP trafiginin cikisini birinden yapsak bir nebze verim sagliyacagimiz
    > kanaatindeyiz.

  5. #5

    Standart İş İlanı

    Merhaba,

    HSBC Bank BT Telekomunikasyon Departmani' nda asagidaki pozisyonlar icin
    takim arkadaslari ariyoruz. Isyeri Zincirlikuyu/ Istanbul' dadır.
    Ilgilenenlerin, basvurduklari pozisyonu (Ilan-1/ Ilan-2) da belirten bir
    onyazi ile birlikte ozgecmislerini en gec 30 Mart 2008 aksamina kadar
    asagidaki mail adreslerine gondermelerini rica ederiz.

    Ilan-1 :

    HSBC Bank BT-Telekomunikasyon Departmani' nda, bankanin network performans
    hedeflerini saglamak uzere network projelerinde ve gunluk operasyonunda
    gorev alacak asagidaki niteliklerde network muhendisi takim arkadaslari
    ariyoruz.

    - Universitelerin 4 yillik muhendislik bolumlerinden mezun (tercihen
    Bilgisayar Muh., Telekomunikasyon Muh., Elektronik Muh.)
    - En az 2-3 yil network alaninda tecrubeli
    - Iyi derecede Ingilizce bilen,
    - Network (LAN/WAN) tasarim ve isletiminde asagidaki konularda bilgili ve
    tecrubeli;
    * WAN routing protocols (EIGRP, IGRP, RIP , OSPF, BGP�)
    * LAN/WAN technologies (VLAN, HSRP, STP, QoS , MPLS , VoIP, VPN, IPSec�)
    * Network management tools
    * TCP/IP networking protokol
    * Cisco network cihazlarinda konfigurasyon deneyimli
    - Tercihen Cisco CCNP/ CCNA sertifikasina sahip
    - Bilgi teknolojilerinde kesintisiz network hizmet sorumlulugunu
    ustlenebilen
    - Erkek adaylar icin askerligini tamamlamis
    - Takim calismasina yatkin ve iletisim becerileri kuvvetli
    - Teknolojiyi ve yenilikleri takip eden, ogrenmeye ve gelismeye acik

    mail adresleri:
    [email][email protected][/email]
    [email][email protected][/email]
    [email][email protected][/email]


    Ilan-2 :

    HSBC Bank BT-Telekomunikasyon Departmani' nda, bankanin santral ve
    transmisyon sistemlerinde performans hedeflerini saglamak uzere projelerde
    ve gunluk operasyonda gorev alacak asagidaki niteliklerde takim arkadaslari
    ariyoruz.

    - Universitelerin 2 veya 4 yillik bolumlerinden mezun (tercihen Bilgisayar,
    Telekomunikasyon, Elektronik)
    - En az 2-3 yil santral ve transmisyon sistemlerinde tecrubeli
    - Telekomunikasyon alaninda tasarim ve isletimde asagidaki konularda
    bilgili ve tecrubeli;
    * Santral ve ses kayit sistemleri (Nortel, Avaya, �)
    * Transmisyon sistemleri (SDH, TDM Nodes, Modem, �)
    * Analog/Digital Telekomunikasyon altyapisi (data ve ses hatlari, ..)
    * IP teknoloji/ IP Telefon uygulamalari
    - Bilgi teknolojilerinde kesintisiz ses network hizmet sorumlulugunu
    ustlenebilen
    - Erkek adaylar icin askerligini tamamlamis
    - Takim calismasina yatkin ve iletisim becerileri kuvvetli
    - Iyi derecede Ingilizce bilen,
    - Teknolojiyi ve yenilikleri takip eden, ogrenmeye ve gelismeye acik

  6. #6
    yaman isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Dec 2007
    Bulunduğu yer
    Londra
    Mesajlar
    245

    Standart

    Merhabalar,

    Aklimdan yazdigim birsey!!! denemedim......., ama denemenizi tavsiye ederim, bu arada bir yanlislik gorurseniz duzeltin yari uykulydum ,yane bana uyarsaniz isiniz Allaha kalmis demektir:)

    Simdi siz anladigim kadari ile 2 ISP'ye ayri baglantilarla baglisiniz ve netwokunuzun LOAD BALANCE yapmasini istoyorsunuz ama secici olup bazi IP address segmentlerinin 1 hattan girip cikamsini istiyorsunuz digerinin baska bir hattan yane HTTP bir yerden DMZ diger yerden

    1) Tabiki 1 hat duserse digerinin butun trafigi devir almasi gerekir
    2) Internet routable "ISP independant" yane PRIVATE olmayan bir Blok IP addresiniz olmali mesela class C 197.100.100.0/24, eger yoksa NAT'ing yapnazi gerekecektir 2 ayri ISP icin.
    3) Bence contiguous IP addressing'e yapilandirmasina ihtiyaciniz var yane bir /24'u mesela ikiye bolmeniz lazimki "/25" ,iki ayri subnetten, iki ayri nOktaya, iki ayri sekilde cikis ve giris yapilabilesiniz.

    Simdi ilk once iceriden disari cikisi konusalim yane sizin networkunuzdan trafigi nasil ikiye ayirabiliriz????

    Oncelikle kullanidigiz IGP nedir??? Mesela diyelimki OSPF!!!!

    Her bir subneti cikisini mesela HSRP ile grouplar halinde ayirabilir her grubu bask bir routera gonderebilirsiniz, bu durumda LOCAL_PREFRENCE kulanmaniza gerek kalmayabilir, mesela *****REFERANS OLARAK NETWORK SEMASINA BAKIN****

    CORE_1 HSRP Actvive state for group 1
    CORE_1 HSRP Standby state for group 2

    Ayni sekilde

    CORE_2 HSRP Actvive state for group 2
    CORE_2 HSRP Standby state for group 1

    Bu sekilde trafigi iki degis noktadan iki ayri routerdan cikarabilisrsiniz, sonuc itibari ile her router kendine en yakin cikisi tercih edecektir, eger 2 tane BGP cikis routeriniz varsa onceden ayrmis oldugunuz trafigin cikis noktasi, ya 1 numarali cikista kedini bulr yada 2 numarali cikista kendini bulur, e hall boyle oluncada BGP gidilmek istene adrese bakar ve en kolydan nasil disari cikarim diye dusunur buda default olarak EBGP hatti olur yane DIS hat.


    Simdi cikisi ayri ayri ciktik, peke gelisi nasil ektileyebiliriz???? bunun icin her IKI ISP'yle konusup gorusmeniz gerekecek!!! Neden??

    Cunki sizin kendinize ait IP adresi INTERNE'e dagtirken nasil dagitmasi gerektigini soylemeniz lazim yane 1. ISP xxxx diye dagitmali 2. ISP xxx diye dagitmali.


    ######################
    # EDGE_R1 #
    ######################

    interface looopback0
    ip address 192.168.1.1 255.255.255.0
    !
    router bgp 100
    network 197.100.100.0
    network 197.100.100.0 mask 255.255.255.128
    neighhbor 192.168.1.102 remote-as 200
    neighhbor 192.168.1.102 update-source loopback0
    neighhbor 192.168.1.102 ebgp-multi-hop 2
    neighhbor 192.168.1.102 remote-as 100
    no auto-summary
    !
    !
    router ospf 100
    network 10.10.10.1 0.0.0.0 area 0 "IGP routing icin ornek IP addressler"
    default-information orginate
    !
    !

    ########################################################
    ########################################################

    ######################
    # EDGE_R2 #
    ######################

    interface looopback0
    ip address 192.168.1.2 255.255.255.0
    !
    router bgp 100
    network 197.100.100.0
    network 197.100.100.128 mask 255.255.255.128
    neighhbor 192.168.1.203 remote-as 300
    neighhbor 192.168.1.203 update-source loopback0
    neighhbor 192.168.1.203 ebgp-multi-hop 2
    neighhbor 192.168.1.2 remote-as 100
    no auto-summary
    !
    !
    router ospf 100
    network 10.10.10.5 0.0.0.0 area 0
    default-information orginate
    !
    !

    ########################################################
    ########################################################

    ######################
    # ISP-A #
    ######################

    ip route 197.100.100.0 255.255.255.0 192.168.1.1 "bu yedek durumlar icin hani olurda ISP-B duser /24'luk yol butun networku temsil eder"
    ip route 197.100.100.0 255.255.255.128 192.168.1.1 "bu (longest match) yane ilk 1-126 adresi internete verir ve derki eger bu /25 icinde bir yere gitmek istiyorsaniz bu yolu kulanin"

    ######################
    # ISP-B #
    ######################

    ip route 197.100.100.0 255.255.255.0 192.168.1.2 "ayni sekilde bu yedek durumlar icin hani olurda ISP-a duser /24'luk yol butun networku temsil eder"
    ip route 197.100.100.128 255.255.255.128 192.168.1.2 "bu (longest match) yane ikinci yariyi 129-254 adresi internete verir ve derki eger bu/25 icinde bir yere gitmek istiyorsaniz bu yolu kulanin"

    Yane bu islemin calismasi icin sirketinize ait,internet routable IP addresine ihtiyaciniz var (ISP independent) ve her iki ISP'yle konusup onlarin sizin networkunuzu istediginiz gibi ADVERTISE etmelerini saglamaniz gerekir. Eger durum boyle degilde ISP'ye bagli bir adres blogunuz varsa bunun icin NAT yapniz gerekecek bunuda sonra anlatirim isterseniz.
    Eklenmiş Dosya Eklenmiş Dosya
    • Dosya tipi: doc BGP.doc‎ (50.5 KB (Kilobyte), 1143 kez indirilmiştir)
    Konu yaman tarafından (22.03.2008 Saat 13:29 ) değiştirilmiştir.
    Yaman

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok