merhaba
asagida dialer interface down olmadan routingi nasil
ayarlayabilecegine ait biseyler anlatmaya calistim
umarim isine yarar...
floating static route'lari eger ios'un 12.3 ise
track feature ile birlikte kullanabilirsin
boylece cok etkili bir link kontrolu yapmis olursun,
ornek vermek gerekirse :
cisco yeni ios'larinda (12.2 de destekliyor ama tum
ozellikleri ile kullanamiyosun) track feature'i ile
belli bir ip'ye ping baslatiyor ve ping'e cevap
alamadigi zaman senin konfigurasyonda tanimladigin
(burada routing tablosundan route silerek diger
route'un aktif olmasini saglamak olacak) davranista
bulunuyor. Bunun icin
1)
bir probe tanimlamak gerekir. Bu probe senin
tanimladigin
ip adresine (adsl linkinin adresi olabilir mesela)
ping
baslatir ve default intervalda birakirsan 1 snde bir
oraya
(bu sure 3 snyeye de cekilebilir) icmp paketi
gonderir.
Router(config)#rtr 1
Router(config-rtr)type echo protocol ipIcmpEcho
xxx.xxx.xxx.xxx
Router(config)rtr schedule 1 start-time now life
forever
-> tanimladigin probe sonsuza kadar calissin

2)
daha sonra tanimladigin probe ile gonderecegin icmp
paketinin sadece senin istedigin interfaceden
cikmasini
saglamalisin ki, yedek hat devreye girdigi zaman
probe pingleyemesin (bu, hat geri geldigi zaman
routing
tablonun eski haline gelmesi icin onemli) Bunu da
routemap
kullanarak halledebilirsin:
Router(config)#access-list 111 permit icmp any host
xxx.xxx.xxx.xxx echo
-> policyde kullanilacak trafik tanimi
Router(config)#ip local policy route-map
LOCAL_TRACK_POLICY
-> router paketleri icin tanimlanan policy, diger
paketleri etkilemez
router(config)#route-map LOCAL_TRACK_POLICY permit 10
router(config-route-map)#match ip address 111
->acl 111'de tanimli trafik (sadece ping paketleri)
router(config-route-map)#set interface Dialer1
-> bu paketler Dialer interfaceinden ciksin
router(config-route-map)#set interface null0
-> eger paketler Dialer1'den forward edilemezse
discard edilsin

3)
Track objesi yaratilir ve bu obje olusturulan probe
ile iliskilendirilir:
router(config)#track 123 rtr 1 reachability

4)
Daha sonra bu track objesi kullanilarak static
routelar yazilir:
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
ip route 0.0.0.0 0.0.0.0 serial 0 254






--- Ilyas Celik <[email protected]> wrote:[color=blue]
> Merhaba ;
>
> cisco 1721 serisi bir routerda primary hat adsl ve
> LL'ı backup olarak kullanmak istiyorum.Dialer
> interface ADSL hat down olsa bile down[/color]
olmadıgı icin[color=blue]
> (spoofing modeda oldugu icin) floating-static route
> devreye girmiyor.
> ATM interface altında backup interface serial 0
> yazsam bile route dialer 0 interface oldugu icin
> olmuyor.
> Default route'u atm interface'e versem ADSL hattan
> trafik gidip gelisi olmuyor.
>
> interface ATM0.1 point-to-point
> pvc 8/35
> pppoe-client dial-pool-number 1
> !
> !
> interface FastEthernet0
> ip address 10.0.0.2 255.255.255.0
> ip nat inside
> ip tcp adjust-mss 1452
> speed auto
> !
> interface serial 0
> ip add a.b.c.d mak
>
> interface Dialer1
> ip address negotiated
> ip nat outside
> encapsulation ppp
> ip tcp adjust-mss 1452
> dialer pool 1
> no cdp enable
> ppp pap sent-username xxx password 0 xxx
>
> ip route 0.0.0.0 0.0.0.0 dialer 0
> ip route 0.0.0.0 0.0.0.0 serial 0 10
>
> Bu durumda ne yapmam gerekir.Yardımcı olan
> arkadaslara simdiden tesekkürler.