BGP yedekliliği (Dual Router - Dual ISP)
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 6 sonuçtan 1 ile 6 arasındakiler gösteriliyor.
BGP yedekliliği (Dual Router - Dual ISP)

kolay gelsin herkese, ilk top. basit şuanki yapı. default route alınıyor. SOL e prepend attık bazı routelar SOL den dönüyor. gidiş tek dönüş çift. amacım ikinci yapı kurup full route

  1. #1
    5LoTh isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Dec 2011
    Mesajlar
    392

    Post BGP yedekliliği (Dual Router - Dual ISP)

    kolay gelsin herkese,

    ilk top. basit şuanki yapı. default route alınıyor. SOL e prepend attık bazı routelar SOL den dönüyor. gidiş tek dönüş çift.

    amacım ikinci yapı kurup full route almak. böylece SOL den yakın olan routelardan oradan gidip gelsin TT den olan routelar oradan gidip gelsin asimetrik e düşmesin. mümkün mü acaba ?

    int-cikis.JPG

  2. #2
    md_mehmet52 isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Oct 2010
    Bulunduğu yer
    Ünye
    Mesajlar
    196

    Standart

    hocam merhaba aşağıdaki örnek konf. çalışan bir noktadan aldım, aktif bir nokta şuan bir sorun olursa yine yardımcı olmaya çalışırım



    ----------------------------------------------------------R-1 TT
    interface Loopback0
    ip address 91.X.70.254 255.255.255.255
    service-policy input icmp
    !
    !
    interface GigabitEthernet0/0/0
    ip address 91.X.70.2 255.255.255.128
    standby 99 ip 91.X.70.1
    standby 99 priority 90
    standby 99 preempt delay minimum 90

    !
    interface GigabitEthernet0/0/1
    description TTNET_MAIN_INTERFACE
    ip address 212.156.135.186 255.255.255.252
    !

    router bgp R-AS-12345
    bgp router-id 91.X.70.254
    bgp log-neighbor-changes
    network 91.X.70.0 mask 255.255.255.0
    aggregate-address 91.X.70.0 255.255.255.0 summary-only
    neighbor 91.X.70.3 remote-as R-AS-12345
    neighbor 91.X.70.3 fall-over bfd
    neighbor 91.X.70.3 next-hop-self
    neighbor 212.156.135.185 remote-as R-AS-4312
    neighbor 212.156.135.185 description *** TTNET ***
    neighbor 212.156.135.185 password 070000001949
    neighbor 212.156.135.185 soft-reconfiguration inbound
    neighbor 212.156.135.185 prefix-list anet-net-out out
    neighbor 212.156.135.185 route-map ttnet-in in
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    ip route 91.X.70.0 255.255.255.0 Null0


    !
    ip prefix-list anet-net-out seq 5 permit 91.X.70.0/24

    !
    route-map BACKUP-in permit 10
    set local-preference 50
    !
    route-map ttnet-in permit 10
    set local-preference 120
    !
    -------------------------------R2 Backup


    !
    interface Null0
    no ip unreachables
    !
    interface Loopback0
    ip address 91.X.70.253 255.255.255.255
    !



    interface GigabitEthernet0/0/0
    ip address 91.X.70.3 255.255.255.128
    standby 99 ip 91.X.70.1
    standby 99 priority 20
    standby 99 preempt delay minimum 90

    !
    interface GigabitEthernet0/0/1
    description BACKUP_MAIN_INTERFACE
    ip address 37.75.8.218 255.255.255.252
    !

    router bgp R-AS-12345
    bgp router-id 91.X.70.253
    bgp log-neighbor-changes
    network 91.X.70.0 mask 255.255.255.0
    aggregate-address 91.X.70.0 255.255.255.0 summary-only
    neighbor 37.75.8.217 remote-as R-AS-4321
    neighbor 37.75.8.217 description ****BACKUP ***
    neighbor 37.75.8.217 interface GigabitEthernet0/0/1
    neighbor 37.75.8.217 soft-reconfiguration inbound
    neighbor 37.75.8.217 prefix-list TT-out out
    neighbor 37.75.8.217 route-map BACKUP-export out
    neighbor 91.X.70.2 remote-as R-AS-12345
    neighbor 91.X.70.2 fall-over bfd
    neighbor 91.X.70.2 next-hop-self
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    ip route 91.X.70.0 255.255.255.0 Null0


    !
    !
    ip prefix-list TT-out seq 5 permit 91.X.70.0/24


    route-map BACKUP-export permit 10
    match ip address prefix-list TT-out
    set as-path prepend R-AS-12345 R-AS-12345 R-AS-12345 R-AS-12345

  3. #3
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,995

    Standart

    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  4. #4
    5LoTh isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Dec 2011
    Mesajlar
    392

    Standart

    eyvallah mehmet hocam da direk config istemiyorum biraz mantığını da anlamay ihtiyacım var.

    nexus hocam,

    bu kısım sadece AS i 300 olanlara local pref 200 ver mi demek oluyor.

    ip as-path access-list 1 permit ^300$

    route-map AS-300-INCOMING permit 10
    match as-path 1
    set local-preference 200


    400 den gelenlere de local pref 150 veriyoruz. o zaman 400 den gelenler öncelikli olmuyor mu. 300 de ki routelara da 400 üzerinden gitmeye çalışmazmı. geri dönş de 400 den olmaya çalışabilir mi? aynı prepend atılmış ikisinede.

    ip as-path access-list 1 permit ^400$

    route-map AS-400-INCOMING permit 10
    match as-path 1
    set local-preference 150

  5. #5
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,995

    Standart

    Alıntı 5LoTh Nickli Üyeden Alıntı Mesajı göster
    eyvallah mehmet hocam da direk config istemiyorum biraz mantığını da anlamay ihtiyacım var.

    nexus hocam,

    bu kısım sadece AS i 300 olanlara local pref 200 ver mi demek oluyor.

    ip as-path access-list 1 permit ^300$

    route-map AS-300-INCOMING permit 10
    match as-path 1
    set local-preference 200


    400 den gelenlere de local pref 150 veriyoruz. o zaman 400 den gelenler öncelikli olmuyor mu. 300 de ki routelara da 400 üzerinden gitmeye çalışmazmı. geri dönş de 400 den olmaya çalışabilir mi? aynı prepend atılmış ikisinede.

    ip as-path access-list 1 permit ^400$

    route-map AS-400-INCOMING permit 10
    match as-path 1
    set local-preference 150

    " permit ^300$ " AS 300 'ü ifade ediyor. (300 ile başlayıp 300 ile bitiyor şartı) Bkz: Cisco IOS Terminal Services Configuration Guide, Release 12.2 - Regular Expressions [Cisco IOS Software Releases 12.2 Mainline] - Cisco

    Öncelikle BGP'de bir prefix'in local pref'i daha yüksek ise o prefix daha tercih edilirdir. Bu örnek'de 200 local pref olan prefixler yönlendirme tablosuna çıkarlar.


    Diğer konu ise burada bakış açısı önemli. Sen ISP'den hizmet alıyorsun. Onlar sana prefix bilgilerini sağlıyorlar. ISP'lerden birisini tercih edip öncelikli olarak kullanıyorsun. Ancak sen ISP'ye BGP yardımı ile prefix anons ediyorsan tercih ettiğin ISP'ye doğrudan anons edip yedek ISP'ne AS numaranı prepend ederek anons edersin. Bu sayede de asimetri gibi bir sorun yaşanmaz.

    Sen prefixini anons ederken bu şekilde anons ettin. Yedek ISP2, main ISP1 olacak.
    Kod:
                                            ------> AS-PATH 100        1.1.1.1/32    -----------------ISP 1  
    Kurum AS-100 (1.1.1.1/32)
                                            ------> AS-PATH 100-100    1.1.1.1/32    -----------------ISP 2
    Sen ISP'den full route, def route veya spesifik route öğrenirken'de ISP1'i öncelikli yapman gerekiyor. Bunun içinde çeşitli attribute'ları kullanabilirsin. Aşağıdaki örnekte. Localpref değeri 200 olan prefixler için tercih edilen ISP 1 numaralı ISP olacaktır.

    Kod:
                                            <------   Localpref 200    0.0.0.0/0    -----------------ISP 1  
    Kurum AS-100 (1.1.1.1/32)
                                            <------   Localpref 150    0.0.0.0/0    -----------------ISP 2
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  6. #6
    5LoTh isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Dec 2011
    Mesajlar
    392

    Standart

    nexus hocam ben bu yapıyı yaparsam. SOL de öncelikli olan routelar SOL routerdan, TT den öncelikli routelar TT routerından mı gidecek. normal yedeklilik istemiyorum açıkçası ikisi de aktif olarak çalışsın.

    bugün iki adet router ı HSRP yapıp IP lerini vereceğim BGP konfiği yapacağım.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok