Tek ISP ile VRRP üstünden BGP konuşmak
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 9 sonuçtan 1 ile 9 arasındakiler gösteriliyor.
Like Tree1Likes
  • 1 Post By 5LoTh
Tek ISP ile VRRP üstünden BGP konuşmak

Arkadaşlar selam, yapmak istediğimiz şey hat yedekliliği değil cihaz yedekliliği. Zaten birbirinin kopyası 2 routerımız var ama kendini devreye sokmadan fiziksel olarak bizden bilmem kaç bin km ötesi durması bir

  1. #1
    Viking isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2010
    Mesajlar
    32

    Standart Tek ISP ile VRRP üstünden BGP konuşmak

    Arkadaşlar selam, yapmak istediğimiz şey hat yedekliliği değil cihaz yedekliliği. Zaten birbirinin kopyası 2 routerımız var ama kendini devreye sokmadan fiziksel olarak bizden bilmem kaç bin km ötesi durması bir şey ifade etmiyor Size sözel olarak şöyle açıklayayım;

    Tek bir BGP komşuluğumuz var. Amacımız 1 routerı master diğerini de backup yapıp, router gitmesi durumunda yedeklilik sağlamak. VRRP virtual adresine BGP neighbor IP adresini yazarak halledebileceğimizi düşünüyorum. Elimizde /30 var komşuluk için verilen, ancak /29 rica edebiliriz sanıyorum. Olabilitesi ile ilgili fikrinizi, gene mantık hataları varsa önerilerinizi almak istiyorum.

    Capture.JPG

  2. #2
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,994

    Standart

    VRRP virtual ip ile bgp komşuluğu kurulsa da yedeklilik umduğunuz gibi olmayabilir.

    Yedek router'iniz için fazladan bir ip adresi daha talep ederek her iki router'inizi ISP'nize BGP komşuşu yapabilirsiniz. /29 sorun olmayacak diyorsanız 2 routerinizi de komşu yapın.
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  3. #3
    5LoTh isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Dec 2011
    Mesajlar
    392

    Standart

    hocam VRRP değil de iki tane BGP komşuluğu kurup birinin local prefini ISP de yüksek verdirirsin.
    anonsları oradan yaparsın biri gittiğinde anonslar diğerine çevrilir.
    bu şekilde de olur.

    ama dediğin gibi VRRP de yapıp priority vererek master -backup router yaparsın. yine BGP çalışır /29 gerekir.
    ISP nin virtual IP ile BGP yapacak, sen gateway le.

    virtual IP 192.168.1.5 desek.

    winermute likes this.

  4. #4
    Viking isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2010
    Mesajlar
    32

    Standart

    teşekkürler arkadaşlar cevaplar için. ikinci bir komşuluktan kaçınıyorum çünkü arada l2tp tünelleri var, dolayısıyla diğer routera geçmek durumunda kalırsak ISP sanıyorum tüneller için diğer bacağa route yazmak durumunda (çok da emin değilim), anlık olarak bunu talep etmek zor.

  5. #5
    5LoTh isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Dec 2011
    Mesajlar
    392

    Standart

    yani şu an BGP yok yapınızda, şu an nasıl bir yapınız var.

    h.a.s.

  6. #6
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,994

    Standart

    VIP ile yedeklilik sağlanır ama bir VRRP failover durumundan sonra BGP'nin re-converce olması çok uzun sürecektir. Beklentinizi karşılayacak bir yedeklilik sağlayacağını düşünmüyorum.

    Ayrıca 2 Cihazınızı VRRP ile yedeklıyorsunuz ama önlerinde tek switch var ve tek ISP'niz var . Bence gerek yok bu uygulama.
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  7. #7
    Viking isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2010
    Mesajlar
    32

    Standart

    biraz para işi hocam. switch cisco dayanıklılığı nispeten iyi ama routerlar çatırdıyor gibi. yoksa gönül ister hem linki hem routerı hem switchleri yedekleyelim

    şu andaki yapıda bgp var. senin üzerinde gösterdiğinin aynısı var hocam. interface kapasite durumuna göre bazılarında iki komşuluk bazılarında tek komşuluk kurduk.

  8. #8
    winermute isimli Üye şimdilik offline konumundadır Senior Member
    Üyelik tarihi
    Oct 2011
    Mesajlar
    124

    Standart

    Ben bu istediğin konfigurasyonu çalıştırdım ancak İSP tarafıdna üstatların dediği gibi tek bi fiberden kullanıldığından bgp kuramadılar, kurduklarında ise düzgün çalışması . Enson R/L ve Fiber olarak 2 ayrı hattı 2 ayrı L2 swtichde sonlandırıp yedekliği sağladık . Örnek konfigde aşağıdan bakabilirsin.


    !
    track 1 interface GigabitEthernet0/0.500 line-protocol
    !
    track 2 interface GigabitEthernet0/0.500 ip routing
    !
    !
    !
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.500
    description Metro_Ethernet
    encapsulation dot1Q 500
    ip address 172.16.45.2 255.255.255.252
    !
    interface GigabitEthernet0/1
    ip address 10.1.7.7 255.255.255.240 görüldüğü gibi /29 standby ip si .9 diğer router ip si .8
    standby 0 ip 10.1.7.9
    standby 0 priority 155
    standby 0 preempt
    standby 0 track 1 decrement 10
    standby 0 track 2 decrement 10
    duplex auto
    speed auto
    !
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 172.16.45.1

    Edit: Bgp yi kendi yedekliliklerinde kullandılar bize yansımadı

  9. #9
    Viking isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2010
    Mesajlar
    32

    Standart

    anladım hocam. çok teşekkürler hepinize.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok