BGP AS Number
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 8 sonuçtan 1 ile 8 arasındakiler gösteriliyor.
BGP AS Number

arkadaşlar merhaba; Çalıştığım şirketin iki farklı ISP den metro ethernet bağlantısı var. BGP yapmayı düşünüyorum ama AS numarasını bir türlü bulamadım. RIPE Network Coordination Centre ten baktım ama pek bişey

  1. #1
    yavuzaras isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Jan 2014
    Mesajlar
    8

    Standart BGP AS Number

    arkadaşlar merhaba;

    Çalıştığım şirketin iki farklı ISP den metro ethernet bağlantısı var. BGP yapmayı düşünüyorum ama AS numarasını bir türlü bulamadım.RIPE Network Coordination Centre ten baktım ama pek bişey anlamadım. AS numaralarını nasıl öğrenebilirim. ISP ye sordum teknik olarak bir şey yapamayız gibi bir cevap verdiler.
    yardımcı olursanız sevinirim.

  2. #2
    5LoTh isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Dec 2011
    Mesajlar
    392

    Standart

    ISP ye sordun teknik olarak bir şey yapamayız mı dediler holaaaa.
    yok öyle bir şey sen kurumsal bir internet alıyorsan ve BGP konuşturmak istiyorsan konuşturursun. ISP sana private bir AS verir ya da kendi AS ini kullanırsın.

    SOL : 34984
    TT : 9121
    VF : 15924

    Hurricane Electric BGP Toolkit

    arama butonuna şirket ismi yaz yeter IP leri ve AS numarası çıkar.

    h.a.s.

  3. #3
    tcos isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Mar 2012
    Bulunduğu yer
    Heilbronn
    Mesajlar
    92

    Standart

    Kendi public AS ini almak belki biraz zahmetli olabilir:
    Autonomous System Numbers — RIPE Network Coordination Centre
    AS Number Request Form — RIPE Network Coordination Centre

    ISP bu konuda yardimci olamiyorsa zaten dahada zahmetli olacaktir diye düsünüyorum...

    Zahmetli olmayacak sey 5LoTh nin da dedigi gibi, ISP den private AS alip (ki bunuda bilmeleri lazim, okadarda degildir herhalde!?) en azindan bir ISPye bgp olusturursunuz. Ikinci ISPde size private AS verir, bununlada ona baglanirsiniz.

    ISR (G2) larda yalniz bir tane bgp process olusturabiliyorsunuz, bu durumda "bgp local-as" komutunu kullanirsiniz. ASR lerde durum farkli diye biliyorum...

    Bir örnek:
    Configuring the BGP Local-AS Feature

    Iki farkli ISP olunca, gelen trafigi yönlendirmek icin de mesela as-path prepending yapabilirsiniz, daha dogrusu yaptirabilirsiniz (ikici secenek olmasi gereken) ISPye demek daha dogru olur, cünki sizin private as ler internette görünmez...

    ISPnin AS'ini sadece Remote-AS i belirlemek icin gerekli. Bunun icinde ISP nin ilk önce BGP yapilandirmis olmasi lazim sizin icin...

    umarim yardimci olmustur.

  4. #4
    yavuzaras isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Jan 2014
    Mesajlar
    8

    Standart

    cevaplar için teşekkür ederim. Cevapların fazlası ile faydası oldu.

    5LoTh :
    aynen öyle dediler. inanması zor olsada

    tcos:
    verdiğiniz örnekler ve gösterdiğiniz yolların faydası oldu teşekkür ederim. Private AS ler iş görebilir. Ancak benim gerçek AS ye üzerinden işlem yapmam gerekiyor. (Neden diye sorduğunuzu duyar gibiyim ) = kurumsal politikalardan dolayı.


    Az önce ISP lerden biri ile bir toplantı yaptık. Onlarda tam olarak bilmediklerini ve bu konuyu araştıracaklarını söylediler. Onlardan gelecek yanıtı burada paylaşıp nasıl bir yol izlenmesi gerektiğini burada yazacağım. Belki birine faydası olur.

  5. #5
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,994

    Standart

    Failover istiyosun , load balance istiyorsun . Eğer iki link'de eşit bw'e sahipse NAT + Load Balance işini rahatlıkla görür. BGP ile bu işi yapabilirsin problem yok.

    Her bir ISP'de next-hop ip'ye default route yazıp trackle . Sonrası için route map + NAT .



    NExt-hop ip adresleri ISP1 için 1.1.1.2 Out İnt Fa 0/0 , ISP2 için 1.1.1.6 Out Int Fa 0/1 olsun . Loop back interface'lerin yerel ağdaki hostlar olduğunu varsayarsak ; R1'deki basit config :
    Kod:
    !
    !
    hostname R1
    !
    no ip icmp rate-limit unreachable
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    
    ip sla monitor 1
     type echo protocol ipIcmpEcho 4.4.4.4 source-ipaddr 192.168.1.1
    ip sla monitor schedule 1 life forever start-time now
    ip sla monitor 2
     type echo protocol ipIcmpEcho 4.4.4.4 source-ipaddr 192.168.1.1
    ip sla monitor schedule 2 life forever start-time now
    !
    !
    ip tcp synwait-time 5
    !
    track 1 rtr 1 reachability
    !
    track 2 rtr 2 reachability
    ! 
    !
    interface Loopback0
     ip address 192.168.1.1 255.255.255.255
     ip nat inside
     ip virtual-reassembly
    !
    interface Loopback1
     ip address 192.168.1.2 255.255.255.255
     ip nat inside
     ip virtual-reassembly
    !
    !
    interface FastEthernet0/0
     ip address 1.1.1.1 255.255.255.252
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     ip address 1.1.1.5 255.255.255.252
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 1.1.1.2 track 1
    ip route 0.0.0.0 0.0.0.0 1.1.1.6 track 2
    ip route 0.0.0.0 0.0.0.0 1.1.1.2
    ip route 0.0.0.0 0.0.0.0 1.1.1.6
    !
    !
    ip nat inside source route-map NAT1 interface FastEthernet0/0 overload
    ip nat inside source route-map NAT2 interface FastEthernet0/1 overload
    !
    access-list 10 permit 192.168.0.0 0.0.255.255
    !
    route-map NAT2 permit 10
     match ip address 10
     match interface FastEthernet0/1
    !
    route-map NAT1 permit 10
     match ip address 10
     match interface FastEthernet0/0
    !
    !
    !
    end
    Kod:
    R1#show  ip route
    
    Gateway of last resort is 1.1.1.6 to network 0.0.0.0
    
         1.0.0.0/30 is subnetted, 2 subnets
    C       1.1.1.0 is directly connected, FastEthernet0/0
    C       1.1.1.4 is directly connected, FastEthernet0/1
         192.168.1.0/32 is subnetted, 2 subnets
    C       192.168.1.1 is directly connected, Loopback0
    C       192.168.1.2 is directly connected, Loopback1
    S*   0.0.0.0/0 [1/0] via 1.1.1.6
                   [1/0] via 1.1.1.2

    Load balance'a bakalım :

    Kod:
    R1# traceroute 4.4.4.4 source loopback 1
    
    Type escape sequence to abort.
    Tracing the route to 4.4.4.4
    
      1 1.1.1.6 32 msec
        1.1.1.2 16 msec
        1.1.1.6 36 msec
      2 10.10.20.4 28 msec
        10.10.10.4 48 msec
        10.10.20.4 60 msec
    Bu yapılandırmada tek eksik SLA operation'larının her biri için oluşturulması gereken bir lokal ip policy. Bunun haricinde ok durumda.

    Linkler equal değillerse ve BGP olacaksa onun içinde bir config yazabilirim.
    Eklenmiş Resim Eklenmiş Resim
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  6. #6
    yavuzaras isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Jan 2014
    Mesajlar
    8

    Standart

    teşekkur ederim.
    konfigürasyon anlamında eksik yok gibi. gerçek ortamda gerçek router larla test ettim. tam istediğim gibi çalışıyor. konunun başında yazdığım gibi, beni asıl yoran şu AS denen zımbırtının nasıl alındığı, değiştirildiği vs. bu konuda yardımcı olabilirseniz çok sevinirim.

  7. #7
    tcos isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Mar 2012
    Bulunduğu yer
    Heilbronn
    Mesajlar
    92

    Standart

    Yukarda iki tane Link ekledim AS Numarasi ile ilgili...

  8. #8
    yavuzaras isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Jan 2014
    Mesajlar
    8

    Standart

    Alıntı tcos Nickli Üyeden Alıntı Mesajı göster
    Yukarda iki tane Link ekledim AS Numarasi ile ilgili...
    Teşekkür ederim. Bize sponsor olan firma ile görüşüyoruz. izinde olduğumdan buraya girip yazamadım.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok