[ Çözüldü ] EIGRP Redist Into BGP
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, artık " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle sitemizde katılıma devam edebilirsiniz.

+ Konuyu Cevapla
Toplam 8 sonuçtan 1 ile 8 arasındakiler gösteriliyor.
EIGRP Redist Into BGP

Arkadaşlar selam, şöyle bir şey oluşturmaya çalıştım. R1 ve R3 EIGRP ile iletişiyor, R1 ve diğer routerlar BGP ile. R1'deki redistribution ile R2 ve R4, R3 ile pingleşebiliyor. Amacım as

  1. #1
    Viking isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2010
    Mesajlar
    32

    Standart EIGRP Redist Into BGP

    Arkadaşlar selam, şöyle bir şey oluşturmaya çalıştım. R1 ve R3 EIGRP ile iletişiyor, R1 ve diğer routerlar BGP ile. R1'deki redistribution ile R2 ve R4, R3 ile pingleşebiliyor. Amacım as numaraları ile bu redistributionı sınırlamak. Yalnızca AS500'e izin vermek istiyorum ancak başaramadım. Şimdiden teşekkürler.
    R1

    interface FastEthernet2/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router eigrp 200
    network 1.0.0.0
    network 2.0.0.0
    network 3.0.0.0
    network 192.168.3.0
    auto-summary
    !
    router bgp 400
    no synchronization
    bgp log-neighbor-changes
    network 192.168.3.0
    redistribute eigrp 200 route-map deneme37
    neighbor 2.2.2.2 remote-as 600
    neighbor 3.3.3.2 remote-as 500
    no auto-summary
    !
    !
    ip as-path access-list 10 permit ^500$
    !
    no ip http server
    no ip http secure-server
    !
    no cdp log mismatch duplex
    !
    !
    !
    route-map deneme37 permit 10
    match as-path 10
    R2

    interface Loopback0
    ip address 192.168.4.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 3.3.3.2 255.255.255.252
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router bgp 500
    no synchronization
    bgp log-neighbor-changes
    network 192.168.4.0
    neighbor 3.3.3.1 remote-as 400
    no auto-summary
    R3


    interface Loopback0
    ip address 192.168.1.1 255.255.255.0
    !
    interface Loopback1
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 1.1.1.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router eigrp 200
    network 1.0.0.0
    auto-summary


    R4

    interface Loopback0
    ip address 192.168.5.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 2.2.2.2 255.255.255.252
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router bgp 600
    no synchronization
    bgp log-neighbor-changes
    network 192.168.5.0
    neighbor 2.2.2.1 remote-as 400
    no auto-summary
    !
    !
    !
    no ip http server
    no ip http secure-server
    !
    no cdp log mismatch duplex

    scree.jpg

  2. #2
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,994

    Standart

    Slm , EIGRP rotalarını sadece AS500'e redist etmek mi istiyorsunuz ?
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  3. #3
    Viking isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2010
    Mesajlar
    32

    Standart

    selam nexus, evet.

  4. #4
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,994

    Standart

    En basit çözüm distribute list uygulamak Olayın sadece R1 üzerinde dönmesi mi gerekiyor ?
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  5. #5
    Viking isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2010
    Mesajlar
    32

    Standart

    yani amacım route map kullanmak hocam. bgp çalışıyorum, böyle ufak çalışmalarla pekiştirmem lazım. neden işe yaramadığını anlamam şart

  6. #6
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,994

    Standart

    BGP kaldırılıyomus biraz bekle istersen , şuan tasarı bakanlar kurulundaymış meclisten geçerse kalkacakmış
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  7. #7
    Nexus isimli Üye şimdilik offline konumundadır Administrator - Founder
    Üyelik tarihi
    May 2012
    Mesajlar
    1,994

    Standart

    Belki çok saçma ama senin topolojin için illegal bir çözüm geldi aklıma

    R1 üzerinde :

    Kod:
    router bgp 400 
    
    redist eigrp 200 route-map For500
    
    route-map For500 permit 10
    set origin 600


    Burada as600 çalışan router ( yani r4) bu redist işlemi sonucu origin olarak as 600 olan bir update paketi alınca ignore eder...


    Bu doğru bir çözüm olur ama çok mantıksız As500 olan bgp router eigrp rotalarını as600'den aldığını zanneder. Hedefi eigrp subnetleri olan paketler as500'den ama nexthop olarak R1'e gönderilir. R1 routing table'da herşey normal oldugundan sorun yasanmaz...



    Sen neighbor x.x.x.x route-map in/out ile yapsan daha iyi olur. Burada route-map altında sadece source protocol olarak eigrp 10 tanımlaman yeterli olur.

    Kısaca :

    Kod:
    neighbor 3.3.3.2 route-map EIGRP_BGP500 out
    neighbor 2.2.2.2 route-map EIGRP_BLOCK out
    redist eigrp 200
    Kod:
    route-map EIGRP_BGP500 permit 10
    match source-protocol eigrp 10
    Kod:
    route-map EIGRP_BLOCK deny 10 
    match source-protocol eigrp 10
    route-map EIGRP_BLOCK permit 20

    Bu şekilde yaparsan daha sağlıklı olur...
    “Bir kez kaçar uçurtman, sonra gökyüzüne küser insan…”

  8. #8
    Viking isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Nov 2010
    Mesajlar
    32

    Standart

    geç oldu ama her iki çözüm için de teşekkürler nexus

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok