PBR ve Multi Homed BGP - Sayfa 3
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 3 Sayfadan 3. Sayfa BirinciBirinci 123
Toplam 27 sonuçtan 21 ile 27 arasındakiler gösteriliyor.
PBR ve Multi Homed BGP

Yani daha zahmetli ama gerçek dünyada böyle. PBR hiç yönetilebilir bir yöntem değil. Tek router olduğunda belki ama yine de dediğim gibi CPU vs. gibi sıkıntılar ortaya çıkabilir.

  1. #21
    shroud41 Guest

    Standart

    Yani daha zahmetli ama gerçek dünyada böyle. PBR hiç yönetilebilir bir yöntem değil. Tek router olduğunda belki ama yine de dediğim gibi CPU vs. gibi sıkıntılar ortaya çıkabilir.

  2. #22
    5LoTh isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Dec 2011
    Mesajlar
    392

    Standart

    aslında bugün gene kafa patlattık arkadaşlarla karşı ISP lerle de bir şeyler yapılması gerek diye düşündük
    as-prepending le yaparız falan dedik bi şekilde

    bir yerde tıkandın

    trafiği yönelticez de diğer ISP ye dönüşte diğer taraftan gelicek asimetrik çalışıcak. ISP lerde de config yapılması lazım sanki. sadece DC routerında yaparak ben trafiği yönlendirebilir miyim ?

  3. #23
    shroud41 Guest

    Standart

    Aslında şöyle, siz med'le vs. oynayıp trafiğin istediğiniz yerden gelmesini isteyebilirsiniz hatta başarabilirsiniz de ancak ISP bir filtreleme, tercih vs. yapıyorsa o zaman dediğin gibi ISP'deki konfigurasyona mecbur kalınır.

  4. #24
    psax isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Dec 2011
    Mesajlar
    42

    Standart

    Alıntı 5LoTh Nickli Üyeden Alıntı Mesajı göster
    evet 11111 e o prefix in gelmesini engelledik fakat kaldı o öyle mahzun diğer tarafa gitmesi lazım şimdi

    5.5.5.0 A ISP den
    6.6.6.0 B ISP den çıkacak kısacası

    5.5.5.0 prefixini başka bir router a da sonlandırıp iki router arasında static konuşup o IP bloğunu da ayrı bir BGP ile diğer ISP ye göndersem olabilir mi acaba ? bu sefer de yedekliliği nasıl sağlayacağım. ISPA düştüğünde geri kalan prefixleri ISPB ye döndürmek lazım. kafa karıştııııı

    R1---------------ISPA
    |
    |
    |
    |
    R2---------------ISPB
    Aylardır bu sorunun cevabını arıyordum, geçen aylarda tesafüden buldum.
    Bunu yapmanın yolu bgp conditional advertisement. BGP tablosundaki belirli prefix/prefixlerin var olup olmadığına göre, komuşulara prefix advertise edilebiliyor. İlk mesajdaki topolojiyi oluşturdum. Test ettim çalıştı. Yalnız test için internet router'ına da bgp konuşuyor.
    prefix-listler:

    ip prefix-list LINK_TO_1111 seq 5 permit 11.11.11.0/30
    ip prefix-list LINK_TO_2222 seq 5 permit 22.22.22.0/30
    ip prefix-list NET5 seq 5 permit 5.5.5.0/24
    ip prefix-list NET6 seq 5 permit 6.6.6.0/24

    Öncelikle P2P linkleri bgp tablosuna koydum. Bu iyi bir yöntem değil sonra söyleyeceğim. Hiçbir yere adv edilmesin dedim.

    redistribute connected route-map P2P_LINK

    route-map P2P_LINK permit 10
    match ip address prefix-list LINK_TO_1111 LINK_TO_2222
    set community no-advertise

    sonra as2222 i as1111 e yedeklemek için,
    neighbor 11.11.11.2 advertise-map AS2222_FAIL non-exist-map AS2222_FAIL_COND

    AS2222_FAIL_COND gerçekleştiğinde AS2222_FAIL adv edilecek,

    route-map AS2222_FAIL_COND permit 10
    match ip address prefix-list LINK_TO_2222

    route-map AS1111_FAIL_COND permit 10
    match ip address prefix-list LINK_TO_1111

    burada LINK_TO_1111 in gittiği görülüyor. O da bgp tablosunda vardı. redistributen dolayı.

    aynı şekilde AS2222 yi AS1111 e yedeklemek için, (genel config)

    router bgp 100
    no synchronization
    bgp log-neighbor-changes
    network 5.5.5.0 mask 255.255.255.0
    network 6.6.6.0 mask 255.255.255.0
    timers bgp 5 15
    redistribute connected route-map P2P_LINK
    neighbor 11.11.11.2 remote-as 1111
    neighbor 11.11.11.2 advertise-map AS2222_FAIL non-exist-map AS2222_FAIL_COND
    neighbor 22.22.22.2 remote-as 2222
    neighbor 22.22.22.2 advertise-map AS1111_FAIL non-exist-map AS1111_FAIL_COND
    no auto-summary
    !
    not: test için bgp timer ların düşürdüm.

    route-map AS2222_FAIL_COND permit 10
    match ip address prefix-list LINK_TO_2222
    !
    route-map AS1111_FAIL_COND permit 10
    match ip address prefix-list LINK_TO_1111
    !
    route-map AS2222_FAIL permit 10
    match ip address prefix-list NET6
    !
    route-map AS1111_FAIL permit 10
    match ip address prefix-list NET5
    !
    route-map P2P_LINK permit 10
    match ip address prefix-list LINK_TO_1111 LINK_TO_2222
    set community no-advertise
    ---------
    DC router'ındaki interface'ler shutdown edilerek test edebilinir. Prefixler flap olacak, sonra stabil hale gelecektir. Biraz beklemek gerek. DC router'ı istenilen duruma göre INVALID gönderiyor. Uç router lar prefixleri silip uzun as-path i best path olarak seçiyor. Tek yol zaten
    Neden interface'i redistribute edmek iyi değil ise, gerçek topolojilerde uç bgp router ı düştüğü zaman interface düşmüyor. Karşı ucu track edilebilir, yada o router'dan alınan ve ona has bir prefix, default-route gibi, ilgili non-exist map e yazılabilir. bgp tablosunda olacak ama
    ---
    cisco(diğer vendorları bilmiyorum) öntanımlı olarak farklı ASN dan gelen MED'i compare etmez, rfc de yazıyor olabilir. Sonradan eklemek gerekiyor. Weight ise sadece o router için özeldir NLRI olarak adv edilmez. Cisco şeysi.

  5. #25
    5LoTh isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Dec 2011
    Mesajlar
    392

    Standart

    Selamlar hocalarım,

    bu konu eskide kalmıştı fakat bir kaç şey öğrenince tekrar gündeme getirmek istedim. önerilen yol olan community lerle işe başladım.


    ________________ISP 1
    /
    /
    R1
    \
    \_______________ ISP 2


    şeklinde bir yapı var düz mantık tek router 2 tane BGP komşuluk.

    R1 bgp IP : 10.100.10.1 ve 20.200.20.1

    ISP 1: 10.100.10.2
    ISP 2: 20.200.20.2


    şöyle bir BGP komşuluğum var.

    router bgp 11
    bgp log-neighbor-changes
    neighbor 10.100.10.2 remote-as 22
    neighbor 20.200.20.2 remote-as 33
    !
    address-family ipv4
    redistribute connected
    redistribute static
    neighbor 10.100.10.2 activate
    neighbor 10.100.10.2 send-community
    neighbor 10.100.10.2 next-hop-self
    neighbor 10.100.10.2 soft-reconfiguration inbound
    neighbor 10.100.10.2 route-map ANONS out
    neighbor 20.200.20.2 activate
    neighbor 20.200.20.2 send-community
    neighbor 20.200.20.2 next-hop-self
    neighbor 20.200.20.2 soft-reconfiguration inbound
    neighbor 20.200.20.2 route-map ANONS out
    no auto-summary
    no synchronization
    network 192.168.100.0
    network 192.168.200.0
    exit-address-family


    ip route 192.168.100.100 255.255.255.255 Null0

    3 tane IP bloğunu anons edeyim dedim. 2 tanesi /24 bir tanesi /24 ün içinden bir /32.

    access-list 5 permit 192.168.100.0 0.0.0.255
    access-list 6 permit 192.168.200.0 0.0.0.255
    access-list 7 permit 192.168.100.100


    IP adreslerini yakalayıp community li gönderdim.

    route-map ANONS permit 10
    match ip address 5
    set community 11:1111
    !
    route-map ANONS permit 20
    match ip address 6
    set community 11:2222
    !
    route-map ANONS permit 30
    match ip address 7
    set community 11:1



    kontrol ettiğimde anons yaptığı gördüm R1 in /24 - /24 ve /32 olarak.

    R1#show ip bgp neighbors 10.100.10.2 advertised-routes
    Network Next Hop Metric LocPrf Weight Path
    *> 192.168.100.0 0.0.0.0 0 32768 i
    *> 192.168.100.100/32 0.0.0.0 0 32768 ?
    *> 192.168.200.0 0.0.0.0 0 32768 i

    Total number of prefixes 3

    --------------------------------------------

    ISP 1 e 100.0/24 gitsin istedim bu yüzden community 11:2222 discard ettim. sorun yok.
    ISP 2 ye de 200.0/24 ve 100.100/32 gitsin istedim. bu yüzden 11:1111 i discard edip 11:1 ve 11:2222 i al dedim.

    normalde 20.200.20.1 den received edilen routelarda /32 mevcut. fakat 11:1111 i discard ettiğimden komple 192.168.100.0/24 bloğunu discard etti route tablosunda /32 yok.

    R3#show ip bgp neighbors 20.200.20.1 received-routes

    Network Next Hop Metric LocPrf Weight Path
    * 192.168.100.0 20.200.20.1 0 0 11 i
    * 192.168.100.100/32 20.200.20.1 0 0 11 ?
    *> 192.168.200.0 20.200.20.1 0 0 11 i



    R3#show ip route 
         10.0.0.0/30 is subnetted, 1 subnets
    [I] 20.0.0.0/30 is subnetted, 1 subnets
    C 20.200.20.0 is directly connected, GigabitEthernet1/0
    B 192.168.200.0/24 [20/0] via 20.200.20.1, 00:16:22



    tamamen teorik düşündüm.öneriniz var mıdır, /32 olarak /24 ün içinden ayıramıyorum galiba.


    teşekkürler.


    h.a.s.

  6. #26
    psax isimli Üye şimdilik offline konumundadır Member
    Üyelik tarihi
    Dec 2011
    Mesajlar
    42

    Standart

    Selam;

    R1, 192.168.100.0/24 networkü için, bgp community 11:1111 olarak set ediliyor (route-map ANONS permit 10), 192.168.100.100/32'ye set edilen route-map satırına gelmez(route-map ANONS permit 30) çünkü, access-list 5 te, /24 dahili olan bütün network'lere 11:1111 set edilsin denmiş. Hatta show access-list te access-list 7 için match counter 0 bile olabilir...
    Kesin biçimde /24 prefix'ine 11:1111 set etmek için, access-list yerine prefix list kullanılabilir.
    ip prefix-list prefix5 seq 5 permit 192.168.100.0/24
    ip prefix-list prefix6 seq 5 permit 192.168.200.0/24
    ip prefix-list prefix7 seq 5 permit 192.168.100.100/32

    route-map ANONS permit 10
    match ip address prefix-list prefix5
    set community 11:1111
    !
    route-map ANONS permit 20
    match ip address prefix-list prefix6
    set community 11:2222
    !
    route-map ANONS permit 30
    match ip address prefix-list prefix7
    set community 11:1
    ----------------------------------
    R3#show ip bgp
    BGP table version is 11, local router ID is 20.200.20.2
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path
    *> 192.168.100.100/32
    20.200.20.1 0 0 11 ?
    *> 192.168.200.0 20.200.20.1 0 0 11 i
    R3#show ip bgp 192.168.200.0
    BGP routing table entry for 192.168.200.0/24, version 11
    Paths: (1 available, best #1, table Default-IP-Routing-Table)
    Not advertised to any peer
    11, (received & used)
    20.200.20.1 from 20.200.20.1 (20.200.20.1)
    Origin IGP, metric 0, localpref 100, valid, external, best
    Community: 11:2222
    R3#show ip bgp
    R3#show ip bgp 192.168.100.100/32
    BGP routing table entry for 192.168.100.100/32, version 10
    Paths: (1 available, best #1, table Default-IP-Routing-Table)
    Not advertised to any peer
    11, (received & used)
    20.200.20.1 from 20.200.20.1 (20.200.20.1)
    Origin incomplete, metric 0, localpref 100, valid, external, best
    Community: 11:1

  7. #27
    Cagdas Yalman isimli Üye şimdilik offline konumundadır Moderator
    Üyelik tarihi
    Feb 2008
    Mesajlar
    427

    Standart

    a.a.a.a _______________ISP 1
    /
    /
    R1
    \
    b.b.b.b_______________ ISP 2
    bu devrelerin gercek ip oldugunu varsayarsak .

    ispler bu ipleri tüm dünyaya duyuruyor. bu sebepten normal internet cıkışını a.a.a.a ya natlayıp. 2. ispden çıkmak istediğimizi b.b.b.b ye natlamak problemi çözümü bırakın paketin gelişini gidişini isp düşünsün

    atladığım bir nokta yoksa problemi bu işlem çözer gibi geliyor.
    Carpe dieM

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok