OSPF ve RIP Routing
CLI Guru - Cisco Eğitim ve Danışmanlık Merkezi |

2007 yılından bu yana aktif olan ciscotr.com, kısa bir süre sonra " www.bilisim.pro " olarak devam edecektir.  
Mevcut mesajlarınız ve kullanıcı bilgilerinizle yenilenen sitemizde katılıma devam edebileceksiniz.

+ Konuyu Cevapla
Toplam 3 sonuçtan 1 ile 3 arasındakiler gösteriliyor.
OSPF ve RIP Routing

Herkese Merhaba, Open Shortest Path First (OSPF) ve Routing Information Protocol (RIP) ile ilgili Turkce dokumana ihtiyacim var, elinde olanlar bana mail atabilir mi? Tesekkurler

  1. #1
    rcelik isimli Üye şimdilik offline konumundadır Junior Member
    Üyelik tarihi
    Oct 2008
    Mesajlar
    2

    Standart OSPF ve RIP Routing

    Herkese Merhaba,

    Open Shortest Path First (OSPF) ve

    Routing Information Protocol (RIP) ile ilgili Turkce dokumana ihtiyacim var, elinde olanlar bana mail atabilir mi?

    Tesekkurler

  2. #2
    Soul isimli Üye şimdilik offline konumundadır Administrator
    Üyelik tarihi
    Jun 2008
    Mesajlar
    1,080

    Standart

    arkadasım sitede zaten mevcut onlar biraz arastırma yaparsan bulabilirsin...

  3. #3
    o.yaz Guest

    Standart

    ROUTİNG :

    NOT BAZI TABLOLAR GÜZÜKMEMEKDE AMA....
    Bir paketin , bir segmentten başka bir segmente yönlendirme işlemine routing denir.
    Routing için, yönlendiricilerin bazı bilgileri edinmeleri gerekir:

    1-Yönlendirilecek paketin hedef adresi
    2- Rotaların keşfedilmesi
    3- En iyi rotanın belirlenmesi
    4- Yönlendirme bilgilerinin, yönlendiriciler arasında devamlılığının sağlanmasıdır.

    Yönlendirme protokolleri , OSI 3 katman protokolleridir . IP ve IPX bu protokollerden olup , paketlerin hedef ve kaynak adresleri bu protokolerle öğrenilir.

    Yöntemler :
    Routing işlemi ; 1- Statik olarak yapılabilir ( static routing )
    2- Dinamik olarak yapılabilir ( dynamic routing ) . Bu yönlendirme tiplerininde kendine göre, avantaj ve dezavantajları vardır ve netwok yapısına göre ilgili algoritmalardan biri seçilebilir. Aşağıda detaylı inceleneceklerdir.

    1-Statik Yönlendirme: Ağdaki bütün subnetleri , her yönlendiricide uygun bir şekilde manuel kon -figüre edilmesidir. Eğer ağ büyük değilse ve IP yapılandırması sürekli değişmiyor ise statik yapılandırma
    yapılar.

    Avantajları:

    • Router’da daha az işlemci kullanımı
    • Bir dinamik yönlendirme algaritması koşmadığı için bant genişliği kaybı olmaz
    • Döngü oluşma riskinin az olması, küçük networklerde bu yöntemi etkin kılar

    Dezavantajları :

    • Ağ yapısının iyi bilinmesi ve yetkin kişilerce yapılması gerekmektedir
    • Büyük ağlarda gerekli konfigürasyonun yapılması çok vakit almakta
    • Hata yapma riskinin yüksek olması sebebiyle, büyük networklerde tercih edilmemesi

    Cisco config:
    RouterA(config)# ip route 10.0.2.0 255.255.255.0 192.168.1.2
    RouterB(config)# ip route 10.0.1.0 255.255.255.0 192.168.1.1

    2-Dinamik Yönlerdirme :
    Büyük ağlardaki yönetim zorluğundan dolayı, yönlendirme işlemi dinamik olarak yapılır.Dinamik yönlendirme protokolleri ile, router’lar routing table bilgilerini, birbirleri ile mesajlaşarak oluştururlar.
    Böylelikle ağ içindeki diğer networklere hangi rotayı veya rotaları izleyerek gidebilecekleri bilgisini oluşturmuş olurlar.

    Amaç :

    • Bütün alt ağlara giden yolları dinamik olarak öğrenmek ,
    • Birden fazla rota varsa, en iyi rotayı belirlemek ağ performansını artırarak yük dağılımı yapmak,
    • Geçerliliğini kaybeden rotayı otomatik silmek, yeni rotayı en kısa sürede bulmak

    İki tip dinamik yönlendirme protokolü vardır.

    1- Dış yönlendirme protokolleri ( Exterior routin protocols ) :
    BGP ( Border Gareway Protocol ) : Organizasyolar arası yönlendirme bilgilerini işleyen protokoldür.

    2- İç yönlendirme protokolleri ( İnterior routing protocols ) :
    RIP ( routing information protocol )
    IGRP ( interior gateway routing protocol )
    EIGRP ( enhanced interior gateway routing protocol )
    OSPF ( open shortest Path first )

    İç yönlendirme protokolleride kullandıkları algoritmaya göre 3 ‘e ayrılırlar.

    a- Uzaklık Vektör Yönlendirme Protokolleri ( Distance vector routig protocols ) :
    Ağdaki herhangi bir subnete olan, vektörel uzaklığı hesaplayarak yönlendirme tablosunu oluşturur.
    RIP v1 – RIP v2
    IGRP , bu protokollerdendir.
    Bu algoritmalar; yönlendiriciye direk bağlı olan ağ bilgilerini periyodik güncelleme mesajları ile , yakın komşulukdaki yönlendiricilere aktarırlar. Ağdaki her bir yönlendirici, diğer yönlendiricilerden aldıkları bu ağ bilgilerini metrik değerini bir artırarak diğer yönlendiricilere yönlendirirler.
    Yönledirme algoritması , her bir ağ için bir metrik değer üretir. Metrik değer , ağa olan uzaklığı belirtir. IP, RIP protokolü , metrik değer olarak bir paketin üzerinden geçtiği yönlendirici sayısını ( hop count ) kullanır.
    IGRP protokolü ise ; bant genişliği, gecikme, yük dengesi, güvenilirlik ve MTU ( max.transmission unit ) değerlerinden oluşan bir fonksiyon ile ağın metrik değerini hesaplamaktadır.

    b- Link Durum Yönlendirme Protokolleri ( link state routing protocols ) :

    OSPF , bu protokollerdendir.
    Her yönlendiricide “ Dijkstra shortest path first “ ( OSPF için ) algoritmasını kullanarak, topolojik veritabanı oluşturulur.Bu veritabanında yönlendiriciye bağlı olan linkler, rotalar ve yakın komşulukda bulunan yönlendi- ricilerin bilgileri bulunmaktadır.

    c- Dengeli Melez Yönlendirme Protokolleri ( balanced hybrid routing protocols ) :
    Diğer iki tip yönlendirme protokolleri karışımı olan “DUAL ( diffusing update algorithm )” algoritmasını kullanarak ağ topolojisi hakkında yakın komşulukdaki yönlendiricileri bilgilendirir.

    EIGRP , bu protokollerdendir.

    Yönetimsel Uzaklık ( Administrative Distance ) :
    Yönlendiriciler; yönlendirme tablolarını belirli bir metodoloji takip ederek oluşturular. Gerek statik olarak konfigüre edilmiş rotaları, gerekse dinamik yönlendirme protokollerinin mesajları ile elde ettikleri ağ bilgile- rini yönlendirme tablosuna kaydetmeden önce incelerler.Eğer bir ağa ait birden fazla rota bilgisi varsa ; bu rotaların hangi protokol ile aracılığı ile elde edildiğine bakılır.Yönetimsel uzaklık değeri en iyi olan rota , yönlendirme tablosuna kaydedilir. Buradaki yönetimsel uzaklık değeri ; yönlendirme protokolleri -nin sahip oldukları mevcut algoritmalara göre , ağ içerisinde en iyi rota tespit edebilme yeteneğine göre belirlenen sabit değerler yönetimsel uzaklık değerleri olarak bilinirler.
    Yönetimsel uzaklık değeri en küçük olan rota tercih edilir. Yönetimsel uzaklığı aynı birçok rotanın da metrik değerine bakılır.
    Yönlendirme protokollerinin yönetimsel uzaklık değerleri ve tercihsel sıralama aşağıdaki tabloda verilmiştir.



    Rotanın kaynağı Öngörülen uzaklık
    değeri Tercih sıralaması
    Direk bağlı arayüz 0 1
    Statik rota 1 2
    EIGRP 90 3
    IGRP 100 4
    OSPF 110 5
    RIP 120 6
    External EIGRP 170 7
    bilinmeyen 255 8




    RIP ( routing information protocol ):

    RIP protokolü , metrik değer olarak bir paketin üzerinden geçtiği yönlendirici sayısını ( hop count ) kullanır. Yani vektöreldir. ( sadece hop count ‘a bakar).
    • Yönlendirme bilgilerini 30 sn ‘ de bir broadcast olarak gönderdiğinden fazla miktarda bant genişliği tüketir. Bu nedenle sadece küçük ağlarda kullanılar.
    RIP v1, VLSM ( variable length subnet masking) desteği yoktur.Subnet mask değeri gönderilmediği için Subnetig ve superneting yapılmış konfigürasyonu anlayamaz ve RIP v1 çalışmaz.
    RIP v1 routing table paketlerini broadcast olarak gönderir.
    RIP v2 routing table paketlerini multicast olarak gönderir.
    • Max seri bağlantı sayısı 15 dir.
    • Metrik değer 16 olan ağ ulaşılamaz ilan edilir.
    RIP v2 clear text ve MD5 kripto metodunu kullanarak güvenlik denetlemesi yapabilmektedir.
    RIP Detaylı bilgi için RFC 1058 ‘ e başvur
    Ospf Detaylı bilgi için RFC 1247 ‘ e başvur
    BGP Detaylı bilgi için RFC 1163 ‘ e başvur


    Cisco config :

    router(config)#router rip
    router(config-router)#version 2
    router(config)#network 10.1.1.0 // kendi üzerine bağlı olan network adresi
    router(config-router)#passive-interface fastEthernet 0 // LAN Ethernet tarafını broadcast
    trafiğine kapatır.

    router(config)#interface serial 0
    router(config-if)#ip rip ? // RIP v2 yapıldığı zaman aşağıdaki parametleride değiştirmek
    gerekiyor.
    authentication Authentication control
    receive advertisement reception
    send advertisement transmission
    triggered enable rfc2091 triggered rip
    v2-broadcast send ip broadcast v2 update

    router(config)#router rip
    router#debug ip rip // RIP mesaj logları gözlemlenir .

    router(config)#router rip
    router(config-router)#maximum-paths 6 // 1-6 adet eşit metrik değerli rotayı yönlen-
    dirme tablosunda tutar.
    router(config-router)#traffic-share min across-interfaces // eşit metrikli rotalar arasında yük
    dağılımı yapar.



    IGRP ( interior gateway routing protocol ) :
    Bant genişliği,gecikme, güvenilik,yük ve max. Transmisyon biriminden ( bandwith,delay,reliability,load,MTU)
    Oluşan fonksiyonu metrik olarak kullanır.
    • Bu özellikleri , ağdaki trafik parametrelerinden oluştuğu için RIP ‘e göre daha etkin-kazançlı rota tespit etmektedir.
    • Ağın subnet mask’ını göndermez. Dolayısıyla VLSM ‘i desteklemez.
    • Mesajlaşma multicast olarak yapılır.


    RIP ve IGRP FARKLILIKLARI:


    özellik RIP IGRP
    ( öngörülen değer )
    ( öngörülen değer )
    Güncelleme zamanı 30 saniye 90 saniye
    Holddown zamanı 180 saniye 280 saniye
    Flash(tetiklenen) güncelleme varmı evet Evet
    Güncellemede subnet maskesi
    Gönderiliyor mu ? RIP v1 : göndermiyor
    RIP v2 : gönderiyor
    Sonsuz metrik değeri 16 4,294,967,295


    Cisco config :

    router(config)# router igrp 10 // buradaki “10” değeri igrp proses numarasıdır
    router(config-router)# network 192.168.10.0 // router ‘ın kendi arayüzündeki network IP ‘sidir.

    dce-router#debug ip igrp transactions // IGRP mesajlarının loglarını görüntüler
    dce-router#debug ip igrp events // IGRP paketlerinin
    Konu o.yaz tarafından (24.06.2009 Saat 16:04 ) değiştirilmiştir.

+ Konuyu Cevapla

Bu Konuyu Paylaşın !

Bu Konuyu Paylaşın !

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok