EIGRP Konfigürasyonu (2)

EIGRP ile ilgili temel bilgilerine önceki dökümanimizda yer vermiştik. Şimdi ise EIGRP konfigürasyonu nasıl yapılır bu konuya değinecegiz. Ilk önce komutları teker teker tanıyalım akabinde örnek konfigürasyonlara geçeceğiz.

1. EIGRP’ yi IP yönlendirme protokolü olarak belirler.

Routerlarin EIGRP yönlendirme update’ lerini alabilmeleri için aynı otonom sistemde yer almaları gerekmektedir.

2.  Router kendisine bağlı olan networkleri EIGRP’ ye tanıtır.

Wildcard mask değeri ise “inverse mask” olarak adlandırılmaktadır. Mask’ ın 255’ e tamamlanmış halidir.

3. Eğer seri bir link (PPP , HDLC ) kullanıyorsanız, yönlendirme update trafiğini göndermek için interface ‘ in bandwidth değerini “bandwidth” komutu ile girin.

Eğer bu değeri değiştirmezseniz, EIGRP linkdeki band genişliği değerini T1’ in hızı olarak algılayacaktır. Link T1 ‘ in hızından daha yavaşsa, converge olamayacağı gibi yönlendirme update paketleri kaybolabilecektir.

Basit EIGRP Konfigurasyonu

Yukarıdaki topolojide görebildiğniz gibi bütün routerlar AS 109 ‘ un üyesidir.  EIGRP için komşuluk ilişkisi kurulabilmesi için bütün routerların aynı otonom sistemde yer alması gerekmektedir. Router A üzerinde;
•routerA(config)#router eigrp 109
•routerA(config-router)#network 10.0.0.0
•routerA(config-router)#network 172.16.0.0

konfigürasyonu yapılmış olup 192.168.1.0 networkü için bir tanım yapılmamıştır. Bunun sebebi 192.168.1.0 networkünün RouterA’ ya direk bağlı olmamasıdır.

Router A üzerindeki konfigürasyonu;

•routerA(config)#router eigrp 109
•routerA(config-router)#network 10.1.0.0
•routerA(config-router)#network 10.4.0.0
•routerA(config-router)#network 172.16.7.0
•routerA(config-router)#network 172.16.2.0

şeklinde yapmış olsaydık nasıl bir sonuçla karşılaşırdık?

Router A, network komutunu classful olarak değiştirirdi ve sonuç konfigürasyon;

•router eigrp 109
•network 10.0.0.0
•network 172.16.0.0
şeklinde olurdu.

Alternatif olarak  wildcard mask ‘ larla bir konfigürasyon yapılabilir;
EIGRP’ de Wildcard Mask Kullanımı
Bir otonom sistemdeki router, başka bir otonom sistemdeki router’ a bağlanırsa wildcard mask kullanılır. Bir router wildcard mask ile konfigure edildiğinde diğer otonom sistemdeki  routerlar ile komşuluk kurmaya çalışmayacaktır. Yukarıdaki örnekde RouterC, AS 100 ‘ de  interface’ lerine B sınıfı subnetler  bağlı durumdadır. RouterC’ nin konfigurasyonu wildcard mask ile yapıldığı için, RouterC’ nin S0 interface’ in de EIGRP çalışmayacaktır. Wildcard masksız, RouterC, EIGRP paketlerini dış ağa gönderecektir. Bu da gereksiz bandwidth ve CPU tüketimine neden olacaktır. Wildcard mask, EIGRP’ ye 172.16.3.0/24 veya 172.16.4.0/24 ile ilişki kurup, 172.16.5.0/25 ile kurmaması gerektiğini söyler.
“ip default-network” Komutu

ip default-network komutu last-resort gateway veya default route konfigürasyonu için kullanılır. Router’ lar direk bağlı oldukları networklerin bilgilerini birbirilerine iletirler. “ip default-network” komutu ile konfigüre edilmiş bir router, komuta parametre olarak verilmiş network ‘ u last-resort gateway olarak belirleyip bunu diğer routerlara anons eder. Aşağıdaki örnekde 172.31.0.0/24 networku RouterA’ ya direk bağlıdır. RouterA, “ip default-network 172.31.0.0” komutu ile 172.31.0.0 networku default network olarak konfigüre edilmiştir. Bu network bilgisi RouterB’ ye geçicektir. Çünkü RouterA, eigrp prosesi içinde network komutu ile bunu tanımlamıştır.
EIGRP Rotalarının Doğrulanması
Doğrulama işlemleri için;

•“show ip eigrp neighbors”
•“show ip route eigrp” komutları kullanılır.

Yukaridaki topolojiye göre konfigürasyon yapıldığı takdirde “show” komutlarının çıktıları aşağıdaki gibi olacaktır:

•H (Handle): Komşuyu işaretlemek için Cisco Ios yazılımı tarafından kullanılan bir numaradır.
•Address: Komşunun OSI 3. Katman adresidir.
•Interface: Komşunun bilgisinin alındığı interface
•Hold time: Saniye cinsindedir. Router’ ın komşuya ait linki ulaşılamaz saymadan önce beklediği max. süredir. Bu  süre içinde komşudan haber alamazsa hattı erişielemez sayar.
•Uptime: Router’ ın komşundan ilk bilgiyi aldığı andan itibaren geçen süredir. Özetle komşuluk ilişkisinin ne kadar süredir aktif olduğunu gösterir.
•SRTT (Smoothed Round Trip Time): (Ortalama milisaniye) EIGRP paketi, komşu routera gönderilip komşudan ACK gelene kadar geçen süredir.
•RTO: milisaniye cinsindendir. Router, kuyrukdaki paketlerden sıradaki paketi göndermeden önce, bir önce göndermiş olduğu paketin güvenli bir şekilde ulaşıp ulaşmadığının bilgisini icin (ACK) beklediği süredir.
•Queue Count: Gönderilmeyi bekleyen kuyrukdaki paketlerin sayısıdır. Bu sayının mümkün olduğunca 0 ‘ a yakın olması gerekmektedir. Diğer türlü bir problem olduğunun göstergesidir.
•Seq Num: Bu komşudan gelen en sonki update,query, veya reply paketlerinin sıra numarasıdır.

“show ip route” komutu routing tablosundaki tüm bilgileri ekrana basarken, “show ip route eigrp” ise sadece EIGRP protokolü üzerinden öğrenilmiş routeları ekrana basacaktır:
EIGRP Operasyonlarının Doğrulanması
EIGRP prosesinin çalışıp çalışmadığını doğrulamak için;

•Show ip protocols
•Show ip eigrp interfaces
•Show ip eigrp neighbors
•Show ip eigrp topology
•Show ip eigrp traffic

Komutları kullanılır.

“show ip protocols” Komutu

Bu komut router üzerinde çalışan bütün dinamik routing protokoller hakkında bilgi vermektedir.

•Outgoing update filter list for all interfaces is not set
• Incoming update filter list for all interfaces is not set

Satırlarında EIGRP’ nin inbound ve outbound updatelerinde herhangi bir filtreleme yapılıp yapılmadığını göstermektedir.

•Maximum path: 4

Satırında 4 hat üzerinden load balance işlemine izin verilmektedir. Max değer 6 dir. İstenilirse bu değeri “maximum-path” komutu ile değiştirebilirsiniz.

•Routing for Networks:

172.16.1.0/24

192.168.1.0

Satırında yer alan 172.16.1.0/24 değerinde subnet maskın belirtilmiş olması “network” komutunda wildcard maskın kullanılmış olduğunu göstermektedir.

•Distance: internal 90 external 170

İle de internal networkler için AD değerinin 90, external networkler için ise AD değerinin 170 olduğunu göstermektedir. Burada bahsedilen external kavramı ile, diğer routing protokolleri ile öğrenilen networkler belirtilmektedir.

“show ip eigrp interfaces” Komutu

•Interface: EIGRP konfigürasyonunun hangi interface’ de yapıldığını gösterir.
•Peers: “Directly connected” bağlanan EIGRP komşularının sayısını ifade eder.
•Xmit Queue Un/Reliable:  Unrealiable ve realiable iletim kuyruğundaki paketlerin sayısı (Paketler bozuksa yada kaynağı belli değil ise)
•Mean SRTT: Milisaniye cinsinden SRTT aralığı.
•Pacing Time Un/Reliable: EIGRP paketlerinin interfaceden gönderileceği zaman belirlenilen pacing süresi.
•Multicast Flow Timer: Router’ ın multicast paketlerini göndereceği maximum süre (sn cinsinden)
•Pending Routes: İletim kuyruğunda gönderilmeyi bekleyen paket sayısı.

“show ip eigrp topology” Komutu

•AS(100): Hangi otonom sistem olduğunu belirtir.
•ID(192.168.1.101): EIGRP ID, Router’ ın aktif interfacelerindeki en yüksek IP adresidir.
•Passive(P): Passive, stable bir durumdur. Networkun erişilebilir olduğunu gösterir. DUAL alg. Calismiyordur.
•Active(A): Bu networkun erişilemez olduğunu belirtir. Network için router’ ın query paketlerini göndererek istekde bulunduğunu gösterir. DUAL algoritması calisir.
•Update(U): Networkun update edildiğini gösterir. Router bu update ile ilgili ACK beklediğinde bu kod görünür.
•Query(Q): Network ile ilgili bir query paketi gönderildğinde bu kod görünür. Router ACK beklemektedir.
•Reply (R) Status: Eğer router bu network ile ilgili bir reply yayınladıysa veya reply paketine bir ACK beklediğinde bu kod görünür.
•Stuck-in-active (SIA) Status: Router B ilk query paketi gönderen cihazdır. Bu query paketi gönderildikten 3 dakika içinde komşu cihazlardan (örneğimizde A, C, D ve E cihazları) reply paketleri gelmez ise router B Stuck-In-Active duruma düşer. Yani bir rotanın active state’de kalabileceği maksimum süre dolmuştur. Bu durumda diğer cihazlar halen cevap vermediğinden diğer cihazlar ile olan komşuluk kesilir. (Convergence problem)
“show ip eigrp traffic” Komutu

EIGRP paketleri hakkında istatistiki bilgi verir.
Hazirlayan: Zeynep YILDIRIM

3 yorum

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir